IP : Protocole OSPF (Open Shortest Path First)

OSPF avec l'exemple de configuration de contiguïté de Multi-zone

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires

Introduction

Ce document décrit comment configurer le protocole de routage d'état de lien de Protocole OSPF (Open Shortest Path First) pour la contiguïté de Multi-zone.

Contribué par Narendra Naukwal, ingénieur TAC Cisco.

Conditions préalables

Conditions requises

Cisco vous recommande de prendre connaissance des rubriques suivantes :

  • OSPF

  • Contiguïté de Multi-zone

Cisco recommande également que ces exigences soient répondues avant que vous tentiez la configuration qui est décrite dans ce document :

  • Le protocole de routage d'état de lien OSPF doit être préconfiguré dans le réseau.

  • Seulement deux orateurs OSPF utilisent l'interface entre laquelle la fonctionnalité de Multi-zone OSPF fonctionne. Travaux OSPF de Multi-zone seulement sur les types de réseau point par point.

Composants utilisés

Les informations dans ce document sont basées sur l'OSPF de Multi-zone.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Informations générales

Le protocole de routage d'état de lien OSPF utilise le concept des zones, qui sont des sous-titre-domaines dans le domaine OSPF. Un routeur dans une zone met à jour les informations topologiques complètes de cette zone. Par défaut, une interface peut seulement appartenir à une zone OSPF. Ceci peut non seulement entraîner le routage suboptimal dans le réseau, mais il peut également mener à d'autres questions si le réseau n'est pas conçu correctement.

Quand la contiguïté de Multi-zone est configurée sur une interface, les haut-parleurs OSPF forment plus d'une contiguïté (réglage) au-dessus de ce lien. L'interface de Multi-zone est une interface logique et point par point au-dessus dont le réglage est formé. Ce document décrit un scénario où le réglage OSPF de Multi-zone peut être utilisé afin de fonctionner autour d'un problème et répondre aux spécifications du réseau.

Configurez

Diagramme du réseau

Dans ce schéma de réseau, un domaine network/OSPF est utilisé. Le système exige que le trafic du routeur 5 (R5) à R1 (10.1.1.1) traverse toujours R3. Supposez que R3 est un Pare-feu dans le réseau par lequel tout les trafic devrait être conduit, ou que le lien entre R3 et R4 a plus de bande passante que le lien entre R2 et R4. Dans l'un ou l'autre de cas, le système exige que le trafic doit traverser R3 quand il passe de R5 à R1 (préfixe 10.1.1.1/32).

Configurations initiales

Cette section décrit les configurations initiales pour R1 par R5.

R1

!
interface Ethernet0/0
ip address 192.168.12.1 255.255.255.0
end

!
interface Loopback0
ip address 10.1.1.1 255.255.255.255
end

!
ip route 0.0.0.0 0.0.0.0 192.168.12.2
!

R2

!
interface Ethernet0/0
ip address 192.168.12.2 255.255.255.0
end

!
interface Ethernet0/1
ip address 192.168.23.2 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
end

!
interface Ethernet0/2
ip address 192.168.24.2 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Loopback0
ip address 10.2.2.2 255.255.255.255
end

!
ip route 10.1.1.1 255.255.255.255 192.168.12.1

!
router ospf 1
router-id 0.0.0.2
redistribute static metric-type 1 subnets
!

R3

!
interface Ethernet0/0
ip address 192.168.34.3 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Ethernet0/1
ip address 192.168.23.3 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
end

!
interface Loopback0
ip address 10.3.3.3 255.255.255.255
end

!
router ospf 1
router-id 0.0.0.3
!

R4

!
interface Ethernet0/0
ip address 192.168.34.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Ethernet0/1
ip address 192.168.45.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Ethernet0/2
ip address 192.168.24.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Loopback0
ip address 10.4.4.4 255.255.255.255
end

!
router ospf 1
router-id 0.0.0.4
!

R5

!
interface Ethernet0/1
ip address 192.168.45.5 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Loopback0
ip address 10.5.5.5 255.255.255.255
end

!
router ospf 1
router-id 0.0.0.5
!

Comportement par défaut

Avec les configurations précédentes en place, cette section décrit les comportements par défaut de routeur.

Voici le suivi de R5 à 10.1.1.1. Notez que le trafic traverse R2, pas R3 :

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 6 msec 6 msec 6 msec   <<< R4
2 192.168.24.2 6 msec 6 msec 8 msec   <<< R2
3 192.168.12.1 8 msec * 3 msec        <<< R1

Dans ce réseau, le routeur R4 doit prendre la décision et devrait conduire le trafic à R3, pas à R2 directement, selon la configuration système requise.

Voici un exemple de la table de routage sur R4 :

R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 30, type extern 1
Last update from 192.168.24.2 on Ethernet0/2, 00:14:33 ago
Routing Descriptor Blocks:
* 192.168.24.2, from 0.0.0.2, 00:14:33 ago, via Ethernet0/2 <<< Towards R2
Route metric is 30, traffic share count is 1

Une mesure de 30 est associée avec cette artère pour le préfixe 10.1.1.1/32. C'est dû à une mesure par défaut de 20 qui est utilisée par le routeur ASBR (Autonomous System Boundary Router) (R2) et un coût de 10 sur l'interface Eth0/2 sur R4.

Le chemin de R4 au préfixe 10.1.1.1/32 par l'intermédiaire de R3 est plus long. Ici, le coût pour les Ethernets 0/2 d'interface sur R4 (le chemin vers R2) est modifié afin de vérifier s'il change le comportement :

!
interface Ethernet0/2
ip address 192.168.24.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
ip ospf cost 100
end

Voici le suivi de R5 et de la sortie de commande de show ip route de R4 :

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 4 msec 9 msec 8 msec   <<< R4
2 192.168.24.2 8 msec 9 msec 10 msec  <<< R2
3 192.168.12.1 10 msec * 5 msec       <<< R1
R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 120, type extern 1
Last update from 192.168.24.2 on Ethernet0/2, 00:01:50 ago
Routing Descriptor Blocks:
* 192.168.24.2, from 0.0.0.2, 00:01:50 ago, via Ethernet0/2
  Route metric is 120, traffic share count is 1

Pendant que le suivi affiche, le trafic de R5 prend le même chemin, et le trafic ne circule pas par l'intermédiaire de R3. En outre, suivant les indications de la sortie de la commande de 10.1.1.1 de show ip route sur R4, le coût de 100 qui a été additionné sur R4 (Ethernets 0/2 d'interface) le prend effet et le coût de l'artère au préfixe est 120 (opposé à 30). Cependant, le chemin n'a toujours pas changé et l'exigence pour que le trafic circule à travers R3 n'est pas encore répondue.

Afin de déterminer la cause de ce comportement, voici la sortie de commande du show ip ospf border-routers R4 (le coût sur les Ethernets 0/2 de l'interface R4 est encore placé à 100) :

R4#show ip ospf border-routers
            OSPF Router with ID (0.0.0.4) (Process ID 1)
                Base Topology (MTID 0)
 Internal Router Routing Table
Codes: i - Intra-area route, I - Inter-area route

i 0.0.0.2 [100] via 192.168.24.2, Ethernet0/2, ABR/ASBR, Area 99, SPF 3
i 0.0.0.3 [10] via 192.168.34.3, Ethernet0/0, ABR, Area 99, SPF 3

Sur R4, vous pouvez voir qu'il y a deux Routeurs de cadre de zone (abr) (0.0.0.2, qui est R2, et de 0.0.0.3, qui est R3) et que R2 est l'ASBR. Cette sortie affiche également les informations de l'Intra-zone (i) pour l'ASBR.

Maintenant, l'Ethernet 0/2 d'interface est arrêté sur R4 afin de déterminer si la circulation par l'intermédiaire de R3 et afin de voir comment la sortie de commande de show ip ospf border-routers apparaît :

interface Ethernet0/2
ip address 192.168.24.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
ip ospf cost 100
shutdown 
end

Voici le suivi de R5 et de la sortie de commande de show ip route de R4 :

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 7 msec 7 msec 8 msec   <<< R4
2 192.168.34.3 9 msec 8 msec 8 msec   <<< R3
3 192.168.23.2 9 msec 9 msec 7 msec   <<< R2
4 192.168.12.1 8 msec * 4 msec        <<< R1
R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 40, type extern 1 <<< Metric 40
Last update from 192.168.34.3 on Ethernet0/0, 00:01:46 ago  <<< Traffic to R2
Routing Descriptor Blocks:
* 192.168.34.3, from 0.0.0.2, 00:01:46 ago, via Ethernet0/0
  Route metric is 40, traffic share count is 1

Comme affiché, quand l'Ethernet 0/2 d'interface est arrêté sur R4, le trafic traverse R3. En outre, le coût qui est associé avec l'artère vers R3 est seulement 40, alors que le coût vers 10.1.1.1/32 par l'intermédiaire de R2 était 120. Le protocole OSPF préfère toujours conduire le trafic par l'intermédiaire de R2 au lieu de R3, quoique le coût pour atteindre 10.1.1.1/32 soit inférieur par l'intermédiaire de R3.

Voici la sortie du show ip ospf border-routers de nouveau sur R4 :

R4#show ip ospf border-routers
           OSPF Router with ID (0.0.0.4) (Process ID 1)
               Base Topology (MTID 0)
Internal Router Routing Table
Codes: i - Intra-area route, I - Inter-area route

I 0.0.0.2 [20] via 192.168.34.3, Ethernet0/0, ASBR, Area 99, SPF 4
i 0.0.0.3 [10] via 192.168.34.3, Ethernet0/0, ABR, Area 99, SPF 4

Les informations qui sont exigées afin d'atteindre l'ASBR sont les informations d'Inter-zone. Cependant, les informations d'Intra-zone ces des détails comment atteindre l'ASBR sont préférées au-dessus des informations d'Inter-zone indépendamment du coût OSPF qui est associé avec les deux chemins.

Pour cette raison, le chemin par l'intermédiaire de R3 n'a pas été préféré, quoique le coût par l'intermédiaire de R3 soit inférieur.

Ici, l'Ethernet 0/2 d'interface est apporté sauvegarde sur R4 :

interface Ethernet0/2
no shutdown
end
!

Le suivi de R5 indique que conduisant des actions revenez à ceux précédemment observés (le trafic ne circule pas par l'intermédiaire de R3) :

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 6 msec 7 msec 7 msec   <<< R4
2 192.168.24.2 7 msec 8 msec 7 msec   <<< R2
3 192.168.12.1 8 msec * 12 msec       <<< R1

Il y a de diverses manières que vous pouvez résoudre ce problème (cette liste n'est pas exhaustive) :

  • Changez la zone entre R2 et R3 à 90, et puis modifiez le coût.

  • Ajoutez un autre lien entre R2 et R3 et configurez-le pour être dans la zone 99.

  • Multi-zone d'utilisation RÉGLABLE.

Référez-vous à la section suivante afin de voir la manière dans laquelle des travaux réglage OSPF de Multi-zone et comment elle peut résoudre ce problème actuel.

Configuration de contiguïté de Multi-zone

Comme précédemment mentionné, le réglage de Multi-zone peut être utilisé afin de former de plusieurs contiguïtés logiques point par point au-dessus d'un lien simple. La condition requise est qu'il doit y avoir seulement deux haut-parleurs OSPF sur le lien, et dans un réseau de diffusion, vous devez manuellement changer le type de réseau OSPF au Point à point sur le lien.

Cette caractéristique permet un lien physique simple à partager par de plusieurs zones et crée un chemin d'Intra-zone dans chacune des zones qui partagent le lien.

Afin de répondre à cette exigence, vous devez configurer le réglage de Multi-zone OSPF entre R2 et R3 au-dessus de l'Ethernet 0/1 de lien, qui est actuellement seulement dans la zone 0.

Voici la configuration pour R2 :

!
interface Ethernet0/1
ip address 192.168.23.2 255.255.255.0
ip ospf network point-to-point
ip ospf multi-area 99
ip ospf 1 area 0
end

Voici la configuration pour R3 :

!
interface Ethernet0/1
ip address 192.168.23.3 255.255.255.0
ip ospf network point-to-point
ip ospf multi-area 99
ip ospf 1 area 0
end

Le réglage OSPF est soulevé au-dessus de la liaison virtuelle :

%OSPF-5-ADJCHG: Process 1, Nbr 0.0.0.2 on OSPF_MA0 from LOADING to FULL, Loading Done

%OSPF-5-ADJCHG: Process 1, Nbr 0.0.0.3 on OSPF_MA0 from LOADING to FULL, Loading Done

Voici le réglage récemment formé :

R2#show ip ospf neighbor 0.0.0.3
<Snip>
Neighbor 0.0.0.3, interface address 192.168.23.3
   In the area 99 via interface OSPF_MA0
   Neighbor priority is 0, State is FULL, 6 state changes
   DR is 0.0.0.0 BDR is 0.0.0.0
   Options is 0x12 in Hello (E-bit, L-bit)
   Options is 0x52 in DBD (E-bit, L-bit, O-bit)
   LLS Options is 0x1 (LR)
   Dead timer due in 00:00:39
   Neighbor is up for 00:03:01
   Index 2/3, retransmission queue length 0, number of retransmission 0
   First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
   Last retransmission scan length is 0, maximum is 0
   Last retransmission scan time is 0 msec, maximum is 0 msec
R3#show ip ospf neighbor 0.0.0.2
<Snip>
Neighbor 0.0.0.2, interface address 192.168.23.2
   In the area 99 via interface OSPF_MA0
   Neighbor priority is 0, State is FULL, 6 state changes
   DR is 0.0.0.0 BDR is 0.0.0.0
   Options is 0x12 in Hello (E-bit, L-bit)
   Options is 0x52 in DBD (E-bit, L-bit, O-bit)
   LLS Options is 0x1 (LR)
   Dead timer due in 00:00:39
   Neighbor is up for 00:01:41
   Index 2/3, retransmission queue length 0, number of retransmission 0
   First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0
   Last retransmission scan length is 0, maximum is 0
   Last retransmission scan time is 0 msec, maximum is 0 msec

Vérifiez

Afin de vérifier si votre configuration fonctionne correctement, sélectionnez la commande de show ip ospf border-routers sur R4 :

R4#show ip ospf border-routers
           OSPF Router with ID (0.0.0.4) (Process ID 1)
                Base Topology (MTID 0)
Internal Router Routing Table
Codes: i - Intra-area route, I - Inter-area route

i 0.0.0.3 [10] via 192.168.34.3, Ethernet0/0, ABR, Area 99, SPF 10
i 0.0.0.2 [20] via 192.168.34.3, Ethernet0/0, ABR/ASBR, Area 99, SPF 10

Comme affiché, les informations d'Intra-zone qui sont utilisées afin de conduire le trafic à R2 (0.0.0.2)/ASBR sont par l'intermédiaire de R3. Ceci devrait résoudre le problème précédemment mentionné.

Voici le suivi de R5 :

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 8 msec 9 msec 8 msec   <<< R4
2 192.168.34.3 8 msec 8 msec 8 msec   <<< R3
3 192.168.23.2 7 msec 8 msec 8 msec   <<< R2
4 192.168.12.1 8 msec * 4 msec        <<< R1

Comme affiché, le trafic de R5 qui est destiné à 10.1.1.1 circule correctement par l'intermédiaire de R3, et la configuration système requise est répondu.

Sélectionnez la commande de show ip ospf neighbor sur R2, R3, et R4 afin de vérifier si l'ADJs sont établis :

R2#show ip ospf neighbor
Neighbor ID Pri  State    Dead Time  Address        Interface
0.0.0.3       0  FULL/ -  00:00:39   192.168.23.3   Ethernet0/1 
0.0.0.4       0  FULL/ -  00:00:37   192.168.24.4   Ethernet0/2
0.0.0.3       0  FULL/ -  00:00:33   192.168.23.3   OSPF_MA0 
R3#show ip ospf neighbor
Neighbor ID Pri  State    Dead Time  Address        Interface
0.0.0.2       0  FULL/ -  00:00:34   192.168.23.2   Ethernet0/1 
0.0.0.2       0  FULL/ -  00:00:35   192.168.23.2   OSPF_MA0 
0.0.0.4       0  FULL/ -  00:00:39   192.168.34.4   Ethernet0/0
R4#show ip ospf neighbor
Neighbor ID Pri  State    Dead Time  Address        Interface
0.0.0.2       0  FULL/ -  00:00:32   192.168.24.2   Ethernet0/2  
0.0.0.5       0  FULL/ -  00:00:32   192.168.45.5   Ethernet0/1
0.0.0.3       0  FULL/ -  00:00:35   192.168.34.3   Ethernet0/0

Remarque: Dans ces sorties, les entrées de l'interface Ethernet0/1 indiquent le réglage au-dessus de la zone 0, et les entrées de l'interface OSPF_MA0 indiquent le réglage de Multi-zone au-dessus de la zone 99.

L'Ethernet 0/2 de l'interface R4 a toujours un coût de 100, et le chemin par l'intermédiaire de R3 est préféré sur R4. Si ce coût est enlevé, alors les artères R4 trafiquent directement à R2 en tant qu'avant.

Voici la configuration et la sortie de commande de show ip route sur R4 avec l'ip ospf cost de 100 toujours configurés sur les Ethernets 0/2 de l'interface R4 :

!
interface Ethernet0/2
 ip address 192.168.24.4 255.255.255.0
 ip ospf network point-to-point
 ip ospf 1 area 99
 ip ospf cost 100
!
R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 40, type extern 1
Last update from 192.168.34.3 on Ethernet0/0, 00:28:45 ago
Routing Descriptor Blocks:
* 192.168.34.3, from 0.0.0.2, 00:28:45 ago, via Ethernet0/0
  Route metric is 40, traffic share count is 1

Voici la configuration et la sortie de commande de show ip route sur R4 quand vous enlevez le coût :

interface Ethernet0/2
ip address 192.168.24.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end
R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 30, type extern 1
Last update from 192.168.24.2 on Ethernet0/2, 00:00:13 ago
Routing Descriptor Blocks:
* 192.168.24.2, from 0.0.0.2, 00:00:13 ago, via Ethernet0/2 <<< Route changed back to R2
     Route metric is 30, traffic share count is 1

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.



Document ID: 118879