Collaboration : Cisco Unified Contact Center Express

La finesse Supervisor Desktop UCCX affiche toutes les files d'attente

15 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires

Introduction

Ce document décrit une question qui est produite avec le Cisco Unified Contact Center Express (UCCX) quand trop d'informations sont affichées sur la finesse Supervisor Desktop et décrivent également un contournement pour la question.

Contribué par Arundeep Nagaraj, ingénieur TAC Cisco.

Conditions préalables

Conditions requises

Cisco recommande que vous ayez la connaissance d'UCCX Versions10.0 et plus tard avec l'appareil de bureau de finesse.

Composants utilisés

Les informations dans ce document sont basées sur des versions 10.0 et ultérieures UCCX avec l'appareil de bureau de finesse.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Problème

La finesse Supervisor Desktop affiche des statistiques pour chaque file d'attente du service de contact (CSQ) qui est configurée dans UCCX sous le compte rendu succinct de la Voix CSQ. Cet état est un instrument encastré de vivant-données qui tire les informations vivantes du centre d'intelligence de Cisco Unified (CUIC).

On l'a observé que les superviseurs peuvent parfois voir toutes les files d'attente, indépendamment des équipes auxquelles ils sont assignés. Ceci devient un problème dans tout l'environnement de centre de contact parce que trop d'informations sont affichées.

Cause

Cette question se produit parce que les superviseurs pourraient également être configurés comme utilisateurs d'enregistrement. Quand un superviseur est incité pour être un utilisateur de rapport historique, le superviseur est également assigné au
Le groupe AllUsers.ReportingUsers, qui change la liste accessible de collections (élargit la portée).

La finesse Supervisor Desktop tire les données pour le compte rendu succinct de la Voix CSQ des données vivantes CUIC et affiche les entrées CSQ qui correspondent à la portée du superviseur, qui est maintenant tous les CSQ parce que le superviseur est également un utilisateur d'enregistrement.

Remarque: Par défaut, le superviseur est donné l'accès seulement aux états de vivant-données qui sont documentés dans le guide utilisateur d'état de Cisco Unified Contact Center Express 10.6(1).

Solution

Remarque: Cette question est dépistée comme demande d'amélioration sous l'ID de bogue Cisco CSCus17605.

Le contournement pour cette question réduit la portée des statistiques qui apparaissent sur la finesse Supervisor Desktop, qui comporte une modification le de l'affichage XML par l'intermédiaire de l'admin de finesse. Vous devez modifier l'URL pour chacun des instruments. Voici un exemple :

<https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?gadgetHeight=310&viewId=
A66DD5561000014600001A310A648114&filterId=ResourceIAQStats.resourceId=CL%20teamName>

Voici quelques informations importantes au sujet de cet exemple :

  • Quand seulement du CL est utilisé dans l'URL, l'état contient des valeurs pour toutes les collections pour lesquelles le superviseur prend l'autorisation.

  • Quand CL%20teamName est utilisé dans l'URL, le teamName est remplacé par le nom réel de l'équipe à laquelle le superviseur appartient ; ainsi, toutes les valeurs pour les équipes auxquelles le superviseur appartient sont affichées. Le teamName dans l'URL est un texte d'attente et est remplacé par la valeur réelle qui est passée par finesse au code d'instrument CUIC avant qu'il soit envoyé au serveur CUIC.

  • Quand CL%20Team1 est utilisé dans l'URL (avec la supposition que Team1 est le nom réel d'équipe), seulement les valeurs qui appartiennent à la collecte Team1 sont affichées.

Vous devez implémenter ces modifications aux instruments CSQ aussi bien. Pour plus d'informations sur l'URL d'instrument et les définitions d'instrument pour les données vivantes, référez-vous au guide d'administration de Cisco Unified CCX, version 10.6.

Remarque: Ce contournement devrait être évalué soigneusement une fois utilisé, comme modification doit être terminé sur l'affichage de bureau au niveau d'équipe. Vous pouvez ignorer l'affichage de paramètres systèmes par défaut quand édite sont faits au niveau d'équipe.


Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Document ID: 118823