Commutateurs : Commutateurs Cisco Catalyst, s�rie�3850

Conversion 3750 MLS à 3850 MQC de configuration QoS

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires

Introduction

Le document décrit la différence de base entre 3750 Qualité de service (QoS) multicouche et Interface MQC (Modular QoS CLI) QoS de la commutation (MLS) de Commutateurs de Cisco Catalyst 3850. Il fournit également les informations détaillées au sujet de la conversion par des configurations d'échantillon. Ce document s'applique seulement au QoS de câble. Ce document est pour les professionnels de réseau qui sont responsables de la conception, de l'implemention, ou de l'administation d'un réseau qui inclut un commutateur autonome de Cisco Catalyst 3850 ou un Cisco Catalyst 3850 piles de commutateurs, désigné sous le nom du commutateur.

Contribué par Jaroslaw Gawron et Vivek Sharma, ingénieurs TAC Cisco.

Conditions préalables

Conditions requises

Cisco vous recommande de prendre connaissance des rubriques suivantes :

  • Logiciel de Cisco IOS®
  • Concepts et terminologie de MLS et de MQC QoS

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Aperçu pour la différence entre 3750 mls qos et 3850 MQC QoS

La configuration de QoS dans la ligne 3850 a été due amélioré à son implémentation de configuration MQC (modèle universel de configuration QoS) au lieu des vieilles commandes de mls qos (configuration QoS plate--dépendante) des 3750 et 3560 lignes des Commutateurs.

Les principales différences sont mises en valeur dans cette table :

Commutez le type

3750

3850

Structure de base

MLS

MQC

Par défaut de QoS

Handicapé

Activé

Configuration globale

Mls qos de support

Prenez en charge une partie de MQC au d'entrée

Ne prend en charge pas le mls qos

Support MQC [class-map, policy-map]

Configuration d'interface

Prenez en charge le config de mls qos et une partie de MQC CLI au d'entrée

Reliez la stratégie à l'interface

Par défaut de confiance de port

Handicapé

Activé

D'entrée de port

Classification/maintien de l'ordre/inscription

Queue

Classification/maintien de l'ordre/marquage

[AUCUNE Mise en file d'attente d'Iingress !]

De sortie de port

Queue

Classification/maintien de l'ordre/marquage/Mise en file d'attente

D'entrée de Switch Virtual Interface (SVI)

Classification/maintien de l'ordre/marquage

Classification/marquage

De sortie SVI

Aucun

Classification/marquage

Il est important d'identifier le changement fondamental principal de l'approche de QoS.

Sur les 3750, par défaut le QoS est désactivé tandis que sur les 3850, il est activé. Afin de préserver également la couche 2 marquage (L2)/Layer 3 (L3) QoS sur la plate-forme 3750, une configuration de confiance doivent être appliqués.

Dans le cas des 3850, tous les paquets par défaut sont de confiance (le marquage L2/L3 QoS est préservé), à moins que vous le changiez avec une application d'une carte spécifique de stratégie sur le d'entrée ou l'interface de sortie.

Modèle de 3750 QoS

Modèle de 3850 QoS

Tableau de comparaison de détail de caractéristique

D'entrée

Caractéristique

3750

3850

Classification

Differentiated Services Code Point de correspondance de class-map (DSCP), priorité (Prec), liste de contrôle d'accès (ACL)

Prend en charge correspondance-tout deux et match any

Classe de service (Cos) de class-map, Prec, DSCP, ACL

Et VLAN

Prend en charge le match any seulement

Repérage

[positionnement sans conditions]

Set dscp et Prec

Set cos, Prec, DSCP et QoS-groupe

Repérage

[marquage conditionnel]

Mutation de DSCP

table-map de Classe-par défaut

Maintien de l'ordre

1r2c

1r2c et 2r3c

Maintien de l'ordre de la baisse

Le maintien de l'ordre dépasse la réduction

[Seulement DSCP de supports]

Le maintien de l'ordre dépasse et viole la réduction

[Cos, DSCP de supports, Prec]

Maintien de l'ordre d'agrégat

Supports

Agg-maintien de l'ordre [un type de HQoS]

Mise en file d'attente d'entrée

Les supports seulement sur 3750 mais ne les prend en charge pas sur 3750x

Ne le prend en charge pas

QoS hiérarchique (HQoS)

Le VLAN a basé HQoS seulement

Agg-maintien de l'ordre basé sur port et Par-VLAN (picovolte)

De sortie

Caractéristique

3750

3850

Soutien de classification d'aucun action de Mise en file d'attente

Ne le prend en charge pas

Cos, Prec, DSCP, QoS-groupe, ACL

et VLAN

Soutien de classification d'action de queue

Cos et DSCP

Cos, Prec, DSCP et QoS-groupe

Repérage

Ne le prend en charge pas

Set cos, Prec, et DSCP

Maintien de l'ordre

Ne le prend en charge pas

1r2c, 2r3c avec dépassent/violent la marque vers le bas par le table-map

Nombre maximum de files d'attente et de types de file d'attente

1P3Q3T [4 files d'attente]

Expédiez la file d'attente prioritaire de queue->

2P6Q3T [jusqu'à 8 files d'attente]

Mise en file d'attente de sortie

Mode de partage, mode de forme, queue-limit, priorité et file d'attente-mémoire tampon

Bande passante, bandwidth remaining, formation, queue-limit, priorité et file d'attente-mémoire tampon

HQoS

Ne le prend en charge pas

HQoS : Agg-maintien de l'ordre, picovolte, Port-modélisateur et modélisateur d'utilisateur de parent avec l'action de non-Mise en file d'attente d'enfant

Commandes show communes de QoS

3750

Commandes show d'entrée :

show run class-map  [name_of_class-map]
show run policy-map [name of policy-map]
show policy-map int [interface_name]

Commandes show générales :

show mls qos maps
show mls qos maps <options>
show mls qos queue-set
show mls qos interface [interface_name] queuing
show platform port-asic stats drop [interface_name] statistics
show mls qos aggregate-policer

3850

show run class-map [name_of_class-map]
show run policy-map [name of policy-map]
show table-map [name_of_table-map]
show run policy-map [name_of_policy-map]
show policy-map int [interface_name]
show platform qos policies port sw [sw#]
show platform qos queue config interface_type [interface_name]
show platform qos queue stats interface_type [interface_name]

3750 à l'échantillon de conversion de 3850 QoS

Config de QoS

3750

[Global]

           3750

        [Interface]

     3850 *

 

Lien témoin

Débronchement de QoS

Aucun mls qos

Deux files d'attente

File d'attente de Control-> (2)

Données - > file d'attente (4)

De sortie sans la stratégie

Contrôle - > queue(1)

Données - > queue(2)

Exemple 1

Confiance ou positionnement au d'entrée et au de sortie

Action de queue basée sur le d'entrée

Confiance ou positionnement

Mls qos

a)

Cos de mls qos trust

La stratégie de Mise en file d'attente de sortie classifient sur le cos [le cos de confiance de config du besoin d'entrée]

Exemple 2

b)

DSCP de mls qos trust

la stratégie de Mise en file d'attente de sortie classifient sur le DSCP

Exemple 3

c)

Politique d'entrée avec l'action de positionnement de marquer la valeur DSCP

La stratégie de Mise en file d'attente de sortie classifient sur le DSCP

Exemple 4

d)

Aucun config de mls qos trust [les deux CoS/DSCP seront placés zéro]

Politique d'entrée avec le classe-par défaut

Placez CoS/DSCP 0

Exemple 5

Mappage de file d'attente CoS/DSCP

Le mls qos a partagé la recherche séquentielle (SRR) - aligne la sortie [la Dscp-MAP CoS-map/]

A, b, c et d utiliseront le nouveau mappage correspondant

Sortez la classification explicite [CoS/DSCP] avec l'action de Mise en file d'attente

Exemple 6

Mutation de DSCP

Mutation de DSCP de mls qos

Configuration du besoin d'interface

DSCP de mls qos trust

Mls qos dscp-mutation [nom]

Politique d'entrée d'interface avec le table-map

Exemple 7

Agg-maintien de l'ordre

Mls qos aggregatepolicing

Configuration niveau de l'interface du besoin

Agg-maintien de l'ordre [un type de HQoS]

Exemple 8

Police-baisse

Mls qos map policed-dscp [10] [11] à [63]

En maintenant l'ordre la stratégie se reliant pour relier, dépassez pas la baisse, le maintenir l'ordre-DSCP global le prendra effet

[Entrée]

Un table-map pour dépassent et une action de forviolate de table-map du maintien de l'ordre

[Entrée et sortie]

Exemple 9

Queue-limit

La queue-set de mls qos a sorti le seuil [1] [100] [100] [50] [200] [1]

1-> queue-set 1

file d'attente 1 <1->

Seuil 1

Seuil 2

Mémoire tampon réservée

Seuil maximum

Queue-set [2] de config

[Queue-set par défaut 1]

Stratégie de Mise en file d'attente de sortie avec la configuration d'action et de queue-limit de Mise en file d'attente

Exemple 10

File d'attente-mémoires tampons

Mémoires tampons de la sortie [1] de queue-set de mls qos

[15] [25] [40] [20]

Queue-set de configuration d'interface

Policy-map avec l'action et le rapport [0-100] de Mise en file d'attente de file d'attente-mémoires tampons

Exemple 11

Partage/bande passante

Mls qos

Config de niveau d'interface

« Srr-queue bandwidth share 1 30 35 5" [mode de partage]

Bande passante dans le policy-map

Exemple 12

file d'attente prioritaire

[Expédiez la file d'attente]

Mls qos

Le config « priority-queue de niveau d'interface », ceci fera la 1ère file d'attente de la queue-set correspondante comme file d'attente prioritaire

Niveau de priorité 1 dans le policy-map

Exemple 13

Modélisateur

Mls qos

Srr-queue bandwidth shape [mode de forme]

Shape average dans le policy-map

Exemple 14

Port-modélisateur

Mls qos

Srr-queue bandwidth limit

Port-modélisateur

Exemple 15

HQoS

Mls qos

SVI [stratégie d'attache au SVI] et interface a besoin de configuration « mls qos VLAN_based »

Stratégie picovolte

Et stratégie d'attache au port à la direction d'entrée

Exemple 16

Exemple 1 : Débronchement de QoS

3750 (configuration globale)

3750 (interface)

3850

Aucun mls qos

File d'attente deux [file d'attente 2 de contrôle un, données une file d'attente 4]

 

De sortie sans la stratégie

[Paquets de contrôle dans file d'attente 1 et paquets de données dans file d'attente 2]

3750

3750#show mls qos
QoS is disabled <- disable
QoS ip packet dscp rewrite is enabled

3750#show mls qos interface gig1/0/1 statistics | b output queues enqueued
output queues enqueued:
queue: threshold1 threshold2 threshold3
-----------------------------------------------
queue 0: 4 0 0
queue 1: 0 0 0 <- control
queue 2: 0 0 0
queue 3: 0 0 0 <- data

output queues dropped:
queue: threshold1 threshold2 threshold3
-----------------------------------------------
queue 0: 0 0 0
queue 1: 0 0 0 <- control
queue 2: 0 0 0
queue 3: 0 0 0 <- data

Policer: Inprofile: 0 OutofProfile: 0

3850

3850#show ru int gig1/0/1
interface GigabitEthernet1/0/1
end

3850#show platform qos queue config gigabitEthernet 1/0/1 sw 1
DATA Port:21 GPN:1 AFD:Disabled QoSMap:0 HW Queues: 168 - 175
DrainFast:Disabled PortSoftStart:1 - 600
----------------------------------------------------------
DTS Hardmax Softmax PortSMin GlblSMin PortStEnd
--- -------- -------- -------- --------- ---------
0 1 5 120 6 480 0 0 0 0 0 800 <- control
1 1 4 0 7 720 2 480 2 180 2 800 <- data
2 1 4 0 5 0 0 0 0 0 0 800
3 1 4 0 5 0 0 0 0 0 0 800
4 1 4 0 5 0 0 0 0 0 0 800
5 1 4 0 5 0 0 0 0 0 0 800
6 1 4 0 5 0 0 0 0 0 0 800
7 1 4 0 5 0 0 0 0 0 0 800
Priority Shaped/shared weight shaping_step
-------- ------------ ------ ------------
0 0 Shared 50 0
1 0 Shared 75 0
2 0 Shared 10000 179
3 0 Shared 10000 0
4 0 Shared 10000 0
5 0 Shared 10000 0
6 0 Shared 10000 192
7 0 Shared 10000 0

Weight0 Max_Th0 Min_Th0 Weigth1 Max_Th1 Min_Th1 Weight2 Max_Th2 Min_Th2
------- ------- ------ ------ ------ ------ ------ ------ ------
0 0 478 0 0 534 0 0 600 0
1 0 573 0 0 641 0 0 720 0
2 0 0 0 0 0 0 0 0 0
3 0 0 0 0 0 0 0 0 0
4 0 0 0 0 0 0 0 0 0
5 0 0 0 0 0 0 0 0 0
6 0 0 0 0 0 0 0 0 0
7 0 0 0 0 0 0 0 0 0

Exemple 2 : COS de confiance d'enable de QoS

3750 (global)

3750 (interface)

3850

Mls qos

Interface « cos de mls qos trust » (basé sur le Cos-mappage par défaut à la queue-set 1)

Stratégie de Mise en file d'attente de sortie basée sur le cos (cos de confiance de config du besoin d'entrée)

 

3750

Global config:
3750(config)#mls qos

Interface config:

interface GigabitEthernet1/0/1
mls qos trust cos

Related show cli:

3750#sh mls qos
QoS is enabled
QoS ip packet dscp rewrite is enabled

3750#sh mls qos int gig1/0/1
GigabitEthernet1/0/1
trust state: trust cos
trust mode: trust cos
trust enabled flag: ena
COS override: dis
default COS: 0
DSCP Mutation Map: Default DSCP Mutation Map
Trust device: none
qos mode: port-based

3750 #show mls qos maps cos-output-q
Cos-outputq-threshold map:
cos: 0 1 2 3 4 6 7
------------------------------------------------------------
queue-threshold: 2-1 2-1 3-1 3-1 4-1 1-1 4-1 4-1

Note: cos value 0 maps to 2-1 [queue-set1 : queue2 threshold 1]

3850

Ingress: apply policy-map trust-cos
Egress: create class based on cos and have queuing action for each class

Ingress policy:
3850#show run policy-map trust-cos
class class-default
set cos cos table default

3850#show table-map default
Table Map default
default copy

Egress policy:
3850#show run policy-map example2
class cos5
bandwidth percent 15
class cos0_1
bandwidth percent 25
class cos2_3
bandwidth percent 40
class cos4_6_7
bandwidth percent 20

3850#show run class-map cos5
class-map match-any cos5
match cos 5

3850#show run class-map cos0_1
class-map match-any cos0_1
match cos 0
match cos 1

3850#show run class-map cos2_3
class-map match-any cos2_3
match cos 2
match cos 3

3850#show run class-map cos4_6_7
class-map match-any cos4_6_7
match cos 4
match cos 6
match cos 7

Exemple 3 : DSCP de confiance d'enable de QoS

3750 (global)

3750 (interface)

3850

Mls qos

Interface « DSCP de mls qos trust » [basé sur le Dscp-mappage par défaut à la queue-set 1]

DSCP par défaut de confiance d'entrée

Stratégie de Mise en file d'attente de sortie basée sur le DSCP

3750

config
3750(config)#mls qos <- Global
interface GigabitEthernet1/0/1 <- Interface
mls qos trust dscp


3750#sh mls qos int gig1/0/1
GigabitEthernet1/0/1
trust state: trust dscp
trust mode: trust dscp
trust enabled flag: ena
COS override: dis
default COS: 0
DSCP Mutation Map: Default DSCP Mutation Map
Trust device: none
qos mode: port-based

3750#show mls qos maps dscp-output-q
Dscp-outputq-threshold map:
d1 :d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------------------------------
0 : 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01
1 : 02-01 02-01 02-01 02-01 02-01 02-01 03-01 03-01 03-01 03-01
2 : 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01
3 : 03-01 03-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01
4 : 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 04-01 04-01
5 : 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01
6 : 04-01 04-01 04-01 04-01

3850

Ingress: default trust dscp, no policy needed

Egress: use dscp as classification and add queuing action based on customer need

One Sample config:
Plolicy-map:
3850#show run policy-map dscp-shape
class dscp56
shape average percent 10
class dscp48
shape average percent 11
class dscp40
shape average percent 12
class dscp32
shape average percent 13
Class-map:
3850#show run class-map dscp56
class-map match-any dscp56
match dscp cs7

3850#show run class-map dscp48

class-map match-any dscp48
match dscp cs6

3850#show run class-map dscp40
class-map match-any dscp40
match dscp cs5

3850#show run class-map dscp32
class-map match-any dscp32
match dscp cs4

Exemple 4 : Enable de QoS avec une interface qui a une stratégie de positionnement

3750 (global)

3750 (interface)

3850

Mls qos

Reliez la politique d'entrée avec l'action de positionnement de marquer la valeur CoS/DSCP

[La valeur marquée sera utilisée pour le mappage de sortie]

Stratégie explicite de sortie du besoin pour faire le mappage de Mise en file d'attente

3750

3750#show run class-map dscp-1
class-map match-any dscp-1
match ip dscp 1

c3750#show run policy-map set-dscp-63
class dscp-1
set dscp 63

3750#show run int f7/0/2
interface FastEthernet7/0/2
mls qos trust dscp
service-policy input set-dscp-63

3750#show policy-map int f7/0/2
FastEthernet7/0/2

Service-policy input: set-dscp-63

Class-map: dscp-1 (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp 1

Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
0 packets, 0 bytes
5 minute rate 0 bps

Note: Pkts come in interface fa7/0/2, dscp1 will be marked to dscp63 which mapping
based on the existing mapping table, other pkts will retain original dscp value
mapping accordingly

3850

Input will be same as 3750 config 

Egress: will add queuing action under class dscp-63


One sample config:

3850#show run policy-map dscp63-queuing
class dscp63
bandwidth percent 50

3850#show class-map dscp63
Class Map match-any dscp63

Match dscp 63

Exemple 5 : Enable de QoS sans le mls qos trust sur l'interface

3750 (global)

3750 (interface)

3850

Mls qos

Mls qos trust CoS/DSCP de config d'interface pas

[CoS/DSCP sera placé à 0]

Politique d'entrée d'interface avec le classe-par défaut

Set dscp 0, stratégie de sortie avec la classe DSCP0 avec l'action de Mise en file d'attente

3750

Global:
c3750(config)#mls qos

Interface:
interface GigabitEthernet2/0/45
!

3850

Input policy:
c3850#show run policy-map example5-input
class class-default
set dscp default

Output policy:
c3850#show run policy-map example5-output
class dscp0
shape average percent 10 <- queuing action based on customer need

Attach to the ingress port:
c3850#show run int gig1/0/1
interface GigabitEthernet1/0/1
service-policy input example5-input

Attach to the egress port:
c3850#show ru int gig1/0/2
interface GigabitEthernet1/0/2
service-policy output example5-output

Exemple 6 : Enable de QoS avec le mappage de file d'attente de la modification CoS/DSCP

3750 (global)

3750 (interface)

3850

Config de mappage de SRR-file d'attente de mls qos

(SRR-file d'attente de mls qos sortie [seuil [3] [4 5] de file d'attente [1] de Cos-MAP)

A, b, c et d utiliseront la nouvelle table de mappage

[Le cos 4 et 5 sera carte pour aligner 1 seuil 3]

Classification explicite de sortie avec l'action de Mise en file d'attente

3750

Before config:
3750#show mls qos maps cos-output-q
Cos-outputq-threshold map:
cos: 0 1 2 3 4 5 6 7
------------------------------------------------
queue-threshold: 2-1 2-1 3-1 3-1 4-1 1-1 4-1 4-1

User config mapping:
3750(config)#mls qos srr-queue output cos-map queue 3 threshold 3 0

New mapping table after config
3750#show mls qos maps cos-output-q
Cos-outputq-threshold map:
cos: 0 1 2 3 4 5 6 7
------------------------------------------------
queue-threshold: 3-3 2-1 3-1 3-1 4-1 1-1 4-1 4-1

3850

Input : need apply trust-cos policy:
3850#show run policy-map trust-cos
class class-default
set cos cos table default

3850#show table-map default
Table Map default
default copy


Egress policy:

Before changing mapping:
Sample config:
3850#show run policy-map example2
class cos5
bandwidth percent 15
class cos0_1
bandwidth percent 25
class cos2_3
bandwidth percent 40
class cos4_6_7
bandwidth percent 20

3850#show run class-map cos5
class-map match-any cos5
match cos 5

3850#show run class-map cos0_1
class-map match-any cos0_1
match cos 0
match cos 1

3850#show run class-map cos2_3
class-map match-any cos2_3
match cos 2
match cos 3

3850#show run class-map cos4_6_7
!
class-map match-any cos4_6_7
match cos 4
match cos 6
match cos 7

After mapping changing , corresponding sample config:

3850#show run policy-map example6
class cos5
bandwidth percent 15
class cos1
bandwidth percent 25
class cos0_2_3
bandwidth percent 40
class cos4_6_7
bandwidth percent 20

3850#show class-map cos5
Class Map match-any cos5 (id 25)
Match cos 5

3850#show run class-map cos1
class-map match-any cos1
match cos 1

3850#show run class-map cos0_2_3
class-map match-any cos0_2_3
match cos 0
match cos 2
match cos 3

3850#show run class-map cos4_6_7
class-map match-any cos4_6_7
match cos 4
match cos 6
match cos 7

Exemple 7 : Enable MLS avec la mutation de DSCP

3750 (global)

3750 (interface)

3850

Mutation de DSCP de mls qos

DSCP de mls qos trust de config du besoin d'interface

Nom de mls qos dscp-mutation [le nom est défini dans global]

Politique d'entrée d'interface avec le table-map traçant le différent DSCP

3750

Global config :
3750(config)#mls qos map dscp-mutation dscp-mutation 0 1 to 63
3750(config)#mls qos map dscp-mutation dscp-mutation 2 3 to 62

Global show cli:
c3750#show mls qos maps dscp-mutation

Dscp-dscp mutation map:
dscp-mutation:
d1 : d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------
0 : 63 63 62 62 04 05 06 07 08 09
1 : 10 11 12 13 14 15 16 17 18 19
2 : 20 21 22 23 24 25 26 27 28 29
3 : 30 31 32 33 34 35 36 37 38 39
4 : 40 41 42 43 44 45 46 47 48 49
5 : 50 51 52 53 54 55 56 57 58 59
6 : 60 61 62 63
Dscp-dscp mutation map:
Default DSCP Mutation Map:
d1 : d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------
0 : 00 01 02 03 04 05 06 07 08 09
1 : 10 11 12 13 14 15 16 17 18 19
2 : 20 21 22 23 24 25 26 27 28 29
3 : 30 31 32 33 34 35 36 37 38 39
4 : 40 41 42 43 44 45 46 47 48 49
5 : 50 51 52 53 54 55 56 57 58 59
6 : 60 61 62 63

Interface config:

interface FastEthernet7/0/3
description trust dscp
mls qos trust dscp
mls qos dscp-mutation dscp-mutation

c3750#show mls qos int f7/0/3
FastEthernet7/0/3
trust state: trust dscp
trust mode: trust dscp
trust enabled flag: ena
COS override: dis
default COS: 0
DSCP Mutation Map: dscp-mutation
Trust device: none
qos mode: port-based

Interface using default dscp-table:

c3750#show mls qos int g3/0/1
GigabitEthernet3/0/1
trust state: not trusted
trust mode: not trusted
trust enabled flag: ena
COS override: dis
default COS: 0
DSCP Mutation Map: Default DSCP Mutation Map
Trust device: none
qos mode: port-based

3850

Ingress : apply policy with dscp table-map
Egress: classify on new dscp value with queuing action

Ingress:
3850#show table-map dscp-2-dscp
Table Map dscp-2-dscp
from 0 to 63
from 1 to 63
from 2 to 62
from 3 to 62
default copy
3850#show run policy-map example7-input
class class-default
set dscp dscp table dscp-2-dscp

Egress:
3850#show run policy-map example7-output

class dscp63
shape average percent 20 [ queuing action based on the user need]
class dscp62
shape average percent 30 [queuing action based on user need]

Exemple 8 : Le mls qos active avec le maintien de l'ordre d'agrégat

3750 (global)

3750 (interface)

3850

Le mls qos agrège le maintien de l'ordre

[Toutes les classes utilisant l'agg-maintien de l'ordre partageront le débit de maintien de l'ordre]

Config de niveau d'interface du besoin

Agg-maintien de l'ordre (HQoS)

Mls qos aggregate-policer 8000 agg_traffic baisse de 8000 exceeds-action

Reliez avoir une stratégie qui a agg_traffic en tant que nom de régulateur d'agg

3750

Global:
mls qos aggregate-policer agg_traffic 8000 8000 exceed-action drop

Access-list:
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 2 permit 10.0.0.0 0.0.0.255

Class-map:
class-map match-all agg1
match access-group 1
class-map match-all agg2
match access-group 2

Policy-map:
policy-map agg_policer
class agg1
set dscp 40
police aggregate agg_traffic
class agg2
set dscp 55
police aggregate agg_traffic

Note: class agg1 and agg2 will share the same policing rate

3850

policy-map agg_police
class class-default
police cir 8000
service-policy child

policy-map child
class agg1
set dscp 40
class agg2
set dscp 55

Exemple 9 : Enable MLS avec maintenir l'ordre la marque vers le bas

3750 (configuration globale)

3750 (interface)

3850

Mls qos map policed-dscp X à y

Tant que l'interface a maintenir l'ordre la stratégie, dépassez est transmet, le CLI global le prendra effet [entrée seulement]

Un table-map pour dépassent et on pour violent l'action du maintien de l'ordre, de l'entrée, et de la sortie

3750

Default policed-dscp map:
3750#show mls qos map policed-dscp
Policed-dscp map:
d1 : d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------
0 : 00 01 02 03 04 05 06 07 08 09
1 : 10 11 12 13 14 15 16 17 18 19
2 : 20 21 22 23 24 25 26 27 28 29
3 : 30 31 32 33 34 35 36 37 38 39
4 : 40 41 42 43 44 45 46 47 48 49
5 : 50 51 52 53 54 55 56 57 58 59
6 : 60 61 62 63

User define policed-dscp map:
3750(config)#mls qos map policed-dscp 0 10 18 24 46 to 8
3750#show mls qos map policed-dscp
Policed-dscp map:
d1 : d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------
0 : 08 01 02 03 04 05 06 07 08 09
1 : 08 11 12 13 14 15 16 17 08 19
2 : 20 21 22 23 08 25 26 27 28 29
3 : 30 31 32 33 34 35 36 37 38 39
4 : 40 41 42 43 44 45 08 47 48 49
5 : 50 51 52 53 54 55 56 57 58 59
6 : 60 61 62 63

Policy config:
class-map match-all policed-dscp
match access-group 2
class policed-dscp
police 8000 8000 exceed-action policed-dscp-transmit

Attach the above policy at ingress:

Note : Mark down table can be used by policing and interface policing
as long as exceed action is transmit

3850

3850(config)#table-map policed-dscp
3850(config-tablemap)#map from 0 to 8
3850(config-tablemap)#map from 10 to 8
3850(config-tablemap)#map from 18 to 8
3850(config-tablemap)#map from 24 to 8
3850(config-tablemap)#map from 46 to 8
3850#show table-map policed-dscp
Table Map policed-dscp
from 0 to 8
from 10 to 8
from 18 to 8
from 24 to 8
from 46 to 8
default copy

3850#show policy-map policed-dscp
Policy Map policed-dscp
Class class-default
police cir percent 10
conform-action transmit
exceed-action set-dscp-transmit dscp table policed-dscp

Exemple 10 : Le mls qos active avec la configuration de queue-limit

3750 (global)

3750 (interface)

3850

La queue-set de mls qos a sorti 1 seuil 1100 100 50 200 (la queue-limit)

[1 - >queue-set 1,

file d'attente 1->first,

100 - >threshold 1,

100 - >threshold 2,

50 - > a réservé la mémoire tampon,

200 - > seuil maximum]

Queue-set de configuration d'interface

[Le par défaut est la queue-set 1]

Stratégie de Mise en file d'attente de sortie avec le config d'action et de q-limite de Mise en file d'attente

3750

Global config:
mls qos srr-queue output cos-map queue 2 threshold 1 2
mls qos srr-queue output cos-map queue 2 threshold 2 3
mls qos srr-queue output cos-map queue 2 threshold 3 6 7


If no interface config, the queue-set 1 will be used:

3750#show mls qos queue-set 1
Queueset: 1
Queue : 1 2 3 4
----------------------------------------------
buffers : 15 25 40 20
threshold1: 100 125 100 60
threshold2: 100 125 100 150
reserved : 50 100 100 50
maximum : 200 400 400 200

For interface config queue-set 2 explicitly:

3750#show mls qos queue-set 2
Queueset: 2
Queue : 1 2 3 4
----------------------------------------------
buffers : 25 25 25 25
threshold1: 100 200 100 100
threshold2: 100 200 100 100
reserved : 50 50 50 50
maximum : 400 400 400 400

3850

(multiple class with queue-limit turn on)
3850#show policy-map q-limit
Policy Map q-limit
Class users-class
Queuing action ( shaper, bandwidth and bandwidth remaining)
queue-limit cos 2 percent 50
queue-limit cos 3 percent 50
queue-limit cos 6 percent 70
queue-limit cos 7 percent 70
Note: using the above config, cos 2 and cos 3 will be dropped earlier then cos 6 and 7

Exemple 11 : Le mls qos active avec la configuration de File d'attente-mémoire tampon

3750 (global)

3750 (interface)

3850

La queue-set de mls qos a sorti les mémoires tampons [15 25 [1] 40 20]

Queue-set de configuration d'interface [queue-set par défaut 1]

Policy-map avec l'action et le rapport [0-100] de Mise en file d'attente de file d'attente-mémoires tampons

3750

Default queue-buffer :
3750#show mls qos queue-set 1
Queueset: 1
Queue : 1 2 3 4
----------------------------------------------
buffers : 25 25 25 25
threshold1: 100 200 100 100
threshold2: 100 200 100 100
reserved : 50 50 50 50
maximum : 400 400 400 400

User define queue-buffer:
mls qos queue-set output 1 buffers 15 25 40 20

3750#show mls qos queue-set 1
Queueset: 1
Queue : 1 2 3 4
----------------------------------------------
buffers : 15 25 40 20
threshold1: 100 125 100 60
threshold2: 100 125 100 150
reserved : 50 100 100 50
maximum : 200 400 400 200

3850

3850#show policy-map  queue-buffer
Policy Map queue-buffer
Class cos7
bandwidth percent 10
queue-buffers ratio 15
Class cos1
bandwidth percent 30
queue-buffers ratio 25

class-map:
========
3850#show class-map cos7
Class Map match-any cos7 (id 22)

Match cos 7

3850#show class-map cos1
Class Map match-any cos1 (id 28)

Match cos 1

Attach to the interface at egress direction:

Exemple 12 : Le mls qos active avec la configuration de bande passante

3750 (global)

3750 (interface)

3850

Mls qos (mode de partage)

Config de niveau d'interface

« Srr-queue bandwidth share 1 30 35 5"

Bande passante dans le policy-map

3750

Default share and shape mode:
3750-3stack#show mls qos interface gig 1/0/1 queueing
GigabitEthernet1/0/1
Egress Priority Queue : disabled
Shaped queue weights (absolute) : 25 0 0 0
Shared queue weights : 25 25 25 25
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1

User config share mode under interface:
interface GigabitEthernet1/0/1
srr-queue bandwidth share 40 30 20 10
srr-queue bandwidth shape 0 0 0 0


3750#show mls qos interface gig1/0/1 queueing
GigabitEthernet1/0/1
Egress Priority Queue : disabled
Shaped queue weights (absolute) : 0 0 0 0
Shared queue weights : 40 30 20 10
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1

3850

3850#show policy-map  bandwidth
Policy Map bandwidth
Class cos1
bandwidth percent 40
Class cos2
bandwidth percent 30
Class cos3
bandwidth percent 20
Class class-default
bandwidth percent 10
3850#show class-map cos1
Class Map match-any cos1

Match cos 1

3850#show class-map cos2
Class Map match-any cos2

Match cos 2

3850#show class-map cos3
Class Map match-any cos3 (id 26)

Match cos 3

3850#show class-map cos4
Class Map match-any cos4 (id 25)

Match cos 4

Exemple 13 : Le mls qos active avec la priorité

3750 (global)

3750 (interface)

3850

Mls qos [expédiez la file d'attente]

Remarque: expédiez la file d'attente mêmes que la file d'attente prioritaire

Config « priority-queue de niveau d'interface » [faites la 1ère file d'attente de la queue-set correspondante en tant que file d'attente prioritaire stricte]

Niveau 1 de Prioriy dans le policy-map

3750

interface GigabitEthernet1/0/2
priority-queue out
end

3750#show mls qos interface gig1/0/2 queueing
GigabitEthernet1/0/2
Egress Priority Queue : enabled
Shaped queue weights (absolute) : 25 0 0 0
Shared queue weights : 25 25 25 25
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1

3850

3850#show run policy-map  priority-queue
class cos7
priority level 1 ? strict priority
class cos1
shape average percent 10
Attach the above policy to interface at egress side:

Exemple 14 : Le mls qos active avec la configuration de modélisateur

3750

Default shape mode:
GigabitEthernet1/0/3
Egress Priority Queue : disabled
Shaped queue weights (absolute) : 25 0 0 0
Shared queue weights : 25 25 25 25
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1

User define shape mode:
interface GigabitEthernet1/0/3
srr-queue bandwidth shape 4 4 4 4


3750-3stack#show mls qos interface gigabitEthernet 1/0/3 queueing
GigabitEthernet1/0/3
Egress Priority Queue : disabled
Shaped queue weights (absolute) : 4 4 4 4
Shared queue weights : 25 25 25 25
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1

3850

3850#show policy-map shape
Policy Map shape
Class cos1
Average Rate Traffic Shaping
cir 25%
Class cos2
Average Rate Traffic Shaping
cir 25%
Class cos3
Average Rate Traffic Shaping
cir 25%
Class cos4
Average Rate Traffic Shaping
cir 25%

Exemple 15 : Le mls qos active avec la bande passante

3750 (global)

3750 (interface)

3850

Mls qos

Srr-queue bandwidth limit

Vitesse, bande passante

3750

interface GigabitEthernet1/0/4
srr-queue bandwidth limit 50


3750-3stack#show mls qos interface g1/0/4 queueing
GigabitEthernet1/0/4
Egress Priority Queue : disabled
Shaped queue weights (absolute) : 25 0 0 0
Shared queue weights : 25 25 25 25
The port bandwidth limit : 50 (Operational Bandwidth:50.0)
The port is mapped to qset : 1

3850

3850#show policy-map default-shape
Policy Map default-shape
Class class-default
Average Rate Traffic Shaping
cir 50%
service-policy child [ queuing based on customer need]

Exemple 16 : HQoS

3750 (configuration globale)

3750 (interface)

3850

Class-map,

Policy-map

Stratégie d'attache au SVI

L'interface a besoin de configuration « mls qos vlan_based »

Stratégie d'entrée picovolte

3750

Note:
SVI: Parent [class acl based class-map->policing]

Child [class interface range class-map->marking]


Child class-map:

3750(config)# class-map cm-interface-1
3750(config-cmap)# match input gigabitethernet3/0/1 - gigabitethernet3/0/2

Child policy-map:
3750(config)# policy-map port-plcmap-1
3750(config-pmap)# class cm-interface-1
3750(config-pmap-c)# police 900000 9000 drop


Parent class-map matching acl:
3750(config)# access-list 101 permit ip any any

Parent class-map:
3750(config)# class-map cm-1
3750(config-cmap)# match access 101

3750(config)# policy-map vlan-plcmap
3750(config-pmap)# class cm-1
3750(config-pmap-c)# set dscp 7
3750(config-pmap-c)# service-policy port-plcmap-1
3750(config-pmap-c)# exit
3750(config-pmap)# class cm-2
3750(config-pmap-c)# service-policy port-plcmap-1
3750(config-pmap-c)# set dscp 10

Attach the policy to the interface:
3750(config)# interface vlan 10
3750(config-if)# service-policy input vlan-plcmap

3850

Note: Due to target change, this can't be one to one mapping, need config based on
customer requirement.


Target is at port level
Parent classify on vlan
Child: none vlan classification [for example cos/dscp]


3850#sh run policy-map PV_parent_marking_child_policing
class vlan10
set dscp 63
service-policy child_class_dscp_policing
class vlan11
set cos 5
service-policy child_class_dscp_policing
class vlan12
set precedence 6
service-policy child_class_dscp_policing

3850#sh run policy-map child_class_dscp_policing
class dscp1
police cir percent 12
class dscp2
police cir percent 15
class dscp3
police cir percent 20
class class-default
police cir percent 22

3850#sh run class-map vlan10
class-map match-any vlan10
match vlan 10

3850#sh run class-map vlan11
class-map match-any vlan11
match vlan 11

3850#sh run class-map vlan12
class-map match-any vlan12
match vlan 12

3850#sh run class-map dscp1
class-map match-any dscp1
match dscp 1

3850#sh run class-map dscp2
class-map match-any dscp2
match dscp 2

3850#sh run class-map dscp3
class-map match-any dscp3
match dscp 3


Document ID: 118629