Commutateurs : Commutateurs de la gamme Cisco Nexus 1000V

Exemples de configuration de Port canalisé de Commutateurs de gamme du Nexus 1000V

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires

Introduction

Ce document décrit les pratiques recommandées de utiliser quand vous déployez des Ports canalisés sur la gamme de Cisco Nexus 1000V commutez (N1KV). Le N1KV exige des Ports canalisés pour les profils de port qui contiennent plus d'une interface par hôte.

Contribué par Carlos Lopez et Matthew Wronkowski, ingénieurs TAC Cisco.

Conditions préalables

Conditions requises

Cisco vous recommande de prendre connaissance des rubriques suivantes :

  • N1KV
  • Système d'informatique unifiée Cisco (UCS)
  • Cisco Nexus et Commutateurs de gamme de Catalyst

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • N1KV
  • UCS

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Configurez

Cette section contient ces configurations :

N1KV sur des serveurs de B-gamme UCS en mode de Fin-hôte

Le Cisco UCS utilise deux chemins divers entre la lame et le réseau en amont. Actuellement, la matrice Interconnects ne font pas Port canalisé du Control Protocol d'agrégation de support (LACP) /Virtual (vpc) allant vers le sud vers les lames. Ceci signifie qu'un Port canalisé statique du point de vue N1KV doit être utilisé. Goupiller de MAC est exigé, puisque les Commutateurs en amont ne prennent en charge pas l'EtherChannel de multichassis.

# VSM configuration
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode on mac-pinning
no shutdown
system vlan 100,101,102,103
state enabled

# Upstream switch configuration
-None required

N1KV sur des serveurs d'UCS série C ou des serveurs de montage sur bâti s'est connecté aux Commutateurs du Nexus 5000/7000 au vpc

Dans cette topologie, chaque serveur rack est physiquement connecté à deux Commutateurs différents de Nexus - un câble à chaque commutateur. Le LACP est le mode préféré, parce qu'il permet la meilleure distribution du trafic et l'ajout/soustraction non perturbateurs des liens. On le suppose que les Commutateurs en amont de Nexus ont déjà un lien de pair de vpc configuré.

# VSM configuration
feature lacp
lacp offload
port-channel load-balance ethernet source-mac
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode active
no shutdown
system vlan 100,101,102,103
state enabled

# Nexus 5k/7k switches #1 & #2 configuration
interface port-channel1000
switchport mode trunk
vpc 1000
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable

no lacp suspend-individual <- Nexus 7k only!!!
!
interface Ethernet1/11
description ESX-Host1
switchport mode trunk
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode active

N1KV sur des serveurs d'UCS série C ou des serveurs de montage sur bâti s'est connecté aux Commutateurs sans vpc

Dans cette topologie, chaque serveur rack est physiquement connecté à deux Commutateurs différents, mais le vpc n'est pas disponible. La seule configuration prise en charge est goupiller de MAC. Cette configuration est identique à cela utilisée sur des serveurs de B-gamme UCS. Un Port canalisé statique (mode en fonction) n'est pas pris en charge, puisque les Commutateurs en amont ne prennent en charge pas une technologie EtherChannel de multichassis.

# VSM configuration
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode on mac-pinning
no shutdown
system vlan 100,101,102,103
state enabled

# Upstream switch configuration
-None required

N1KV sur des serveurs d'UCS série C ou des serveurs de montage sur bâti connectés à 6500 VSS ou à Commutateurs d'empilement

Dans cette topologie, les Commutateurs en amont agissent en tant que châssis unique. Ceci permet au N1KV pour se connecter au LACP.

# VSM configuration
feature lacp
lacp offload
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode active
no shutdown
system vlan 100,101,102,103
state enabled

# 6500 VSS configuration
interface Port-channel1000
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100-103,200-300
switchport mode trunk
spanning-tree portfast edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
!
interface GigabitEthernet1/1/1
description ESX-Host1 adapter 1
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100-103,200-300
switchport mode trunk
spanning-tree portfast edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode active
!
interface GigabitEthernet2/1/1
description ESX-Host1 adapter 2
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100-103,200-300
switchport mode trunk
spanning-tree portfast edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode active

N1KV sur des serveurs d'UCS série C ou des serveurs de montage sur bâti connectés à un commutateur en amont simple à un Port canalisé statique

Dans cette topologie, les serveurs simple-sont autoguidés à un commutateur en amont. Cette topologie ne fournit aucune Redondance de commutateur et n'est pas une pratique recommandée.

# VSM configuration
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode on
no shutdown
system vlan 100,101,102,103
state enabled

# Upstream Nexus switch
interface port-channel 1000
switchport mode trunk
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
!
interface Ethernet1/11
description ESX-Host1
switchport mode trunk
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode on

Vérifiez

Utilisez cette section pour confirmer que votre configuration fonctionne correctement.

show run interface po{X} membership
show port-channel summary

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

show port-channel summary
show port-channel internal event-history [all|errors]debug lacp all

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Document ID: 116739