Voix et communications unifiées : Cisco Unity Connection

Qualité audio pauvre CUC avec le VMware

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires

Introduction

Ce document décrit le processus pour l'identifier si les questions de qualité audio sont un problème de réseau, ou une question avec l'application virtualisée.

Contribué par des ingénieurs TAC Cisco.

Problème

Pendant que des Applications voix plus en temps réel sont virtualisées, il devient beaucoup plus complexe pour dépanner des questions de qualité audio. Utilisez l'Unity Connection comme sujet pour cette « application vocale en temps réel ».

Les informations de rassemblement

  1. La première étape est de déterminer si les demandes sont tordues quand vous laissez l'Unity Connection. Afin de recueillir un paquet, taille toute du fichier capture1 de la capture eth0 de réseau d'utils de capture « compte 100000".

    Remarque: Les demandes de Cisco Unified Communications (CUC) sont une bonne grande ligne pour déterminer la qualité indésirable. N'utilisez pas l'utilisateur a enregistré des messages d'accueil comme ils peuvent être une spécification de base peu fiable.

          
  2. Analysez la capture de paquet : Wireshark, de supports a-law G.711 ou G.711 MU-loi.
  3. Vérifiez la qualité du flot sortant de protocole de tables de routage (RTP) avec Wireshark :
    1. Décodez avec les valeurs par défaut.
    2. Décodez avec l'option « horodateur de RTP d'utilisation » dans Wireshark.

Causes possibles

Si les deux flots décodés éprouvent des problèmes de qualité voix, le problème pourrait être avec la demande (fichier wav) ou l'Unity Connection.

Si l'enregistrement par défaut est tordu, mais l'utilisation des horodateurs de RTP est bien, le problème pourrait être avec des ressources/VMware.

Si la qualité est acceptable quand vous écoutez le flot de RTP utilisant décoder par défaut, le problème pourrait être avec la connexion réseau entre le CUC et le téléphone.

Remarque: Une suggestion est prennent une capture de paquet du commutateur où le serveur d'ESXi est connecté et vérifient la qualité. S'il est mauvais, il est probable que les gestionnaires soient vérifiés l'hôte d'ESXi lui-même.

Solution

Si le problème indique la question est avec l'Unity Connection ou le fichier wav, vérifient d'abord la qualité de l'enregistrement :

  1. Vérifiez le Protocole NTP (Network Time Protocol).
    1. Si le client fait configurer plusieurs NTPs, assurez que le CUC ne commute pas entre les deux fréquemment.
    2. Vérifiez pour voir si les serveurs de NTP ont NTPv4 (capture de paquet) : « état de ntp d'utils ».
  2. Utilisez le GUI de Web pour vérifier la qualité.
  3. Assurez qu'il n'y a aucun coredumps sur CUC. Recherchez la bogue connu : les « utils creusent la liste active ».
  4. Employez l'éditeur de sauvegarde du cobra pour vérifier la qualité.

Si le problème indique que la question est avec le VMware vérifiez, suivez ces étapes :

  1. Vérifiez que la réservation appropriée est faite sur les virtual machine d'Unity Connection : vérifiez les réservations CPU et de RAM comme dans des Plateformes prises en charge.
  2. Assurez-vous que les grands reçoivent débarquent (LRO) sont arrêtés pour l'hôte d'ESXi (pas une question avec ESXi 5.1+). Voir le débronchement LRO sur le pour en savoir plus de déploiements d'applications UCS/UC.
  3. Prenez un instantané de la VM CUC. Voir le pour en savoir plus d'instantanés de VMware.

    Remarque: Des instantanés des VMs d'Unity Connection ne sont pas pris en charge et pourraient entraîner des questions avec la Qualité vocale.

  4. Assurez que les outils de VMware sont installés. Voir le pour en savoir plus d'outils de VMware.

    Remarque: Les outils de VMware installe les gestionnaires du network interface card (NIC) sur la VM pour améliorer des performances du réseau.

  5. Assurez-vous que la VM de sync avec l'hôte n'est pas vérifiée. Ce syncs d'option le temps du virtual machine avec l'hôte d'ESXi. Dans le client de sphère, naviguez pour sélectionner le virtual machine et cliquer avec le bouton droit le virtual machine éditez les configurations. Des options tabulez, choisissez les outils de VMware > a avancé. Assurez-vous que le temps d'invité de synchroniser avec la case d'hôte est décoché.


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