Communication sans fil/mobilité : Réseau local sans fil (WLAN)

Exemple Sans fil de configuration ISR

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires

Introduction

Ce document décrit comment faire la différence entre le legs de Cisco et les Integrated Services Router de la deuxième génération (ISR) et fournit des informations au sujet de la façon les configurer.

Contribué par Surendra BG, ingénieur TAC Cisco.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Informations générales

Il y a différents types de Cisco ISR, et seulement quelques uns de eux sont intégrés avec le Cisco IOS® pour des Routeurs. Par exemple, avec le legs 851W, 857W, 871W, et 877W ISR, vous devez accéder au routeur par l'intermédiaire du telnet/du Protocole Secure Shell (SSH), ou utilisez le Security Device Manager (SDM) afin d'accéder aux configurations Sans fil. En comparaison, une certaine nouvelle génération ISR, tels que 861W, 881W, 891W, 1941W, 819W, été livré avec les points d'accès sans fil (aps) déjà intégrés, et peut être accédée à séparément avec l'interface de l'interface virtuelle de passerelle AP (BVI) (avec le GUI ou Telnet/SSH).

Identifiez le legs et la nouvelle génération ISR

Afin d'identifier l'ISR, sélectionnez la commande brief de show ip interface sur le routeur.

Si la yole 0 de l'interface WLAN-AP 0 et de l'interface WLAN sont présente sur la liste interface, alors il signifie que c'est un routeur de nouvelle génération et a AP sans fil intégré à l'intérieur du routeur. Vous pouvez accéder à ceci par l'intermédiaire du CLI avec Telnet/SSH ou du GUI.

Remarque: Si vous ne voyez pas l'interface WLAN-AP 0 sur la liste interface pour un 861W, un 881W, un 891W, ou un 1941W, alors il signifie que le routeur ne prend en charge pas la radio.

Pour les Routeurs existants, c'est ce qui apparaît quand vous sélectionnez la commande brief du show ip international :

Comme affiché, pour les Routeurs existants, vous voyez seulement l'interface par radio directement sur l'IOS. 

Configurez

Il y a des différentes méthodes utilisées afin de configurer des ISR. Afin de configurer les Routeurs existants, où l'IOS du routeur prend en charge la radio, vous devez configurer le routeur par l'intermédiaire de l'interface BVI pour chaque VLAN. En outre, vous devez jeter un pont sur le trafic avec l'interface par radio et la passerelle d'interface VLAN par l'intermédiaire du BVI. Si vous utilisez les identifiants de l'ensemble de plusieurs services (SSID), alors chaque SSID doit être tracé à chaque VLAN, et chaque VLAN doit être tracé à un seul groupe de passerelle (BG) par une interface BVI distincte.

D'autre part, quand vous configurez une nouvelle génération ISR, puis la configuration est moins complexe. Vous devez établir une connexion entre le routeur et l'AP, et configurez AP juste comme n'importe quel autre AP autonome. Il y aura une interface BVI simple, avec les plusieurs sous-interfaces, que les aides communiquent entre le multiple SSID et VLAN.

La nouvelle génération ISR peut synched avec l'architecture du gestionnaire de Cisco Unified Wireless (CUWM) aussi bien. Le module AP à l'intérieur du routeur peut être converti en point d'accès léger Protocol (LWAPP) /Control et ravitaillement du mode des points d'accès sans fil (CAPWAP), qui est enregistré au contrôleur LAN Sans fil (WLC). Cette section décrit comment convertir le module AP d'autonome et de LWAPP.

Remarque: 861W ne prend en charge pas le mode LWAPP.

Exemple existant de configuration ISR

Cet exemple de configuration utilise deux VLAN (VLAN 1 et VLAN 2) qui chacun sont tracés à un SSID différent avec le WiFi Protected Access - Sécurité principale pré partagée (de WPA-PSK) :

en
conf t

vlan 2 mapped to GUESTRITS SSID..Use the vlan
  as per the network configuration


dot11 ssid GUESTRITS
vlan 2
mbssid
authentication open
authentication key-management wpa
wpa-psk ascii 0 cisco123


dot11 ssid INTERNAL
vlan 1                               >> vlan 1 mapped to INTERNAL SSID
authentication open
mbssid
authentication key-management wpa
wpa-psk ascii 0 cisco123
!

!
bridge irb                          <<< Enables IRB. Allows bridging of
                                        traffic

!

interface Dot11Radio0
no ip address
mbssid
!
encryption vlan 1 mode ciphers tkip  << Encryption            
!
encryption vlan 2 mode ciphers tkip
!
ssid GUESTRITS
!
ssid INTERNAL
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0
  basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Dot11Radio0.1             <<< Corresponding Sub Interface
encapsulation dot1Q 1 native            configuration for Radio
bridge-group 1                      <<< Bridging between VLAN 1 and
bridge-group 1 subscriber-loop-control  Dot11 0.1
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!


interface Dot11Radio0.2               <<< Corresponding Sub Interface
encapsulation dot1Q 2                     configuration for Radio
bridge-group 2                        <<< Bridging between VLAN 2 and
bridge-group 2 subscriber-loop-control    Dot11 0/2  
bridge-group 2 spanning-disabled
bridge-group 2 block-unknown-source
no bridge-group 2 source-learning
no bridge-group 2 unicast-flooding
!


interface Vlan1
no ip address
bridge-group 1                        <<< Bridging between VLAN 1 and
                                          Dot11 0/1

 

interface Vlan2
no ip address
bridge-group 2                        <<< Bridging between VLAN 2 and
!                                         Dot11 0.2


interface BVI1                         << BVI 1 for VLAN 1
ip address 10.0.0.2 255.255.255.0               
!
interface BVI2                         << BVI 2 for VLAN 2
ip address 192.168.1.1 255.255.255.0
!

!
bridge 1 protocol ieee                <<< Mandatory Bridging commands
bridge 1 route ip
bridge 2 protocol ieee
bridge 2 route ip
!

Exemple de configuration de la nouvelle génération ISR

Terminez-vous ces étapes afin de configurer des Routeurs de nouvelle génération :

  1. Établissez la Connectivité entre le routeur et l'AP avec l'interface de la console inverse qui est disponible sur le routeur (interface WLAN-AP 0). Employez l'adresse IP pour cette interface (vous pouvez assigner l'adresse IP, ou utilisez la commande de l'ip unnumbered VLAN X) afin d'assigner l'IP.

    Voici un exemple où la commande de l'ip unnumbered VLAN est utilisée :

    en
    conf t
    int wlan-ap 0
    ip unnumbered vlan 1
    no shut

    Ceci apparaît quand vous sélectionnez la commande de Br du show ip international :



    Ceci vous aide à ouvrir une session au module AP.

  2. Sélectionnez la commande de session du module de service WLAN-AP 0 afin d'ouvrir une session à AP.



    Suivez le même processus utilisé afin de configurer AP autonome. Pour des exemples de configuration supplémentaire, voyez la page d'index d'exemples et de TechNotes de configuration.

    Si votre déploiement se compose des VLAN multiples ou du SSID, vous devez placer l'interface WLAN-GIG 0 comme port de joncteur réseau qui permet les VLAN exigés sur le routeur.


Améliorez un ISR AP de léger à autonome

Quand AP intégré exécute l'image LWAPP, telle qu'AP801-RCVK9W8-M, AP801-RCVK9 "W8" - M (indique LWAPP), ou W7 (indique une image autonome), la commande de configuration t ne fonctionne pas ; AP devrait employer l'image autonome afin d'exécuter les commandes. Afin de résoudre ce problème, vous devez améliorer l'ISR AP de léger à autonome.

Sélectionnez ces commandes :

Router>en
Router#config t
Router(config t)#service-module wlan-ap0 bootimage autonomous

Avec ces commandes, vous pouvez changer le mode AP. Si vous voulez qu'AP charge et exécute une image autonome, utilisation autonome dans la commande précédente. Si vous voulez qu'AP charge et démarre avec une image LWAPP, alors le type a unifié et recharge AP avec cette commande :

Router(config t)#service-module wlan-ap 0 reload

Ceci place AP à autonome. Les travaux par processus pour la majorité des cas. Cependant, si vous rencontrez des questions, vous pouvez utiliser le processus manuel :

  1. Téléchargez TFTPd32 sur votre ordinateur portable et installez-le. Téléchargez la dernière image IOS pour la gamme AP801 :

    1. Naviguez vers Cisco.com.
    2. Cliquez sur l'onglet de support près du haut de l'écran.
    3. Cliquez sur Download le logiciel.
    4. La radio choisie, et mettent en position alors les Routeurs et les Commutateurs intégrés de la liste déroulante de produit.
    5. Sélectionnez le modèle de routeur.
    6. Sélectionnez l'image appropriée IOS : 12.4(21a)JY (ou plus tard, comme désiré).
  2. Ouvrez une session au module AP du routeur, et sélectionnez ces commandes :

    • AP>en
    • Console cli de capwap d'AP#debug OU debug lwapp console cli
    • AP#config t (travaux de cette commande de configuration maintenant)
    • YOLE 0 de #int AP (configuration t) ou international fa 0
    • AP (config - international) # <address > <mask> d'IP address (assurez-vous que vous avez la Connectivité à votre adresse IP d'ordinateur portable, et qu'ils sont tous deux dans le même sous-réseau)
    • #no AP (config - international) fermé
    • #end AP (config - international)
  3. Sélectionnez les commandes de téléchargement d'archives afin d'améliorer AP à autonome :

    • IP address de /force-reload /overwrite tftp:// <TFTP de téléchargement-SW d'AP#archive (IP d'ordinateurs portables) >/<Autonomous image.tar >
    • Téléchargement-SW /overwrite /force-reload tftp://10.0.0.4/ap801-k9w7-tar.124-21a.JY.tar d'AP#archive

    Ceci complète le processus de configuration manuelle.

    Remarque: Si AP est en mode autonome et vous voulez le convertir en LWAPP, utilisez les commandes de téléchargements d'archives et sélectionnez l'image de reprise LWAPP au lieu de l'image du système d'exploitation d'interconnexion de réseaux d'Autonome-Cisco (AIOS).

Vérifiez 

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez 

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration. 

Informations connexes



Document ID: 116579