Commutateurs : Commutateurs Cisco Catalyst, s�rie�6500

Commutateur Microflow de gamme Catalyst 6500 maintenant l'ordre l'exemple de configuration

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires

Introduction

Ce document décrit le microflow maintenant l'ordre sur des Commutateurs de gamme Catalyst 6500.

Contribué par Souvik Ghosh, ingénieur TAC Cisco.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations dans ce document sont basées sur une gamme Cisco Catalyst 6500 commutent que des passages sur une engine 720 de superviseur.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Informations générales

Voici un cas d'utilisation pour votre considération. Il y a une condition requise d'université de limiter chaque étudiant à une bande passante de 10Mbps tandis qu'ils utilisent l'Internet. Si le maintien de l'ordre d'agrégat est configuré, alors il y a une distribution inégale de bande passante parmi les étudiants. Le régulateur de Microflow peut mieux nous aider à réaliser cette tâche.

Microflow maintenant l'ordre le trafic de police d'utilisateurs d'aides basé sur des écoulements. Un écoulement est habituellement défini port par du source ip (SRC-IP), de la destination IP (DST-IP), IP SRC-DST, SRC-DST, ou SRC-interface. Voici un exemple :

Source 10.0.0.1 sending a tcp stream to 15.0.0.1 with a source tcp port of 50
and destination 2000
Source 10.0.0.1 sending a tcp stream to 15.0.0.2 with a source tcp port of 60
and destination 2000.

Si la classification est faite basait sur le SRC-IP, alors le nombre d'écoulements égale un. Si la classification est faite basait sur le DST-IP, alors le nombre d'écoulements égale deux. Si la classification est faite basait sur le port DST, alors le nombre d'écoulements égale un.

Remarque: Des régulateurs de Microflow peuvent seulement être appliqués dans la direction d'entrée, à la différence du régulateur d'agrégation.

Quand nous appliquons une stratégie de service sous une interface, l'interface physique ou le Switch Virtual Interface (SVI), la stratégie de service est programmée dans le matériel. La mémoire associative ternaire de Qualité de service (QoS) (TCAM) est utilisée afin d'enregistrer l'entrée. Supplémentaire, puisque le commutateur doit se souvenir les écoulements, il stocke les informations individuelles d'écoulement dans le matériel. Le NetFlow TCAM est utilisé à cet effet. Par conséquent, il y a deux endroits où vous pouvez vérifier la programmation dans le matériel : la liste de contrôle d'accès (ACL) TCAM et le NetFlow TCAM.

Puisque le même NetFlow TCAM est utilisé par d'autres caractéristiques, comme le Traduction d'adresses de réseau (NAT), le Data Export de NetFlow (NDE), et le Web Cache Communication Protocol (WCCP), il est possible qu'il y ait un conflit dans le régulateur de microflow programmant dans le matériel. Des scénarios de conflit certain TCAM sont fournis à la fin de ce document.

Exemples de configuration

Exemple 1

Il y a une gamme Cisco Catalyst 6500 commutent occupé dans le routage d'interVLAN. Les sources de trafic se trouvent dans le VLAN 20, et ont ces adresses IP : 20.20.20.2 et 20.20.20.3. Chacun des deux essai de sources pour envoyer le trafic vers l'adresse IP 30.30.30.2, qui se trouve dans le VLAN 30. Le but est d'allouer 100Kbps de bande passante à chaque source.

  1. Créez et tracez un ACL dans un class-map afin d'apparier le trafic qui provient ces deux sources.
    ip access-list ext vlan20_30
    permit ip 20.20.20.0 0.0.0.255 30.30.30.0 0.0.0.255

    class-map POLICE_DIFF_SRC
    match access-group name vlan20_30


  2. Appliquez le class-map dans un policy-map. Configurez le débit de données garanti (CIR) et les valeurs de rafale au besoin.

    policy-map POLICE_DIFF_SRC
    class POLICE_DIFF_SRC
    police flow mask src-only 100000 3000 conform transmit exceed drop


    Voici les options qui sont disponibles après masque de flux de police :
    police flow mask ?
    dest-only
    full-flow
    src-only


  3. Appliquez la stratégie de service sous le d'entrée SVI ou sous l'interface physique d'entrée. Au cas où vous l'appliqueriez sous l'interface vlan, configurez le mls qos vlan-based sous l'interface physique. Ceci demande au Cisco IOS® pour rechercher une stratégie sous l'interface vlan dès qu'un paquet atteindra un interface de couche 2 dans une particularité VLAN.

    interface vlan 20
    service-policy input POLICE_DIFF_SRC

Exemple 2

Il y a une gamme Catalyst 6500 commutent occupé dans la commutation de la couche 2 du trafic dans le même VLAN. Deomonstrates de cet exemple comment limiter le trafic qui provient 10.10.10.2 et va vers 10.10.10.3 dans le VLAN à 100Kbps de bande passante. Afin d'avoir le trafic de la couche 2-switched d'affect de régulateur, vous devez sélectionner la commande de mls qos bridged sous l'interface vlan 10.

ip access-list ext VLAN10
permit ip 10.10.10.0 0.0.0.255 10.10.10.0 0.0.0.255
class-map POLICE_SAME


match access-group name VLAN10
policy-map POLICE_SAME
class POLICE_SAME    
police flow mask src-only 100000 3000 conform transmit exceed drop


int vlan 10
service-policy in POLICE_SAME
mls qos bridged

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

  1. Sélectionnez la commande d'IP de show mls qos, et vérifiez l'ID de FL près du nom de régulateur. Si l'ID de FL est 1, alors la stratégie est en service pour le maintien de l'ordre de microflow.

    6500#show mls qos ip
     QoS Summary [IPv4]:      (* - shared aggregates, Mod - switch module)

     Int Mod Dir  Class-map DSCP  Ag  Trust   FL   AgForward-By   AgPoliced-By
                                                           Id           Id
    ---------------------------------------------------------------------------

    Fa3/3  1 In   POLICE_SAM   0   0*   dscp    1   11266001160            0

    Voici quelques points remarquables basés sur cette sortie :

    • La stratégie est tracée dans le matériel.
    • L'interface sur laquelle il est appliqué est Fa3/3.
    • S'il y a une carte de transfert distribué (DFC) - présent activé du linecard (LC) dans le châssis, alors le QoS maintient l'ordre sont programmés séparément pour chaque carte DFC et de fonctionnalité de stratégie (PFC). Le numéro de module donne l'entrée pour le PFC/DFC dans l'emplacement 1.
    • L'engine 720 de superviseur crée un ID d'agrégat (AgID) pour chaque régulateur d'agrégation qui est créé. 1020 AgIDs sont les id utilisables maximum, qui sont une limitation matérielle. Ce n'est pas approprié pour le régulateur de microflow, mais est une commande utile pour le régulateur d'agrégation.
    • Le champ de confiance ne tient aucune pertinence dans ce cas.
    • FL ID=1, comme discuté précédemment.
    • L'AgForward ? Par et AgPoliced-par ne sont pas utilisés afin de calculer les paquets qui sont transmis ou lâchés par le régulateur de microflow (il y a une commande distincte pour cela). Cependant, les mêmes compteurs sont utilisés afin de calculer des paquets transmis/abandonnés par un régulateur d'agrégation.


  2. Entrez dans le show tcam commande physique d'IP de type 1 de qos d'interface> international < vlan/or afin de déterminer si l'ACL est programmé dans le QoS TCAM.

    6500#show tcam interface fa3/3 qos type1 ip   
        QOS Results:   A - Aggregate Policing       F - Microflow Policing
        M - Mark          T - Trust
        U - Untrust
        ------------------------------------------------------
        FT     ip 10.10.10.0 0.0.0.255 10.10.10.0 0.0.0.255  ==> entry is
        programmed correctly
        MU     ip any any


  3. Vérifiez la sortie de la commande de nowrap de qos de show mls netflow ip afin de le découvrir si les écoulements sont installés dans le Netlflow TCAM.

    6500#show mls NetFlow ip qos nowrap 
    Displaying NetFlow entries in Active Supervisor EARL in module 1
    DstIP           SrcIP           Prot         : SrcPort :   DstPort   Src i/f         :AdjPtr    Pkts  
    Bytes         LastSeen      QoS       PoliceCount  Threshold   Leak          Drop     Bucket
    ------------------------------------------------------------------------------------------------------
    0.0.0.0          0.0.0.0            0                     :0                   :0           --
    0x0       140394     
    67383880   15:16:29        0x0                   0                    0           0
    NO             0

    0.0.0.0         10.10.10.2      0                     :0                   :0           --              
    0x0           227
    108506        15:16:22        0x0                  35996208    0           0                NO         3386


    Dans cette sortie, vous pouvez voir que l'écoulement (réservé à la source) est installé dans le NetFlow TCAM, et il y a 35,996,208 paquets qui ont été maintenus l'ordre.

Problèmes éventuels

Il est possible que la stratégie de service ne soit pas programmée dans le matériel dans ces scénarios. Voici quelques possibles raison :

  1. Il y a une limitation matérielle sur le nombre de régulateurs d'agrégat/microflow qui peuvent être configurés. Afin de réserver des ressources en matériel, la stratégie de service n'est pas programmée dans le matériel.

    Sélectionnez la commande qoscan de show platform hardware capacity afin de vérifier la Disponibilité des régulateurs.

    6500#show platform hardware capacity qos
    QoS Policer Resources
      Aggregate policers: Module                      Total         Used     %Used
                          1                            1024            102     10%
                          6                            1024            102     10%
      Microflow policer configurations: Module        Total         Used     %Used
                                        1                64            32        50%
                                        6                64            32        50%


  2. En raison d'un conflit de masque de flux avec d'autres configurations configurées sous la même interface, le régulateur de microflow ne pourrait pas pouvoir aux flux de cache dans le NetFlow TCAM.

    Il est important de comprendre le concept du masque de flux. Afin de prendre en charge l'accélération matérielle de certaines caractéristiques, il y a des parties dédiées de matériel (TCAMs) qui sont utilisées afin d'installer certaines caractéristiques. Il y a de plusieurs caractéristiques qui utilisent le même TCAM, tel que le NetFlow NAT WCCP. Ils utilisent un TCAM qui s'appelle généralement le NetFlow TCAM, tandis que pour des caractéristiques comme la Sécurité ACLs, la Gestion de réseau à base de règles utilise l'ACL TCAM.

    Pour le NetFlow TCAM, un masque de flux est nécessaire afin d'installer des entrées dans le matériel. Les masques de flux de NetFlow déterminent la finesse des écoulements à mesurer. Les masques de flux très spécifiques génèrent un grand nombre d'entrées de table de NetFlow, et un de large volume des statistiques pour exporter. Moins de masques de flux spécifiques agrègent les statistiques de trafic dans moins entrées de table de NetFlow, et génèrent un volume inférieur de statistiques.

    L'article de configuration de Tableau de NetFlow décrit les caractéristiques de condition requise de masque de flux (prise en charge).

    • Sélectionnez la commande de show fm summary, et déterminez si l'interface est dans un état inactif. Un état inactif indique qu'il y a une certaine caractéristique configurée sous l'interface qui ne peut pas être programmée dans le matériel. Paquets reçus sur cette interface qui exigent que la caractéristique sont programmées en logiciel.

      6500#show fm summary
      Interface: Vlan13 is up
      TCAM screening for features: INACTIVE inbound
      TCAM screening for features: INACTIVE outbound
      Interface: Vlan72 is up
      TCAM screening for features: ACTIVE inbound
      TCAM screening for features: ACTIVE outbound
      Interface: Vlan84 is up
      TCAM screening for features: ACTIVE inbound
      TCAM screening for features: INACTIVE outbound


    • Sélectionnez la commande de <> d'interface de fie de show fm, et déterminez si le régulateur de microflow est configuré dans le matériel.

      6500#show fm fie int vlan 10
      Interface Vl10:
      Feature interaction state created: Yes
       Flowmask conflict status for protocol IP :
      FIE_FLOWMASK_STATUS_SUCCESS
      Flowmask conflict status for protocol OTHER :
      FIE_FLOWMASK_STATUS_SUCCESS Interface Vl10 [Ingress]:
       Slot(s) using the protocol IP : 1
       FIE Result for protocol IP : FIE_SUCCESS_NO_CONFLICT 
      Features Configured : [empty] - Protocol : IP 
      FM Label when FIE was invoked : 66  Current FM Label : 66 
      Last Merge is for slot: 0  num# of strategies tried : 1
        num# of merged VMRs in bank 1 = 0
        num# of free TCAM entries in Bank1 = Unknown
        num# of merged VMRs in bank 2 = 1
        num# of free TCAM entries in Bank2 = Unknown
       Slot(s) using the protocol OTHER : 1
       FIE Result for protocol OTHER : FIE_SUCCESS_NO_CONFLICT
       Features Configured : OTH_DEF   - Protocol : OTHER
       FM Label when FIE was invoked : 66
       Current FM Label : 66
       Last Merge is for slot: 0
       Features in Bank1 = OTH_DEF
      +-------------------------------------+
              Action Merge Table
      +-------------------------------------+
         OTH_DEF      RSLT    R_RSLT  COL
      +-------------------------------------+
         SB           HB      P       0
          X            P       P       0
      +-------------------------------------+
       num# of strategies tried : 1
       Description of merging strategy used:
       Serialized Banks: FALSE
       Bank1 Only Features: [empty]
       Bank2 Only Features: [empty]
       Banks Swappable: TRUE
       Merge Algorithm: ODM
       num# of merged VMRs in bank 1 = 1
       num# of free TCAM entries in Bank1 = 32745
       num# of merged VMRs in bank 2 = 0
       num# of free TCAM entries in Bank2 = 32744 Interface Vl10 [Egress]:
      No Features Configured
      No IP Guardian Feature Configured
      No IPv6 Guardian Feature Configured
      IP QoS Conflict resolution configured, QoS policy name: POLICE_SAME
    Des masques de flux compatibles devraient être utilisés pour les caractéristiques configurées sous la même interface qui partagent le NetFlow TCAM. Les masques de flux compatibles sont disponibles pour presque tous les types de combinaisons.

D'autres commandes utiles

  • Appliquez la stratégie
  • Contrôle FL-ID=1 - IP de show mls qos
  • Vérifiez QoS TCAM - IP de type 1 de qos de <> du show tcam international
  • Vérifiez le NetFlow TCAM - nowrap de module de qos de show mls netflow ip
  • Vérifiez la Disponibilité des régulateurs - matrice de show platform hardware capacity
  • Vérifiez le show log de conflit de masque de flux (FM), show fm summary
  • Vérifiez les caractéristiques configurées sous l'interface - interface de fie de show fm


Document ID: 116468