Routeurs : Routeurs à services d'agrégation de la gamme Cisco ASR 9000

Configuration de la commutation L2 au processus de conversion de configuration de L2VPN XR

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires

Introduction

Ce document décrit comment convertir une configuration de changement de la couche 2 de Cisco IOS® en configuration de réseau privé virtuel de la couche 2 de Cisco IOS XR (L2VPN).

Contribué par Manuel Irizarry, alimentations de David, et Samuel Milstead, ingénieurs TAC Cisco.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité au logiciel spécifique mais est limité à versions de matériel liées du routeur de service agrégées par gamme 9000 (ASR) qui emploient le modèle du circuit virtuel d'Ethernets (EVC) afin de configurer le L2VPN. Les Routeurs de gamme 9000 ASR utilisent le modèle EVC alors que les Routeurs du système de routage de transporteur (CRS) qui exécutent le Cisco IOS XR ne font pas.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Informations générales

Le routeur de gamme 9000 ASR ne suit pas le modèle d'IEEE de la configuration de la couche 2 (L2), spécialement 802.1Q et 802.1AD. Au lieu de cela il utilise le modèle EVC. Le modèle EVC permet au Cisco IOS XR pour accroître les balises en cours du 802.1Q VLAN d'une nouvelle manière. Traditionnellement, la balise VLAN définit la classification, le VLAN, l'expédition, et qui table associative de mémoire (CAM) à l'utiliser afin d'exécuter une consultation d'adresse MAC. Avec le modèle EVC, ce concept est découplé afin de laisser plus de flexibilité et d'échelle plus élevée. Le modèle EVC élimine la restriction de Cisco IOS de 4,096 VLAN maximum.

EVC utilise ces modules :

  • Les Ethernets circulent le point (l'EFP) - L'EFP est une sous-interface L2 logique qui est utilisée afin de classifier le trafic sous un examen médical ou une interface de paquet.

  • EVC - EVC est une représentation de bout en bout d'un exemple simple de L2. Un EFP est défini comme point final d'un EVC dans un noeud. Puisque plusieurs EVCs peut traverser une interface physique, le but principal d'une configuration EFP est d'identifier le trafic qui appartient à une particularité EVC sur cette interface et d'appliquer le comportement et les caractéristiques d'expédition spécifiques à celle EVC.

  • Domaine de passerelle (BD) - Le BD est un domaine d'émission d'Ethernets interne au périphérique. Le BD te permet de découpler le VLAN du domaine d'émission. Le BD a un-à-beaucoup de mappages avec des EFP : tous les EFP dans un noeud pour une particularité EVC sont groupés avec l'utilisation du BD. Si les EFP appartiennent au même BD et ont le même nombre du BD, alors les EFP reçoivent le trafic même si ils ont différents nombres VLAN.

Problème

Le Cisco IOS XR sur des Routeurs de gamme 9000 ASR utilise le modèle du circuit virtuel d'Ethernets (EVC). Le modèle EVC n'a pas le concept des joncteurs réseau, des interfaces VLAN, ou de Switch Virtual Interface (SVI). Des joncteurs réseau, les interfaces VLAN, et les SVI du Cisco IOS doivent être convertis en configurations de Cisco IOS XR par l'intermédiaire des sous-interfaces, du L2VPN BDs, et des interfaces virtuelles de passerelle (BVIs). Le modèle EVC pourrait être nouveau à quelques utilisateurs de Cisco IOS quand ils migrent d'abord vers le Cisco IOS XR.

Solution

La configuration sur le Cisco IOS XR se compose de trois étapes :

  1. Créez l'EFP par l'intermédiaire de la configuration d'une interface ou d'une sous-interface avec l'option de l2transport, qui représente un VLAN.

  2. Créez le BD afin de grouper les EFP.

  3. Quand la couche 3 (L3) SVI sont nécessaire, configurez par l'intermédiaire de l'interface bvi dans le Cisco IOS XR, au lieu de l'interface vlan dans le Cisco IOS, afin de fournir les fonctions L3 de base pour les interfaces L2 qui appartiennent au BD.

Remarque: Les interfaces BVI ne prennent en charge pas des balises VLAN ; ainsi pour que le BVI traite le trafic entrant sur l'EFP, la balise VLAN doit être sautée sur le d'entrée et être ajoutée sur le de sortie. Ceci est terminé avec la commande de réécriture.

Convertissez une configuration

Cet exemple montre comment convertir une configuration de Cisco IOS en Cisco IOS XR.

Configuration IOS

interface GigabitEthernet3/13
switchport
switchport access vlan 4
speed 1000
duplex full
!
interface GigabitEthernet3/14
switchport
switchport access vlan 130
speed 1000
duplex full
!
interface GigabitEthernet3/15
switchport
switchport access vlan 133
speed 1000
duplex full
!
interface TenGigabitEthernet13/3
description IOS Trunk
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1*,4,130,133
switchport mode trunk
no ip address
!
interface Vlan 4
ip address 10.10.4.1 255.255.255.0

interface Vlan 130
ip address 10.10.130.1 255.255.255.0
!

*Vlan 1 is the native vlan

Créez une interface EFP. Le Cisco IOS XR implémente un CLI structuré pour la configuration EFP et EVC. Afin de configurer un EFP, utilisez ces commandes de configuration d'interface :

  • commande de l2transport - Cette commande identifie une sous-interface, un port physique, ou une interface de parent de paquet-port comme EFP.

  • commande d'encapsulation - Cette commande est utilisée afin de spécifier des critères VLAN-appariants.

  • commande de réécriture - Cette commande est utilisée afin de spécifier les critères de réécriture de balise VLAN.

Configuration ASR 9000 pour Interfate TenGigabitEhternet 13/3 (port de joncteur réseau)

interface GigabitEthernet 0/0/0/1
!
interface GigabitEthernet 0/0/0/1.1 l2transport
encapsulation dot1q untagged **
!

interface GigabitEthernet 0/0/0/1.4 l2transport
encapsulation dot1q 4
rewrite ingress tag pop 1 symmetric

interface GigabitEthernet 0/0/0/2
!
interface GigabitEthernet 0/0/0/2.130 l2transport
encapsulation dot1q 130
rewrite ingress tag pop 1 symmetric
!
interface GigabitEthernet 0/0/0/3
!
interface GigabitEthernet 0/0/0/3.133 l2transport
encapsulation dot1q 133
rewrite ingress tag pop 1 symmetric
!
interface tengig0/0/0/0
!
interface tengig0/0/0/0.4 l2transport
no ip address
encapsulation dot1q 4
rewrite ingress tag pop 1 symmetric
!
interface tengig0/0/0/0.130 l2transport
no ip address
encapsulation dot1q 130
rewrite ingress tag pop 1 symmetric
!
interface tengig0/0/0/0.133 l2transport
no ip address
encapsulation dot1q 133
rewrite ingress tag pop 1 symmetric
!

Afin d'ajouter le VLAN 1, le trafic indigènes d'untag, et créer une sous-interface de l2transport avec l'encapsulation non-marquée dot1q. Utilisez la commande non-marquée de l'encapsulation dot1q sous une interface de l2transport ou une sous-interface si le port est connecté à un port configurent pour l'accès de switchport dans le périphérique IOS.

Voici un exemple :

IOS:

interface Gigabitethernet 1/1
switchport
switchport access vlan 3

IOSXR:

interfage GigabitEthernet 0/1/1/1.1 l2transport
encapsulation dot1q untagged

Après que l'EFP soit créé, une interface BVI peut être créée et ajoutée au BD. L'interface BVI est utilisée afin de faciliter l'interface vlan dans le Cisco IOS.

interface BVI4
ipv4 address 10.10.4.1 255.255.0.0
!
interface BVI130
ipv4 address 10.130.1.1 255.255.0.0
!

Le nombre d'interface BVI n'a pas besoin nécessairement d'apparier l'identifiant VLAN. Le même est vrai pour le numéro de sous-interface des interfaces de l2transport. Cependant, pour la clarté dans cet exemple, le BVI number apparie la balise dot1q aussi bien que le numéro de sous-interface EFP.

Dans cet exemple, un l2-VPN BD est créé afin de jeter un pont sur les EFP et le BVIs ensemble :

l2vpn
bridge group VLAN4
bridge-domain VLAN4
interface ten0/0/0/0.4
!
interface GigabitEthernet 0/0/0/1.4
!
routed interface bvi4
!
!
bridge-domain VLAN130
interface ten0/0/0/0.130
!
interface GigabitEthernet 0/0/0/2.130
!
routed interface bvi130
!
!
bridge-domain VLAN133
interface ten0/0/0/0.133
!
interface GigabitEthernet 0/0/0/3.133
!
!
!
!

Le groupe de passerelle (BG) est une hiérarchie non fonctionnelle de configuration qui attache plusieurs BDs ensemble en partie du même groupe fonctionnel. Il fonctionne juste comme la création de plusieurs différents groupes avec leurs domaines fait, par opposition à un groupe avec des plusieurs domaines.

Commandes équivalentes

Ce tableau présente d'autres commandes disponibles dans le Cisco IOS, et les commandes équivalentes dans le Cisco IOS XR configuré sous le BD :

IOSIOS XR
switchport block unicast}inondation du débronchement d'UNKNOWN-unicast
switchport port-security maximummaximum de limite de MAC (plage 5-512000)
switchport port-security violationnotification de limite de MAC d'action de limite de MAC (inondation, NO--inondation, arrêt) (chacun des deux, aucune, déroutement)
MAC-mouvement de mac address-table notificationLe besoin de configurer ce qui suit : l'action sécurisée de MAC aucun MAC sécurisent se connecter
switchport port-security mac-addressreliez la statique-MAC-adresse maximum H.H.H de la limite y de MAC x

Informations connexes


Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Document ID: 116500