IP : Protocole L2TP (Layer Two Tunnel Protocol)

L2 jetant un pont sur à travers un exemple de la configuration réseau L3

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires

Introduction

Ce document décrit comment jeter un pont sur un réseau de la couche 2 (L2) à travers un réseau de la couche 3 (L3).

Contribué par Atri Basu, geai jeune Taylor, et Mani Ganesan, ingénieurs TAC Cisco.

Conditions préalables

Conditions requises

Cisco vous recommande de prendre connaissance des rubriques suivantes :

  • Version 3 (L2TPv3) de Layer 2 Tunneling Protocol
  • Encapsulation de routage générique (GRE)

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Informations générales

Dans beaucoup de situations, vous exigez d'une solution afin d'agréger le trafic de WiFi des hotspots à un site central. En pareil cas, la solution doit permettre à des périphériques de l'équipement client (CPE) pour jeter un pont sur le trafic Ethernet de l'hôte d'extrémité, et encapsule les modules par le trafic Ethernet à un point final.

Si vous utilisez les Routeurs de services d'agrégation (ASR), la méthode facile de faire ceci est d'utiliser des Ethernets au-dessus de GRE doux. Cependant, pour les Routeurs de service intégré (ISR) et tous autres périphériques CPE, ce n'est pas une option. Dans des versions plus anciennes de Cisco IOS®, il était possible de percer un tunnel L2 au-dessus de GRE en jetant un pont sur l'interface physique avec une interface de tunnel GRE. Bien que la transition de militaire de carrière élimine l'en-tête VLAN des paquets entrant, l'utilisation du Routage et mise en parallèle intégrés (IRB) sur le routeur peut conduire et jeter un pont sur le même protocole de couche réseau relatif à la même interface et encore permettre au routeur pour mettre à jour l'en-tête VLAN d'une interface à l'autre.

Remarque: Quand vous configurez le passerelle-groupe sur l'interface de tunnel sur des versions plus anciennes de Cisco IOS, les états IOS que la commande est indisponible et non vérifiée, mais lui reçoit toujours la commande. Dans des versions plus récentes, cette commande est complètement Désuet(e), et les affichages de message d'erreur.

La solution précédente n'est pas prise en charge par Cisco. La solution prise en charge pour jeter un pont sur un réseau L2 est d'utiliser L2TPv3 comme décrit dans ce document. L2TPv3 fournit le support pour le transport des divers protocoles L2 comme des Ethernets, le 802.1Q (VLAN), le Relais de trames, le High-Level Data Link Control (HDLC), et le Protocole point à point (PPP). Le centre de ce document est extension d'Ethernets.

Configurez

Cette installation est très de base. Servir r101 et r201 de Routeurs d'hôtes sur le même réseau, alors que r100 et r202 ont une interface L3 et une interface L2. L'objectif est d'installer la connexion L2TPv3 tels que r101 et r201 peuvent se cingler sans condition requise de toutes les artères.

Diagramme du réseau

Configuration de tunnel

La configuration de tunnel L2TP implique trois étapes :

  1. Configurez un l2tp-class (facultatif)

    Cette classe est utilisée afin de définir quelques paramètres d'authentification et de contrôle pour le tunnel L2TP. S'il est utilisé, les deux extrémités doivent se refléter.
    l2tp-class test
    hostname stanford
    password 7 082E5C4B071F091805

  2. Configurez le pseudowire-class

    Pendant que le nom suggère, cette section est utilisée afin de configurer le tunnel ou le « pseudowire » réel entre les deux points finaux. Définissez un modèle qui contient l'encapsulation de pseudowire, un point final, et le protocole de canal de contrôle.
    pseudowire-class test
    encapsulation l2tpv3
    ip local interface Loopback0
    ip pmtu

  3. Xconnect d'utilisation afin de fournir la destination de tunnel

    Liez le pseudowire L2TP au circuit de connexion (interface vers côté L2 local) et définissez sa destination. 

Points à noter :

  • Le circuit de connexion lui-même n'a aucune adresse IP configurée.
  • La source du tunnel configurée avec l'ip local interface est dans la section de pseudowire-class.
  • La destination de tunnel est définie avec la commande de xconnect.

Considérations

  • Comme avec la solution de Tunnellisation GRE, l'utilisation d'un routeur sur lequel terminer le tunnel L2 ne permet toujours pas des messages du Protocol Data Unit L2 (PDU) à expédier à travers le tunnel. Sans Tunnellisation approprié du protocole L2, qui n'est pas pris en charge sur ce périphérique, ces messages sont consommés par l'interface L2.

  • Le soutien du Tunnellisation du protocole L2 (Cisco Discovery Protocol, Protocole Spanning Tree, VLAN trunking protocol, et Discovery Protocol de couche de liaison) exige que le périphérique est un commutateur. Ce commutateur doit être L3 averti afin de pouvoir au trafic du tunnel et limiter les choix possibles.

  • L'encapsulation du Tunnellisation L3 dépend du périphérique qui fait le Tunnellisation :
    1. Encapsulation des supports L2TPv3 de Cisco 7301.
    2. Cisco 65xx ne prend en charge pas l'extension L2 avec le tunnel L2TPv3. Cependant, le L2 peut être étendu à travers un noyau MLPS avec le n'importe quel transport au-dessus de l'option MPLS (atome).
    3. Le tunnel L2TP n'est pas pris en charge sur Cisco 4500 Commutateurs.

  • Seulement une interface de tunnel simple de xconnect peut être configurée sur une interface physique ou une sous-interface. Une interface distincte est nécessaire pour chaque point final de pseudowire. Vous ne pouvez pas configurer des plusieurs interfaces avec le xconnect avec la même picowatt-classe et les mêmes id L2TP.

  • La taille maximum de Maximum Transmission Unit de charge utile pour un tunnel L2TP est généralement de 1460 octets pour le trafic qui voyage au-dessus des Ethernets standard. Dans le cas de L2TP au-dessus de Protocole UDP (User Datagram Protocol), le temps système est le résultat de l'en-tête IP (20 octets), de l'en-tête d'UDP (8 octets), et de l'en-tête L2TP (12 octets).

Exemple de configuration

Configuration du routeur r101

interface Ethernet0/0
ip address 172.16.1.100 255.255.255.0

Configuration du routeur r100

pseudowire-class test
encapsulation l2tpv3
protocol none
ip local interface fast 0/0
!
interface FastEthernet0/0
description WAN
ip address 198.51.100.100 255.255.255.0
!
interface FastEthernet0/1
description LAN
no ip address
speed 100
full-duplex
xconnect 203.0.113.102 1 encapsulation l2tpv3 manual pw-class test
l2tp id 1 2
!
ip route 0.0.0.0 0.0.0.0 198.51.100.1

Configuration du routeur r202

pseudowire-class test
encapsulation l2tpv3
protocol none
ip local interface fast 0/0
!
interface FastEthernet0/0
description WAN
ip address 203.0.113.102 255.255.255.255

interface FastEthernet0/1
no ip address
duplex auto
speed auto
xconnect 198.51.100.100 1 encapsulation l2tpv3 manual pw-class test
l2tp id 2 1

Configuration du routeur r201

interface Ethernet0/0
ip address 172.16.1.201 255.255.255.0

Remarque: Utilisez l'Outil de recherche de commande (clients enregistrés seulement) pour obtenir plus d'informations sur les commandes utilisées dans cette section.

Vérifiez

Afin d'afficher les informations détaillées au sujet des canaux de contrôle L2TP qui sont installés à d'autres périphériques L2TP-enabled pour toutes les sessions L2TP sur le routeur, utilisez le show l2tun tunnel toute la commande.

Afin de vérifier que l'encapsulation L2TPv3 fonctionne correctement, cinglez un hôte au site distant qui est censé être sur le même VLAN. Si le ping est réussi, vous pouvez employer cette commande afin de confirmer que votre configuration fonctionne correctement. L'Output Interpreter Tool (clients enregistrés seulement) prend en charge certaines commandes show. Utilisez l'Output Interpreter Tool afin de visualiser une analyse de sortie de commande show.

  • La commande de show arp affiche le cache de Protocole ARP (Address Resolution Protocol).

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.


Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Document ID: 116266