Informatique unifiée : Cisco UCS Manager

Exemple de configuration de liaison ascendante UCS FCoE

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires

Introduction

Ce document décrit comment configurer la Manche de fibre au-dessus des liaisons ascendantes d'Ethernets (FCoE). Dans des versions de version 2.1 et ultérieures du Système d'informatique unifiée Cisco (UCS), la Manche de multi-alimentation de fibre au-dessus du support d'Ethernets (FCoE) a été introduite. Ce support permet la fusion de liaison ascendante de deux liens distincts à une liaison ascendante simple qui porte la Manche de fibre (FC) et des Ethernets.

Remarque: Les liaisons ascendantes unifiées sont différentes des ports unifiés. N'importe quelle interconnexion de matrice (fi), qui inclut la génération 1, peut avoir unifié des liaisons ascendantes. Cependant, seulement la génération 2 FIs ont unifié des ports.

Contribué par brun de Christopher, ingénieur TAC Cisco.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations dans ce document sont basées sur la version 2.1 des UCS Manager (UCSM). Vous devez exécuter au moins la version 2.1(1a) afin d'utiliser ce document.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Configurez

Configurations prises en charge

En tout de ces configurations, vous pouvez remplacer n'importe quel lien avec un Port canalisé du même type. Par exemple, si la configuration affiche un lien, il peut être configuré avec un Port canalisé à la place. Cependant, vous ne pouvez pas avoir un Ethernet et un port unifié dans le même Port canalisé.

Liaison ascendante de FCoE avec le Port canalisé virtuel (vpc)

Cette configuration ne contient aucun lien unifié, mais c'est le moyen le plus simple d'intégrer des liaisons ascendantes de FCoE dans votre environnement en cours. Cette configuration élimine la nécessité de croiser les matrices FC.

Croix-connecté à goupiller

Dans cette configuration, les Commutateurs de gamme de Nexus 5000 (N5ks) et FIs croix-sont connectés, mais ensemble port-pas creusés des rigoles. Ceci te permet pour avoir quelques liaisons ascendantes unifiées, mais vous mettez à jour toujours une conception de réseaux réputée.

Toutes les liaisons ascendantes unifiées

Cette configuration fournit la plupart de fusion. Souvenez-vous que ces liens peuvent également être des Ports canalisés, mais tous les liens doivent être les liaisons ascendantes unifiées. C'est susceptible d'être l'implémentation la plus commune.

Configuration sur l'UCS

Il y a trois étapes pour configurer l'UCS :

  1. Configurez le réseau de stockage virtuel (VSAN).
  2. Configurez les liaisons ascendantes unifiées.
  3. Configurez les Ports canalisés (facultatifs).

Configurez VSAN

Dans cette configuration, VSAN 500 est hors de la matrice A, et VSAN 600 est hors de la matrice B. C'est la même configuration que vous aviez l'habitude afin de créer un VSAN pour un FC normal.

Configurez les liaisons ascendantes unifiées

La liaison ascendante unifiée est masquée dans le GUI. Afin de faire un port unifié, vous devez d'abord le configurer comme liaison ascendante ou liaison ascendante de FCoE. Puis, vous pouvez le configurer comme un port unifié. Cette configuration ne retire pas le premier rôle. Au lieu de cela, il crée une interface qui a chacun des deux.

Veillez à placer votre VSAN en ce moment.

En ce moment, votre UCS est configuré pour le trafic unifié. Cet exemple n'utilise pas des Ports canalisés. Cependant, vous pouvez configurer des Ports canalisés normalement en ce moment. Veillez à placer le VSAN sous l'onglet VSAN pour le Port canalisé.

Configuration sur le N5k

La configuration sur le N5k se compose de 3 étapes :

  1. Enable FCoE et configurations par défaut de Qualité de service (QoS). Créez le FCoE VLAN et liez le VSAN à lui.
  2. Configurez l'interface Ethernet (ou le Port canalisé).
  3. Créez une Manche virtuelle de fibre (vFC) et liez-la à l'interface Ethernet.

Remarque: L'UCS est un commutateur de la virtualisation de port N (NPV) par défaut ainsi le commutateur en amont doit être en mode d'Identifer Virtulization (NPIV) de port N (sélectionnez la commande de npiv de caractéristique afin d'activer).  Voyez configurer la virtualisation de port N pour plus d'informations sur cette caractéristique.

Enable FCoE et configurations de QoS de par défaut

Vous pouvez ignorer cette étape si le N5k est déjà configuré pour FCoE. Si le N5k n'est pas configuré pour FCoE, référez-vous à l'annexe A à la fin de ce document pour l'instruction.

Configurez les interfaces Ethernet (ou les Ports canalisés)

C'est la configuration pour l'interface qui se connecte normalement à l'UCS.  Veillez à permettre le FCoE VLAN.

f340-31-15-5596-1(config)# interface ethernet 1/32
f340-31-15-5596-1(config-if)# switchport mode trunk
f340-31-15-5596-1(config-if)# switchport trunk allowed vlan all

C'est un exemple d'une configuration de jonction très de base. Notez qu'il n'y a aucune configuration de FCoE sur cette interface.

Configurez le vFC

C'est la configuration pour le vFC, qui traite tout le trafic de FCoE de l'UCS :

f340-31-15-5596-1(config-if)# int vfc 25
f340-31-15-5596-1(config-if)# switchport trunk allowed vsan 500
f340-31-15-5596-1(config-if)# no shut
f340-31-15-5596-1(config-if)# bind interface ethernet 1/32
f340-31-15-5596-1(config-if)#

Il y a quelques points à noter dans cet exemple :

  • Le nombre de vFC n'importe pas. Il peut être quelque chose, tant que il n'est pas déjà en service.
  • C'est un port de la matrice de jonction (TF), ainsi veillez à permettre votre VSAN.
  • Liez ceci à l'interface qui fait face à l'UCS. C'est l'interface physique sur laquelle le trafic de FCoE est envoyé/reçu. Il est envoyé sur le VLAN associé avec le VSAN.

En ce moment, vous avez tout saturé. Sélectionnez la commande du vfc xx d'interface d'exposition afin de s'assurer que le VSAN monte.

f340-31-15-5596-1(config-if)# show interface vfc 25
vfc25 is trunking
Bound interface is Ethernet1/32
Hardware is Ethernet
Port WWN is 20:18:54:7f:ee:d3:f8:bf
Admin port mode is F, trunk mode is on
snmp link state traps are enabled
Port mode is TF
Port vsan is 500
Trunk vsans (admin allowed and active) (500)
Trunk vsans (up) (500)
Trunk vsans (isolated) ()
Trunk vsans (initializing) ()
1 minute input rate 4448 bits/sec, 556 bytes/sec, 1 frames/sec
1 minute output rate 610448 bits/sec, 76306 bytes/sec, 27 frames/sec
27347 frames input, 45743308 bytes
0 discards, 0 errors
114710 frames output, 218235936 bytes
0 discards, 0 errors
last clearing of "show interface" counters Thu May 9 13:37:42 2013

Interface last changed at Thu May 9 14:03:44 2013

Si le VSAN n'est pas, vérifiez votre configuration et vos connexions. S'il est toujours avalez, agitez le port Ethernet sur le N5k.

En ce moment, vous appliquez votre configuration normale FC (stratégie de démarrage, répartissant en zones).

f340-31-15-5596-1(config-if)# show flogi database
--------------------------------------------------------------------------------
INTERFACE VSAN FCID PORT NAME NODE NAME
--------------------------------------------------------------------------------
fc2/3 500 0xd80000 20:42:00:0d:ec:b1:34:c0 21:f4:00:0d:ec:b1:34:c1
fc2/3 500 0xd80001 20:00:00:25:b5:12:dc:5f 20:00:00:25:b5:13:dc:2f
[svinfra-esxi-1]
fc2/3 500 0xd80003 20:00:00:25:b5:12:dc:3f 20:00:00:25:b5:13:dc:0f
[svinfra-esxi-2]
vfc7 500 0xd80060 25:f6:00:0d:ec:cc:d3:ff 21:f4:00:0d:ec:cc:d3:c1
vfc7 500 0xd80061 20:00:00:25:b5:19:70:28 20:00:00:25:b5:19:70:18
vfc25 500 0xd80042 20:00:00:25:b5:ab:1a:01 20:00:00:25:b5:00:00:8f
vfc25 500 0xd80043 20:00:00:25:b5:ab:1a:02 20:00:00:25:b5:00:00:9f
vfc25 500 0xd80044 20:00:00:25:b5:00:3a:08 20:00:00:25:b5:00:00:5f
vfc25 500 0xd80045 20:00:00:25:b5:00:3a:09 20:00:00:25:b5:00:00:4f
vfc25 500 0xd80048 2d:9a:00:05:73:c2:c6:3f 21:f4:00:05:73:c2:c6:01

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Annexe A - Configuration de base N5k FCoE

Afin de configurer le N5k pour FCoE, entrez :

feature fcoe
system qos
service-policy type network-qos fcoe-default-nq-policy
service-policy type queuing input fcoe-default-in-policy
service-policy type queuing output fcoe-default-out-policy
service-policy type qos input fcoe-default-in-policy

Ces commandes activent d'abord FCoE, et activent ensuite les stratégies QoS par défaut qui sont nécessaires pour FCoE. Si vous avez les configurations faites sur commande de QoS, utilisez ceux comme base. Voici les configurations par défaut :

  policy-map type qos fcoe-default-in-policy
class type qos class-fcoe
set qos-group 1
class type qos class-default
set qos-group 0

policy-map type queuing fcoe-default-in-policy
class type queuing class-fcoe
bandwidth percent 50
class type queuing class-default
bandwidth percent 50
policy-map type queuing fcoe-default-out-policy
class type queuing class-fcoe
bandwidth percent 50
class type queuing class-default
bandwidth percent 50

policy-map type network-qos fcoe-default-nq-policy
class type network-qos class-fcoe

pause no-drop
mtu 2158
class type network-qos class-default

mtu 1500
multicast-optimize

Comme vous pouvez voir, ces stratégies créent la classe du trafic de FCoE, la marquent pour la NO--baisse, et lui donnent la bande passante dédiée. Vous pouvez modifier ces derniers pendant que vous avez besoin (par exemple, afin d'ajouter des Trames étendues).

Ensuite, vous devez lier le VSAN au VLAN :

f340-31-15-5596-1(config)# vlan 500
f340-31-15-5596-1(config-vlan)# name VNX_500
f340-31-15-5596-1(config-vlan)# fcoe vsan 500
f340-31-15-5596-1(config-vlan)#

Ceci indique au N5k que VLAN 500 est un FCoE VLAN et que n'importe quel trafic qui entre devrait être commuté à VSAN 500.

En ce moment, votre N5k est configuré pour FCoE et prépare pour la connexion UCS.



Document ID: 116188