Commutation multiprotocole par étiquette (MPLS) : MPLS

Exemple unifié de configuration MPLS

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires

Introduction

Ce document décrit le but du Commutation multiprotocole par étiquette (MPLS) unifié et fournit un exemple de configuration.

Contribué par Luc De Ghein, ingénieur TAC Cisco.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Fond

Le but du MPLS unifié est tout au sujet de l'évolution. Afin de mesurer un réseau MPLS, où il y a différents types des patforms et de services dans les parties du réseau, il semble raisonnable de couper le réseau en différentes zones. Une conception typique introduit une hiérarchie qui a un noyau au centre avec l'agrégation du côté. Afin de mesurer, là peut être différents protocoles d'Interior Gateway (IGP) dans le le noyau contre l'agrégation. Afin de mesurer, vous ne pouvez pas distribuer les préfixes d'IGP d'un IGP dans l'autre. Si vous ne distribuez pas les préfixes d'IGP d'un IGP dans l'autre IGP, les chemins Étiquette-commutés de bout en bout (LSP) ne sont pas possibles.

Afin de fournir les services MPLS de bout en bout, vous avez besoin du LSP pour être de bout en bout. Le but est de garder les services MPLS (L2VPN MPLS VPN, MPLS) car ils sont, mais d'introduire la meilleure évolutivité. Afin de faire ceci, entrez certains des préfixes d'IGP dans le Protocole BGP (Border Gateway Protocol) (les préfixes de bouclage des Routeurs de Provider Edge (PE)), qui distribuent alors les préfixes de bout en bout.

Architecture

La figure 1 affiche un réseau avec trois zones différentes : un noyau et deux zones d'agrégation du côté. Chaque zone exécute son propre IGP, sans la redistribution entre eux sur le routeur de cadre de zone (ABR). L'utilisation du BGP est nécessaire afin de fournir un MPLS de bout en bout LSP. Le BGP annonce les bouclages des Routeurs de PE avec une étiquette à travers le domaine entier, et fournit un LSP de bout en bout. Le BGP est déployé entre le siège potentiel d'explosion et les abr avec RFC 3107, ainsi il signifie que le BGP envoie le préfixe d'ipv4 + l'étiquette (AFI/SAFI 1/4).

Puisque les pièces de noyau et d'agrégation du réseau sont intégrées et des LSP de bout en bout sont fournis, la solution unifiée MPLS désigné également sous le nom « du MPLS sans couture. »

De nouvelles Technologies ou protocoles ne sont pas utilisés ici, seulement MPLS, protocole de distribution d'étiquette (LDP), IGP, et BGP. Puisque vous ne voulez pas distribuer les préfixes de bouclage des Routeurs de PE d'une part du réseau dans une autre partie, vous devez porter les préfixes dans le BGP. L'Internal Border Gateway Protocol (iBGP) est utilisé dans un réseau, ainsi l'adresse du prochain saut des préfixes est les préfixes de bouclage des Routeurs de PE, qui n'est pas connue par l'IGP dans les autres parties du réseau. Ceci signifie que l'adresse du prochain saut ne peut pas être utilisée au recurse à un préfixe d'IGP. L'astuce est d'inciter les Routeurs d'ABR à conduire les réflecteurs (rr) et à placer le prochain saut à l'individu, même pour les préfixes reflétés d'iBGP. Pour que ceci fonctionne, une nouvelle molette est nécessaire.

Seulement le logiciel plus nouveau du besoin de RRs pour prendre en charge cette architecture. Puisque le RRs annoncent les préfixes BGP avec le prochain saut réglé à eux-mêmes, ils assignent des mpls label locaux aux préfixes BGP. Ceci signifie que dans le plan de données, les paquets expédiés sur ces LSP de bout en bout ont des mpls label supplémentaires dans la pile d'étiquette. Le RRs sont dans le chemin de transfert.

Remarque: Au-dessus de cette architecture, n'importe quel service MPLS est fourni. Par exemple, le L2VPN MPLS VPN ou MPLS sont fournis entre les Routeurs de PE. La différence dans le plan de données pour ces paquets est qu'ils ont maintenant trois étiquettes dans la pile d'étiquette, tandis qu'ils ont eu deux étiquettes dans la pile d'étiquette quand le MPLS unifié n'a pas été utilisé.

Il y a deux scénarios possibles :

  • L'ABR ne place pas le prochain saut à l'individu pour les préfixes annoncés (reflété par BGP) par l'ABR dans la pièce d'agrégation du réseau. Pour cette raison, l'ABR doit redistribuer les préfixes de bouclage des abr du principal IGP dans l'IGP d'agrégation. Si ceci est fait, il reste évolutivité. Seulement les préfixes de bouclage d'ABR (du noyau) doivent être annoncés dans la pièce d'agrégation, pas les préfixes de bouclage des Routeurs de PE des pièces distantes d'agrégation.

  • L'ABR place le prochain saut à l'individu pour les préfixes annoncés (reflété par BGP) par l'ABR dans la cloison d'agrégation pour cette raison, l'ABR n'a pas besoin de redistribuer les préfixes de bouclage des abr du principal IGP dans l'IGP d'agrégation.

Dans les deux scénarios, l'ABR place le prochain saut à l'individu pour les préfixes annoncés (reflété par BGP) par l'ABR de la pièce d'agrégation du réseau dans la cloison de noyau. Si ceci n'est pas fait, l'ABR doit redistribuer les préfixes de bouclage du siège potentiel d'explosion de l'IGP d'agrégation dans le principal IGP. Si ceci est fait, il n'y a aucune évolutivité.

Afin de placer le prochain saut à l'individu pour les artères reflétées d'iBGP, vous devez configurer le next-hop-self du voisin x.x.x.x toute la commande.

Configurez

C'est la configuration des Routeurs et des abr de PE pour le scénario 2.

Remarque: Le toplogy est affiché dans la figure 2. Le service d'exemple est xconnect (L2VPN MPLS). Entre les Routeurs de PE et les abr, il y a de BGP pour l'ipv4 + l'étiquette.

PE1

interface Loopback0
 ip address 10.100.1.4 255.255.255.255

!
interface Ethernet1/0
 no ip address
 xconnect 10.100.1.5 100 encapsulation mpls
!
router ospf 2
 network 10.2.0.0 0.0.255.255 area 0
 network 10.100.1.4 0.0.0.0 area 0
!
router bgp 1
 bgp log-neighbor-changes
 network 10.100.1.4 mask 255.255.255.255
 neighbor 10.100.1.1 remote-as 1
 neighbor 10.100.1.1 update-source Loopback0
 neighbor 10.100.1.1 send-label

RR1


interface Loopback0
 ip address 10.100.1.1 255.255.255.255
router ospf 1
 network 10.1.0.0 0.0.255.255 area 0
 network 10.100.1.1 0.0.0.0 area 0
!
router ospf 2
 redistribute ospf 1 subnets match internal route-map ospf1-into-ospf2
 network 10.2.0.0 0.0.255.255 area 0
!
router bgp 1
 bgp log-neighbor-changes
 neighbor 10.100.1.2 remote-as 1
 neighbor 10.100.1.2 update-source Loopback0
 neighbor 10.100.1.2 next-hop-self all
 neighbor 10.100.1.2 send-label
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 route-reflector-client
 neighbor 10.100.1.4 next-hop-self all
 neighbor 10.100.1.4 send-label

ip prefix-list prefix-list-ospf1-into-ospf2 seq 5 permit 10.100.1.1/32

route-map ospf1-into-ospf2 permit 10
 match ip address prefix-list prefix-list-ospf1-into-ospf2


RR2

interface Loopback0
 ip address 10.100.1.2 255.255.255.255

router ospf 1
 network 10.1.0.0 0.0.255.255 area 0
 network 10.100.1.2 0.0.0.0 area 0
!
router ospf 3
 redistribute ospf 1 subnets match internal route-map ospf1-into-ospf3
 network 10.3.0.0 0.0.255.255 area 0
!
router bgp 1
 bgp log-neighbor-changes
 neighbor 10.100.1.1 remote-as 1
 neighbor 10.100.1.1 update-source Loopback0
 neighbor 10.100.1.1 next-hop-self all
 neighbor 10.100.1.1 send-label
 neighbor 10.100.1.5 remote-as 1
 neighbor 10.100.1.5 update-source Loopback0
 neighbor 10.100.1.5 route-reflector-client
 neighbor 10.100.1.5 next-hop-self all
 neighbor 10.100.1.5 send-label

ip prefix-list prefix-list-ospf1-into-ospf3 seq 5 permit 10.100.1.2/32

route-map ospf1-into-ospf3 permit 10
 match ip address prefix-list prefix-list-ospf1-into-ospf3


PE2

interface Loopback0
 ip address 10.100.1.5 255.255.255.255

interface Ethernet1/0
 no ip address
 xconnect 10.100.1.4 100 encapsulation mpls

router ospf 3
 network 10.3.0.0 0.0.255.255 area 0
 network 10.100.1.5 0.0.0.0 area 0

router bgp 1
 bgp log-neighbor-changes
 network 10.100.1.5 mask 255.255.255.255
 neighbor 10.100.1.2 remote-as 1
 neighbor 10.100.1.2 update-source Loopback0
 neighbor 10.100.1.2 send-label

Remarque: Redistribution du principal IGP (OSPF 1) dans l'IGP d'agrégation (ospf2 ou OSPF 3) est exécuté avec un route-map. Ce route-map permet aux préfixes de bouclage du rr pour redistribuer dans l'IGP d'agrégation. La raison pour ceci est que le préfixe de bouclage du rr seulement est directement annoncé dans le principal IGP (OSPF 1). Cependant, le préfixe de bouclage du rr doit être connu dans l'IGP d'agrégation également, de sorte que le BGP sur le routeur PE puisse scruter avec le bouclage du rr.

Vérifiez

Voir la figure 2 afin de vérifier l'exécution d'avion de contrôle.

Voir la figure 3 afin de vérifier les annonces de mpls label.

Voir la figure 4 le vérifier le transfert de paquet.

C'est comment des paquets sont expédiés de PE1 à PE2. Le préfixe de bouclage de PE2 est 10.100.1.5/32, de sorte que le préfixe soit d'intérêt.

PE1#show ip route 10.100.1.5

Routing entry for 10.100.1.5/32
  Known via "bgp 1", distance 200, metric 0, type internal
  Last update from 10.100.1.1 00:11:12 ago
  Routing Descriptor Blocks:
  * 10.100.1.1, from 10.100.1.1, 00:11:12 ago
    Route metric is 0, traffic share count is 1
    AS Hops 0
    MPLS label: 22


PE1#show ip cef 10.100.1.5
10.100.1.5/32
  nexthop 10.2.2.6 Ethernet0/0 label 19 22


PE1#show ip cef 10.100.1.5 detail
10.100.1.5/32, epoch 0, flags rib defined all labels
  1 RR source [no flags]
  recursive via 10.100.1.1 label 22
    nexthop 10.2.2.6 Ethernet0/0 label 19

PE1#show bgp ipv4 unicast labels

   Network          Next Hop      In label/Out label
   10.100.1.4/32    0.0.0.0         imp-null/nolabel
   10.100.1.5/32    10.100.1.1      nolabel/22


P1#show mpls forwarding-table labels 19 detail
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop  
Label      Label      or Tunnel Id     Switched      interface             
19         Pop Label  10.100.1.1/32    603468        Et1/0      10.2.1.1  
        MAC/Encaps=14/14, MRU=1504, Label Stack{}
        AABBCC000101AABBCC0006018847
        No output feature configured


RR1#show mpls forwarding-table labels 22 detail
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop  
Label      Label      or Tunnel Id     Switched      interface            
22         21         10.100.1.5/32    575278        Et0/0      10.1.1.3  
        MAC/Encaps=14/22, MRU=1496, Label Stack{17 21}
        AABBCC000300AABBCC0001008847 0001100000015000
        No output feature configured


RR1#show bgp ipv4 unicast labels
   Network          Next Hop      In label/Out label
   10.100.1.4/32    10.100.1.4      19/imp-null
   10.100.1.5/32    10.100.1.2      22/21


P3#show mpls forwarding-table labels 17 detail
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop  
Label      Label      or Tunnel Id     Switched      interface            
17         Pop Label  10.100.1.2/32    664306        Et1/0      10.1.2.2  
        MAC/Encaps=14/14, MRU=1504, Label Stack{}
        AABBCC000201AABBCC0003018847
        No output feature configured


RR2#show mpls forwarding-table labels 21 detail
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop  
Label      Label      or Tunnel Id     Switched      interface            
21         17         10.100.1.5/32    615958        Et0/0      10.3.1.7  
        MAC/Encaps=14/18, MRU=1500, Label Stack{17}
        AABBCC000700AABBCC0002008847 00011000
        No output feature configured


RR2#show bgp ipv4 unicast labels
   Network          Next Hop      In label/Out label
   10.100.1.4/32    10.100.1.1      22/19
   10.100.1.5/32    10.100.1.5      21/imp-null


P2#show mpls forwarding-table labels 17 detail
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop  
Label      Label      or Tunnel Id     Switched      interface            
17         Pop Label  10.100.1.5/32    639957        Et1/0      10.3.2.5  
        MAC/Encaps=14/14, MRU=1504, Label Stack{}
        AABBCC000500AABBCC0007018847
        No output feature configured


PE1#trace
Protocol [ip]:
Target IP address: 10.100.1.5
Source address: 10.100.1.4

DSCP Value [0]:
Numeric display [n]:
Timeout in seconds [3]:
Probe count [3]:
Minimum Time to Live [1]:
Maximum Time to Live [30]:
Port Number [33434]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Type escape sequence to abort.
Tracing the route to 10.100.1.5
VRF info: (vrf in name/id, vrf out name/id)
  1 10.2.2.6 [MPLS: Labels 19/22 Exp 0] 3 msec 3 msec 3 msec
  2 10.2.1.1 [MPLS: Label 22 Exp 0] 3 msec 3 msec 3 msec
  3 10.1.1.3 [MPLS: Labels 17/21 Exp 0] 3 msec 3 msec 2 msec
  4 10.1.2.2 [MPLS: Label 21 Exp 0] 2 msec 3 msec 2 msec
  5  *  *  *
  6 10.3.2.5 4 msec *  4 msec

Remarque: Expositions du saut 5 ? 5 * * * ?. C'est parce que le routeur P2 n'a pas une artère pour l'adresse IP source 10.100.1.4 (PE1) de la traceroute. Ainsi, le routeur P2 ne peut pas envoyer le message d'erreur de Protocole ICMP (Internet Control Message Protocol) de nouveau à PE1. C'est normal, car le point du MPLS unifié est de ne pas avoir les préfixes de bouclage de tous les Routeurs de PE dans une pièce d'agrégation à révéler dans les IGP des autres pièces d'agrégation. Le routeur P2 ne tente pas d'expédier le message d'erreur ICMP avec la pile d'étiquette d'origine. C'est parce que la pile d'étiquette d'origine a seulement une étiquette. Si cette pile d'étiquette d'origine du paquet a deux étiquettes ou plus, le message d'erreur ICMP est expédié le long du LSP et peut revenir à la source de la traceroute. Si la pile d'étiquette d'origine a seulement une étiquette, le routeur qui génère le message d'erreur ICMP tente une recherche de route et l'essaye de la conduire avec l'utilisation de la table de routage (sans utilisation de la pile d'étiquette d'origine).

P2#show ip route 10.100.1.4
% Subnet not in table

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Informations connexes



Document ID: 116127