Interfaces et modules Cisco : Module contrôleur de réseau local sans fil

Maille et exemple de configuration de support de multiple VLAN WGB

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit à une configuration d'échantillon support pour de maille et de pont de groupe de travail (WGB) VLAN multiple en authentification ouverte (authentique ouvert) et le Lightweight Extensible Authentication Protocol (LEAP).

Remarque: Contribué par Surendra BG, ingénieur TAC Cisco.

D'autres documents dans cette gamme

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour obtenir plus d'informations sur les commandes utilisées dans cette section.

Diagramme du réseau

Ce document utilise cette configuration réseau, qui affiche comment réaliser le support de VLAN multiple sur le commutateur derrière le WGB avec authentique ouvert. Le LEAP est ajouté à l'extrémité.

La topologie est :

Serveur DHCP — Commutateur — Contrôleur LAN Sans fil (WLC) — Point d'accès de racine (RAP) (maille))))) (((((WGB — Commutateur

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-01.gif

  • Le serveur du protocole DHCP (DHCP) est configuré pour VLAN 50 et 100.

  • Le WLC a les interfaces dynamiques créées pour VLAN 50 et 100.

  • Le WGB a des sous-interfaces pour des VLAN exigés — 50 et 100.

  • Le commutateur derrière le WGB a exigé des VLAN — 50 et 100.

Dans l'installation de laboratoire, VLAN 40 est pour la Gestion WLC, le VLAN 40 sur le RAP de maille, et le VLAN 50 sur le WGB. Les clients derrière le commutateur WGB obtiennent l'adresse IP de VLAN 50 et de VLAN 100 au-dessus de l'air à travers le WGB et le RAP de maille.

Remarque: La même installation juge bon pour le Point d'accès de mode local (AP) aussi bien.

Configurations

Ce document utilise les configurations suivantes :

  • WLC WGB

  • Commutateur

  • LEAP

WLC WGB

Sur l'interface de ligne de commande WLC (CLI), sélectionnez la commande d'enable de VLAN de wgb de config.

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-02.gif

Sur le WGB CLI, sélectionnez la commande d'unifier-VLAN-client de pont de groupe de travail.

workgroup-bridge unified-vlan-client
dot11 ssid WGB_LWAPP
   vlan 50
   authentication open
   guest-mode
   infrastructure-ssid
end

interface Dot11Radio0
 no ip address
 no ip route-cache
 ssid WGB_LWAPP
 station-role workgroup-bridge
 
interface Dot11Radio0.50
 encapsulation dot1Q 50 native
 no ip route-cache
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface Dot11Radio0.100
 encapsulation dot1Q 100
 no ip route-cache
 bridge-group 100
 
interface FastEthernet0.50
 encapsulation dot1Q 50 native
 no ip route-cache
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface FastEthernet0.100
 encapsulation dot1Q 100
 no ip route-cache
 bridge-group 100

interface BVI1

!--- Grab the IP address from VLAN 50 which is across wireless
 
 ip address dhcp  
 no ip route-cache

Commutateur

La configuration pour le commutateur est :

Switch#sh cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
 
Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
BGL14-TACLAB-ASW-S8
                 Fas 0/2           150          R S I     WS-C3550- Fas 0/27
SURBG-AP         Fas 0/1           130           T I      AIR-AP124 Fas 0
Switch#
Switch#sh run int fa 0/1
Building configuration...

Current configuration : 127 bytes
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 50
 switchport mode trunk
end

Switch#sh vlan br
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                         
12   VLAN0012                         active
40   VLAN0040                         active
50   VLAN0050                         active
100  VLAN0100                         active
Switch#sh run int vlan 50
Building configuration...
Current configuration : 41 bytes
!
interface Vlan50
 ip address dhcp
end

Switch#sh run int vlan 100
Building configuration...
 
Current configuration : 42 bytes
!
interface Vlan100
 ip address dhcp
end

Switch#sh ip int br | i up
Vlan12                 unassigned      YES DHCP    up                    up
Vlan50                 172.16.1.7      YES DHCP    up                    up
Vlan100                100.0.0.21      YES DHCP    up                    up

En conclusion, les interfaces VLAN 50 et 100 obtiennent l'adresse IP du serveur DHCP, qui est derrière le commutateur sur le lieu d'exploitation principal à travers la radio par l'intermédiaire de RAP et de WGB de maille.

Sur le WLC, le VLAN correct est tracé aux interfaces appropriées.

Le VLAN 100 saisit l'adresse IP et cette entrée sur le WLC.

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-03.gif

Le VLAN 50 saisit l'adresse IP et cette entrée sur le WLC.

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-04.gif

LEAP

Configurez le WLAN pour le WPA2 - eap profile de gens du pays de 802.1X.

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-05.gif

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-06.gif

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-07.gif

Assurez l'authentication priority sur les points locaux de Protocole EAP (Extensible Authentication Protocol) à la base de données locale des utilisateurs.

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-08.gif

WGP AP

dot11 ssid WGB_LWAPP
   vlan 50
   authentication open eap eap
   authentication network-eap eap
   authentication key-management wpa version 2
   dot1x credentials wgb
   dot1x eap profile eapfast
   infrastructure-ssid
   no ids mfp client
!

!--- Profile configured -- LEAP

eap profile eapfast                
 method leap
!
!
!

!--- Credentials used by this WGB AP to get auth with WLC (Local net users)

dot1x credentials wgb         
 username cisco123
 password 7 0822455D0A16544541
 

interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption mode ciphers aes-ccm
 !
 encryption vlan 50 mode ciphers aes-ccm
 !
 ssid WGB_LWAPP
 !
 packet retries 128
 station-role workgroup-bridge
!
interface Dot11Radio0.50
 encapsulation dot1Q 50 native
 no ip route-cache
 bridge-group 1
!
interface Dot11Radio0.100
 encapsulation dot1Q 100
 no ip route-cache
 bridge-group 100
 bridge-group 100 spanning-disabled

Le client est dans l'état de passage avec la Sécurité de LEAP.

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-09.gif

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 115752