Commutation LAN : 802.1Q

Perte de paquets au-dessus d'un tunnel Dot1Q/L2P

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document discute au sujet de dépanner la perte de paquets au-dessus d'un tunnel Dot1Q/L2P dû à la conception de réseaux pauvre dans le Ý de Cisco IOS avec une étude de cas.

Conditions préalables

Conditions requises

Cisco vous recommande de prendre connaissance des rubriques suivantes :

  • Connaissance de base sur le Tunnellisation Dot1Q

  • Connaissance de base d'OSPF

Composants utilisés

Ce document n'est pas limité à des versions de matériel ou de logiciel spécifiques.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Diagramme du réseau

En cette configuration réseau, l'interface Gi1/44 et le Gi 1/43 du routeur 7600-Core a le routeur sur un bâton installé avec Fa0/13 et Fa0/12 du routeur 3400-Metro-1 respectivement. Dans 7600-Dot1Q commutez l'interface Gi9/44 et le Gi 9/45 sont activés avec le tunnel mode Dot1q. Des interfaces de VLAN SVI sont créées sur la périphérie 3400-Metro et Fa0/13 et Fa0/12 sont configurés comme ports de joncteur réseau. L'OSPF d'utilisation de Routeurs à communiquer les uns avec les autres.

http://www.cisco.com/c/dam/en/us/support/docs/lan-switching/8021q/113632-packet-loss-dot1q-l2p-01.gif

Configurations

Noyau 7609
!
version 15.0
hostname 7609-CORE
interface GigabitEthernet1/43
 mtu 9216
 no ip address
 no ip redirects
 no ip proxy-arp
 load-interval 60
 carrier-delay 2
 flowcontrol send off
 storm-control broadcast level 1.00
!
interface GigabitEthernet1/43.3503
 encapsulation dot1Q 3503
 ip address 172.16.41.17 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip mtu 1500
 ip ospf authentication-key 7 072C0E6B6B272D
 ip ospf network point-to-point
 ip ospf hello-interval 3
 ip ospf dead-interval 10
!
!
interface GigabitEthernet1/44
 mtu 9216
 no ip address
 no ip redirects
 no ip proxy-arp
 load-interval 60
 carrier-delay 2
 flowcontrol send off
 storm-control broadcast level 1.00
!
interface GigabitEthernet1/44.3803
 encapsulation dot1Q 3803
 ip address 172.16.73.137 255.255.255.248 secondary
 ip address 172.16.41.21 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip mtu 1500
 ip ospf authentication-key 7 072C0E6B6B272D
 ip ospf network point-to-point
 ip ospf cost 5
 ip ospf hello-interval 3
 ip ospf dead-interval 10

!--- Output omitted.

!
end

7609 DOT1Q
!
version 12.2
!
interface GigabitEthernet9/44
  switchport
 switchport access vlan 24
 switchport mode dot1q-tunnel
 mtu 9216
 load-interval 60
 carrier-delay 2
 flowcontrol send off
 storm-control broadcast level 1.00
 l2protocol-tunnel cdp
 l2protocol-tunnel stp
 l2protocol-tunnel vtp
 no cdp enable
 spanning-tree portfast disable
 spanning-tree bpdufilter enable
!
!
interface GigabitEthernet9/45
 switchport
 switchport access vlan 24
 switchport mode dot1q-tunnel
 mtu 9216
 load-interval 60
 carrier-delay 2
 flowcontrol send off
 storm-control broadcast level 1.00
 l2protocol-tunnel cdp
 l2protocol-tunnel stp
 l2protocol-tunnel vtp
 no cdp enable
 spanning-tree portfast disable
 spanning-tree bpdufilter enable
!

!--- Output omitted.

!
end

3400-Metro-1
!
version 12.2
!
interface FastEthernet0/3
  port-type nni
 switchport trunk allowed vlan 1052,3503
 switchport mode trunk
 load-interval 60
!
interface FastEthernet0/4
 port-type nni
 switchport trunk allowed vlan 1052,3803
 switchport mode trunk
 load-interval 60
!
!
interface FastEthernet0/12
 port-type nni
 switchport trunk allowed vlan 2-4094
 switchport mode trunk

!
interface FastEthernet0/13
 port-type nni
 switchport trunk allowed vlan 2-4094
 switchport mode trunk
!
end

périphérie 3400-Metro
!
version 12.2
!
interface FastEthernet0/12
 port-type nni
 switchport mode trunk
 load-interval 60
 storm-control broadcast level 1.00
 spanning-tree portfast disable
 spanning-tree bpdufilter disable
!
interface FastEthernet0/13
 port-type nni
 switchport mode trunk
 load-interval 60
 storm-control broadcast level 1.00
 spanning-tree portfast disable
 spanning-tree bpdufilter disable
!
!
interface Vlan3503
 ip address 172.16.41.18 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip ospf authentication-key 7 072C0E6B6B272D
 ip ospf network point-to-point
 ip ospf hello-interval 3
 ip ospf dead-interval 10
!
interface Vlan3803
 ip address 172.16.73.139 255.255.255.248 secondary
 ip address 172.16.41.22 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip ospf authentication-key 7 072C0E6B6B272D
 ip ospf network point-to-point
 ip ospf cost 5
 ip ospf hello-interval 3
 ip ospf dead-interval 10
!

!--- Output omitted.

!
end

Observation

Les baisses aléatoires de ping se produisent quand le paquet traverse par le tunnel Dot1Q. Mais, il n'y a aucune baisse d'entrée/sortie sur les interfaces et également il n'y a aucun symptôme des questions de couche physique. Émettez le <interface > la commande d'interface d'exposition afin de vérifier les baisses d'entrée/sortie sur l'interface :

7609-Dot1Q#show interface gi9/44 

!--- Output omitted.

 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    0 input errors, 0 CRC, 1 frame, 0 overrun, 0 ignored
    0 output errors, 0 collisions, 1 interface resets
    0 lost carrier, 0 no carrier, 0 PAUSE output

!--- Output omitted.

Quand un trafic d'ICMP d'environ 100 pings sont envoyés de la Métro-périphérie, seulement 95 échos sont reçus au centre, qui suggère que les paquets d'ICMP obtiennent a relâché dans le chemin.

Metro-Edge#ping 172.16.41.21 re 100

Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 172.16.41.21, timeout is 2 seconds:
.....!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 95 percent (95/100), round-trip min/avg/max = Ý/9 ms

Remarque: La commande de show ip traffic dans les 7609 prouve que seulement 95 échos sont reçus tandis que dans la Métro-périphérie et elle affiche que 100 échos sont envoyés.

show ip traffic
En Métro-périphérie
ICMP statistics:
  Rcvd: 0 format errors, 0 checksum errors, 0 redirects, 0 unreachable
        0 echo, 95 echo reply, 0 mask requests, 0 mask replies, 0 quench
        0 parameter, 0 timestamp, 0 info request, 0 other
        0 irdp solicitations, 0 irdp advertisements
  Sent: 0 redirects, 0 unreachable, 100 echo, 0 echo reply
        0 mask requests, 0 mask replies, 0 quench, 0 timestamp
        0 info reply, 0 time exceeded, 0 parameter problem
        0 irdp solicitations, 0 irdp advertisements

!--- The above output shows that 100 echos are sent
!--- but received 95 replies from 7609-Core.

Dans 7609-Core
ICMP statistics:
  Rcvd: 0 format errors, 0 checksum errors, 0 redirects, 0 unreachable
        95 echo, 0 echo reply, 0 mask requests, 0 mask replies, 0 quench
        0 parameter, 0 timestamp, 0 info request, 0 other
        0 irdp solicitations, 0 irdp advertisements
  Sent: 0 redirects, 0 unreachable, 0 echo, 95 echo reply
        0 mask requests, 0 mask replies, 0 quench, 0 timestamp
        0 info reply, 0 time exceeded, 0 parameter problem
        0 irdp solicitations, 0 irdp advertisements

Dépannage

Vérifiez si les adresses MAC sont apprises correctement afin de dépanner la baisse en paquets.

Commande de table de MAC address d'exposition d'utilisation afin de vérifier les entrées d'adresse MAC.

Pour le ping réussi

7609-DOT1q#sh mac-address-table address E05F.B972.1F00 all
Legend: * - primary entry
age - seconds since last seen
n/a - not available
vlan mac address type learn age ports
------+----------------+--------+-----+----------+--------------------------
Active Supervisor:
* 24 e05f.b972.1f00 dynamic Yes 0 Gi9/44

!--- This output displays the MAC address learnt
!--- and its associated port, in this case the associated 
!--- port for successful ping is Gi9/44.

Pour le ping de panne

7609-DOT1q#sh mac-address-table address E05F.B972.1F00 all
Legend: * - primary entry
age - seconds since last seen
n/a - not available
vlan mac address type learn age ports
------+----------------+--------+-----+----------+--------------------------
Active Supervisor:
* 24 e05f.b972.1f00 dynamic Yes 5 Gi9/45

!--- This output displays the MAC address learnt
!--- and its associated port, in this case, 
!--- the port number is Gi9/45.

Afin de voir le MAC détaillé indexer la programmation, utilisez la commande de show mac-address-table.

7609-DOT1q#sh mac-address-table address E05F.B972.1F00 det

MAC Table shown in details
========================================

PI_E RM RMA Type Alw-Lrn Trap Modified Notify Capture Flood Mac Address Age Pvlan SWbits Index XTag
----+---+---+----+-------+----+--------+------+-------+------+--------------+----+------+------+----

Active Supervisor:

Yes No No DY No No Yes No No No e05f.b972.1f00 0xE0 24 0 0x22C 0

Émettez les commandes de number> de <Index d'index LTL-information de mcast de commutateur et de test de remote login afin de connaître quel numéro de port que la valeur HEXADÉCIMALE précédente a dénoté.

7609-DOT1q-sp#test mcast ltl-info index 22B
index 0x22B contain ports 9/44
7609-DOT1q-sp#test mcast ltl-info index 22C
index 0x22C contain ports 9/45

!--- The output shows that hex number 22B 
!--- points to 9/44 port and hex 22C points to 9/45.

Pour le ping défectueux la source et l'index de destination sont le même port et par conséquent la baisse. Quand le MAC-mouvement activé avec la commande de mac-address-table notification mac-move sur les 7600 il affiche des instabilités de MAC entre deux ports différents et c'est le message d'erreur :

Remarque: Puisque 6500/7600 utilise une adresse MAC commune pour le commutateur., la même adresse MAC a assigné entre différents ports. La commande de châssis-MAC-adresse de show catalyst6000 affiche l'adresse MAC réservée de commutateur.

* Jul 2 10:29:44.011: %MAC_MOVE-SP-4-NOTIF: Host e05f.b972.1f00 in 
vlan 24 is flapping between port Gi9/45 and port Gi9/44

!--- The previous error message indicates 
!--- that the same MAC address is assigned between 
!--- two different ports: Gi9/45 and port Gi9/44.

Solution

Le réseau précédent est une configuration réseau de maillage complet qui a des périphériques du tunnel DOT1Q sur le même commutateur. Dans ce genre de configuration réseau des MAC-instabilités sont prévues. Afin d'éviter le MAC-lien instable, une de ces solutions peut être mise en application.

  • Déplacez le périphérique du tunnel à un commutateur différent, par exemple, l'encapsulation et le décapsulage devraient se produire dans le commutateur différent.

  • L'élagage VLAN peut être fait afin de régler les VLAN dans des ports de joncteur réseau l'uns des.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 113632