IP : IP version 6 (IPv6)

Redistribuez le default route BGP d'IPv6 dans l'exemple de la configuration EIGRPv6

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit une configuration d'échantillon de la façon redistribuer un default route du protocole BGP (BGP d'IPv6) dedans à Enhanced Interior Gateway Routing Protocol (EIGRPv6) utilisant la redistribution mutuelle entre le BGP EIGRPv6 et d'IPv6.

Conditions préalables

Assurez-vous que vous répondez à ces exigences avant que vous tentiez cette configuration :

  • Ayez une connaissance de base d'EIGRPv6

  • Ayez une connaissance de base de BGP d'IPv6

  • Ayez une connaissance de base de l'adressage d'IPv6

Matériel et versions de logiciel

Les configurations dans ce document sont basées sur le routeur de gamme Cisco 7200 avec la version de logiciel 15.0(1) de Ý de Cisco IOS.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Dans cet exemple, les Routeurs R2 et les R1 communiquent les uns avec les autres utilisant l'eBGP d'IPv6. Utilisation R1 et R3 EIGRPv6 de Routeurs. Le default route est créé dans le routeur R2 en émettant la commande de neighbor default-originate. Afin de redistribuer mutuellement les artères d'eBGP d'IPv6 dedans à EIGRPv6, employez la commande BGP de redistribuer avec des mesures EIGRP. De même, afin de redistribuer les artères EIGRPv6 dedans à IPv6BGP, utilisez la commande de numéro de système autonome d'eigrp de redistribuer sous le mode de configuration d'address-family.

Remarque: Utilisez l'outil de recherche de commande (réservé aux clients inscrits) pour plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6-ipv6/113598-redis-ipv6-default-route-01.gif

Configurations

Ce document utilise les configurations suivantes :

Routeur R1
R1#show run
Building configuration...
!
version 15.0
!
hostname R1
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback10
 no ip address
 ipv6 address BB10::10/128
!
interface Loopback20
 no ip address
 ipv6 address BB20::20/128
!
interface Loopback30
 no ip address
 ipv6 address BB30::30/128
 ipv6 eigrp 1
!
interface Serial1/0
 no ip address
 ipv6 address 3030:1:1:1::11/64
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 ipv6 address 4040:1:1:1::10/64
 ipv6 eigrp 1
 serial restart-delay 0
!
!
router bgp 505
 no synchronization
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 neighbor 3030:1:1:1::10 remote-as 500
 no auto-summary
 !
 address-family ipv6
  redistribute eigrp 1

!--- EIGRP is redistributed in to BGP.

  no synchronization
  network BB10::10/128
  network BB20::20/128
  neighbor 3030:1:1:1::10 activate
 exit-address-family
!
!
ipv6 router eigrp 1
 eigrp router-id 1.1.1.1
 redistribute bgp 505 metric 100 1 255 1 1500

!--- EIGRP for IPv6 has a shutdown feature.
!--- Make sure that the routing process is in "no shut" mode 
!--- in order to start running the protocol.


!--- BGP is redistributed with EIGRP default metrics.

!
end

Routeur R2
R2#show run
Building configuration...
!
hostname R2
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback10
 no ip address
 ipv6 address AB10::10/128
!
interface Loopback20
 no ip address
 ipv6 address AB20::20/128
!
interface Serial1/0
 no ip address
 ipv6 address 3030:1:1:1::10/64
 serial restart-delay 0
!
router bgp 500
 no synchronization
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 neighbor 3030:1:1:1::11 remote-as 505
 neighbor 3030:1:1:1::11 default-originate
 no auto-summary
!
 address-family ipv6
  no synchronization
  network AB10::10/128
  network AB20::20/128
  neighbor 3030:1:1:1::11 activate
  neighbor 3030:1:1:1::11 default-originate
 exit-address-family
!
end

!--- Originates default route to the 
!--- neighbor 3030:1:1:1::11.

Routeur R3
R3#show run
!
version 15.0
!
hostname R3
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback10
 no ip address
 ipv6 address CC10::10/128
 ipv6 eigrp 1
!
interface Loopback20
 no ip address
 ipv6 address CC20::20/128
 ipv6 eigrp 1
!
interface Serial1/0
 no ip address
 ipv6 address 4040:1:1:1::11/64
 ipv6 eigrp 1
 serial restart-delay 0
!
!
ipv6 router eigrp 1
 eigrp router-id 3.3.3.3
!
end

Vérifiez

Utilisez cette section pour confirmer que votre configuration fonctionne correctement.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Employez l'OIT afin d'afficher une analyse de la sortie de la commande show.

Commandes show

Afin de vérifier que le routeur R3 reçoit le default route redistribué BGP d'IPv6, utilisez la commande d'eigrp de show ipv6 route dans le routeur R3.

eigrp de show ipv6 route
Dans le routeur R3
R3#show ipv6 route eigrp
IPv6 Routing Table - default - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       D - EIGRP, EX - EIGRP external, ND - Neighbor Discovery
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
EX  ::/0 [170/26112256]
     via FE80::C806:16FF:FE08:0, Serial1/0
EX  AB10::10/128 [170/26112256]
     via FE80::C806:16FF:FE08:0, Serial1/0
EX  AB20::20/128 [170/26112256]
     via FE80::C806:16FF:FE08:0, Serial1/0
D   BB30::30/128 [90/2297856]
     via FE80::C806:16FF:FE08:0, Serial1/0

!--- The above output shows that the default route
!--- is redistributed in EIGRP. EX indicates EIGRP external routes.

Afin de vérifier les artères EIGRPv6 sont redistribués dans le routeur R2 correctement, utilisent la commande BGP de show ipv6 route dans le routeur R2.

BGP de show ipv6 route
Dans le routeur R2
R2#show ipv6 route bgp
IPv6 Routing Table - default - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       D - EIGRP, EX - EIGRP external, ND - Neighbor Discovery
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B   BB10::10/128 [20/0]
     via FE80::C806:16FF:FE08:0, Serial1/0
B   BB20::20/128 [20/0]
     via FE80::C806:16FF:FE08:0, Serial1/0
B   CC10::10/128 [20/2297856]
     via FE80::C806:16FF:FE08:0, Serial1/0
B   CC20::20/128 [20/2297856]
     via FE80::C806:16FF:FE08:0, Serial1/0

!--- The above output shows that the eigrp routes
!--- are redistributed in to BGP.

Vérifiez l'accessibilité entre les Routeurs R2 et R3 utilisant la commande ping.

ping
Du routeur R2 :
 
R2#ping  CC10::10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to CC10::10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/40/96 ms

R2#ping CC20::20

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to CC20::20, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/44/100 ms
Du routeur R3 :
 
R3#ping AA10::10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to AA10::10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/33/92 ms

R3#ping AA20::20

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to AA20::20, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/33/92 ms

!--- The above ping responses shows that R1 and R3 are able
!--- to communicate with each other.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 113598