Commutateurs : Commutateurs Cisco Catalyst, s�rie�6500

Commutateurs de gamme Catalyst 6500 utilisant l'exemple de configuration VPLS

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (19 décembre 2015) | Commentaires


Contenu


Introduction

Ce document fournit une configuration d'échantillon pour le service privé virtuel réseau local (VPLS) sur les entreprises d'enables de Commutateurs de la gamme Cisco Catalyst 6500 pour joindre ensemble leur LANs basé sur Ethernets des plusieurs sites par leur fournisseur de services.

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant d'essayer cette configuration :

  • Connaissance de base de configuration sur le Commutateurs de la gamme Cisco Catalyst 6500

  • Ayez la connaissance de base de VPLS

Composants utilisés

Les informations dans ce document sont basées sur la gamme Cisco Catalyst 6500 commutent.

VPLS est pris en charge sur le commutateur de Catalyst 6500 avec SIP-600/SUP3B ou plus tard avec la version de logiciel 12.2(33)SXH ou ultérieures de½ du¿Â du Cisco IOSïÂ. Le commutateur exige l'utilisation des cartes de SIP d'exécuter la fonctionnalité VPLS.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

Du point de vue d'entreprise, VPLS utilise le réseau public du fournisseur de services en tant qu'un LAN Ethernet de trame géante qui connecte des périphériques de la CE de plusieurs sites, qui semble se connecter à une passerelle logique qui est gérée au-dessus d'un réseau IP/MPLS.

VPLS simplifie la borne LAN/WAN et présente pendant qu'un Ethernet relie, qui semble être sur le même RÉSEAU LOCAL, indépendamment de l'emplacement.

Créez d'abord une instance de transfert virtuelle (VFI) sur chaque commutateur de Catalyst 6500 afin d'installer un VPLS. Le VFI spécifie le VPN ID d'un domaine VPLS, les adresses de l'autre périphérique dans le domaine, et le type de la signalisation de tunnel et de mécanisme d'encapsulation pour chaque périphérique de pair. L'ensemble de VFIs a formé par l'interconnexion des périphériques s'appelle un exemple VPLS, qui forme la passerelle de logique au-dessus d'un réseau de commutation de paquets.

La décision de transfert de paquets est prise quand vous recherchez l'instance de transfert virtuelle de la couche 2 (VFI). Afin d'éviter le problème d'un paquet faisant une boucle dans le noyau de fournisseur, les périphériques imposent un principe de fractionnement-horizon pour le VCs émulé.

Avant que vous configuriez VPLS, configurez le MPLS au centre de sorte qu'un chemin commuté par étiquette (LSP) existe entre les périphériques.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour obtenir plus d'informations sur les commandes utilisées dans cette section.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-series-switches/113563-vpls-6500-config-01.gif

Configurations

Ce document utilise les configurations suivantes :

Commutateur 1 de Catalyst 6500
switch6500_1#configure terminal


!--- Enable the Layer 2 VFI manual configuration mode.

switch6500_1(config)#l2 vfi VPLS-A manual

!--- Configure a VPN ID for a VPLS domain.

switch6500_1(config-vfi)#vpn id 500

!--- Specify the remote peering router ID 
!--- and the tunnel encapsulation type or the pseudo-wire 
!--- property to be used to set up the emulated VC.

switch6500_1(config-vfi)#neighbor 10.7.1.3 encapsulation mpls
switch6500_1(config-vfi)#exit

switch6500_1(config)#interface Loopback 0
switch6500_1(config-if)#ip address 10.7.1.2 255.255.255.255

switch6500_1(config)#interface GigabitEthernet 6/3
switch6500_1(config-if)#switchport

!--- Set the interface as an 802.1Q tunnel port. 

switch6500_1(config-if)#switchport mode dot1qtunnel

!--- Set the VLAN when the interface is in Access mode.

switch6500_1(config-if)#switchport access vlan 500


!--- Create a dynamic switched virtual interface (SVI).

switch6500_1(config)#interface Vlan 500

!--- Disable IP processing.

switch6500_1(config-if)#no ip address

!--- Specify the Layer 2 VFI that you are binding to the VLAN port.

switch6500_1(config-if)#xconnect vfi VPLS-A
switch6500_1(config-if)#exit

switch6500_1(config)#vlan 500
switch6500_1(config-vlan)#state active
switch6500_1(config-vlan)#exit


!--- Save the configurations in the device.

switch6500_1(config)#copy running-config startup-config
switch6500_1(config)#exit

Catalyst 6500 Comm2
switch6500_2#configure terminal

switch6500_2(config)#l2 vfi VPLS-B manual
switch6500_2(config-vfi)#vpn id 500
switch6500_2(config-vfi)#neighbor 10.7.1.2 encapsulation mpls
switch6500_2(config-vfi)#exit

switch6500_2(config)#interface Loopback 0
switch6500_2(config-if)#ip address 10.7.1.3 255.255.255.255

switch6500_2(config)#interface GigabitEthernet 3/3
switch6500_2(config-if)#switchport
switch6500_2(config-if)#switchport mode dot1qtunnel
switch6500_2(config-if)#switchport access vlan 500

switch6500_2(config)#interface Vlan 500
switch6500_2(config-if)#no ip address
switch6500_2(config-if)#xconnect vfi VPLS-B
switch6500_2(config-if)#exit

switch6500_2(config)#interface vlan 500
switch6500_2(config-vlan)#state active
switch6500_2(config-vlan)#exit


!--- Save the configurations in the device.

switch6500_2(config)#copy running-config startup-config
switch6500_2(config)#exit

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

  • Employez la commande de show vfi afin de visualiser les informations sur le VFI.

  • Employez la commande du MPLS l2 vc d'exposition afin de visualiser les informations sur l'état du circuit virtuel.

  • Employez la commande de show mpls l2transport vc afin de visualiser les informations sur les circuits virtuels.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.


Informations connexes


Document ID: 113563