IP : Protocole BGP (Border Gateway Protocol)

Exemple de configuration MP-EBGP

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit des informations comment configurer le protocole BGP étendu multiprotocole (MP-EBGP) dans des routeurs Cisco IOS. MP-BGP est un BGP étendu qui permet au BGP pour diffuser les informations de routage pour le plusieurs IPv6 de protocoles de couche réseau, le VPNv4, et d'autres. MP-BGP te permet pour avoir une topologie de routage d'unicast différente d'une topologie de routage de Multidiffusion, qui aide à contrôler le réseau et les ressources.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les configurations dans ce document sont basées sur le routeur de gamme Cisco 3700 qui exécute la version de logiciel 12.4 (15)T 13 de Cisco IOSÝ.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Dans cet exemple, les Routeurs R1 et R3 sont configurés pour être dedans EN TANT QU'iBGP 5500 de formation. Le routeur R2 est configuré pour être dedans EN TANT QUE 6500. Les Routeurs R1 et R2 communiquent les uns avec les autres utilisant MP-EBGP. Tous les Routeurs sont configurés avec des adresses de bouclage.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/113555-mp-ebgp-config-01.gif

Configurations

Ce document utilise les configurations suivantes :

Configuration sur le routeur R1
R1#show run
Building configuration...
!
version 12.4
!
hostname R1
!
ip cef
!
!
interface Loopback0
 ip address 10.10.10.10 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.100.10 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 172.16.10.1 255.255.255.0
 mpls ip
 clock rate 2000000
!
router bgp 5500
 no synchronization
 bgp router-id 10.10.10.10
 bgp log-neighbor-changes
 network 192.168.100.0
 redistribute connected
 neighbor 172.16.10.2 remote-as 6500
 neighbor 172.16.10.2 soft-reconfiguration inbound
 neighbor 192.168.100.11 remote-as 5500
 no auto-summary
 !
 address-family vpnv4
  neighbor 172.16.10.2 activate
  neighbor 172.16.10.2 send-community both

!--- Sends the community attribute to a BGP neighbor.

 exit-address-family
!
!
end

Configuration sur le routeur R2
R2#show run
Building configuration...
!
version 12.4
!
hostname R2
!
ip cef
!
ip vrf WAN
 rd 2020:1
 route-target export 2020:1
 route-target import 2020:1
!
!
interface Loopback0
 ip vrf forwarding WAN

!--- Associates a VRF instance with an interface or subinterface.

 ip address 20.20.20.20 255.255.255.255
!
interface Serial0/0
 ip vrf forwarding WAN
 ip address 172.16.10.2 255.255.255.0
 mpls ip
 clock rate 2000000
!
router bgp 6500
 no synchronization
 bgp router-id 20.20.20.20
 bgp log-neighbor-changes
 neighbor 172.16.10.1 remote-as 5500
 no auto-summary
 !
 !
 address-family vpnv4
  neighbor 172.16.10.1 activate
  neighbor 172.16.10.1 send-community both
 exit-address-family
 !
 address-family ipv4 vrf WAN
  redistribute connected
  redistribute static
  neighbor 172.16.10.1 remote-as 5500
  neighbor 172.16.10.1 activate
  no synchronization
 exit-address-family
!
!
!
end

Configuration sur le routeur R3
R3#show run
Building configuration...
!
version 12.4
!
hostname R3
!
ip cef
!
!
!
interface Loopback0
 ip address 11.11.11.11 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.100.11 255.255.255.0
 duplex auto
 speed auto
!
router bgp 5500
 no synchronization
 bgp router-id 11.11.11.11
 bgp log-neighbor-changes
 neighbor 192.168.100.10 remote-as 5500
 no auto-summary
!
end

Vérifiez

Afin d'afficher des entrées dans la table du routage (BGP), utilisez la commande de show ip bgp.

show ip bgp
Dans le routeur R1
R1#show ip bgp 172.16.10.2
BGP routing table entry for 172.16.10.2/32, version 14
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Advertised to update-groups:
        1    2
  Local
    0.0.0.0 from 0.0.0.0 (10.10.10.10)
      Origin incomplete, metric 0, localpref 100, weight 32768, valid, sourced, best

!--- Displays the routing table entries for the host 172.16.10.2

R1#sh ip bgp 192.168.100.11
BGP routing table entry for 192.168.100.0/24, version 4
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Advertised to update-groups:
        1    2
  Local
    0.0.0.0 from 0.0.0.0 (10.10.10.10)
      Origin IGP, metric 0, localpref 100, weight 32768, valid, sourced, local, best

!--- Displays the entries for the host 192.168.100.11

Dans le routeur R3
R3#sh ip bgp 192.168.100.10
BGP routing table entry for 192.168.100.0/24, version 4
Paths: (1 available, best #1, table Default-IP-Routing-Table, RIB-failure(17))
  Not advertised to any peer
  Local
    192.168.100.10 from 192.168.100.10 (10.10.10.10)
      Origin IGP, metric 0, localpref 100, valid, internal, best

!--- Displays the entries for the host 192.168.100.10

Dans le routeur R2, utilisez la commande de show ip bgp vpnv4 d'afficher les informations d'adresse (VPNv4) de la table (BGP).

show ip bgp vpnv4
Dans le routeur R2
R2#sh ip bgp vpnv4 vrf WAN
BGP table version is 24, local router ID is 20.20.20.20
Status codes: s suppressed, d damped, h history, * valid, > best, I - internal,
              r RIB-failure, S Stale
Origin codes: I - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 2020:1 (default for vrf WAN)
*> 10.10.10.0/24    172.16.10.1              0             0 5500 ?
*> 20.20.20.20/32   0.0.0.0                  0         32768 ?
*  172.16.10.0/24   172.16.10.1              0             0 5500 ?
*>                  0.0.0.0                  0         32768 ?
r> 172.16.10.2/32   172.16.10.1              0             0 5500 ?
*> 192.168.100.0    172.16.10.1              0             0 5500 I

!--- Displays prefixes associated with the (VRF) instance WAN. 

R2#show ip bgp vpnv4 vrf WAN 172.16.10.1
BGP routing table entry for 2020:1:172.16.10.0/24, version 7
Paths: (2 available, best #2, table WAN)
  Advertised to update-groups:
        1
  5500
    172.16.10.1 from 172.16.10.1 (10.10.10.10)
      Origin incomplete, metric 0, localpref 100, valid, external
      Extended Community: RT:2020:1
      mpls labels in/out 18/nolabel
  Local
    0.0.0.0 from 0.0.0.0 (20.20.20.20)
      Origin incomplete, metric 0, localpref 100, weight 32768, valid, sourced, best
      Extended Community: RT:2020:1
      mpls labels in/out 18/aggregate(WAN)

!--- Displays prefixes associated with neighbor 172.16.10.1

MP-EBGP est établi entre les Routeurs R1 et R2. Utilisez la commande ping de vérifier l'accessibilité de R1 à R2 et vice versa.

ping
Dans le routeur R1
R1#ping 172.16.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/64/208 ms

R1#ping 192.168.100.11

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/41/96 ms

!--- Router R1 can successfully ping the routers R2 and R3.

Dans le routeur R2
R2#ping vrf WAN 172.16.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/32/96 ms

R2#ping vrf WAN 192.168.100.11

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/73/204 ms


!--- Router R2 can successfully reach router R1 and R3.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 113555