IP : Protocole BGP (Border Gateway Protocol)

Redistribution mutuelle entre l'EIGRP et l'exemple de configuration BGP

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document décrit comment configurer la redistribution mutuelle entre Enhanced Interior Gateway Routing Protocol (EIGRP) et le Border Gateway Protocol (BGP).

Conditions préalables

  • Connaissance de base d'EIGRP

  • Connaissance de base de BGP

Matériel et versions de logiciel

Les configurations dans ce document sont basées sur le routeur de gamme Cisco 7200 avec la version de logiciel 15.0(1) de Ý de Cisco IOS.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Dans cet exemple, les Routeurs R1 et les R2 communiquent les uns avec les autres utilisant l'EIGRP. EBGP de l'utilisation R2 et R3 de Routeurs. Afin de redistribuer mutuellement les artères d'eBGP dedans à l'EIGRP, employez la commande BGP de redistribuer avec des mesures EIGRP. De même, afin de redistribuer des artères EIGRP dedans au BGP, utilisez la commande de numéro de système autonome d'eigrp de redistribuer.

Remarque: Utilisez l'outil de recherche de commande (réservé aux clients inscrits) pour plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/113506-failover-eigrp-bgp-01.gif

Configurations

Ce document utilise les configurations suivantes :

Routeur R1
!
hostname R1
!
ip cef
!
!
interface Loopback0
 ip address 30.30.30.30 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.1.101 255.255.255.0
 duplex auto
 speed auto

!
router eigrp 100
 network 30.0.0.0
 network 192.168.1.0
 no auto-summary
!
end

Routeur R2
!
hostname R2
!
ip cef
!
!
interface Loopback0
 ip address 10.10.10.10 255.255.255.255
!
interface Loopback1
 ip address 20.20.20.20 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.1.100 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 172.16.100.50 255.255.255.0
 serial restart-delay 0
 clock rate 2000000

!
router eigrp 100
 redistribute static
 redistribute bgp 1000 metric 100 1 255 1 1500
 network 10.0.0.0
 network 192.168.1.0
 no auto-summary
!
router bgp 1000
 no synchronization
 bgp log-neighbor-changes
 network 20.20.20.20 mask 255.255.255.255
 redistribute connected
 redistribute static
 redistribute eigrp 100
 neighbor 172.16.100.51 remote-as 2000
 neighbor 172.16.100.51 next-hop-self

 
 no auto-summary
!
end

Routeur R3
!
hostname R3
!
ip cef
!
interface Loopback0
 ip address 22.22.22.22 255.255.255.255

!
interface Serial0/0
 ip address 172.16.100.51 255.255.255.0
 serial restart-delay 0
 clock rate 2000000
!
router bgp 2000
 no synchronization
 bgp log-neighbor-changes
 network 22.22.22.22 mask 255.255.255.255
 network 172.16.100.0 mask 255.255.255.0
 neighbor 172.16.100.50 remote-as 1000
 neighbor 172.16.100.50 default-originate
 default-information originate

!--- Default route is configured!


 no auto-summary

!
end

Vérifiez

Utilisez cette section pour confirmer que votre configuration fonctionne correctement.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Employez l'OIT afin d'afficher une analyse de la sortie de la commande show.

Commandes show

Afin de vérifier que l'EIGRP reçoit les artères redistribuées, utilisez la commande d'eigrp de show ip route.

eigrp de show ip route
Dans le routeur R1
R1#show ip route eigrp
20.0.0.0/32 is subnetted, 1 subnets
D EX    20.20.20.20
           [170/25625856] via 192.168.1.100, 01:00:33, FastEthernet0/0
     22.0.0.0/32 is subnetted, 1 subnets
D EX    22.22.22.22
           [170/25625856] via 192.168.1.100, 00:59:49, FastEthernet0/0
     10.0.0.0/32 is subnetted, 1 subnets
D       10.10.10.10 [90/409600] via 192.168.1.100, 00:55:17, FastEthernet0/0
D*EX 0.0.0.0/0 [170/25625856] via 192.168.1.100, 00:46:24, FastEthernet0/0


!--- Shows the default route from router R3.



!--- EX indicates that the routes are EIGRP external routes.



Afin de vérifier que des artères EIGRP sont redistribuées dans le BGP correctement, utilisez la commande BGP de show ip route dans le routeur R3.

BGP de show ip route
Dans le routeur R3
R3#show ip route bgp
show ip route bgp
     20.0.0.0/32 is subnetted, 1 subnets
B       20.20.20.20 [20/0] via 172.16.100.50, 01:03:02
     10.0.0.0/32 is subnetted, 1 subnets
B       10.10.10.10 [20/0] via 172.16.100.50, 01:03:02
B    192.168.1.0/24 [20/0] via 172.16.100.50, 01:03:02
     30.0.0.0/32 is subnetted, 1 subnets
B       30.30.30.30 [20/409600] via 172.16.100.50, 00:59:06

!--- The output indicates that the EIGRP routes are
!--- redistributed in BGP.


Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 113506