IP : Protocole BGP (Border Gateway Protocol)

Exemple de configuration de Fonction BGP Prefix-Based Outbound Route Filtering d'IPv6

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit une configuration d'échantillon utilisant l'IPv6 qui vous aide à configurer le Fonction BGP Prefix-Based Outbound Route Filtering. Cette caractéristique utilise le BGP le filtre que sortant d'artère (ORF) envoient et reçoivent les capacités qui réduisent le nombre de mises à jour BGP envoyées entre les Routeurs de pair. La configuration de cette caractéristique peut aider en filtrant les mises à jour non désirées de routage à la source.

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant que vous tentiez cette configuration :

  • Ayez une compréhension de protocole de routage BGP et de son exécution

  • Ayez une compréhension du système d'adressage d'IPv6

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les configurations dans ce document sont basées sur le routeur de gamme Cisco 7200 avec la version de logiciel 15.0(1) de½ du¿Â du Cisco IOSïÂ.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Dans cet exemple, le routeur R1 est annoncer-préfixe configuré basé ORF envoient des capacités au routeur R2. Sur l'autre routeur d'extrémité R2 est configuré pour annoncer l'ORF basé sur préfixe reçoit des capacités au routeur R1. Avant que la caractéristique de Fonction BGP Prefix-Based Outbound Route Filtering puisse être activée envoyer ou recevoir des annonces basées sur préfixe d'ORF, les sessions scrutantes BGP doivent être en service et des capacités d'ORF BGP doivent être activées sur chaque routeur participant avant un routeur.

Ce document emploie la commande voisine de préfixe-filtre d'orf afin d'activer la capacité de liste de préfixes d'ORF sur le routeur. Cette commande a été introduite dans le Logiciel Cisco IOS version 12.0(11)ST.

Remarque: Utilisez l'outil de recherche de commande (réservé aux clients inscrits) pour plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/113504-ipv6-bgp-outbound-prefixfilter-01.gif

Exemples de configuration

Ce document utilise les configurations suivantes :

Routeur R1
!
hostname R1
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback1
 no ip address
 ipv6 address 1111::1/128
!
!
interface Loopback2
 no ip address
 ipv6 address 2222::1/128
! 
!
interface Serial1/0
 no ip address
 ipv6 address 2011:11:11:11::1/64
 serial restart-delay 0
!
!
router bgp 6501
 no synchronization
 no bgp default ipv4-unicast
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 neighbor 2011:11:11:11::2 remote-as 6502
 neighbor 2011:11:11:11::2 ebgp-multihop 255
 no auto-summary
 !
 address-family ipv6
  neighbor 2011:11:11:11::2 activate
  neighbor 2011:11:11:11::2 capability orf prefix-list send
  neighbor 2011:11:11:11::2 prefix-list FILTER_IPv6 in
 exit-address-family
!
!
ipv6 prefix-list FILTER_IPv6 seq 10 permit 1111::1/128
ipv6 prefix-list FILTER_IPv6 seq 20 permit 2222::1/128
!
!
end

Routeur R2
!
hostname R2
!
!
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
!
interface Loopback1
 no ip address
 ipv6 address 1010::1/128
 !
!
interface Loopback2
 no ip address
 ipv6 address 2020::1/128
!
interface Serial1/0
 no ip address
 ipv6 address 2011:11:11:11::2/64
 serial restart-delay 0
!
!
router bgp 6502
 no synchronization
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 neighbor 2011:11:11:11::1 remote-as 6501
 neighbor 2011:11:11:11::1 ebgp-multihop 255
 no auto-summary
 !
 address-family ipv6

  network 1010::1/128
  network 2020::1/128
  neighbor 2011:11:11:11::1 activate
  neighbor 2011:11:11:11::1 capability orf prefix-list receive
  neighbor 2011:11:11:11::1 prefix-list R2_list in
 exit-address-family
!
ipv6 prefix-list R2_list seq 10 permit 1010::1/128
ipv6 prefix-list R2_list seq 20 permit 2020::1/128
!
end

Scénario 1 : Artères de filtre basées sur le prefix-list avec des expressions

Dans ce scénario, une adresse de bouclage 1000::1/45 est configurée dans R1 sous le bouclage 0 d'interface. Un prefix-list est créé afin de permettre toutes les artères qui sont plus grandes que la longueur de préfixe : : /64.

Remarque: La configuration de routeur R2 demeure la même que précédemment donnée et des modifications de configuration R1 comme affiché ici. Les adresses IP sur ces Routeurs demeure les mêmes.

Routeur R1

!--- Output omitted.
 
!
interface Loopback0
 no ip address
 ipv6 address 1000::1/45
 !

!--- Output omitted.

  router bgp 6501
 no synchronization
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 neighbor 2011:11:11:11::2 remote-as 6502
 neighbor 2011:11:11:11::2 ebgp-multihop 255
 no auto-summary
 !
 address-family ipv6
  network 1000::1/45
  network 1111::1/128
  network 2222::1/128
  neighbor 2011:11:11:11::2 activate
  neighbor 2011:11:11:11::2 prefix-list IPV6-LONG in

!--- Applies the prefix-list and filters 
!--- the incoming updates from the neighbor 2011:11:11:11::2.

 exit-address-family
!
ipv6 prefix-list IPV6-LONG description Match any prefix longer than /64
ipv6 prefix-list IPV6-LONG seq 1 permit ::/0 ge 64

!--- seq 1 permit ::/0 ge 64 permits anything
!--- that is ge /64 subnet mask.

!
end

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Ces commandes show sont utilisées de vérifier la configuration :

Vérifiez le Fonction BGP Prefix-Based Outbound Route Filtering d'IPv6 configuré en mode d'envoi

Dans le routeur R1 :

show running-config | priez le BGP
router bgp 6501
 no synchronization
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 neighbor 2011:11:11:11::2 remote-as 6502
 neighbor 2011:11:11:11::2 ebgp-multihop 255
 no auto-summary
 !
 address-family ipv6
  neighbor 2011:11:11:11::2 activate
  neighbor 2011:11:11:11::2 capability orf prefix-list send

!--- Indicates that the neighbor 2011:11:11:11::2 
!--- is configured with the prefix-based 
!--- ORF feature in send mode.

voisins d'unicast de show bgp ipv6
R1#show bgp ipv6 unicast neighbors 2011:11:11:11::2
BGP neighbor is 2011:11:11:11::2,  remote AS 6502, external link
  BGP version 4, remote router ID 2.2.2.2
  Session state = Established, up for 01:30:36
  Last read 00:00:44, last write 00:00:42, hold time is 180, keepalive interval is 60 seconds 
 BGP multisession with 2 sessions (2 established), first up for 01:31:26
  Neighbor sessions:
    2 active, is multisession capable
  Neighbor capabilities:
    Route refresh: advertised and received(new) on session 1, 2
    Four-octets ASN Capability: advertised and received on session 1, 2
    Address family IPv4 Unicast: advertised and received
    Address family IPv6 Unicast: advertised and received

!--- Output omitted.

 For address family: IPv6 Unicast
  Session: 2011:11:11:11::2 session 2
  BGP table version 1, neighbor version 1/0
  Output queue size : 0
  Index 2
  session 2 member
  2 update-group member
  AF-dependant capabilities:
    Outbound Route Filter (ORF) type (128) Prefix-list:

!--- Shows that the neighbor 2011:11:11:11::2 
!--- is configured with the prefix-based 
!--- ORF feature in send mode.

      Send-mode: advertised
      Receive-mode: received
  Outbound Route Filter (ORF): sent;
  Incoming update prefix filter list is FILTER_IPv6
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               2          4
    Prefixes Total:                 0          0
    Implicit Withdraw:              1          0
    Explicit Withdraw:              1          0
    Used as bestpath:             n/a          0
    Used as multipath:            n/a          0

                                   Outbound    Inbound
  Local Policy Denied Prefixes:    --------    -------
    
  
!--- Output omitted.

Vérifiez le Fonction BGP Prefix-Based Outbound Route Filtering d'IPv6 configuré dedans reçoivent le mode

Dans le routeur R2 :

show running-config | priez le BGP
router bgp 6502
 no synchronization
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 neighbor 2011:11:11:11::1 remote-as 6501
 neighbor 2011:11:11:11::1 ebgp-multihop 255
 no auto-summary
 !
 address-family ipv6
  network 1010::1/128
  network 2020::1/128
  neighbor 2011:11:11:11::1 activate
  neighbor 2011:11:11:11::1 capability orf prefix-list receive

!--- Indicates that the neighbor 2011:11:11:11::1 
!--- is configured with the prefix-based 
!--- ORF feature in receive mode.

voisins d'unicast de show bgp ipv6
R2#show bgp ipv6 unicast nei 2011:11:11:11::1
BGP neighbor is 2011:11:11:11::1,  remote AS 6501, external link
  BGP version 4, remote router ID 1.1.1.1
  Session state = Established, up for 01:47:11
  Last read 00:00:44, last write 00:00:32, hold time is 180, keepalive interval is 60 seconds  
multisession with 2 sessions (2 established), first up for 01:48:02
  Neighbor sessions:
    2 active, is multisession capable
  Neighbor capabilities:
    Route refresh: advertised and received(new) on session 1, 2
    Four-octets ASN Capability: advertised and received on session 1, 2
    Address family IPv4 Unicast: advertised and received
    Address family IPv6 Unicast: advertised and received
    Multisession Capability: advertised and received
 
!--- Output omitted.


 For address family: IPv6 Unicast
  Session: 2011:11:11:11::1 session 2
  BGP table version 3, neighbor version 3/0
  Output queue size : 0
  Index 3
  session 2 member
  3 update-group member
  AF-dependant capabilities:
    Outbound Route Filter (ORF) type (128) Prefix-list:

!--- Shows that the neighbor 2011:11:11:11::1 
!--- is configured with the prefix-based 
!--- ORF feature in receive mode.

      Send-mode: received
      Receive-mode: advertised
  Outbound Route Filter (ORF): received (2 entries)
Incoming update prefix filter list is R2_list
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               2          5
    Prefixes Total:                 0          0
    Implicit Withdraw:              0          0
    Explicit Withdraw:              2          0
    

!--- Output omitted.
 

Vérifiez le scénario 1 : Artères de filtre basées sur le prefix-list avec des expressions

Émettez la commande BGP de show ipv6 route dans le routeur R1 afin d'afficher le contenu en cours de la table de routage BGP d'IPv6.

BGP de show ipv6 route
Dans le routeur R1 :
R1#show ipv6 route bgp
IPv6 Routing Table - default - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       D - EIGRP, EX - EIGRP external, ND - Neighbor Discovery
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B   1010::1/128 [20/0]
     via 2011:11:11:11::2
B   2020::1/128 [20/0]
     via 2011:11:11:11::2

!--- In this ouput, 1000::1/45 is not 
!--- displayed because the network is lesser 
!--- than ::/64 prefix and its filtered. 

Employez la commande de show ipv6 prefix-list afin d'afficher des informations des entrées sur d'IPv6 liste de préfixes ou de liste de préfixes d'IPv6.

show ipv6 prefix-list
Dans le routeur R1 :
 
R1#show ipv6 prefix-list detail

Prefix-list with the last deletion/insertion: IPV6-LONG
ipv6 prefix-list IPV6-LONG:
   Description: Match any prefix longer than /64
   count: 1, range entries: 1, sequences: 1 - 1, refcount: 3
   seq 1 permit ::/0 ge 64 (hit count: 14, refcount: 1)

R1#show ipv6 prefix-list summary

Prefix-list with the last deletion/insertion: IPV6-LONG
ipv6 prefix-list IPV6-LONG:
   Description: Match any prefix longer than /64
   count: 1, range entries: 1, sequences: 1 - 1, refcount: 3

R1#show ipv6 prefix-list  IPV6-LONG

ipv6 prefix-list IPV6-LONG: 1 entries
   seq 1 permit ::/0 ge 64


Informations connexes


Document ID: 113504