Commutateurs : Commutateurs Cisco Nexus, s�rie�7000

Exemple de configuration du commutateur ERSPAN de gamme de Nexus 7000

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document décrit comment configurer une session encapsulée de l'analyseur de port commutée par distant (ERSPAN) sur la gamme d'un Nexus 7000 commutent que surveille le trafic entre les ports Ethernet sur deux Commutateurs différents de gamme de Nexus 7000.

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant que vous tentiez cette configuration :

  • Ayez la connaissance de base de la configuration sur des Commutateurs de gamme de Nexus 7000

  • Ayez la connaissance de base d'ERSPAN

Composants utilisés

Les informations dans ce document sont basées sur la version de logiciel 5.1(3) du Switch on Cisco NX-OS de gamme 7018 de Nexus.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

Au sujet d'ERSPAN

  • ERSPAN active la télésurveillance des plusieurs commutateurs à travers votre réseau.

  • Les transports ERSPAN reflétés trafiquent des ports de source de différents Commutateurs à la destination port, où l'analyseur de réseau s'est connecté.

  • Le trafic est encapsulé au commutateur source et est transféré vers le commutateur de destination, où le paquet est désencapsulé et puis envoyé à la destination port.

  • ERSPAN se compose d'une session de source ERSPAN, d'un Encapsulation de routage générique (GRE) routable ERSPAN - le trafic encapsulé, et d'une session de destination ERSPAN.

  • Vous pouvez configurer des sessions de source ERSPAN et des sessions de destination sur différents Commutateurs séparément.

  • ERSPAN ne fait pas ne surveille aucun paquet qui sont générés par le superviseur, indépendamment de leur source.

Sources ERSPAN

  • Les interfaces dont le trafic peut être surveillé s'appellent les sources ERSPAN.

  • Vous pouvez surveiller tous les paquets pour le port de source qui est reçu (d'entrée), transmis (de sortie), ou bidirectionnel (chacun des deux).

  • Les sources ERSPAN incluent des ports de source, la source VLAN, ou la source VSANs. Quand un VLAN est spécifié comme source ERSPAN, toutes les interfaces prises en charge dans le VLAN sont des sources ERSPAN.

Destinations ERSPAN

  • Les destinations port reçoivent le trafic copié des sources ERSPAN.

  • La destination port est un port qui a été connecté au périphérique tel que le périphérique SwitchProbe ou tout autre sonde de surveillance à distance (RMON) ou périphérique de sécurité qui peuvent recevoir et analysent les paquets copiés du port de source simple ou plusieurs.

  • Les destinations port ne participent à aucun exemple de spanning-tree ou en posent 3 protocoles.

Configurez

Cet exemple de configuration utilise un port de source sur le commutateur 1 de gamme de Nexus 7000 et une destination port sur un autre commutateur de Nexus 7000, où l'analyseur de réseau s'est connecté. Il y a un lien d'Ethernets entre les les deux les Commutateurs, suivant les indications du diagramme.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour obtenir plus d'informations sur les commandes utilisées dans cette section.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

http://www.cisco.com/c/dam/en/us/support/docs/switches/nexus-7000-series-switches/113480-erspan-nexus-7k-01.gif

Configurations

Ce document utilise les configurations suivantes :

Commutateur 1 de Nexus 7000
switch_1#configure terminal


!--- Configures an ERSPAN source session.

switch_1(config)#monitor session 48 type erspan-source

!--- Configure the sources and traffic direction.

switch_1(config-erspan-src)#source interface Ethernet2/10 both

!--- Configure the destination IP address in the ERSPAN session.

switch_1(config-erspan-src)#destination ip 10.11.11.3

!--- Configure the ERSPAN ID.

switch_1(config-erspan-src)#erspan-id 902

!--- Configure the VRF.

switch_1(config-erspan-src)#vrf default

!--- Enable the ERSPAN source session (by default the session is 
!--- in shutdown state).

switch_1(config-erspan-src)#no shut
switch_1(config-erspan-src)#exit


!--- Configure the ERSPAN global origin IP address.

switch_1(config)#monitor erspan origin ip-address 10.254.254.21 global



!--- Configure the IP address for loopback interface, which is used
!--- as source of the ERSPAN traffic.

switch_1(config)#interface loopback1
switch_1(config-if)#ip address 10.254.254.21/32
switch_1(config-if)#exit

switch_1(config)#interface Ethernet1/1
switch_1(config-if)#switchport
switch_1(config-if)#switchport mode trunk
switch_1(config-if)#no shutdown
switch_1(config-if)#exit

switch_1(config)#feature interface-vlan
switch_1(config)#interface Vlan 11
switch_1(config-if)#ip address 10.11.11.2/29
switch_1(config-if)#no ip redirects
switch_1(config-if)#no shutdown
switch_1(config-if)#exit


!--- Save the configurations in the device.

switch_1(config)#copy running-config startup-config
Switch_1(config)#exit

Commutateur 2 de Nexus 7000
switch_2#configure terminal


!--- Configures an ERSPAN destination session.

switch_2(config)#monitor session 47 type erspan-destination

!--- Configures the source IP address.

switch_2(config-erspan-src)#source ip 10.11.11.3

!--- Configures a destination for copied source packets.

switch_2(config-erspan-src)#destination interface Ethernet2/34

!--- Configure the ERSPAN ID.

switch_2(config-erspan-src)#erspan-id 902

!--- Configure the VRF.

switch_2(config-erspan-src)#vrf default

!--- Enable the ERSPAN destination session (by default the session is 
!--- in shutdown state).

switch_2(config-erspan-src)#no shut
switch_2(config-erspan-src)#exit

switch_2(config)#interface Ethernet2/34
switch_2(config-if)#switchport monitor
switch_2(config-if)#exit

switch_2(config)#feature interface-vlan
switch_2(config)#interface Vlan 11
switch_2(config-if)#ip address 10.11.11.3/29
switch_2(config-if)#no ip redirects
switch_2(config-if)#no shutdown
switch_2(config-if)#exit

switch_2(config)#interface Ethernet1/2
switch_2(config-if)#switchport
switch_2(config-if)#switchport mode trunk
switch_2(config-if)#no shutdown
switch_2(config-if)#exit


!--- Save the configurations in the device.

switch_2(config)#copy running-config startup-config
Switch_2(config)#exit

Vérifiez

Utilisez cette section pour confirmer que votre configuration fonctionne correctement.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Ce sont certaines des commandes de vérification ERSPAN :

  • Employez la commande de show monitor afin d'afficher le statut des sessions ERSPAN :

    switch_1# show monitor
    Session  State        Reason                  Description
    -------  -----------  ----------------------  --------------------------------
    4        up           The session is up
  • Employez la commande de show monitor session [session_number de session] afin d'afficher la configuration de session ERSPAN :

    switch_1# show monitor session 48
       session 48
    ---------------
    type              : erspan-source
    state             : up
    erspan-id         : 902
    vrf-name          : default
    acl-name          : acl-name not specified
    ip-ttl            : 255
    ip-dscp           : 0
    destination-ip    : 10.11.11.3
    origin-ip         : 10.254.254.21 (global)
    source intf       :
        rx            : Eth2/10
        tx            : Eth2/10
        both          : Eth2/10
    source VLANs      :
        rx            :
        tx            :
        both          :
    filter VLANs      : filter not specified
  • Utilisez le show monitor session toute la commande afin d'afficher toute la configuration de sessions ERSPAN dans le périphérique.

  • Employez la commande de moniteur de show running-config afin d'afficher la configuration de l'exécution ERSPAN :

    switch_1# show running-config monitor
    
    !Command: show running-config monitor
    !Time: Thu Apr 19 10:15:33 2012
    
    version 5.1(3)
    monitor session 48 type erspan-source
      erspan-id 902
      vrf default
      destination ip 10.11.11.3
      source interface Ethernet2/10 both
      no shut
    
    monitor erspan origin ip-address 10.254.254.21 global
  • Employez la commande de moniteur de show startup-config afin d'afficher la configuration de startup ERSPAN.


Informations connexes


Document ID: 113480