IP : IP version 6 (IPv6)

Redistribuez les artères OSPFv3 dans l'exemple de configuration BGP

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit un exemple de redistribuer des artères de la version 3 de protocole OSPF (OSPFv3) dedans au BGP multiprotocole pour l'IPv6. OSPFv3 examine la version 2 OSPF afin de fournir le support pour l'IPv6 conduisant des préfixes et les adresses plus grandes d'IPv6. Le BGP multiprotocole est un BGP amélioré telles que lequel diffuse les informations de routage pour la plusieurs famille de familles d'adresse de protocole de couche réseau, d'ipv6 addres et pour des artères de Protocole IP Multicast.

Conditions préalables

Conditions préalables

Assurez-vous que vous répondez à ces exigences avant que vous tentiez cette configuration :

Matériel et versions de logiciel

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les configurations dans ce document sont basées sur le routeur de gamme Cisco 3700 avec la version de logiciel 12.4 (15)T1 de½ du¿Â du Cisco IOSïÂ.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Dans cet exemple, les Routeurs R2 et R3 sont connectés par une interface série et sont configurés avec le BGP multiprotocole. Les Routeurs R2 et R3 communiquent avec leurs routeurs locaux R1 et R4 utilisant OSPFv3. Des adresses de bouclage sont créées dans les Routeurs pour générer des réseaux. Les Routeurs R2 et R3, qui exécutent le BGP et l'OSPFv3, emploient la commande de redistribuer afin de redistribuer les artères OSPFv3 dedans au BGP. Tous les Routeurs sont configurés avec des adresses d'IPv6.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6-ipv6/113453-redis-ospfv3-bgp-01.gif

Configurations

Ce document utilise les configurations suivantes :

Routeur R1
!
version 12.4
!
hostname R1
!
ip cef
!
ipv6 unicast-routing

!--- Enables the forwarding of IPv6 packets.

!
interface Loopback0
 no ip address
 ipv6 address 2222::1/128
 ipv6 ospf 1 area 0

!--- Enables OSPFv3 on the interface and associates
!--- the interface loopback0 to area 0.

!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 1010:1:1:1::1/64
 ipv6 ospf 1 area 0

!--- Associates the Interface Fa0/0 to area 0.

!
ipv6 router ospf 1
 router-id 1.1.1.1

!--- Router R1 uses 1.1.1.1 as router ID.

 log-adjacency-changes
!
end

Routeur R2
!
version 12.4
!
hostname R2
!
ip cef
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 2010::1/128
 ipv6 ospf 1 area 1
!
interface Loopback1
 no ip address
 ipv6 address 2011::1/128
 ipv6 ospf 1 area 1
!
interface Loopback99
 no ip address
 ipv6 address 5050:55:55:55::55/128
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 1010:1:1:1::2/64
 ipv6 ospf 1 area 0
!
interface Serial0/0
 no ip address
 ipv6 address 3030:1:1:1::10/64
 clock rate 2000000
!
router bgp 65000
 bgp router-id 1.1.1.1
 no bgp default ipv4-unicast

!--- Without configuring "no bgp default ipv4-unicast" only 
!--- IPv4 will be advertised.

 bgp log-neighbor-changes
 neighbor 3030:1:1:1::11 remote-as 65000
 neighbor 3030:1:1:1::11 update-source Serial0/0
 !
 address-family ipv6
  neighbor 3030:1:1:1::11 activate
  network 5050:55:55:55::55/128
  redistribute connected
  redistribute ospf 1 match internal external 1 external 2

!--- This redistributes all OSPF routes into BGP.

  no synchronization
 exit-address-family
!
ipv6 router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
!
end

Routeur R3
!
version 12.4
!
hostname R3
!
ip cef
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 1111::1/128
 ipv6 ospf 1 area 1
!
interface Loopback1
 no ip address
 ipv6 address 1112::1/128
 ipv6 ospf 1 area 1
!
interface Loopback99
 no ip address
 ipv6 address 6060:66:66:66::66/128
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2020:1:1:1::2/64
 ipv6 ospf 1 area 0
!
interface Serial0/0
 no ip address
 ipv6 address 3030:1:1:1::11/64
 clock rate 2000000
!
router bgp 65000
 bgp router-id 2.2.2.2
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 3030:1:1:1::10 remote-as 65000
 neighbor 3030:1:1:1::10 update-source Serial0/0
 !
 address-family ipv6
  neighbor 3030:1:1:1::10 activate
  network 6060:66:66:66::66/128
  redistribute connected
  redistribute ospf 1 match internal external 1 external 2
  no synchronization
 exit-address-family
!
ipv6 router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
!
end

Routeur R4
!
version 12.4
!
hostname R4
!
ip cef
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 3333::1/128
 ipv6 ospf 1 area 0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2020:1:1:1::1/64
 ipv6 ospf 1 area 0
!
ipv6 router ospf 1
 router-id 5.5.5.5
 log-adjacency-changes
!
end

Vérifiez

Utilisez cette section pour confirmer que votre configuration fonctionne correctement.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Ces commandes show sont utilisées de vérifier la configuration :

Vérifiez la configuration OSPFv3

Afin de vérifier qu'OSPFv3 est configuré correctement, utilisez la commande OSPF de show ipv6 route dans des Routeurs R1 et R4.

OSPF de show ipv6 route
Dans le routeur R1
 
R1#show ipv6 route ospf
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
OI  2010::1/128 [110/10]
     via FE80::C001:16FF:FEDC:0, FastEthernet0/0
OI  2011::1/128 [110/10]
     via FE80::C001:16FF:FEDC:0, FastEthernet0/0
Dans le routeur R4
 
R4#show ipv6 route ospf
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
OI  1111::1/128 [110/10]
     via FE80::C002:16FF:FEDC:0, FastEthernet0/0
OI  1112::1/128 [110/10]
     via FE80::C002:16FF:FEDC:0, FastEthernet0/0

Vérifiez la configuration BGP

Afin de vérifier si les artères OSPFv3 sont redistribuées dedans au BGP, utilisez la commande BGP de show ipv6 route dans des Routeurs R2 et R3.

BGP de show ipv6 route
Dans le routeur R2
R2#show ipv6 route bgp
IPv6 Routing Table - 14 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
B   1111::1/128 [200/0]
     via 3030:1:1:1::11
B   1112::1/128 [200/0]
     via 3030:1:1:1::11
B   2020:1:1:1::/64 [200/0]
     via 3030:1:1:1::11
B   3333::1/128 [200/10]
     via 3030:1:1:1::11

!--- The above routes are OSPFv3 routes
!--- that are redistributed in to BGP.

B   6060:66:66:66::66/128 [200/0]
     via 3030:1:1:1::11
Dans le routeur R3
R3#show ipv6 route bgp
IPv6 Routing Table - 14 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
B   1010:1:1:1::/64 [200/0]
     via 3030:1:1:1::10
B   2010::1/128 [200/0]
     via 3030:1:1:1::10
B   2011::1/128 [200/0]
     via 3030:1:1:1::10
B   2222::1/128 [200/10]
     via 3030:1:1:1::10

!--- The above routes are OSPFv3 routes
!--- that are redistributed in to BGP.

B   5050:55:55:55::55/128 [200/0]
     via 3030:1:1:1::10


Informations connexes


Document ID: 113453