IP : Protocole EIGPR (Enhanced Interior Gateway Routing Protocol)

Basculement avec l'EIGRP utilisant l'exemple de configuration de VRF

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document décrit comment configurer le Basculement avec le Protocole EIGPR (Enhanced Interior Gateway Routing Protocol) utilisant le routage et l'expédition virtuels (VRF). Le VRF est une extension de Routage IP qui fournit des exemples de plusieurs routage. Les fournisseurs d'accès Internet (ISP) tirent profit de ce VRF afin de créer le Réseaux privés virtuels (VPN) distinct pour les clients pendant qu'il permet à des multiples instances de la table de routage d'exister dans un routeur.

Conditions préalables

  • Connaissance de base d'EIGRP

  • Connaissance de base de VRF

Matériel et versions de logiciel

Les configurations dans ce document sont basées sur le routeur de gamme Cisco 3700 sur la version de logiciel 12.4 (15)T 13 de½ du¿Â du Cisco IOSïÂ.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Dans cet exemple, le routeur R1 est considéré un routeur PE. Les Routeurs R2 et R3 sont considérés des Routeurs de la CE. L'utilisation EIGRP de Routeurs de communiquer les uns avec les autres. Si R2 perd la Connectivité avec R1 (c'est-à-dire, en cas de Basculement), les artères peuvent accéder R1 par R3. Les Routeurs R2 et R3 ont une connexion MPLS entre eux.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/113446-failover-eigrp-vrf-01.gif

Configurations

Ce document utilise les configurations suivantes :

Routeur R1
!
version 12.4
!
hostname R1
!
ip cef
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.1.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 57.35.169.2 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 220
 network 2.2.2.2 0.0.0.0
 network 57.35.169.2 0.0.0.0
 network 192.168.1.0
 no auto-summary

!--- Configured EIGRP and advertised the networks.

!
end

Routeur R2
!
version 12.4
!
hostname R2
!
ip cef
!
ip vrf A

!--- Configures VRF routing table!

 rd 1.1.1.1:111

!---Configuring a route distinguisher RD creates routing and forwarding
table for a VRF.

The RD can be used in either of these formats:

    - 16-bit AS number: Your 32-bit number (for example, 1:100)

    - 32-bit IP address: Your 16-bit number (In our case, 1.1.1.1:111)


 route-target export 1.1.1.1:111
 route-target import 1.1.1.1:111

!--- Creates a list of import and/or export
 route target communities for the specified VRF.

!
ip vrf B
 rd 2.2.2.2:222
import ipv4 unicast map vrfA-to-vrfB

!--- Associates the specified route map with the VRF.

 route-target export 2.2.2.2:222
 route-target import 2.2.2.2:222
!
mpls label protocol ldp
!
interface Loopback1
 ip vrf forwarding B

!--- Associates a VRF instance with an interface.

 ip address 172.16.2.1 255.255.255.255
!
interface FastEthernet0/0
 ip vrf forwarding A
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip vrf forwarding A
 ip address 10.0.0.1 255.255.255.0
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet1/0
 ip vrf forwarding B
 ip address 203.197.194.1 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 1
 no auto-summary
 !
 address-family ipv4 vrf B

!--- Enter address family configuration mode
  for configuring EIGRP routing sessions.


  network 172.16.2.0 0.0.0.255
  network 203.197.194.0
  no auto-summary
  autonomous-system 330

!--- Defines the autonomous system number for this 
specific instance of EIGRP.

 exit-address-family
 !
 address-family ipv4 vrf A
  network 10.0.0.1 0.0.0.0
   network 192.168.1.0
  no auto-summary
  autonomous-system 220
 exit-address-family
!
access-list 99 permit 172.16.1.0 0.0.0.255
access-list 99 permit 192.168.1.0 0.0.0.255
access-list 101 permit udp host 192.168.1.1 eq bootps host 1.1.1.1 eq bootps

!--- Create access list in order to permit the host addresses.

!
route-map vrfA-to-vrfB permit 10
 match ip address 99

!--- Created a route map and distributed the routes
permitted by access list 99. 

!
end

Routeur R3
!
version 12.4
!
hostname R3
!
ip cef
!
!
!
!
ip vrf A
 rd 1.1.1.1:111
!
mpls label protocol ldp
!
interface Loopback1
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip vrf forwarding A
 ip address 10.0.0.2 255.255.255.0
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet0/1
 ip vrf forwarding A
 ip address 57.35.169.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 203.197.194.2 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 330
 network 1.1.1.1 0.0.0.0
 network 10.0.0.2 0.0.0.0
 network 57.35.169.1 0.0.0.0
 network 203.197.194.0
 no auto-summary
 !
 address-family ipv4 vrf A
  network 10.0.0.2 0.0.0.0
  network 57.35.169.1 0.0.0.0
  no auto-summary
 autonomous-system 220
 exit-address-family
!
end

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Commandes show

Afin de vérifier que l'EIGRP est configuré correctement, utilisez la commande de show ip route vrf.

show ip route vrf
Dans le routeur R2
R2#show ip route vrf A

Routing Table: A
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       I - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/409600] via 192.168.1.2, 00:15:47, FastEthernet0/0
     57.0.0.0/24 is subnetted, 1 subnets
D       57.35.169.0 [90/307200] via 192.168.1.2, 00:15:47, FastEthernet0/0
                    [90/307200] via 10.0.0.2, 00:15:47, FastEthernet0/1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, FastEthernet0/1
C    192.168.1.0/24 is directly connected, FastEthernet0/0
Dans le routeur R3
R3#show ip route vrf A

Routing Table: A
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       I - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/409600] via 57.35.169.2, 00:16:59, FastEthernet0/1
     57.0.0.0/24 is subnetted, 1 subnets
C       57.35.169.0 is directly connected, FastEthernet0/1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, FastEthernet0/0
D    192.168.1.0/24 [90/307200] via 57.35.169.2, 00:17:02, FastEthernet0/1
                    [90/307200] via 10.0.0.1, 00:17:02, FastEthernet0/0

!--- Displays the routing table associated with
VRF instance A.

Si R2 perd la Connectivité à R1, les artères de R2 accéderont le routeur R1 par R3.

En cas de Basculement
Quand R2 perd sa Connectivité à R1, émettre d'essai s'est arrêté sur R2 Fa0/0. Dans le routeur R2
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#int fa0/0
R2(config-if)#shut down
R2(config-if)#
*Mar  1 00:01:01.539: %TDP-5-INFO: VRF A: TDP ID removed
*Mar  1 00:01:01.675: %LDP-5-NBRCHG: LDP Neighbor (vrf A) 57.35.169.1:0 (1) is
  DOWN (LDP Router ID changed)
*Mar  1 00:01:01.679: %DUAL-5-NBRCHANGE: IP-EIGRP(1) 220: Neighbor 192.168.1.2
  (FastEthernet0/0) is down: interface down
R2(config-if)#
*Mar  1 00:01:03.519: %LINK-5-CHANGED: Interface FastEthernet0/0, changed state
  to administratively down
*Mar  1 00:01:04.519: %LINEPROTO-5-UPDOWN: Line protocol on Interface 
  FastEthernet0/0, changed state to down
Au même exemple dans le routeur R3, le lien de Basculement obtient lancé.
R3#
*Mar  1 00:00:52.527: %LDP-5-NBRCHG: LDP Neighbor (vrf A) 192.168.1.1:0 (1) is 
  DOWN (TCP connection closed by peer)
R3#
*Mar  1 00:00:59.591: %LDP-5-NBRCHG: LDP Neighbor (vrf A) 10.0.0.1:0 (1) is UP

Afin de vérifier que le routeur R2 peut encore atteindre R1, émettez la commande de ping vrf afin de cingler R1 du routeur R2.

Ping
Dans le routeur R2
R2#ping vrf A 192.168.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/51/96 ms

!--- R2 can still reach R1 through R3.


Informations connexes


Document ID: 113446