IP : IP version 6 (IPv6)

Artères de charge statique de mise en place pour l'exemple de configuration d'IPv6

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document décrit comment configurer les artères statiques pour l'IPv6. Les artères statiques sont les artères manuellement configurées qui définit le chemin explicite entre deux périphériques. Dans le cas du changement de topologie d'un réseau, les artères statiques ne sont pas automatiquement mises à jour comme celle de l'des protocoles dynamiques et doivent être manuellement modifiées. Les artères statiques sont utiles pour des réseaux plus petits qui a seulement un chemin aux réseaux extérieurs.

L'inconvénient principal de l'utilisation des artères statiques est le manque de configuration automatique en cas de modifications de topologie. Des artères statiques sont également mises en application pour fournir la Sécurité pour certains types de trafics à d'autres réseaux qui ont besoin de plus de contrôle. Les limites qui sont considérées dans l'utilisation des artères statiques sont le manque de Redondance et dans les réseaux plus vastes que la reconfiguration manuelle des artères peut devenir de grands frais d'administration.

Employez la commande d'ipv6 route afin de configurer le routage statique. Notez qu'avant que vous configuriez le routeur avec un ipv6 route statique, vous devez activer l'expédition des paquets d'IPv6 avec la commande d'ipv6 unicast-routing en mode de configuration globale.

Conditions préalables

Assurez-vous que vous répondez à ces exigences avant d'essayer cette configuration :

  • La connaissance du routage statique d'ipv4

  • La connaissance du système d'adressage d'IPv6

Composants utilisés

Les informations dans ce document sont basées sur le routeur de gamme Cisco 3700 sur la version de logiciel 12.4 (15)T 13 de Ý de Cisco IOS.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6-ipv6/113361-ipv6-static-routes-01.gif

Configurations

Ce document utilise les configurations suivantes :

Voici un lien à un vidéo, disponible sur la Communauté de support de Ciscoleavingcisco.com , qui explique comment configurer les artères statiques pour le réseau d'IPv6 dans des routeurs Cisco IOS :

Configuration des artères de charge statique pour l'IPv6 dans le Cisco IOS leavingcisco.com

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6-ipv6/113361-ipv6-static-routes-02.gif

Routeur R1
version 12.4
!
hostname R1
!
ip cef
!
ipv6 unicast-routing

!--- Enables the forwarding of IPv6 packets.

!
interface Loopback1
 no ip address
 ipv6 address 1010::1/128
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2000::1/126
!
ip forward-protocol nd
!
ipv6 route 2001::/126 2000::2
ipv6 route 2020::1/128 2000::2
ipv6 route 3030::1/128 2000::2

!--- Static routes are configured in router R1, 
!--- to reach the networks in router R2 and R3.
!--- This is done when you specify 
!--- the next-hop address, which in this case is
!--- 2000::2 from which the output interface 
!--- is automatically derived.


!
end

Routeur R2
version 12.4
!
hostname R2
!
ip cef
!
ipv6 unicast-routing
!
interface Loopback2
 no ip address
 ipv6 address 2020::1/128
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2000::2/126
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001::1/126
!
ip forward-protocol nd
!
ipv6 route 1010::1/128 2000::1
ipv6 route 3030::1/128 2001::2

!--- Static routes are configured to reach
!--- routers R1 and R3 loopback address when you 
!--- specify the corresponding interface address.

!
end

Routeur R3
version 12.4
!
hostname R3
!
ip cef
!
ipv6 unicast-routing
!
interface Loopback3
 no ip address
 ipv6 address 3030::1/128
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001::2/126
!
ip forward-protocol nd
!
ipv6 route 1010::1/128 2001::1
ipv6 route 2000::/126 2001::1
ipv6 route 2020::1/128 2001::1

!--- For router 3, to reach R1 and R2, 
!--- static routes are configured when you 
!--- mention 2001::1 as the next-hop address.

!
end

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Employez la commande statique de show ipv6 route afin d'afficher le contenu de la table de routage d'IPv6, et la sortie est exposition ci-dessous :

charge statique de show ipv6 route
Dans le routeur R1
R1#show ipv6 route static
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
S   2001::/126 [1/0]
     via 2000::2
S   2020::1/128 [1/0]
     via 2000::2
S   3030::1/128 [1/0]
     via 2000::2

!--- Displays the static routes learnt by router R1 through 2000::2.

Dans le routeur R3
R3#show ipv6 route static
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
S   1010::1/128 [1/0]
     via 2001::1
S   2000::/126 [1/0]
     via 2001::1
S   2020::1/128 [1/0]
     via 2001::1

!--- Displays the static routes learnt by router R3 through 2001::1.

Le routeur R1 a les artères au routeur R2 et R3, donc, le routeur R1 devrait pouvoir cingler l'adresse de bouclage et le routeur R3 du routeur R2. Employez la commande ping afin de vérifier la même chose.

Dans le routeur R1
Adresse de bouclage de cinglement du routeur R2
R1#ping 2020::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2020::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/36/104 ms

!--- Router R1 is successfully able to ping 
!--- router R2's loopback address.

Routeur R3 de cinglement
R1#ping 2001::2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/40/116 ms

R1#ping 3030::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3030::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/32/84 ms

!--- Similarly R1 is also able to reach R3,
!--- for example, ping to R3's interface address
!--- and loopback address from router R1 is successful.

Remarque: De même le routeur R3 peut également atteindre l'adresse 2000::1 des Routeurs R1 Fa0/0 et son adresse de bouclage 1010::1.

Employez la commande de show ipv6 static afin d'afficher le contenu en cours de la table de routage et employer la syntaxe de détail afin d'afficher plus d'informations utiles, qui sont discutées dans cet exemple :

show ipv6 static
Dans le routeur R1
R1#show ipv6 static
IPv6 Static routes
Code: * - installed in RIB
* 2001::/126 via nexthop 2000::2, distance 1
* 2020::1/128 via nexthop 2000::2, distance 1
* 3030::1/128 via nexthop 2000::2, distance 1

!--- Displays the routes that are installed in 
!--- the IPv6 Routing Information Base(RIB) marked with *!

Quand le mot clé de détail est spécifié, les informations complémentaires sont affichées. C'est un échantillon de la sortie :

détail de show ipv6 static
Dans le routeur R2
R2#show ipv6 static detail
IPv6 Static routes
Code: * - installed in RIB
* 1010::1/128 via nexthop 2000::1, distance 1
     Resolves to 1 paths (max depth 1)

!--- Displays the output path set, and maximum 
!--- resolution depth, which in this case is 1.

     via FastEthernet0/0
* 3030::1/128 via nexthop 2001::2, distance 1
     Resolves to 1 paths (max depth 1)
     via FastEthernet0/1

!--- Displays that the route is received through 
!--- the next-hop 2000::1 through interface fa0/0.

Remarque: En cas d'artères non valides, ces informations sont affichées :

  • Pour les artères récursives non valides, la raison pour laquelle l'artère est non valide.

  • Pour non valide dirigez ou avez entièrement spécifié les artères, la raison pour laquelle l'artère est non valide.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 113361