IP : Protocole OSPF (Open Shortest Path First)

Redistribuez les réseaux connectés dans l'OSPF avec le mot clé subnet

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document décrit le comportement de la redistribution des routes connectées dans le Protocole OSPF (Open Shortest Path First). Il y a deux comportements qui dépendent de si le mot clé subnet est donné ou pas quand vous redistribuez les réseaux connectés. En général, lorsque la commande de redistribution est utilisée pour redistribuer des routes dans un domaine OSPF, le routeur devient automatiquement un routeur inter-système autonome (ASBR). Par défaut quand des artères des protocoles sont redistribuées dedans à l'OSPF avec le mot clé connecté, ces artères deviennent aussi externes redistribué au EN TANT QU'et seulement les artères qui pas subnetted sont redistribuées. Quand vous incluez le mot clé de sous-réseaux, l'OSPF redistribue les artères, qui subnetted. Le processus utilise 20 comme mesure par défaut. Ceci se produit quand aucune mesure n'est spécifiée en employant le mot clé de type de mesure.

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant d'essayer cette configuration :

  • La connaissance du Routage IP général

  • La connaissance des concepts et des termes de protocole de routage OSPF

Composants utilisés

Les configurations dans ce document est basées sur le routeur de gamme Cisco 3700 sur le logiciel 12.4 (15)T 13 de version logicielle de ½ du ¿  de Cisco IOSïÂ.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Les Routeurs R1, R2 et R3 sont connectés par l'interface série entre eux et sont configurés avec l'adresse IP. Il y a quelques adresses de bouclage créées sur R1 et R3 pour générer des réseaux. L'EIGRP fonctionne sur les Routeurs R1 et R2 tandis que R3 communique à R1 utilisant l'OSPF. Le routeur R2, qui exécute l'EIGRP et l'OSPF, emploie la commande de redistribuer afin de redistribuer des artères EIGRP dedans à l'OSPF.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/113339-ospf-connected-net-01.gif

Configurations

Ce document utilise les configurations suivantes :

Routeur R1
version 12.4
!
hostname R1
!
ip cef
!
interface Loopback0
 ip address 10.10.10.10 255.255.255.240
!
interface Loopback1
 ip address 20.20.20.20 255.255.255.240
!
interface Loopback2
 ip address 30.30.30.30 255.255.255.240
!
interface Serial0/0
 ip address 172.16.10.1 255.255.248.0
 clock rate 2000000
!
router eigrp 100
 network 10.10.10.0 0.0.0.15
 network 20.20.20.16 0.0.0.15
 network 30.30.30.16 0.0.0.15
 network 172.16.8.0 0.0.7.255
 no auto-summary

!--- Auto-summary is disabled so that 
!--- the networks are summarized with subnets.

!
end

Routeur R2
version 12.4
!
hostname R2
!
ip cef
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
 ip address 2.2.2.2 255.255.255.255
!
interface Loopback2
 ip address 3.3.3.3 255.255.255.255
!
interface Serial0/0
 ip address 172.16.10.2 255.255.248.0
 clock rate 2000000
!
interface Serial0/1
 ip address 172.16.64.1 255.255.255.0
 clock rate 2000000
!
router eigrp 100
 network 1.0.0.0
 network 3.0.0.0
 network 172.16.8.0 0.0.7.255
 auto-summary
!
router ospf 100
 log-adjacency-changes
 redistribute eigrp 100 
 redistribute connected
 network 2.2.2.2 0.0.0.0 area 0
 network 172.16.64.0 0.0.0.255 area 0
!
end

Routeur R3
version 12.4
!
hostname R3
!
ip cef
!
interface Loopback0
 ip address 11.1.1.1 255.255.255.255
!
interface Loopback1
 ip address 12.1.1.1 255.255.255.255
!
interface Loopback2
 ip address 13.1.1.1 255.255.255.255
!
interface Serial0/0
 ip address 172.16.64.2 255.255.255.0
 clock rate 2000000
!
router ospf 100
 log-adjacency-changes
 network 11.1.1.1 0.0.0.0 area 0
 network 12.1.1.1 0.0.0.0 area 0
 network 13.1.1.1 0.0.0.0 area 0
 network 172.16.64.0 0.0.0.255 area 0
!
end

Vérifiez

Vérifiez la redistribution des réseaux connectés dans l'OSPF

Utilisez cette section pour confirmer que votre configuration fonctionne correctement.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Employez la commande OSPF de show ip route afin de vérifier que le routeur R3 a reçu les artères redistribuées.

OSPF de show ip route
Quand des routes connectées sont redistribuées avec le redistribuer connecté dans le routeur R2 : Dans le routeur R3
R3#show ip route ospf
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 172.16.64.1, 06:14:14, Serial0/0

!--- Only the classful routes are shown without actual subnets.

Une fois redistribué avec la spécification du mot clé de sous-réseaux dans le redistribuer a connecté des sous-réseaux dans le routeur R2 : Dans le routeur R3
R3#show ip route ospf
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 172.16.64.1, 06:14:14, Serial0/0
R3#sh ip route ospf
     1.0.0.0/32 is subnetted, 1 subnets
O E2    1.1.1.1 [110/20] via 172.16.64.1, 00:00:02, Serial0/0

!--- When routes are redistributed in to OSPF, 
!--- OSPF uses 20 as the default metric if 
!--- the metric-type keyword is not mentioned
!--- and the routes are redistributed as External Type 2(E2) routes.

     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 172.16.64.1, 06:36:58, Serial0/0
     3.0.0.0/32 is subnetted, 1 subnets
O E2    3.3.3.3 [110/20] via 172.16.64.1, 00:00:02, Serial0/0
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O E2    172.16.8.0/21 [110/20] via 172.16.64.1, 00:00:02, Serial0/0

!--- On specifying the keyword subnets, 
!--- the routes are reflected along with the subnets.



!--- Only the classful routes are shown without actual subnets.

Vérifiez la redistribution des artères EIGRP dans l'OSPF

Quand des artères EIGRP sont redistribuées dedans à l'OSPF avec la commande < d'identificateur de processus > d'eigrp de redistribuer, les artères sont redistribuées en tant qu'artères E2 avec la mesure par défaut de 20 quand aucun mot clé de type de mesure n'est spécifié.

OSPF de show ip route
Quand l'EIGRP est redistribué avec la commande de l'eigrp 100 de redistribuer dans le routeur R2 : Dans le routeur R3
R3#show ip route ospf
O E2 1.0.0.0/8 [110/20] via 172.16.64.1, 00:00:09, Serial0/0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 172.16.64.1, 07:03:16, Serial0/0
O E2 3.0.0.0/8 [110/20] via 172.16.64.1, 00:00:09, Serial0/0
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O E2    172.16.0.0/16 [110/20] via 172.16.64.1, 00:00:09, Serial0/0

!--- Only classful networks are redistributed by default.

Quand vous spécifiez le mot clé subnet dans les sous-réseaux de l'eigrp 100 de redistribuer commandez dans le routeur R2 : Dans le routeur R3
R3#sh ip route ospf
O E2 1.0.0.0/8 [110/20] via 172.16.64.1, 00:06:19, Serial0/0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 172.16.64.1, 07:09:26, Serial0/0
O E2 3.0.0.0/8 [110/20] via 172.16.64.1, 00:06:19, Serial0/0
     20.0.0.0/28 is subnetted, 1 subnets
O E2    20.20.20.16 [110/20] via 172.16.64.1, 00:00:06, Serial0/0
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O E2    172.16.0.0/16 [110/20] via 172.16.64.1, 00:06:19, Serial0/0
     10.0.0.0/28 is subnetted, 1 subnets
O E2    10.10.10.0 [110/20] via 172.16.64.1, 00:00:06, Serial0/0
     30.0.0.0/28 is subnetted, 1 subnets
O E2    30.30.30.16 [110/20] via 172.16.64.1, 00:00:06, Serial0/0

!--- On specifying the keyword subnets, 
!--- the subnetted routes are reflected along
!--- with their subnet mask.


Informations connexes


Document ID: 113339