IP : Traduction d'adresses de réseau (NAT)

NAT-PT statique pour l'exemple de configuration d'IPv6

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

La traduction d'adresses réseau - La traduction de port (NAT-PT) est un IPv6 au mécanisme de traduction d'ipv4, qui permet à des périphériques IPv6-only pour communiquer avec des périphériques IPv4-only et vice versa. Le NAT-PT est conçu pour être déployé pour permettre la transmission directe entre les réseaux IPv6-only et les réseaux IPv4-only d'une manière transparente qui utilisent une adresse V4 simple.

Ce document explique comment implémenter le NAT-PT statique qui utilise un exemple de configuration où les Noeuds de réseau d'IPv6 communiquent avec les Noeuds de réseau d'ipv4 qui utilisent une cartographie d'IPv6 de l'ipv4 addres configuré sur le routeur de NAT-PT.

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant d'essayer cette configuration :

  • Connaissance de base des concepts NAT et des exécutions.

  • Connaissance de base de système d'adressage d'IPv6

  • Connaissance de base du routage statique d'IPv6

Remarque: Le NAT-PT a été considéré désapprouvé par l'IETF en raison de son couplage serré avec le Système de noms de domaine (DNS) et de ses limites générales dans la traduction, et elle s'est avérée comme technologie être trop complexe pour mettre à jour des services translationnels extensibles. Avec la condamnation du NAT-PT et la transition croissante d'IPv6 parmi des utilisateurs a mené à l'introduction de NAT64. Référez-vous à ces documents pour plus d'informations sur NAT64 :

Composants utilisés

Les configurations dans ce document sont basées sur le routeur de gamme Cisco 3700 sur la version de logiciel 12.4 (15)T 13 de Ý de Cisco IOS.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Dans cet exemple, trois Routeurs R1, R2 et R3 sont connectés par une interface série où R1 agit en tant que routeur de NAT-PT, qui connecte au routeur R2 utilisant l'ipv4 addres et à R3 utilisant l'ipv6 addres.

Remarque: Le NAT-PT n'est pas pris en charge dans le Technologie Cisco Express Forwarding (CEF) et doit être désactivé.

Remarque: Utilisez l'outil de recherche de commande (réservé aux clients inscrits) pour plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Cet exemple utilise cette configuration réseau :

http://www.cisco.com/c/dam/en/us/support/docs/ip/network-address-translation-nat/113275-nat-ptv6-01.gif

Configurations

Cet exemple utilise ces la configuration :

Configuration R1
hostname R1
ipv6 unicast-routing
!
interface Serial0/0
 ip address 192.168.30.10 255.255.255.0
 duplex auto
 speed auto
 ipv6 nat
!
interface Serial0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:DB8:3002::9/64
 ipv6 enable
!
ipv6 route ::/0 2001:DB8:3002::10
ipv6 nat v4v6 source 192.168.30.9 2000::960B:202

!--- Translates the ipv4 add of R2 fa0/0 to ipv6 address.
          
ipv6 nat v6v4 source 3001:11:0:1::1 150.11.3.1

!--- Translates the ipv6 add of loop0 of R3 to ipv4 address.
              
ipv6 nat prefix 2000::/96

!--- The destination prefixes that matches 2000::/96 
!--- are translated by NAT-PT.
                            
!
end

Configuration R2
hostname R2
!
interface Serial0/0
 ip address 192.168.30.9 255.255.255.0
 duplex auto
 speed auto
!
ip route 0.0.0.0 0.0.0.0 192.168.30.10
!

!
end

Configuration R3
hostname R3
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 3001:11:0:1::1/64
!
interface Serial0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:DB8:3002::10/64
!
ipv6 route ::/0 2001:DB8:3002::9
!

Vérifiez

Utilisez cette section pour confirmer que votre configuration fonctionne correctement.

Dans le routeur R3

Maintenant n'importe quel paquet d'ipv6 addres de Loopback0 de R3 devrait pouvoir atteindre l'ipv4 addres fa0/0 de R2 utilisant l'ipv6 addres 2000::960B:202 comme affiché ici :

Ping
R3#ping 2000::960b:202 sou lo 0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2000::960B:202, timeout is 2 seconds:
Packet sent with a source address of 3001:11:0:1::1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/60/124 ms

!--- This shows that the router R3 is able to reach 
!--- the router R2 through lo address 3001:11:0:1::1.

Dans le routeur R2

Ping
R2#ping 150.11.3.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.11.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/68/120 ms

!--- The successful ping response shows that the router R2
!--- is able to reach the IPv6 network.

Dans le routeur R1

show ipv6 nat translations

show ipv6 nat translations
R1#show ipv6 nat translations
Prot  IPv4 source              IPv6 source
      IPv4 destination         IPv6 destination
---   ---                      ---
      192.168.30.9             2000::960B:202

---   150.11.3.1               3001:11:0:1::1
      ---                      ---

R1#show ipv6 nat translations
Prot  IPv4 source              IPv6 source
      IPv4 destination         IPv6 destination
---   ---                      ---
      192.168.30.9             2000::960B:202

---   150.11.3.1               3001:11:0:1::1
      ---                      ---

!--- This command displays the active NAT-PT translations in the router.

debug ipv6 nat détaillé

debug ipv6 nat détaillé
R1#debug ipv6 nat detailed
R1#
*Mar  1 09:12:41.877: IPv6 NAT: Found prefix 2000::/96
*Mar  1 09:12:41.881: IPv6 NAT: IPv4->IPv6:
                 src (192.168.30.9 -> 2000::960B:202)
                 dst (0.0.0.0 -> ::)
                 ref_count = 1, usecount = 0, flags = 513,
                 rt_flags = 0, more_flags = 0

*Mar  1 09:12:41.881: IPv6 NAT: IPv4->IPv6:
                 src (0.0.0.0 -> ::)
                 dst (150.11.3.1 -> 3001:11:0:1::1)
                 ref_count = 1, usecount = 0, flags = 257,
                 rt_flags = 0, more_flags = 0

*Mar  1 09:12:41.925: IPv6 NAT: IPv6->IPv4:
                 src (3001:11:0:1::1 -> 150.11.3.1)
                 dst (2000::960B:202 -> 192.168.30.9)
                 ref_count = 1, usecount = 0, flags = 2,
                 rt_flags = 0, more_flags = 0

*Mar  1 09:12:41.925: IPv6 NAT: icmp src (3001:11:0:1::1) -> (150.11.3.1), 
                 dst (2000::960B:202) -> (192.168.30.9)
*Mar  1 09:12:41.965: IPv6 NAT: Found prefix 2000::/96
*Mar  1 09:12:41.965: IPv6 NAT: IPv4->IPv6:
                 src (192.168.30.9 -> 2000::960B:202)
                 dst (150.11.3.1 -> 3001:11:0:1::1)
                 ref_count = 1, usecount = 0, flags = 2,
                 rt_flags = 0,


!--- This command displays detailed information about NAT-PT events.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 113275