IP : Services d'applications IP

Exemple de configuration de HSRP d'IPv6

30 juillet 2013 - Traduction automatique
Autres versions: PDFpdf | Anglais (31 octobre 2011) | Commentaires


Contenu


Introduction

Ce document décrit comment configurer le protocole de routage de secours immédiat (HSRP) pour l'IPv6. Le HSRP est utilisé dans un groupe de Routeurs afin de sélectionner un routeur actif et un routeur de réserve. Dans un groupe d'interfaces de routeur, le routeur actif est le routeur du choix pour conduire des paquets ; le routeur de réserve est le routeur qui succède quand le routeur actif échoue ou quand des conditions de présélection sont remplies. Le HSRP est conçu pour fournir seulement un premier saut virtuel pour des hôtes d'IPv6.

Un groupe d'IPv6 de HSRP a une adresse MAC virtuelle qui est dérivée du nombre de groupe de HSRP et d'une adresse locale à la liaison virtuelle d'IPv6 c'est-à-dire, par défaut, dérivée de l'adresse MAC virtuelle de HSRP. Des annonces périodiques de routeur (RAs) sont envoyées pour l'adresse locale à la liaison virtuelle d'IPv6 de HSRP quand le groupe de HSRP est en activité. Ces arrêt de RAs après qu'un RA final soit envoyé quand le groupe quitte l'état active.

Le HSRP emploie un mécanisme prioritaire afin de déterminer quel HSRP a configuré le routeur est d'être le routeur actif par défaut. Afin de configurer un routeur en tant que routeur actif, vous devez lui assigner une priorité qui est supérieur à la priorité de tous autres Routeurs Hsrp-configurés. La priorité par défaut est 100 ; donc, si vous configurez juste un routeur pour avoir une haute priorité, ce routeur sera le routeur actif par défaut. La version 2 de HSRP emploie la nouvelle adresse 224.0.0.102 de Protocole IP Multicast pour envoyer bonjour des paquets au lieu de l'adresse de multidiffusion de 224.0.0.2, qui est utilisée par la version 1.

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant d'essayer cette configuration :

  • La connaissance de configurer le HSRP ; référez-vous à configurer le pour en savoir plus de HSRP.

  • Connaissance de base de mettre en application l'adressage d'IPv6 et la Connectivité de base ; référez-vous à mettre en application l'adressage d'IPv6 et le pour en savoir plus de base de Connectivité.

  • La version 2 de HSRP doit être activée sur une interface avant que l'IPv6 de HSRP puisse être configuré.

  • Le routage d'unicast d'IPv6 doit être activé sur le périphérique pour que l'IPv6 de HSRP soit configuré

Composants utilisés

Les configurations dans ce document est basées sur le routeur de gamme Cisco 3700 sur le logiciel 12,4 (15)T 13 de version du logiciel Cisco IOS.

Remarque: Vérifiez les données de licence pour les commandes d'IPv6.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Les Routeurs R1 et R2 sont connectés à R3 par l'intermédiaire d'une interface série. Les ports Fast Ethernet de R1 et de R2 sont configurés avec l'IPv6 de HSRP de telle manière que R1 agisse en tant que routeur actif et R2 agisse en tant que routeur de réserve. Au cas où l'interface série S0/0 de R1 descendrait, le routeur R2 change son état de standby à l'Active.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/113216/ipv6-hsrp-01.gif

Configurations

Ce document utilise les configurations suivantes :

Voici un lien à un vidéo (disponible sur la Communauté de support de Ciscoleavingcisco.com ) qui explique comment configurer le HSRP pour l'IPv6 dans des routeurs Cisco IOS :

Configurer le HSRP pour l'IPv6 leavingcisco.com

ipv6-hsrp-02.gif

Configuration du routeur R1
R1#show run
Building configuration...
!
hostname R1
!
ip cef
!
ipv6 unicast-routing
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2020:AB8:2001::1010/64
 ipv6 enable
 standby version 2
 standby 1 ipv6 autoconfig

!--- Assigns a standby group and standby IP address.


 standby 1 priority 120


!--- R1 is configured as the active router.
!--- This is done by assigning a priority value 
!--- (in this case 120) to the router's Fa0/0 interface.
!--- The default priority value is 100.


 standby 1 preempt delay minimum 30


!--- The preempt command allows the router to become the 
!--- active router when it has the priority higher than 
!--- all the other HSRP-configured routers. 
!---- Without this command, even if a router has higher 
!--- priority value, it will not become an active router.
!--- The delay minimum value causes the local router to postpone
!--- taking over the active role for a minimum of 30 seconds.


 standby 1 track Serial0/0 90


!--- Indicates that HSRP tracks serial0/0.
!--- The interface priority is configured (in this case 90) which 
!--- indicates that if the tracked interface goes down the router 
!--- priority value is to be decremented by 90. 
!--- Default decrement value is 10.

!
interface Serial0/0
 no ip address
 ipv6 enable
 ipv6 address 2010:AB8:2001::1010/64
 clock rate 2000000
!
end

Configuration du routeur R2
R2#show run
Building configuration...
!
hostname R2
!
ip cef
!
ipv6 unicast-routing
!
interface FastEthernet0/0

!--- R2 is configured as a standby router
!--- with a default priority value of 100.

 no ip address
 duplex auto
 speed auto
 ipv6 address 2020:AB8:2001::1011/64
 ipv6 enable
 standby version 2
 standby 1 ipv6 autoconfig
 standby 1 preempt delay minimum 30
 standby 1 track Serial0/0
!
interface Serial0/0
 no ip address
 ipv6 address 2010:AB8:2010::1020/64
 ipv6 enable
 clock rate 2000000
!
end

Configuration du routeur R3
R3#show run
Building configuration...
!
hostname R3
!
ip cef
!
ipv6 unicast-routing
!
interface Serial0/0
 no ip address
 ipv6 address 2010:AB8:2001::1011/64
 ipv6 enable
 clock rate 2000000
!
interface Serial0/1
 no ip address
 ipv6 address 2010:AB8:2010::1021/64
 clock rate 2000000
!
end

Vérifiez

Employez la commande de show standby sur les Routeurs R1 et R2 afin de vérifier la configuration.

Routeur R1
R1#show standby
FastEthernet0/0 - Group 1 (version 2)
  State is Active 
!--- R1 router is in Active state.

    4 state changes, last state change 02:51:30
  Virtual IP address is FE80::5:73FF:FEA0:1
  Active virtual MAC address is 0005.73a0.0001
    Local virtual MAC address is 0005.73a0.0001 (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.480 secs
  Preemption enabled, delay min 30 secs
  Active router is local
  Standby router is FE80::C010:21FF:FE78:0, priority 100 (expires in 7.036 sec)
  Priority 120 (configured 120)
    Track interface Serial0/0 state Up decrement 10
  Group name is "hsrp-Fa0/0-1" (default)

Routeur R2
R2#show standby
FastEthernet0/0 - Group 1 (version 2)
  State is Standby
!--- R2 router is in Standby state.

    4 state changes, last state change 02:51:43
  Virtual IP address is FE80::5:73FF:FEA0:1
  Active virtual MAC address is 0005.73a0.0001
    Local virtual MAC address is 0005.73a0.0001 (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.900 secs
  Preemption enabled, delay min 30 secs
  Active router is FE80::C00F:21FF:FE78:0, priority 120 (expires in 9.928 sec)
    MAC address is c20f.2178.0000
  Standby router is local
  Priority 100 (default 100)
    Track interface Serial0/0 state Up decrement 10
  Group name is "hsrp-Fa0/0-1" (default)

Au cas où le routeur actif (R1 dans cet exemple) descendrait, le routeur de réserve change son état immédiatement à l'Active suivant les indications de cette table :

Quand le routeur actif (R1) va en bas de…
Routeur R1
R1(config)#interface s0/0
R1(config-if)#shut
R1(config-if)#exit
*Mar  1 00:01:34.879: %LINK-5-CHANGED: Interface Serial0/0, changed state to 
      administratively down
*Mar  1 00:01:35.879: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, 
      changed state to down
R1#
*Mar  1 00:04:06.691: %SYS-5-CONFIG_I: Configured from console by console
R1#
*Mar  1 00:04:36.175: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Active -> Speak
R1#
*Mar  1 00:04:46.175: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Speak -> Standby

!--- When the interface goes down, the active router changes its state to Standby.

Routeur R2
*Mar  1 00:04:35.631: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Standby ->Active


!--- The standby router is now the active router.
 

R2#show standby
FastEthernet0/0 - Group 1 (version 2)
  State is Active
    2 state changes, last state change 00:10:39
  Virtual IP address is FE80::5:73FF:FEA0:1
  Active virtual MAC address is 0005.73a0.0001
    Local virtual MAC address is 0005.73a0.0001 (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.532 secs
  Preemption enabled, delay min 30 secs
  Active router is local
  Standby router is FE80::C00F:21FF:FE78:0, priority 30 (expires in 7.524 sec)
  Priority 100 (default 100)
    Track interface Serial0/0 state Up decrement 10
  Group name is "hsrp-Fa0/0-1" (default)

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 113216