Voix : Protocole MGCP (Media Gateway Control Protocol)

Support MGCP sur un exemple de configuration de routeur activé de VRF

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document décrit comment configurer le protocole de contrôle de passerelle de message (MGCP) relatif à un routeur activé de routage et d'expédition de Voix (VRF).

Il y a deux éléments principaux que vous devriez comprendre considérer le MGCP :

  • Points finaux

  • Agents d'appel

Les points finaux sont les ports vocaux l'uns des sur la passerelle indiquée. Ces port vocal fournissent Connectivité à port analogique, comme Foreign Exchange Office) (FXO/Foreign Exchange Station (FXS), et jonctions numériques, telles qu'un t1 ou E1, au PSTN. Les passerelles peuvent avoir de plusieurs points finaux dépendants du nombre de ports qu'il contient.

Les agents d'appel sont des périphériques de contrôle externe dans un système vocal. Le Cisco CallManager est l'agent d'appel référencé dans ce document. Dans le MGCP, l'agent d'appel est le périphérique qui a le contrôle complet de la passerelle. C'est un système très efficace car toute la gestion est exécutée par l'agent d'appel. Il y a installation très petite exigée sur l'extrémité de la passerelle, car tout conduit des modèles et des Plans de composition sont configurés sur le Cisco CallManager.

Il est important de se souvenir que ce protocole est utilisé pour le contrôle seulement. Aucune données vocales n'est transmise par le protocole MGCP lui-même. Tout le transfert de données vocales se produit directement entre le téléphone et la passerelle. Ce graphique dépeint les relations de transmissions MGCP :

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/113180-mgcp-support-vrf-enabled-01.gif

Les Téléphones IP de Cisco dans cette utilisation d'exemple le Protocole SCCP (Skinny Call Control Protocol) de communiquer avec le Cisco CallManager. Les données vocales réelles sont transférées par le Protocole RTP (Real-Time Transport Protocol) directement entre les deux périphériques. Le MGCP est utilisé par le Cisco CallManager pour contrôler seulement la passerelle.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Version de logiciel 12.4(24)T 4 de Cisco IOS

  • Routeur de la gamme Cisco 2800

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

MGCP et VRF Lite

L'intelligence de routage de VRF n'existe pas dans le protocole MGCP.

Puisque le MGCP n'est pas un protocole « Vrf-averti », vous ne pouvez pas configurer une passerelle de Voix IOS pour mettre le trafic MGCP dans le voice vrf. Le trafic MGCP utilisera seulement la table de routage par défaut du routeur indépendamment des configurations de VRF.

Il y a deux solutions pour prendre en charge le MGCP dans un déploiement typique de VRF. Référez-vous à ce scénario typique de réseau de VRF :

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/113180-mgcp-support-vrf-enabled-02.gif

Utilisant deux Routeurs vous pouvez établir un, c.-à-d., avec la passerelle MGCP agissant en tant que routeur de base (aucun vrf) fournissant le trafic Ethernet à un deuxième routeur qui fait le routage de VRF MPLS. Vous pouvez alors conduire le trafic MGCP au-dessus d'un routeur de VRF car c'est juste une technique de acheminement et le MGCP est inconscient.

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/113180-mgcp-support-vrf-enabled-03.gif

Une autre solution semblable est d'utiliser un routeur simple de VRF et d'utiliser une deuxième interface disponible pour diriger le trafic MGCP vers le réseau voix.

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/113180-mgcp-support-vrf-enabled-04.gif

Connecter l'interface à la Voix VLAN sur le réseau de commutation permet les protocoles MGCP à conduire de nouveau dans le routeur par l'intermédiaire de l'interface de VRF et finalement du CallManager.

L'artère globale des besoins de routeur de VRF seulement d'être donné un IP et une route statique pointant à l'IP du VRF relient ou une adresse DHCP outre de la Voix VLAN. Voir les ces détails de configuration :

hostname VRF_MGCP_rtr
!
ip DATA
rd 65232:1
route-target export 65232:1
route-target import 65232:1
!
ip VOICE
rd 65232:3
route-target export 65232:3
route-target import 65232:3
!
interface GigabitEthernet0/0
 description MGCP interface
 ip address dhcp 
!-- USE DHCP or Static IP address from VOICE VLAN

!
interface GigabitEthernet0/1
 no ip address
 duplex full
 speed auto
 no keepalive
!
interface GigabitEthernet0/1.100
description DATA VLAN
encapsulation dot1Q 1 native
ip forwarding DATA
ip address 10.1.232.1 255.255.255.0
ntp broadcast
!
Interface GigabitEthernet0/1.300
Description VOICE VLAN
encapsulation dot1Q 2
ip forwarding VOICE
ip address 10.2.20.129 255.255.255.128
!
Interface Serial0/0/0
no ip address
no encapsulation ppp
encapsulation frame-relay IETF
!
interface Serial0/0/0.100 point-to-point
description DATA PVC
ip forwarding DATA
ip address 10.1.52.198 255.255.255.252
frame-relay interface-dlci 100 IETF
!
interface Serial0/0/0.300 point-to-point
description VOICE PVC
ip forwarding VOICE
ip address 10.2.54.198 255.255.255.252
frame-relay interface-dlci 300 IETF
!
mgcp
mgcp call-agent 10.1.255.241 2427 service-type mgcp version 0.1
mgcp bind control source-interface GigabitEthernet0/0 
!-- Bind to MGCP Interface

mgcp bind media source-interface GigabitEthernet0/0
mgcp bind media source-interface GigabitEthernet0/0
!
mgcp profile default
!

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 113180