WAN : Relais de trames

Exemple distribué de configuration de formatage du trafic

15 août 2013 - Traduction automatique
Autres versions: PDFpdf | Anglais (1 juin 2005) | Commentaires


Contenu


Introduction

Ce document discute le formatage de trafic distribué (DTS) et consolide une grande partie des informations qui sont disponibles aujourd'hui.

Le formatage de trafic (SOLIDES TOTAUX) fournit un mécanisme pour contrôler le flux de trafic sur une interface particulière.  les SOLIDES TOTAUX « distribués » est un détail de fonctionnalité aux plates-formes plus à extrémité élevé telles que le Cisco 7500 ou le routeur Internet de gamme 12000.  Ces plates-formes ont la capacité de débarquer le formatage de trafic du processeur principal (processeur de commutation routage - RSP ou processeur de route Gigabit - GRP) aux processeurs d'interface individuelle (Versatile Interface Processor - VIP ou carte de ligne - LC).  Dans les réseaux où Cisco Express Forwarding distribué (dCEF) est le mode préféré de la commutation, DTS sur le VIP ou carte de ligne est le choix logique pour le formatage de trafic.

Pourquoi le trafic de forme avec DTS ?

Si vous lisez ce document, alors, très probablement, vous avez déjà une idée de pourquoi vous voulez former le trafic.  La pièce du puzzle distribuée devrait être joli espace libre, trop - vous distribuez les fonctions du processeur principal aux différents processeurs de carte.  En ce qui concerne la formation, beaucoup de clients essayent simplement d'éviter de dépasser le taux garanti du circuit basé sur l'accord avec le fournisseur.  Ceci empêche des suppressions dans le nuage et, en conséquence, réduit des retransmissions (avec le TCP/IP) quand le fournisseur rejette des paquets.  Un scénario commun où vous devez former le trafic est dépeint ci-dessous.  Dans cet exemple, il n'y a aucun besoin du site central de transférer le trafic au débit de t1 si la succursale a seulement un circuit 128K :

Il y a beaucoup de raisons supplémentaires pour l'usage de DTS.  Les avantages incluent un assortiment de fonctionnalités relatives de qualité de service (QoS), et le lecteur pour utiliser la bande passante aussi efficacement comme possible à travers les types de trafic divers.  DTS configure le formatage de trafic au niveau d'interface, au niveau de sous-interface, ou au niveau d'interface logique pour l'atmosphère ou les circuits virtuels permanents en relais de trame (PVC).

La formation peut atteindre un choix de buts de réseau, et peut introduire sur les critères suivants :

  • Tous trafiquent sur l'examen médical ou l'interface logique
  • Le trafic classifié par le contrôle d'accès simple et étendu d'IP le répertorie (ACL) (IP address, TCP/UDP met en communication, l'ip precedence)
  • Le trafic classifié par le groupe de QoS (un en amont appliqué d'étiquette interne de paquet par Committed Access Rate - CAR, ou propagation de stratégie QoS - QPPB)
DTS prend en charge jusqu'à 200 files d'attente de forme par VIP, prenant en charge jusqu'aux débits OC-3 quand la taille moyenne des paquets est de 250 octets ou plus grand, et quand en utilisant un VIP2-50 ou meilleur avec la MÉMOIRE RAM statique de 8M (SRAM). À la différence du trafic habituel formant (GTS), DTS ne l'exige pas que la mise en file d'attente pondérée (WFQ) soit activée. Au lieu de cela, DTS utilise la queue de foire ou le first-in, first-out distribué (FIFO) pour la file d'attente formée.

Détails de plate-forme

Le tableau suivant affiche comment configurer des SOLIDES TOTAUX selon la plate-forme - principalement illustrant que la fonctionnalité est significative pour des plates-formes haut de gamme :
 
 
Gamme 12000
Gamme 7500
7200, 3600, 2600 et d'autres plates-formes de Non-VIP
Mécanismes de mise en forme pris en charge
DTS
DTS
GTS ou TS en relais de trame
Commande de configuration
commande de forme dans un policy-map
commande de forme dans un policy-map
trafic-débit ou frame-relay traffic-shaping sur une interface principale, et avec FRTS - commandes de configuration de map-class de spécifier des paramètres de mise en forme
Requires a distribué Cisco Express Forwarding (le dCEF)
Le défaut est CEF
Oui (vérifiez avec la commande de show cef linecard
Non

Notes en gamme 7500 DTS

Sur la gamme Cisco 7500, la capacité de configurer le formatage de trafic de relais de trame (FRTS) utilisant la commande de frame-relay traffic-shaping est maintenant bloquée puisque FRTS exécute sur le RSP en mode des non-distribuer. Avec le dCEF et le FRTS, une contiguïté de « coup de volée » de CEF rend tous les paquets à commutation rapide par le RSP, qui est suboptimal pour des performances de transfert maximales.

En date du logiciel Cisco IOS Version 12.1(5)T® , les stratégies QoS doivent fonctionner dans le mode distribué sur le VIP ; La route/processeur du commutateur (RSP) QoS basé sur n'est plus prise en charge. Ainsi, vous devez utiliser la commande de forme et d'autres commandes de l'interface de ligne de commande modulaire de QoS (MQC) de mettre en application DTS pour des interfaces sur des VIPs sur la gamme Cisco 7500.

Tandis que le logiciel Cisco IOS Version 12.1(2)T introduisait le soutien du Low Latency Queuing (LLQ) sur des plates-formes autres que la gamme Cisco 7500, le LLQ distribué (dLLQ) a été introduit dans 12.1(5)T sur le VIP. La version distribuée améliore les performances de cette fonctionnalité. Vous pouvez configurer un seul service-policy par identificateur de connexion logique (DLCI). Vous n'avez pas besoin d'utiliser un map-class et pouvez s'appliquer la commande de service-policy directement à la sous-interface ou au DLCI. Cependant, nous recommandons configurer le dLLQ à l'intérieur d'un map-class.

En s'appliquant le FRF.12 distribué (fragmentation) à une interface de relais de trame, vous devez définir un map-class et appliquer le service-policy sous le map-class. Le FRF.12 a été introduit dans la version 12.0(4)T de logiciel Cisco IOS et est étendu 1600, 1700, 2500, 4500, et 4700 aux plates-formes de routeur de Cisco 805, comme de la version 12 1(2)T de logiciel Cisco IOS. Les détails supplémentaires sont disponibles au support de FRF.12 sur les plates-formes supplémentaires.

Notes en Routeur Internet de la série Cisco 12000 DTS

Sur la gamme 12000, la commutation rapide et la commutation par processus ne sont pas des options. Si un préfixe de destination ne peut pas être résolu à une entrée de transfert dans les tables de la carte de ligne d'arrivée (LC), le paquet est rejeté. Seulement des paquets correspondant une contiguïté de glaner sont donnés un coup de volée au processeur de routage de gigabit (GRP). En outre, sur les 12000, le LC CPU ne donnera pas un coup de volée des paquets au GRP pour des fonctionnalités, et le LC envoie un Internet Control Message Protocol (ICMP) inaccessible (tant que l'aucune commande d'ip unreachables n'est configurée). Sur les 12000, le seul trafic donné un coup de volée au GRP sont des paquets destinés à une interface sur le routeur ou des paquets approvisionnés du routeur. Pour information le plus d'informations, voir les fonctionnalités QoS par le type de moteur.

Configurer DTS

Employez les deux premières étapes pour configurer DTS sur les interfaces de relais de trame basées sur VIP (gamme 7500) :
  1. DCEF d'enable avec la commande suivante :
  2. router(config)#ip cef distributed
  3. Assurez-vous que l'interface de relais de trame est activée pour la commutation distribuée.
router(config-if)# interface serial 2/0/0
router(config-if)# ip route-cache distributed
router#show ip interface serial 2/0/0
Serial8/0/0 is up, line protocol is up
  Internet address is 64.0.0.2/24
  Broadcast address is 255.255.255.255
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP fast switching on the same interface is disabled
  IP Flow switching is disabled
  IP CEF switching is enabled
  IP Distributed switching is enabled
  IP Fast switching turbo vector
  IP CEF switching with tag imposition turbo vector
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast, Distributed, CEF
  Router Discovery is disabled
  IP output packet accounting is disabled
  1. Créant une classe de trafic (exigée)
  2. Configurant une stratégie de trafic qui utilise DTS (exigé)
  3. Reliant la stratégie de trafic et activant DTS (exigé)
  4. Surveillant et mise à jour de DTS (facultatif)

Création d'une classe de trafic

La première étape en activant n'importe quelle fonctionnalité utilisant le CLI modulaire de QoS crée une classe de trafic.
 

  Commande But
Étape 1 
Router(config)# class-map [match-any | match-all] class-name

Spécifie le nom et si tout ou une partie des critères constituera une correspondance.

Pour les informations sur le CLI modulaire de QoS, et la procédure pour créer une classe de trafic, voir l'aperçu de qualité de service modulaire d'interface de ligne de commande.

Configurant une stratégie de trafic qui utilise DTS

Pour activer DTS, vous devez configurer une stratégie de trafic. Vous pouvez configurer des stratégies de trafic pour autant de classes comme sont définis sur le routeur jusqu'au maximum de 256.

Pour configurer une stratégie de trafic, employer le début de commande de policy-map dans le mode de configuration globale pour spécifier le nom de stratégie de trafic, puis utiliser les commandes de configuration dans la table ci-dessous en mode de configuration de la carte de stratégie de configurer le nom et le formatage de trafic de classe de trafic.

Le trafic est dirigé vers la classe par défaut de stratégie de trafic s'il ne répond pas au critère de correspondance d'aucune autre classe dont les politiques sont définies dans la stratégie de trafic.
 

  Commande But
Étape 1 
Router(config)# policy-map 
policy-name

Spécifie le nom de la stratégie de trafic à créer.
Étape 2 
Router(config-pmap)# class class-name 

 
Spécifie le nom d'une classe de trafic de prédéfinis incluse dans la stratégie de trafic. La classe a été définie dans l'étape précédente de ce processus.
Étape 3 
Router(config-pmap-c)# shape 
<average | peak> <meanrate>[<burst size> [<excess 
burst size>]]
Spécifie le débit des bits par seconde de cible (bps).

Reliant la politique et activer de service DTS

Pour relier une stratégie de trafic à l'interface, la sous-interface, ou le map-class et l'enable DTS sur l'interface, utilisent la commande suivante dans le mode de configuration d'interface (ou map-class).  Des applications du dLLQ et le FRF.12 sont fortement recommandés pour avoir la politique de service appliquée à la classe de mappage de relais de trame.

Voir le FRF.12 et le DTS pour des détails supplémentaires pour la fragmentation.
 

Commande But
Router(config-if)# service-policy output policy-name
* APPLY TO FR MAP-CLASS for llq and fragmentation
Les enables DTS et relie la politique du trafic indiqué à l'interface ou au map-class.

Surveillant et mise à jour de DTS

Pour surveiller et mettre à jour la fonctionnalité DTS, utilisez les commandes suivantes dans le mode EXEC, comme nécessaire.

Pour la surveillance supplémentaire commande en ce qui concerne QoS, voient le show policy-map interface.
 

Commande But
Router# show interface [interface-name] shape

Statut de petit groupe d'affiches du formatage de trafic.
Router# show policy policy-name

Affiche la configuration de toutes les classes composant la politique du trafic indiqué.
Router# show policy policy-name class class-name

Affiche la configuration de la classe spécifiée de la politique du trafic indiqué.

Exemples de configuration

DTS sur l'interface principale
Dans l'exemple suivant, le trafic qui sort sur l'interface pos1/0/0 est formé au débit de 10Mbits/sec.
router(config)# class-map class-interface-all

router(config-cmap)# match any

router(config-cmap)# exit

router(config)# policy-map DTS-interface-all-action
router(config-pmap)# class class-interface-all

router(config-pmap-c)# shape average 10000000 
router(config-pmap-c)# exit

router(config)# interface pos1/0/0

router(config-if)# service-policy output DTS-interface-all-action

DTS basé sur classe sur l'interface principale

Dans l'exemple suivant, deux classes sont créées et le critère de correspondance est défini a basé sur le nombre de listes d'accès. Trafiquez qui sort sur l'interface fdi4/0/0 et correspond les critères dans la liste d'accès 10 est formé à 16Mbps. Trafiquez qui correspond les critères dans la liste d'accès 20 est formé à 8 Mbits/s.

Remarque: Les IP address suivants sont des exemples seulement.

router(config)# access-list 10 permit 171.69.0.0

router(config)# access-list 20 permit 192.168.0.0

router(config)# class-map class1

router(config-cmap)# match access-group 10

router(config-cmap)# exit

router(config)# class-map class2

router(config-cmap)# match access-group 20

router(config-cmap)# exit

router(config)# policy-map DTS-interface-class-action
router(config-pmap)# class class1

router(config-pmap-c)# shape average 16000000

router(config-pmap-c)# exit

router(config-pmap)# class class2

router(config-pmap-c)# shape average 8000000

router(config-pmap-c)# exit

router(config-pmap)# interface fd4/0/0

router(config-if)# service-policy output DTS-interface-class-action
Voir les
échantillons de configuration supplémentaire.

Outils pour identifier des problèmes

Une interface de VIP configurée avec l'encapsulation Frame Relay peut tomber en panne avec une erreur sur le bus si appliquant un service-policy tandis que l'interface transmet le trafic. Ce problème est résolu dans diverses versions de logiciel Cisco IOS (ID de bogue Cisco CSCdt88568). Pour plus d'informations sur le ce les ddts et les bogues supplémentaires, voient les outils Cisco TAC ou le Bug Toolkit.

Les informations d'outils

Pour des ressources supplémentaires, référez-vous aux outils Cisco TAC pour des technologies de Access-Numérotation.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes

Rubriques connexes

Documentation supplémentaire



Document ID: 22600