IP : IP version 6

Configurez la caractéristique de préférence locale BGP d'IPv6

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document explique la caractéristique de local-preference de Protocole BGP (Border Gateway Protocol) d'IPv6. La préférence locale est une indication transmise à l'AS concernant le chemin préféré pour quitter l'AS afin d'atteindre un réseau donné. Un chemin avec une préférence locale plus élevée est préféré plus. La valeur par défaut de la préférence est 100.

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant d'essayer cette configuration :

  • Compréhension de protocole de routage BGP et de son exécution

  • Compréhension de système d'adressage d'IPv6

Composants utilisés

Les informations dans ce document sont testées sur des ces logiciel et versions de matériel

  • Version du logiciel Cisco IOS 12.4, positionnement anticipé de caractéristique de Services IP

  • ? Routeurs d'accès multiservices de la gamme Cisco 3700

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

Dans l'exemple, le routeur R1, les R2 et les R3 font partie du numéro de système autonome 123 BGP. R4 fait partie de la partie 101 et R5 d'Autonomous System d'Autonomous System 100.

Les trois Routeurs (R1, R2 et R3) sont configurés avec OSPFv3 pour la Connectivité d'IGP. Le préfixe d'IPv6 de l'interface Lo 0 (1111:111:111:A::/64 eui-64, 2222:222:222:A::/64 eui-64 et 3333:333:333:A::/64 eui-64) de réalimentation de chacun des trois Routeurs est annoncé dans la zone 0 du protocole de routage OSPFv3.

Scruter IBGP est formé entre les Routeurs R1, R2 et R3 par des préfixes appris de bouclage. Le routeur R1 et R4 sont connectés au-dessus d'un lien WAN (connexion série) et forment scruter EBGP. De même le routeur R3 et R5 forment EBGP scrutant au-dessus du lien WAN.

Le routeur R4 et R5 injectent les mêmes préfixes d'IPv6 :

  1. réseau BC01:BC1:10:A::/64

  2. réseau BC02:BC1:11:A::/64

  3. réseau BC03:BC1:12:A::/64

Car les deux Routeurs R4 et R5 injectent les mêmes préfixes d'IPv6, la sélection de chemin est basée sur des attributs réputés BGP. Dans cet exemple, la préférence locale est choisie. La valeur de préférence locale BGP de 500 est placée pour le préfixe BC01:BC1:10:A::/64 sur le routeur R3 par le route-map. Ceci a comme conséquence R3 comme point de sortie pour ces préfixe et R1 le point de sortie pour les deux préfixes demeurants.

Configurez

Les interfaces Ethernet rapides (F0/0 et F0/1) des Routeurs R1, R2 et R3 sont IPv6 activé avec l'ipv6 addres du format eui-64.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-01.gif

Configurations

Ce document utilise les configurations suivantes :

Remarque: Tous les Routeurs sont activés avec l'expédition des paquets d'IPv6 à l'aide de la commande d'ipv6 unicast-routing.

R1
interface Loopback0
 no ip address
 ipv6 address 1111:111:111:A::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0

!--- Enables OSPFv3 on the interface and associates
!--- the interface loopback0 to area 0.

!
interface FastEthernet0/0
 description CONNECTED TO Rtr2
 no ip address
 duplex auto
 speed auto
 ipv6 address AB01:CD1:123:A::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0
!
interface Serial0/0
 no ip address
 ipv6 address AB01:CD1:123:C::/64 eui-64
 ipv6 enable
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address AB01:CD1:123:B::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0
!
ipv6 router ospf 10
 router-id 1.1.1.1
 log-adjacency-changes
 redistribute connected route-map CONNECTED
!
route-map CONNECTED permit 10
 match interface Serial0/0
!
router bgp 123
 bgp router-id 1.1.1.1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 2222:222:222:A:C602:3FF:FEF0:0 remote-as 123
 neighbor 2222:222:222:A:C602:3FF:FEF0:0 update-source Loopback0
 neighbor 3333:333:333:A:C603:3FF:FEF0:0 remote-as 123
 neighbor 3333:333:333:A:C603:3FF:FEF0:0 update-source Loopback0
 neighbor AB01:CD1:123:C:C604:16FF:FE98:0 remote-as 101
 neighbor AB01:CD1:123:C:C604:16FF:FE98:0 ebgp-multihop 5
 !
 address-family ipv6
  neighbor 2222:222:222:A:C602:3FF:FEF0:0 activate
  neighbor 2222:222:222:A:C602:3FF:FEF0:0 next-hop-self
  neighbor 3333:333:333:A:C603:3FF:FEF0:0 activate
  neighbor 3333:333:333:A:C603:3FF:FEF0:0 next-hop-self
  neighbor AB01:CD1:123:C:C604:16FF:FE98:0 activate
 exit-address-family

R2
interface Loopback0
 no ip address
 ipv6 address 2222:222:222:A::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address AB01:CD1:123:A::/64 eui-64
 ipv6 ospf 10 area 0
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address AB01:CD1:123:D::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0
!
ipv6 router ospf 10
 router-id 2.2.2.2
 log-adjacency-changes
!
router bgp 123
 no synchronization
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 neighbor 1111:111:111:A:C601:3FF:FEF0:0 remote-as 123
 neighbor 1111:111:111:A:C601:3FF:FEF0:0 update-source Loopback0
 neighbor 3333:333:333:A:C603:3FF:FEF0:0 remote-as 123
 neighbor 3333:333:333:A:C603:3FF:FEF0:0 update-source Loopback0
 no auto-summary
 !
 address-family ipv6
  neighbor 1111:111:111:A:C601:3FF:FEF0:0 activate
  neighbor 3333:333:333:A:C603:3FF:FEF0:0 activate
 exit-address-family

R3
interface Loopback0
 no ip address
 ipv6 address 3333:333:333:A::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address AB01:CD1:123:B::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0
!
interface Serial0/0
 no ip address
 ipv6 address AB01:CD1:123:E::/64 eui-64
 ipv6 enable
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address AB01:CD1:123:D::/64 eui-64
 ipv6 ospf 10 area 0
!
ipv6 router ospf 10
 router-id 3.3.3.3
 log-adjacency-changes
 redistribute connected route-map CONNECTED
!
router bgp 123
 no synchronization
 bgp router-id 3.3.3.3
 bgp log-neighbor-changes
 neighbor 1111:111:111:A:C601:3FF:FEF0:0 remote-as 123
 neighbor 1111:111:111:A:C601:3FF:FEF0:0 update-source Loopback0
 neighbor 2222:222:222:A:C602:3FF:FEF0:0 remote-as 123
 neighbor 2222:222:222:A:C602:3FF:FEF0:0 update-source Loopback0
 neighbor AB01:CD1:123:E:C605:16FF:FE98:0 remote-as 202
 neighbor AB01:CD1:123:E:C605:16FF:FE98:0 ebgp-multihop 5
 no auto-summary
 !
 address-family ipv6
  neighbor 1111:111:111:A:C601:3FF:FEF0:0 activate
  neighbor 1111:111:111:A:C601:3FF:FEF0:0 next-hop-self
  neighbor 1111:111:111:A:C601:3FF:FEF0:0 route-map LOCAL_PREF out
  neighbor 2222:222:222:A:C602:3FF:FEF0:0 activate
  neighbor 2222:222:222:A:C602:3FF:FEF0:0 next-hop-self
  neighbor 2222:222:222:A:C602:3FF:FEF0:0 route-map LOCAL_PREF out
  neighbor AB01:CD1:123:E:C605:16FF:FE98:0 activate
 exit-address-family

!
ipv6 prefix-list 10 seq 5 permit BC01:BC1:10:A::/64
!
route-map LOCAL_PREF permit 10
 match ipv6 address prefix-list 10
 set local-preference 500
!
route-map LOCAL_PREF permit 20
!
route-map CONNECTED permit 10
 match interface Serial0/0

R4
interface Serial0/0
 no ip address
 ipv6 address AB01:CD1:123:C::/64 eui-64
 ipv6 enable
 clock rate 2000000
!
interface Loopback10
 no ip address
 ipv6 address BC01:BC1:10:A::/64 eui-64
 ipv6 enable
!
interface Loopback11
 no ip address
 ipv6 address BC02:BC1:11:A::/64 eui-64
 ipv6 enable
!
interface Loopback12
 no ip address
 ipv6 address BC03:BC1:12:A::/64 eui-64
 ipv6 enable

router bgp 101
 bgp router-id 4.4.4.4
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor AB01:CD1:123:C:C601:3FF:FEF0:0 remote-as 123
 neighbor AB01:CD1:123:C:C601:3FF:FEF0:0 ebgp-multihop 5
 !
 address-family ipv6
  neighbor AB01:CD1:123:C:C601:3FF:FEF0:0 activate
  network BC01:BC1:10:A::/64
  network BC02:BC1:11:A::/64
  network BC03:BC1:12:A::/64
 exit-address-family

R5
interface Serial0/0
 no ip address
 ipv6 address AB01:CD1:123:E::/64 eui-64
 ipv6 enable
 clock rate 2000000
!
interface Loopback10
 no ip address
 ipv6 address BC01:BC1:10:A::/64 eui-64
 ipv6 enable
!
interface Loopback11
 no ip address
 ipv6 address BC02:BC1:11:A::/64 eui-64
 ipv6 enable
!
interface Loopback12
 no ip address
 ipv6 address BC03:BC1:12:A::/64 eui-64
 ipv6 enable
!
router bgp 202
 bgp router-id 5.5.5.5
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor AB01:CD1:123:E:C603:3FF:FEF0:0 remote-as 123
 neighbor AB01:CD1:123:E:C603:3FF:FEF0:0 ebgp-multihop 5
 !
 address-family ipv6
  neighbor AB01:CD1:123:E:C603:3FF:FEF0:0 activate
  network BC01:BC1:10:A::/64
  network BC02:BC1:11:A::/64
  network BC03:BC1:12:A::/64
 exit-address-family

Vérifiez

Cette section fournit des informations que vous pouvez employer pour confirmer votre configuration fonctionne correctement.

Sur le routeur R1

  1. brief de show ipv6 interface

    http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-02.gif

  2. résumé d'unicast de show bgp ipv6

    http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-03.gif

Sur le routeur R2

  1. brief de show ipv6 interface

    http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-04.gif

  2. unicast de show bgp ipv6

    Remarque: Quand la préférence locale n'est pas configurée, le routeur R2 (Rtr2) a le routeur R1 (Rtr1) en tant que son prochain saut pour toutes les adresses apprises d'IPv6. http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-05.gif

  3. unicast de show bgp ipv6

    Après avoir configuré la préférence locale 500 pour le préfixe BC01:BC1:10:A::/64, R2 a une sortie différente seulement pour ce préfixe.

    http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-06.gif

    Remarque: Le préfixe BC01:BC1:10:A::/64 prend un chemin de sortie du routeur R3 pendant que la préférence locale est placée plus élevée.

Sur le routeur R3

  1. brief de show ipv6 interface

    http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-07.gif

  2. résumé d'unicast de show bgp ipv6

    http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-08.gif

Dépannez

Utilisez ces commandes pour le dépannage

  1. debug bgp ipv6 updates
  2. clear bgp ipv6 {unicast | Multidiffusion}

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 113035