IP : Protocole BGP (Border Gateway Protocol)

Compréhension de l'attribut de MED BGP

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Le but de ce document est de fournir une meilleure compréhension de l'attribut de Multi Exit Discriminator de Protocole BGP (Border Gateway Protocol) (MED) en croisant au-dessus d'une borne de système autonome (AS) en la mettant en application dans différents scénarios.

Le MED fournit une façon dynamique d'influencer des autres COMME de la manière d'atteindre une certaine artère quand il y a des points de plusieurs entrées pour cela AS. Le BGP suit une procédure systématique pour choisir le meilleur chemin. Il y a d'autres importants attributs tels que le poids, préférence locale, lance l'artère, et COMME chemin qui sont rentrés pour rendre compte avant de considérer l'attribut de MED. Ainsi, si l'un de ces critères s'assortit, l'attribut de MED ne sera pas considéré.

Remarque: Quand tous autres facteurs sont égaux, le point de sortie avec le plus bas MED est préféré.

Conditions préalables

Conditions requises

Cisco recommande que vous ayez la connaissance de base du BGP.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques. Les scénarios discutés dans ce document utilisent ces le matériel et les versions de logiciel :

  • Scénario 1 : Routeurs de Cisco 2600 sur la version de logiciel 12.4 ou ultérieures de ½ du ¿  de Cisco IOSïÂ

  • Scénario 2 : Routeurs de Cisco 2600 sur version du logiciel Cisco IOS 12.4 ou plus tard

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Étude de cas

Scénario 1

Quand un speaker BGP apprend une artère d'un pair, le MED de l'artère est passé à d'autres pairs BGP d'interne (iBGP), mais pas à BGP extérieur (eBGP) scrute.

Considérez cette configuration réseau :

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-01.gif

Ici, le routeur R1 et le routeur R2 sont considérés dans les mêmes QUE, par exemple AS#100, et routeur R3 appartient à AS#101. Pour la convention facile, des adresses IP dans le bloc de /24 sont utilisées.

Les Routeurs R1 et R2 sont configurés comme suit :

Routeur 1
(Config)#interface Loopback10
(Config-if)#ip address 10.10.10.10 255.255.255.255
(Config-if)#interface FastEthernet0/0
(Config-if)#ip address 192.1.12.1 255.255.255.0
(Config)#router bgp 100
(Config-router)#no synchronization
(Config-router)#bgp router-id 10.10.10.10
(Config-router)#bgp log-neighbor-changes
(Config-router)#network 10.10.10.10 mask 255.255.255.255 route-map ATTACH_MED
(Config-router)#neighbor 192.1.12.2 remote-as 100
(Config-router)#no auto-summary
(Config)#access-list 10 permit 10.10.10.10
(Config)#route-map ATTACH_MED permit 10
(Config)#match ip address 10
(Config)#set metric 100

Routeur 2
(Config)#interface FastEthernet0/0
(Config-if)#ip address 192.1.12.2 255.255.255.0
(Config-if)#interface Serial1/0
(Config-if)#ip address 192.1.23.2 255.255.255.0
(Config-if)#encapsulation frame-relay IETF
(Config-if)#no fair-queue
(Config-if)#frame-relay map ip 192.1.23.3 203 broadcast
(Config-if)#no frame-relay inverse-arp
(Config-if)#frame-relay lmi-type ansi
(Config)#router bgp 100
(Config-router)#no synchronization
(Config-router)#bgp router-id 22.22.22.22
(Config-router)#bgp log-neighbor-changes
(Config-router)#neighbor 192.1.12.1 remote-as 100
(Config-router)#neighbor 192.1.23.3 remote-as 101
(Config-router)#neighbor 192.1.23.3 ebgp-multihop 3
(Config-router)#no auto-summary

La configuration du routeur R3 est donnée ici :

Routeur 3
(Config)#interface Serial1/0
(Config-if)#ip address 192.1.23.3 255.255.255.0
(Config-if)#encapsulation frame-relay IETF
(Config-if)#no fair-queue
(Config-if)#frame-relay map ip 192.1.23.2 302 broadcast
(Config-if)#no frame-relay inverse-arp
(Config-if)#frame-relay lmi-type ansi
(Config)#router bgp 101
(Config-router)#no synchronization
(Config-router)#bgp log-neighbor-changes
(Config-router)#neighbor 192.1.23.2 remote-as 100
(Config-router)#neighbor 192.1.23.2 ebgp-multihop 3
(Config-router)#no auto-summary

Dans cette installation, R1 et R2 ont l'exécution d'iBGP. Par conséquent, quand une mise à jour entre dans COMME avec une certaine mesure, cette mesure est utilisée pour prendre des décisions à l'intérieur de AS. La commande de show ip bgp une fois vérifié de l'exposition R2 vous la valeur métrique pour 10.10.10.10, qui est penchée par l'intermédiaire du voisin 192.1.12.1 d'iBGP et aura une valeur de MED de 100.

La sortie de R2 est affichée ici :

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-02.gif

l'eBGP fonctionne entre R2 et R3 parce que ceux-ci sont dans un différent AS. Quand la même mise à jour passe à un tiers COMME, par exemple AS#101, des retours de cette mesure à 0. La commande de show ip bgp quand vérifié de R3 aura sa mesure retirée, parce que 10.10.10.10 croise EN TANT QUE boundary(101).

La sortie de R3 est affichée ici :

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-03.gif

De ce scénario il est évident que l'attribut de MED puisse influencer le trafic entrant des Autonomous System voisins. L'attribut de MED ne peut pas influencer les décisions de routage des Autonomous System de plus-distant. Quand un speaker BGP apprend une artère d'un pair, il peut passer le MED de l'artère à tous les pairs d'iBGP, mais pas à l'eBGP scrute. En conséquence, le MED a la pertinence seulement entre les Autonomous System voisins.

Scénario 2

Si l'artère injectée dans le BGP (ou en utilisant le réseau ou redistribuez la commande) provient un IGP (RIP ou EIGRP ou OSPF), le MED est dérivé de la mesure d'IGP et l'artère est annoncée à un voisin d'eBGP avec ce Med.

Ce scénario utilise cette configuration réseau :

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-04.gif

Dans ce réseau, R1 est configuré pour fonctionner dans un réseau de RIP. BGP du passage R2 et R3 de Routeurs, où R2 est configuré avec l'AS 100 tandis que R3 est avec EN TANT QUE 101.

Le routeur R1 est configuré comme suit :

Routeur R1
(Config)#interface Loopback10
(Config-if)#ip address 10.10.10.10 255.255.255.255
(Config-if)#interface FastEthernet0/0
(Config-if)#ip address 192.1.12.1 255.255.255.0
(Config)#router rip
(Config-router)#network 10.0.0.0
(Config-router)#network 192.1.12.0
(Config-router)#no auto-summary

Les Routeurs R2 et R3 sont configurés pour le BGP, où la redistribution est faite dans R2 afin d'injecter les réseaux de RIP à un BGP.

Routeur R2
(Config)#interface FastEthernet0/0
(Config-if)#ip address 192.1.12.2 255.255.255.0
(Config-if)#interface Serial1/0
(Config-if)#ip address 192.1.23.2 255.255.255.0
(Config-if)#encapsulation frame-relay IETF
(Config-if)#no fair-queue
(Config-if)#frame-relay map ip 192.1.23.3 203 broadcast
(Config-if)#no frame-relay inverse-arp
(Config-if)#frame-relay lmi-type ansi
(Config)#router rip
(Config-router)# network 192.1.12.0
(Config-router)#no auto-summary
(Config-router)#router bgp 100
(Config-router)#no synchronization
(Config-router)#bgp router-id 22.22.22.22
(Config-router)#bgp log-neighbor-changes
(Config-router)#neighbor 192.1.23.3 remote-as 101
(Config-router)#neighbor 192.1.23.3 ebgp-multihop 3
(Config-router)#redistribute rip metric 1
 Config-router)#no auto-summary

Routeur R3
(Config)#interface Serial1/0
(Config-if)#ip address 192.1.23.3 255.255.255.0
(Config-if)#encapsulation frame-relay IETF
(Config-if)#no fair-queue
(Config-if)#frame-relay map ip 192.1.23.2 302 broadcast
(Config-if)#no frame-relay inverse-arp
(Config-if)#frame-relay lmi-type ansi
(Config)#router bgp 101
(Config-router)# no synchronization
(Config-router)#bgp router-id 33.33.33.33
(Config-router)#bgp log-neighbor-changes
(Config-router)#neighbor 192.1.23.2 remote-as 100
(Config-router)#neighbor 192.1.23.2 ebgp-multihop 3
(Config-router)#no auto-summary

RIP et BGP exécuté sur R2. Si vous vérifiez utilisant la commande de show ip bgp, vous pouvez voir que le réseau de 10.0.0.0 de préfixe est affiché avec une mesure de 1, qui est dérivé du RIP.

La sortie de R2 est affichée ici :

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-05.gif

Cependant, dans R3 qui fonctionne sur l'eBGP, le réseau est annoncé en considérant la valeur de MED dérivée de l'IGP. Dans ce cas c'est RIP. Le préfixe 10.0.0.0 est annoncé avec la valeur de MED d'IGP, qui est la mesure 1. du RIP.

Ceci peut vu dans cette sortie :

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-06.gif

De ce scénario le comportement du MED, dans le cas des réseaux étant injectés au routeur BGP par l'intermédiaire du réseau ou redistribuent la commande, est clairement vu où la valeur réelle de MED est remplacée par celle de la mesure d'IGP. Maintenant, étant donné que cet attribut est un signe aux voisins externes au sujet de la préférence de chemin dans AS. Comme indiqué plus tôt, il n'est pas toujours considéré s'il y a d'autres attributs plus importants pour déterminer la meilleure route. Afin d'avoir le même effet avec un attribut plus déterministe, utilisez le set as-path ajoutent la commande au début sous le mappage de route. Si vous ajoutez au début COMME chemin pour certaines artères, il continuera à être vu par autre AS. Pour plus d'informations sur l'utilisation du Comme-chemin ajoutez au début, référez-vous à l'utilisation du positionnement-aspath ajoutent la commande au début.


Informations connexes


Document ID: 112965