Interfaces et modules Cisco : Modules de réseau Cisco

Catalyst 6500 EIGRP au-dessus d'exemple de configuration de Vrf-Lite

30 juillet 2013 - Traduction automatique
Autres versions: PDFpdf | Anglais (3 janvier 2011) | Commentaires


Contenu


Introduction

Ce document décrit comment configurer l'EIGRP au-dessus de l'expédition de route virtuelle (VRF) - lite sur une gamme Cisco Catalyst 6500 commutent. L'artère statique est configurée sur les Commutateurs et est redistribuée par l'intermédiaire de l'EIGRP entre les Commutateurs.

Conditions préalables

Conditions requises

Cisco vous recommande de prendre connaissance des rubriques suivantes :

  • Connaissance de base d'EIGRP

  • Connaissance de base de la configuration de Catalyst 6500

Composants utilisés

Les informations dans ce document sont basées sur les Commutateurs de gamme Catalyst 6500 qui exécutent la version de logiciel 12.2(33).SXH6.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

Vrf-lite permet à un fournisseur de services pour prendre en charge deux VPN ou plus avec une adresse IP superposante utilisant une interface. Vrf-lite se nomme également périphérique de Customer Edge de la CE ou de multi-VRF de multi-VRF. Dans le passé, Vrf-lite a été pris en charge seulement avec le RIP, l'OSPF, et le BGP. Mais dans des versions récentes, Vrf-lite est également pris en charge avec l'EIGRP. Ce document fournit un exemple d'un EIGRP au-dessus de configuration de Vrf-lite CLI où des artères statiques de VRF sont redistribuées par l'intermédiaire de l'EIGRP à d'autres Commutateurs.

Configurez Vrf-Lite au-dessus de Catalyst 6500

Ce sont les instructions pour configurer Vrf-lite au-dessus de Catalyst 6500 :

  • Un commutateur avec Vrf-lite est partagé par des plusieurs clients, et tous les clients ont leurs propres tables de routage.

  • Puisque les clients utilisent différentes tables de VRF, les mêmes adresses IP peuvent être réutilisées. On permet des adresses IP superposées dans différents VPN.

  • Vrf-lite permet des plusieurs clients de partager le même lien physique entre le PE et le CE. Les ports de joncteur réseau avec des VLAN multiples séparent des paquets parmi des clients. Tous les clients ont leurs propres VLAN.

  • Pour le routeur PE, il n'y a aucune différence entre utiliser Vrf-lite ou utiliser le plusieurs ces.

  • Un client peut utiliser des VLAN multiples tant que ils ne superposent pas avec ceux d'autres clients. Les VLAN d'un client sont tracés à un ID spécifique de table de routage qui est utilisé pour identifier les tables de routage appropriées enregistrées sur le commutateur.

  • Vrf-lite n'affecte pas le débit de commutation par paquets.

Configuration CLI

Cette section affiche la configuration CLI :

 6500A(config)#ip vrf TEST-LAB
 6500A(config)#rd 10.244.0.10:100

 6500A(config)#interface Loopback100
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.1 255.255.255.255
 6500A(config-if)#exit

 6500A(config)#interface GigabitEthernet7/1
 6500A(config-if)# ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.121 255.255.255.252
 6500A(config-if)#exit

 6500A(config)#no snmp trap link-status
 6500A(config)#interface TenGigabitEthernet8/6
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.21 255.255.255.252
 6500A(config-if)#exit
 6500A(config)# no snmp trap link-status
 6500A(config)# router eigrp 99
 6500A(config-router)# network 10.0.0.0
 6500A(config-router)# no auto-summary
 6500A(config-router)# address-family ipv4 vrf TEST-LAB
 6500A(config-router)# redistribute static metric 10000 100 255 1 1500
 
 
!--- Redistribute static routes

 6500A(config-router)# network 10.244.128.0 0.0.0.255
 6500A(config-router)# network 10.244.129.0 0.0.0.255 
 6500A(config-router)# autonomous-system 99
 6500A(config-router)#exit-address-family
 6500A(config-router)#exit  
 6500A(config)#ip classless
 6500A(config)#ip route vrf TEST-LAB 10.0.0.0 255.0.0.0 10.244.129.251
 6500A(config)#interface Vlan129
 6500A(config)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.250 255.255.255.248
 6500A(config)#ip vrf TEST-LAB
 6500A(config)#rd 10.244.0.10:100

 6500A(config)#interface Loopback100
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.1 255.255.255.255
 6500A(config-if)#exit

 6500A(config)#interface GigabitEthernet7/1
 6500A(config-if)# ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.121 255.255.255.252
 6500A(config-if)#exit

 6500A(config)#no snmp trap link-status
 6500A(config)#interface TenGigabitEthernet8/6
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.21 255.255.255.252
 6500A(config-if)#exit
 6500A(config)# no snmp trap link-status
 6500A(config)# router eigrp 99
 6500A(config-router)# network 10.0.0.0
 6500A(config-router)# no auto-summary
 6500A(config-router)# address-family ipv4 vrf TEST-LAB
 6500A(config-router)# redistribute static metric 10000 100 255 1 1500
 
 
!--- Redistribute static routes

 6500A(config-router)# network 10.244.128.0 0.0.0.255
 6500A(config-router)# network 10.244.129.0 0.0.0.255 
 6500A(config-router)# autonomous-system 99
 6500A(config-router)#exit-address-family
 6500A(config-router)#exit  
 6500A(config)#ip classless
 6500A(config)#ip route vrf TEST-LAB 10.0.0.0 255.0.0.0 10.244.129.251
 6500A(config)#interface Vlan129
 6500A(config)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.250 255.255.255.248

 6500c(config)#ip vrf TEST-LAB
 6500c(config)#rd 10.244.0.10:100
!
 6500c(config-if)#interface Loopback0
 6500c(config-if)#ip vrf forwarding TEST-LAB
 6500c(config-if)#ip address 1.1.1.1 255.255.255.0
!         
 6500c(config-if)#interface GigabitEthernet1/1
 6500c(config-if)#switchport
 6500c(config-if)#switchport access vlan 129
 6500c(config-if)#no ip address
!                  
 6500c(config-if)#interface Vlan129
 6500c(config-if)#ip vrf forwarding TEST-LAB
 6500c(config-if)#ip address 10.244.129.251 255.255.255.248

Dépannez l'EIGRP

Un problème courant vu avec l'EIGRP est le routeur local n'établit pas des relations voisines EIGRP avec des routeurs voisins.

Artère statique pas Redistriubted à l'EIGRP

  1. Utilisez la valeur de métrique par défaut pour les artères statiques dans la commande de charge statique de redistribuer.

  2. Retirez et ajoutez la commande statique de redistribuer sur le routeur ; les expositions statiques de l'artère 10.0.0.0/8 sous la topologie EIGRP.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 112245