IP : IP version 6 (IPv6)

Routage basé sur la politique par l'exemple de configuration d'IPv6

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Le routage basé sur la politique fournit un mécanisme pour exprimer et mettre en application l'expédition/routage des paquets de données basés sur les stratégies définies par les administrateurs réseau. Le routage basé sur la politique est appliqué aux paquets entrant et emploie des mappages de route pour définir les stratégies. Basé sur les critères définis dans les mappages de route, des paquets sont expédiés/conduits au prochain saut approprié. Ce document fournit une configuration d'échantillon pour le routage basé sur la politique par l'IPv6.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Remarque: Référez-vous aux restrictions pour l'IPv6 PBR pour plus d'informations sur des restrictions.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Dans ce scénario de configuration, la Gestion de réseau à base de règles est configurée sur un routeur WAN et le routage de stratégie est appliqué sur l'interface fa1/0. Selon le trafic de configuration du réseau, 6001:66:66:66::6 est réorienté au routeur intermédiaire. Ceci est réalisé par le routage basé sur la politique. Cet exemple de configuration place le prochain-saut à 2001:10:10:10::2. Si la source de trafic est 6001:66:66:66::6, alors le trafic est réorienté au routeur intermédiaire où il atteint alors le routeur internet.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/112218/policy-based-routing-ipv6-configex-1.gif

Configurations

Ce document utilise les configurations suivantes :

Configuration de routeur WAN
WAN_Router#
!
ipv6 unicast-routing
ipv6 cef
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed 100
 ipv6 address 1001:10:10:10::1/64
 ipv6 enable
 ipv6 eigrp 55
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed 100
 ipv6 address 2001:10:10:10::1/64
 ipv6 enable
 ipv6 eigrp 55
!
interface FastEthernet1/0
 no ip address
 speed 100
 full-duplex
 ipv6 address 3001:10:10:10::1/64
 ipv6 enable
 ipv6 eigrp 55
 ipv6 policy route-map ipv6
!
ipv6 router eigrp 55
 router-id 3.3.3.3
 no shutdown
!
route-map ipv6 permit 10
 match ipv6 address ALLOW_INTERNAL_NETWORK
 set ipv6 next-hop 2001:10:10:10::2
!
ipv6 access-list ALLOW_INTERNAL_NETWORK
 permit ipv6 6001:66:66:66::/64 any

!--- Creates IPv6 access-list ALLOW_INTERNAL_NETWORK 
!--- and permits any ipv6 address in the network 6001:66:66:66::/64

!

Configuration de routeur intermédiaire
Intermediate_Router#
!
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed 100
 ipv6 address 2001:10:10:10::2/64
 ipv6 enable
 ipv6 eigrp 55
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed 100
 ipv6 address 4001:10:10:10::2/64
 ipv6 enable
 ipv6 eigrp 55
!
ipv6 router eigrp 55
 router-id 2.2.2.2
 no shutdown
!

Configuration de routeur internet
Internet_Router#
!
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback10
 no ip address
 ipv6 address 5001:55:55:55::5/64
 ipv6 enable
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed 100
 ipv6 address 1001:10:10:10::2/64
 ipv6 enable
 ipv6 eigrp 55
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed 100
 ipv6 address 4001:10:10:10::1/64
 ipv6 enable
 ipv6 eigrp 55
!

ipv6 route ::/64 Loopback10
ipv6 router eigrp 55
 router-id 1.1.1.1
 no shutdown
 redistribute connected
!

Configuration de routeur local
Local_Router#
!
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback10
 no ip address
 ipv6 address 6001:66:66:66::6/64
 ipv6 enable
!
interface FastEthernet0/0
 no ip address
 speed 100
 full-duplex
 ipv6 address 3001:10:10:10::2/64
 ipv6 enable
!
!
ipv6 route ::/64 FastEthernet0/0

!--- Static route is configured in the local router.

!

Vérifiez

Émettez la commande ping de Local_Router afin de vérifier le routage basé sur la politique :

Local_Router#ping ipv6 5001:55:55:55::5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5001:55:55:55::5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/40/76 ms

Permettez à cette commande de débogage sur WAN_Router afin de voir si le routage basé sur la politique fonctionne correctement ou pas :

Wan_Router#
debug ipv6 policy

IPv6 policy-based routing debugging is on

Wan_Router#
*Mar  1 04:10:43.846: IPv6 PBR (CEF): FastEthernet1/0, 
      matched src 6001:66:66:66::6 dst 5001:55:55:55::5 protocol 17
*Mar  1 04:10:43.846: IPv6 PBR (CEF): FIB policy route via FastEthernet0/1
*Mar  1 04:10:46.826: IPv6 PBR (CEF): FastEthernet1/0, 
      matched src 6001:66:66:66::6 dst 5001:55:55:55::5 protocol 17
*Mar  1 04:10:46.826: IPv6 PBR (CEF): FIB policy route via FastEthernet0/1
*Mar  1 04:10:49.834: IPv6 PBR (CEF): FastEthernet1/0, 
      matched src 6001:66:66:66::6 dst 5001:55:55:55::5 protocol 17
*Mar  1 04:10:49.834: IPv6 PBR (CEF): FIB policy route via FastEthernet0/1
*Mar  1 04:10:52.838: IPv6 PBR (CEF): FastEthernet1/0, 
      matched src 6001:66:66:66::6 dst 5001:55:55:55::5 protocol 17
*Mar  1 04:10:52.838: IPv6 PBR (CEF): FIB policy route via FastEthernet0/1

Dépannez

Exemple d'une configuration incorrecte

L'ipv4 et l'IPv6 PBR ne peuvent pas coexister sur une interface pendant que cet exemple de sortie affiche :

route-map BGP-NLGP-MSP-I2RandE-ALLOW permit 10
 description For allowing BGP sessions and setting next hops
 match ipv6 address BGP-NLGP-MSP-I2RandE-IPV6-ALLOW		
!
route-map BGP-NLGP-MSP-I2RandE-ALLOW permit 20
 match ip address BGP-NLGP-MSP-I2RandE-IPV4-ALLOW	
!
route-map BGP-NLGP-MSP-I2RandE-ALLOW permit 30
 set ip next-hop 192.168.48.41
 set ipv6 next-hop 2620:32:0:1000::2
!

Exemple d'une configuration correcte

Afin d'appliquer l'ipv4 et l'IPv6, vous devez utiliser deux route-map distincts pour l'ipv4 et l'IPv6 et puis les appliquer sur une interface. Cette sortie témoin fournit un exemple :

route-map IPv6 permit 10
 match ipv6 address BGP-NLGP-MSP-I2RandE-IPV6-ALLOW
 set ipv6 next-hop 2620:32:0:1000::2
route-map IPV4 permit 10
 match ip address BGP-NLGP-MSP-I2RandE-IPV4-ALLOW
 set ip next-hop 192.168.48.41
Router#show run interface e0/0
Building configuration...

Current configuration : 163 bytes
!
interface Ethernet0/0
 ip address 10.57.253.109 255.255.255.252
 ip policy route-map IPV4
 ipv6 address 2001:468:1900:70::1/64
 ipv6 policy route-map IPv6
end

Informations connexes


Document ID: 112218