IP : Protocole BGP (Border Gateway Protocol)

L'allowas-in comporte dans l'exemple de configuration BGP

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document décrit un scénario où deux Routeurs secondaires sont connectés par l'intermédiaire d'un ISP et d'un Protocole BGP (Border Gateway Protocol) courant entre eux. Les deux Routeurs secondaires (R1 et R2), cependant aux endroits différents, partagent le même numéro de système autonome. Une fois les artères arrivent d'un branchement (R1 dans ce cas) au réseau de fournisseur de services (fournisseur de services), elles seront étiquetées avec le client AS. Une fois que le fournisseur de services le passe au l'autre routeur secondaire (R2), par défaut, les artères sera lâché si l'autre branchement exécutait également le BGP avec le fournisseur de services à l'aide du même numéro de système autonome. Dans ce scénario, la commande de neighbor allowas-in est émise afin de permettre au BGP sur l'autre côté pour injecter des mises à jour. Ce document fournit une configuration d'échantillon qui vous aide à comprendre la caractéristique d'allowas-in dans le BGP.

Remarque: Cette caractéristique peut seulement être utilisée pour de véritables pairs d'eBGP. Vous ne pouvez pas utiliser cette caractéristique pour deux pairs qui sont des membres de sous-titre-âne différent de confédération.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous présente avec les informations pour configurer les caractéristiques que ce document décrit.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112236-allowas-in-bgp-config-example-1.gif

Configurations

Ce document utilise les configurations suivantes :

Configuration sur Router_A
Router_A#interface Loopback1
 ip address 1.1.1.1 255.255.255.255
!
interface Loopback2
 ip address 2.2.2.2 255.255.255.255
!
interface Loopback3
 ip address 3.3.3.3 255.255.255.255
!
interface GigabitEthernet0/1
 no switchport
 ip address 192.1.12.2 255.255.255.0
!
router eigrp 100
 network 1.1.1.1 0.0.0.0
 network 2.2.2.2 0.0.0.0
 network 3.3.3.3 0.0.0.0
 network 192.1.12.0
 auto-summary
!

Configuration sur le routeur R1
R1#interface Loopback22
 ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.1.12.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 172.16.12.1 255.255.255.0
!
!
router eigrp 100
 network 192.1.12.0
 no auto-summary
!
router bgp 121
 no synchronization
 bgp router-id 22.22.22.22
 bgp log-neighbor-changes
 network 22.22.22.22 mask 255.255.255.255 

!--- This is the advertising loopback address.

 redistribute eigrp 100 

!--- This shows the redistributing internal routes in BGP.

 neighbor 172.16.12.2 remote-as 500 

!--- This shows the EBGP connection with ISP.

 neighbor 172.16.12.2 ebgp-multihop 5
 no auto-summary
!

Cet exemple prouve que l'EIGRP fonctionne entre Router_A et R1 :

r1#show ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.1.12.2              Fa0/0             14 01:17:12  828  4968  0  7

Cet exemple affiche comment le routeur R1 apprend des artères de Router_A par l'EIGRP :

r1#show ip route eigrp 100
D    1.0.0.0/8 [90/156160] via 192.1.12.2, 00:02:24, FastEthernet0/0
D    2.0.0.0/8 [90/156160] via 192.1.12.2, 00:02:24, FastEthernet0/0
D    3.0.0.0/8 [90/156160] via 192.1.12.2, 00:02:24, FastEthernet0/0

Cet exemple affiche comment le routeur R1 établit une connexion BGP avec un ISP exécutant BGP AS500 :

r1#show ip bgp summary
BGP router identifier 22.22.22.22, local AS number 121
BGP table version is 19, main routing table version 19
7 network entries using 924 bytes of memory
7 path entries using 364 bytes of memory
5/4 BGP path/bestpath attribute entries using 840 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 2) using 32 bytes of memory
BGP using 2184 total bytes of memory
BGP activity 40/33 prefixes, 42/35 paths, scan interval 60 secs

Neighbor        V          AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
172.16.12.2     4        500      86      76       19    0    0 00:25:13        2

Cet exemple affiche comment R1 annonce les routes apprises BGP :

r1#show ip bgp
BGP table version is 19, local router ID is 22.22.22.22
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.0.0.0          192.1.12.2          156160         32768 ? 
*> 2.0.0.0          192.1.12.2          156160         32768 ?
*> 3.0.0.0          192.1.12.2          156160         32768 ?
*> 10.10.12.0/24    172.16.12.2              0             0 500 i
*> 22.22.22.22/32   0.0.0.0                  0         32768 i
r> 172.16.12.0/24   172.16.12.2              0             0 500 i
*> 192.1.12.0       0.0.0.0                  0         32768 ?
r1#ping 10.10.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.12.2, timeout is 2 seconds:
!!!!!  
!--- This is the connectivity with Router 2 across the Internet cloud.

Configuration sur le routeur R2
R2#interface Loopback33
 ip address 33.33.33.33 255.255.255.255
!
interface Serial1/0
 ip address 10.10.12.1 255.255.255.0

router bgp 121
 no synchronization
 bgp router-id 33.33.33.33
 bgp log-neighbor-changes
 network 33.33.33.33 mask 255.255.255.255 

!--- This is the advertising loopback address.
 
 neighbor 10.10.12.2 remote-as 500 

!--- This is the EBGP connection with ISP.

 neighbor 10.10.12.2 ebgp-multihop 5
no auto-summary

Le routeur R2 n'apprend aucune artère du routeur R1.

C'est comportement naturel parce que les essais BGP pour éviter des boucles de routage. Par exemple, la deuxième annonce de tous les préfixes qui contiennent les numéros de système autonome en double (ASNs) est désactivée par défaut.

Des artères redistribuées EIGRP (1.0.0.0, 2.0.0.0, 3.0.0.0) et la route interne 22.22.22.22 BGP de R1 ne sont pas reçues par R2 pendant qu'elles proviennent du même ASN à travers l'Internet. Puisque R2 voient son propre numéro de système autonome (121) dans l'AS-PATH, R2 ne prend pas ces artères.

r2#show ip bgp
BGP table version is 20, local router ID is 33.33.33.33
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
r> 10.10.12.0/24    10.10.12.2               0             0 500 i
*> 33.33.33.33/32   0.0.0.0                  0         32768 i
*> 172.16.12.0/24   10.10.12.2               0             0 500 i

Afin de permettre la deuxième annonce de tous les préfixes qui contiennent ASNs en double, utilisez le neighbor allowas-in commandent dans le mode de configuration du routeur dans le routeur R2.

r2(config-router)#neighbor 10.10.12.2 allowas-in
r2#clear ip bgp*
r2#show ip bgp
BGP table version is 10, local router ID is 33.33.33.33
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.0.0.0          10.10.12.2                             0 500 121 ?
*> 2.0.0.0          10.10.12.2                             0 500 121 ?
*> 3.0.0.0          10.10.12.2                             0 500 121 ?
r> 10.10.12.0/24    10.10.12.2               0             0 500 i
*> 22.22.22.22/32   10.10.12.2                             0 500 121 i
*  33.33.33.33/32   10.10.12.2                             0 500 121 i
*>                  0.0.0.0                  0         32768 i
*> 172.16.12.0/24   10.10.12.2               0             0 500 i
*> 192.1.12.0       10.10.12.2                             0 500 121 ?

Maintenant essai à cingler de R1 à R2 :

r2#ping 22.22.22.22
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/57/60 ms

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Message d'erreur

Le message d'erreur : Artère factice A.B.C.D de recv voisin de %BGP% : COMME le message d'erreur de boucle est reçu.

Cette notification signifie que la route BGP reçue par le routeur CE a son propre numéro de système autonome dans COMME chemin et est considérée une boucle de routeur pour le routeur CE. Comme contournement, configurez le routeur CE avec la configuration d'allowas-in comme illustrée dans l'exemple précédent.


Informations connexes


Document ID: 112236