IP : Protocoles de routage IP

Configuration d'IPv6 d'échantillon pour le BGP avec deux fournisseurs de services différents (hébergement multiple)

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Le protocole BGP (Border Gateway Protocol) est l'un des protocoles clés à utiliser pour réaliser la redondance de connexion Internet. Quand vous connectez votre réseau à deux fournisseurs de services Internet différents (ISPs), cela s'appelle l'hébergement multiple. L'hébergement multiple fournit la redondance et l'optimisation du réseau. Il sélectionne l'ISP qui offre le meilleur chemin à une ressource. Quand vous exécutez le BGP avec plus d'un fournisseur de services, vous courez le risque que votre système autonome (AS) deviendra un transit AS. Le trafic Internet passe ainsi par votre AS et utilise potentiellement toute la bande passante et toutes les ressources sur le CPU de votre routeur. Ce document aborde cette question et fournit des exemples appropriés de configuration.

Conditions préalables

Conditions requises

Référez-vous à ce document avant que vous poursuiviez :

Exemple de configuration pour BGP avec deux fournisseurs de services différents (multihébergement)

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Routeur de gamme Cisco 2800 avec la version de logiciel 12.4(13r)T de Ý de Cisco IOS

  • Routeur de gamme Cisco 3800 avec la version du logiciel Cisco IOS 12.4(13r)T

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/112228/bgp2isp-01.gif

Dans ce routeur de réseau A connecte deux aux fournisseurs de services différents la STATION THERMALE et le SP-B formant l'hébergement multiple par où 1010:1010::/64 et 2020:2020::/64 est annoncé PENDANT QUE 101 à l'extérieur et au réseau 1212:1212::/64 est reçus de deux différents COMME, EN TANT QUE 202 et EN TANT QUE 303.

Remarque: Être un lien à un vidéo (disponible sur la Communauté de support de Cisco)leavingcisco.com qui fournit l'aperçu de l'hébergement multiple BGP et voici donne des conseils sur la façon dont dépanner des problèmes communs BGP comme la CPU de scruter et de haute.

Multihébergement BGP : Conception et dépannage - Vidéo de vidéo web vivante leavingcisco.com

Configurations

Ce document utilise les configurations suivantes :

Routeur-Un
Router-A#
ipv6 unicast-routing

!---Enables the forwarding of IPv6 packets.

ipv6 cef
interface Serial3/0
 description CONNECTED TO SP-A
 ip address 192.168.10.1 255.255.255.0
 ipv6 address 1202:ABCD::/64 eui-64
 ipv6 enable
 no fair-queue
 clock rate 64000
!
interface Serial3/1
 description CONNECTED TO SP-B
 no ip address
 ipv6 address 2303:ABCD::/64 eui-64
 clock rate 64000
!
 router bgp 101
 bgp router-id 1.1.1.1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 1202:ABCD::21B:54FF:FEA9:24B0 remote-as 202

!--- Configures SP-A as neighbor.

 neighbor 1202:ABCD::21B:54FF:FEA9:24B0 ebgp-multihop 2
 neighbor 2303:ABCD::21B:54FF:FE54:FB10 remote-as 303

!--- Configures SP-B as neighbor.

 !
 address-family ipv6
  neighbor 1202:ABCD::21B:54FF:FEA9:24B0 activate
  neighbor 2303:ABCD::21B:54FF:FE54:FB10 activate
  network 1010:1010::/64
  network 2020:2020::/64
 exit-address-family
!

Entretenez ProviderA
SP-A#
ipv6 unicast-routing
ipv6 cef
interface Serial1/0
 no ip address
 ipv6 address 1202:ABCD::/64 eui-64
 ipv6 enable
 no fair-queue
!
router bgp 202
 bgp router-id 2.2.2.2
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 1202:ABCD::21C:58FF:FEED:3E90 remote-as 101

!--- Configuers Router A as neighbor.

 !
 address-family ipv6
  neighbor 1202:ABCD::21C:58FF:FEED:3E90 activate
  network 1212:1212::/64
 exit-address-family
!

Entretenez ProviderB
SP-B#
ipv6 unicast-routing
ipv6 cef
interface Serial1/0
 no ip address
 ipv6 address 2303:ABCD::/64 eui-64
 no fair-queue
!
router bgp 303
 no synchronization
 bgp router-id 3.3.3.3
 bgp log-neighbor-changes
 neighbor 2303:ABCD::21C:58FF:FEED:3E90 remote-as 101

!--- Configures as Router A as neighbor.

 neighbor 2303:ABCD::21C:58FF:FEED:3E90 ebgp-multihop 5
 no auto-summary
 !
 address-family ipv6
  neighbor 2303:ABCD::21C:58FF:FEED:3E90 activate
  network 1212:1212::/64
 exit-address-family
!

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

  • Routeur A scrutant avec deux ISP

    Router-A#
    show bgp ipv6 unicast summary
    
    BGP router identifier 1.1.1.1, local AS number 101
    BGP table version is 6, main routing table version 6
    3 network entries using 447 bytes of memory
    4 path entries using 304 bytes of memory
    4/2 BGP path/bestpath attribute entries using 496 bytes of memory
    2 BGP AS-PATH entries using 48 bytes of memory
    0 BGP route-map cache entries using 0 bytes of memory
    0 BGP filter-list cache entries using 0 bytes of memory
    BGP using 1295 total bytes of memory
    BGP activity 3/0 prefixes, 14/10 paths, scan interval 60 secs
    
    Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
    1202:ABCD::21B:54FF:FEA9:24B0   4   202   108     119   6    0    0 00:31:41   1
    2303:ABCD::21B:54FF:FE54:FB10   4   303   108     121   6    0    0 00:25:1    1
    
    !--- Indicates that Router A is peering with both the ISP SP-A and SP-B
    
    
  • Routes apprises de routeur-Un de STATION THERMALE et de SP-B

    Router-A#show bgp ipv6 unicast
    BGP table version is 6, local router ID is 1.1.1.1
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
    
       Network          Next Hop            Metric LocPrf Weight Path
    *> 1010:1010::/64   ::                       0                          32768 i
    *  1212:1212::/64   2303:ABCD::21B:54FF:FE54:FB10 0  0 303 i
    *>                              1202:ABCD::21B:54FF:FEA9:24B0 0  0 202 i
    *> 2020:2020::/64   ::                       0                         32768 i
  • Sur la STATION THERMALE :

    SP-A#sh bgp ipv6 unicast
    BGP table version is 4, local router ID is 2.2.2.2
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
    
       Network          Next Hop            Metric LocPrf Weight Path
    *> 1010:1010::/64   1202:ABCD::21C:58FF:FEED:3E90 0 0 101 i
    *> 1212:1212::/64   ::                       0            32768              i
    *> 2020:2020::/64   1202:ABCD::21C:58FF:FEED:3E90 0 0 101 i
  • Sur SP-B :

    SP-B#sh bgp ipv6 unicast
    BGP table version is 4, local router ID is 3.3.3.3
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
    
       Network          Next Hop            Metric LocPrf Weight Path
    *> 1010:1010::/64   2303:ABCD::21C:58FF:FEED:3E90 0             0 101 i
    *  1212:1212::/64   2303:ABCD::21C:58FF:FEED:3E90  0                 101 202 i
    *>                  ::                       0         32768 i
    *> 2020:2020::/64   2303:ABCD::21C:58FF:FEED:3E90 0             0 101 i

Dépannez

Employez la commande de mise à jour d'IPv6 BGP de débogage afin d'afficher les informations de débogage sur les mises à jour pour aider à déterminer l'état de scruter.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 112228