IP : IP version 6 (IPv6)

BGP multiprotocole pour l'exemple de configuration d'IPv6

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit un exemple de configuration pour le multiprotocole Border Gateway Protocol (BGP) pour l'IPv6. Le BGP est un protocole de passerelle extérieure (EGP) utilisé principalement pour connecter des domaines de routage distincts qui contiennent des stratégies indépendantes de routage (des systèmes autonomes). Le BGP est utilisé généralement pour se connecter à un fournisseur de services pour l'accès à Internet. Le BGP peut également être utilisé dans un Autonomous System, et cette variation désigné sous le nom de BGP interne (iBGP). Le BGP multiprotocole est un BGP amélioré telles que lequel diffuse les informations de routage pour la plusieurs famille de familles d'adresse de protocole de couche réseau, d'ipv6 addres et pour des artères de Protocole IP Multicast. Toutes les commandes BGP et les fonctions de stratégie de routage peuvent être utilisées avec le BGP multiprotocole.

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant d'essayer cette configuration :

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Dans cette topologie, le R0 et les R1 de Routeurs forment des relations EBGP : Le R0 est dans le numéro de système autonome 1 (AS1) et R1 est dans AS2. Le R0 de routeur annonce deux réseaux d'IPv6 : 2010:AB8:2::/48 et 2010:AB8:3::/48.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/112135/ipv6-bgp-01.gif

Configurations

C'est la configuration d'échantillon du BGP multiprotocole d'IPv6 pour les Routeurs affichés dans le diagramme :

R0 de routeur

ipv6 unicast-routing

!--- Enables forwarding of IPv6 packets.

ipv6 cef

interface Loopback10
 no ip address
 ipv6 address 2010:AB8:2::/48
 ipv6 enable
!
interface Loopback20
 no ip address
 ipv6 address 2010:AB8:3::/48
 ipv6 enable
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2010:AB8:0:2::/64 eui-64
 ipv6 enable
!

router bgp 1
 bgp router-id 1.1.1.1
 no bgp default ipv4-unicast

!--- Without configuring ""no bgp default ipv4-unicast"" only IPv4 will be 

!--- advertised

 bgp log-neighbor-changes
 neighbor 2010:AB8:0:2:C601:10FF:FE58:0 remote-as 2
 !
 address-family ipv6
  neighbor 2010:AB8:0:2:C601:10FF:FE58:0 activate
  network 2010:AB8:2::/48
  network 2010:AB8:3::/48
 exit-address-family
!

Routeur R1
ipv6 unicast-routing
ipv6 cef

interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2010:AB8:0:2::/64 eui-64
 ipv6 enable
!

router bgp 2
 bgp router-id 2.2.2.2
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 2010:AB8:0:2:C600:10FF:FE58:0 remote-as 1
 !
 address-family ipv6
  neighbor 2010:AB8:0:2:C600:10FF:FE58:0 activate
 exit-address-family
!

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

show ipv6 route

Cette commande affiche la la table de routage d'IPv6.

R1#
show ipv6 route

IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
C   2010:AB8:0:2::/64 [0/0]
     via ::, FastEthernet0/0
L   2010:AB8:0:2:C601:10FF:FE58:0/128 [0/0]
     via ::, FastEthernet0/0
B   2010:AB8:2::/48 [20/0]
     via FE80::C600:10FF:FE58:0, FastEthernet0/0
B   2010:AB8:3::/48 [20/0]
     via FE80::C600:10FF:FE58:0, FastEthernet0/0
L   FF00::/8 [0/0]
     via ::, Null0

BGP de show ipv6 route

Quand vous spécifiez un protocole, seulement des artères pour ce protocole de routage particulier sont affichées. Cette sortie témoin est de la commande de show ipv6 route une fois entré avec le mot clé BGP :

R1#
show ipv6 route bgp

IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
B   2010:AB8:2::/48 [20/0]
     via FE80::C600:10FF:FE58:0, FastEthernet0/0
B   2010:AB8:3::/48 [20/0]
     via FE80::C600:10FF:FE58:0, FastEthernet0/0

résumé d'unicast de show bgp ipv6

Cette commande fournit la sortie semblable à la commande de show ip bgp summary, à moins que ce soit IPv6-specific.

R1#
show bgp ipv6 unicast summary

BGP router identifier 2.2.2.2, local AS number 2
BGP table version is 3, main routing table version 3
2 network entries using 304 bytes of memory
2 path entries using 152 bytes of memory
2/1 BGP path/bestpath attribute entries using 248 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 728 total bytes of memory
BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2010:AB8:0:2:C600:10FF:FE58:0
                4     1      15      14        3    0    0 00:11:52        2

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 112135