IP : IP version 6 (IPv6)

Configuration d'échantillon pour OSPFv3

20 septembre 2014 - Traduction automatique
Autres versions: PDFpdf | Anglais (16 septembre 2014) | Commentaires


Contenu


Introduction

Open Shortest Path First (OSPF) est un protocole de routage pour IP. C'est un protocole de routage à état de liens, par opposition à un protocole à vecteur de distance. Un protocole de routage à état de liens prend des décisions de routage basées sur les états des liens qui connectent la source et les ordinateurs de destination. L'état d'un lien est une description de cette interface et des relations à ses périphériques réseau voisins. Les informations d'interface incluent le préfixe d'IPv6 de l'interface, le masque de réseau, le type de réseau qu'il est connecté à, les Routeurs connectés à ce réseau, et ainsi de suite. Ces informations sont propagées dans le divers type d'annonces d'état de lien (LSAs).

La version 3 OSPF, qui est décrite dans RFC 2740, prend en charge l'IPv6.

Conditions préalables

Conditions requises

Avant que vous activiez l'OSPF pour l'IPv6 sur une interface, vous devez exécuter ce qui suit :

  • Terminez-vous la stratégie et la planification de réseau OSPF pour votre réseau d'IPv6. Par exemple, vous devez décider si de plusieurs zones sont exigées.

  • Routage d'unicast d'IPv6 d'enable.

  • IPv6 d'enable sur l'interface.

  • Configurez la sécurité IP (IPsec) sécurisent l'Application Program Interface de socket (API) sur l'OSPF pour l'IPv6 afin d'activer l'authentification et le cryptage.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/112100/ospfv3-config-guide-01.gif

Configuration

C'est la configuration d'OSPFv3 pour les Routeurs affichés dans le diagramme :

Routeur d'extrémité
ipv6 unicast-routing
ipv6 cef
!
interface serial 0/0
 no ip address
 ipv6 enable
 ipv6 address 2001:ABAB::/64 eui-64
 ipv6 ospf 1 area 2
!
ipv6 router ospf 1
 router-id 3.3.3.3
 area 2 stub
!

Routeur ABR1
ipv6 unicast-routing
ipv6 cef
!
interface FastEthernet0/0
 no ip address
 speed auto
 ipv6 address 2003::1/124
 ipv6 enable
 ipv6 ospf 1 area 0
!
interface Serial0/0
 no ip address
 ipv6 address 2002:ABAB::/64 eui-64
 ipv6 enable
 ipv6 ospf 1 area 2
!
ipv6 router ospf 1
 router-id 1.1.1.1
 area 2 stub no-summary
!

Routeur ASBR
ipv6 unicast-routing
ipv6 cef
!
interface FastEthernet0/0
 no ip address
 ipv6 address 2003::2/124
 ipv6 enable
 ipv6 ospf 1 area 0
!
interface Serial0/0
 no ip address
 ipv6 address 2003::1:1/124
 ipv6 enable
 ipv6 rip EXT enable
!
ipv6 router ospf 1
 router-id 2.2.2.2
 default-metric 25
 redistribute rip EXT metric-type 1 include-connected
!
ipv6 router rip EXT
 redistribute ospf 1 match internal external 1 external 2 include-connected
!

Routeur externe
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address 2004:ABAB::/64 eui-64
 ipv6 enable
 ipv6 rip EXT enable
!
interface Serial0/0
 no ip address
 ipv6 address 2003::1:2/124
 ipv6 enable
 ipv6 rip EXT enable
!
ipv6 router rip EXT

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

La commande de show ipv6 ospf database affiche la base de données d'État de lien (LSDB) du routeur.

Stub_Router#show ipv6 ospf database

            OSPFv3 Router with ID (3.3.3.3) (Process ID 1)

                Router Link States (Area 2)

ADV Router      Age         Seq#            Fragment ID  Link count  Bits
1.1.1.1             885         0x80000007      0                    1           B
3.3.3.3             919         0x80000008      0                    1           None

                Inter Area Prefix Link States (Area 2)

ADV Router      Age         Seq#                Prefix
1.1.1.1             373         0x80000002          ::/0

                Link (Type-8) Link States (Area 2)

ADV Router      Age         Seq#            Link ID    Interface
1.1.1.1             964         0x80000006      5          Se0/0
3.3.3.3             1165        0x80000006     5          Se0/0

                Intra Area Prefix Link States (Area 2)

ADV Router      Age         Seq#            Link ID    Ref-lstype  Ref-LSID
1.1.1.1             964         0x80000005      0          0x2001      0
3.3.3.3             1172        0x80000005     0          0x2001      0

Le routeur de show ipv6 ospf database auto-commencent la commande affiche aux LSAs du routeur où le routeur commence et reçoit. Les LSAs du routeur ne diffusent aucune adresse ou informations de préfixe.

Stub_Router#

            OSPFv3 Router with ID (3.3.3.3) (Process ID 1)

                Router Link States (Area 2)

  Routing Bit Set on this LSA
  LS age: 753
  Options: (V6-Bit R-bit DC-Bit)
  LS Type: Router Links
  Link State ID: 0
  Advertising Router: 1.1.1.1
  LS Seq Number: 80000007
  Checksum: 0xFCA4
  Length: 40
  Area Border Router
  Number of Links: 1

    Link connected to: another Router (point-to-point)
      Link Metric: 64
      Local Interface ID: 5
      Neighbor Interface ID: 5
      Neighbor Router ID: 3.3.3.3


  LS age: 791
  Options: (V6-Bit R-bit DC-Bit)
  LS Type: Router Links
  Link State ID: 0
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000008
  Checksum: 0x178A
  Length: 40
  Number of Links: 1

    Link connected to: another Router (point-to-point)
      Link Metric: 64
      Local Interface ID: 5
      Neighbor Interface ID: 5
      Neighbor Router ID: 1.1.1.1

Le LSAs portent un champ d'options qui a ces bits :

  • Bit V6 — Indique si le routeur/lien devrait être utilisé dans le calcul de routage.

  • Bit R — C'est le « routeur mordu ». Il indique si le créateur est un routeur actif.

  • Bit C.C — Indique la manipulation du routeur du circuit de demande.

Le lien de show ipv6 ospf database auto-commencent les expositions de commande qui joignent LSAs portent des adresses de lien-particularité.

Stub_Router#show ipv6 ospf database link self-originate

            OSPFv3 Router with ID (3.3.3.3) (Process ID 1)

                Link (Type-8) Link States (Area 2)

  LS age: 627
  Options: (V6-Bit R-bit DC-Bit)
  LS Type: Link-LSA (Interface: Serial0/0)
  Link State ID: 5 (Interface ID)
  Advertising Router: 1.1.1.1
  LS Seq Number: 80000006
  Checksum: 0x215C
  Length: 56
  Router Priority: 1
  Link Local Address: FE80::D20E:16FF:FE50:0
  Number of Prefixes: 1
  Prefix Address: 2002:ABAB::
  Prefix Length: 64, Options: None

  LS age: 828
  Options: (V6-Bit R-bit DC-Bit)
  LS Type: Link-LSA (Interface: Serial0/0)
  Link State ID: 5 (Interface ID)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000006
  Checksum: 0xB4C2
  Length: 56
  Router Priority: 1
  Link Local Address: FE80::D20D:16FF:FE50:0
  Number of Prefixes: 1
  Prefix Address: 2001:ABAB::
  Prefix Length: 64, Options: None

Puisque le routeur d'extrémité appartient à une région de Total-stub, le routeur ABR1 envoie seulement le default route au routeur d'extrémité.

Stub_Router#
show ipv6 route

IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
OI  ::/0 [110/65]
     via FE80::D20E:16FF:FE50:0, Serial0/0
C   2001:ABAB::/64 [0/0]
     via ::, Serial0/0
L   2001:ABAB::D20D:16FF:FE50:0/128 [0/0]
     via ::, Serial0/0
O   2002:ABAB::/64 [110/128]
     via FE80::D20E:16FF:FE50:0, Serial0/0
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0

Le routeur ABR1 est le routeur de cadre de zone.

ABR1#
show ipv6 ospf

 Routing Process "ospfv3 1" with ID 1.1.1.1
 It is an area border router
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 2. Checksum Sum 0x00A1E0
 Number of areas in this router is 2. 1 normal 1 stub 0 nssa
 Reference bandwidth unit is 100 mbps
    Area BACKBONE(0)
        Number of interfaces in this area is 1
        SPF algorithm executed 5 times
        Number of LSA 8. Checksum Sum 0x052E71
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0
    Area 2
        Number of interfaces in this area is 1
        It is a stub area, no summary LSA in this area
          generates stub default route with cost 1
        SPF algorithm executed 6 times
        Number of LSA 7. Checksum Sum 0x042237
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

Le routeur ABR1 reçoit les artères externes (routes RIP) du routeur ASBR.

ABR1#
show ipv6 route

IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
O   2001:ABAB::/64 [110/128]
     via FE80::D20D:16FF:FE50:0, Serial0/0
C   2002:ABAB::/64 [0/0]
     via ::, Serial0/0
L   2002:ABAB::D20E:16FF:FE50:0/128 [0/0]
     via ::, Serial0/0
C   2003::/124 [0/0]
     via ::, FastEthernet0/0
L   2003::1/128 [0/0]
     via ::, FastEthernet0/0
OE1  2003::1:0/124 [110/26]
     via FE80::D20F:BFF:FE24:0, FastEthernet0/0
OE1  2004:ABAB::/64 [110/26]
     via FE80::D20F:BFF:FE24:0, FastEthernet0/0
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0

Le routeur ASBR est le routeur de borne d'Autonomous System pour le réseau. Il est connecté au réseau de RIP par l'interface de l'interface série 0/0.

ASBR#
show ipv6 ospf

 Routing Process "ospfv3 1" with ID 2.2.2.2
 It is an autonomous system boundary router
 Redistributing External Routes (with default metric 25) from,
    rip with metric-type 1 include-connected
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 2. Checksum Sum 0x00A1E0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 Reference bandwidth unit is 100 mbps
    Area BACKBONE(0)
        Number of interfaces in this area is 1
        SPF algorithm executed 2 times
        Number of LSA 8. Checksum Sum 0x052E71
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

ASBR#
show ipv6 rip

RIP process "EXT", port 521, multicast-group FF02::9, pid 156
     Administrative distance is 120. Maximum paths is 16
     Updates every 30 seconds, expire after 180
     Holddown lasts 0 seconds, garbage collect after 120
     Split horizon is on; poison reverse is off
     Default routes are not generated
     Periodic updates 69, trigger updates 6
  Interfaces:
    Serial0/0
  Redistribution:
    Redistributing protocol ospf 1 include-connected

Dépannez

Utilisez cette section pour dépanner votre configuration.

Remarque: Référez-vous aux informations importantes sur les commandes de débogage avant d'utiliser les commandes de débogage.

mettez au point l'IPv6

Dès qu'OSPFv3 sera activé sur le routeur d'extrémité, il envoie des messages Hello du type 1 OSPFv3 à l'adresse de multidiffusion FF02::5. Une fois qu'il reçoit bonjour des paquets du routeur ABR1, ils négocient les relations master/slave et puis les commencent à envoyer des paquets DBD.

Stub_Router#debug ipv6 ospf events

Stub_Router# debug ipv6 ospf packet
*Mar  1 00:14:20.999: OSPFv3: rcv. v:3 t:1 l:36 rid:1.1.1.1
      aid:0.0.0.2 chk:142A inst:0 from Serial0/0
*Mar  1 00:14:21.023: OSPFv3: rcv. v:3 t:2 l:28 rid:1.1.1.1
      aid:0.0.0.2 chk:EB8A inst:0 from Serial0/0
*Mar  1 00:14:21.027: OSPFv3: rcv. v:3 t:1 l:40 rid:1.1.1.1
      aid:0.0.0.2 chk:E1C inst:0 from Serial0/0
*Mar  1 00:14:21.027: OSPFv3: 2 Way Communication to 1.1.1.1 on Serial0/0, state 2WAY
*Mar  1 00:14:21.027: OSPFv3: Send DBD to 1.1.1.1 on Serial0/0 seq 0x1737 opt 0x0011 
flag 0x7 len 28
*Mar  1 00:14:21.031: OSPFv3: Rcv DBD from 1.1.1.1 on Serial0/0 seq 0x2402 opt 0x0011 
flag 0x7 len 28  mtu 1500 state EXSTART
*Mar  1 00:14:21.031: OSPFv3: First DBD and we are not SLAVE
*Mar  1 00:14:21.035: OSPFv3: rcv. v:3 t:2 l:88 rid:1.1.1.1
      aid:0.0.0.2 chk:5CF3 inst:0 from Serial0/0
*Mar  1 00:14:21.039: OSPFv3: Rcv DBD from 1.1.1.1 on Serial0/0 seq 0x1737 opt 0x0011 flag 
0x2 len 88  mtu 1500 state EXSTART
*Mar  1 00:14:21.039: OSPFv3: NBR Negotiation Done. We are the MASTER
*Mar  1 00:14:21.039: OSPFv3: Send DBD to 1.1.1.1 on Serial0/0 seq 0x1738 opt 0x0011 flag 
0x3 len 88
*Mar  1 00:14:21.043: OSPFv3: rcv. v:3 t:2 l:28 rid:1.1.1.1
      aid:0.0.0.2 chk:F85B inst:0 from Serial0/0
*Mar  1 00:14:21.047: OSPFv3: Rcv DBD from 1.1.1.1 on Serial0/0 seq 0x1738 opt 0x0011 flag 
0x0 len 28  mtu 1500 state EXCHANGE
*Mar  1 00:14:21.047: OSPFv3: Send DBD to 1.1.1.1 on Serial0/0 seq 0x1739 opt 0x0011 flag 
0x1 len 28Send LS REQ to 1.1.1.1 length 36 LSA count 3
*Mar  1 00:14:21.051: OSPFv3: rcv. v:3 t:3 l:52 rid:1.1.1.1
      aid:0.0.0.2 chk:C326 inst:0 from Serial0/0
*Mar  1 00:14:21.055: OSPFv3: rcv. v:3 t:2 l:28 rid:1.1.1.1
      aid:0.0.0.2 chk:F85A inst:0 from Serial0/0

Une fois que les paquets DBD sont permutés, les Routeurs envoient des messages de la requête d'état de liaison (LS REQ) et de la mise à jour d'État de lien (LS UPD) de construire leur LSDB. Après les messages successifs LS REQ et LS UPD, et quand l'état atteint COMPLÈTEMENT, les Routeurs continuent à permuter bonjour des paquets.

Stub_Router#
*Mar  1 00:14:21.055: OSPFv3: rcv. v:3 t:4 l:144 rid:1.1.1.1
      aid:0.0.0.2 chk:58BC inst:0 from Serial0/0Rcv LS REQ from 1.1.1.1 on Serial0/0 length 52 
LSA count 3Send UPD to 131.88.101.156 on Serial0/0 length 128 LSA count 3
*Mar  1 00:14:21.059: OSPFv3: Rcv DBD from 1.1.1.1 on Serial0/0 seq 0x1739 opt 0x0011 flag 
0x0 len 28  mtu 1500 state EXCHANGE
*Mar  1 00:14:21.063: OSPFv3: Exchange Done with 1.1.1.1 on Serial0/0Rcv LS UPD from 
1.1.1.1 on Serial0/0 length 144 LSA count 3
*Mar  1 00:14:21.067: OSPFv3: Synchronized with 1.1.1.1 on Serial0/0, state FULL
*Mar  1 00:14:21.067: %OSPFv3-5-ADJCHG: Process 1, Nbr 1.1.1.1 on Serial0/0 from 
LOADING to FULL, Loading Done
*Mar  1 00:14:21.687: OSPFv3: rcv. v:3 t:4 l:60 rid:1.1.1.1
      aid:0.0.0.2 chk:66EB inst:0 from Serial0/0Rcv LS UPD from 1.1.1.1 on Serial0/0 length 60 
LSA count 1
*Mar  1 00:14:23.683: OSPFv3: rcv. v:3 t:5 l:96 rid:1.1.1.1
      aid:0.0.0.2 chk:4BB5 inst:0 from Serial0/0

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 112100