Voix et communications unifiées : Logiciel Cisco Unified Border Element

Haute disponibilité de Logiciel Cisco Unified Border Element (ha) utilisant l'exemple de configuration de HSRP

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Le logiciel Cisco Unified Border Element (CUBE) fournit la haute disponibilité (HA) par l'intermédiaire des configurations de redondance de boîte à boîte lors de la mise en oeuvre sur une plate-forme de routeur de génération 2 d'Integrated Services Router Cisco (ISR G2). La Redondance de case-à-case de CUBE accroît la longue technologie de secours immédiat basée sur routeur disponible de routeur de protocole de routage (HSRP).

La technologie de HSRP fournit la disponibilité de réseau élevée par le trafic d'IP de routage des hôtes sur des réseaux sans compter sur la Disponibilité de n'importe quel routeur unique. Le HSRP est utilisé dans un groupe de Routeurs pour sélectionner un routeur actif et un routeur de réserve. Le HSRP surveille les les deux les interfaces internes et externes ? si n'importe quelle interface descend, le périphérique entier est considéré vers le bas, le périphérique de réserve devient active et assure les responsabilités du routeur actif.

la Redondance de Case-à-case emploie le protocole de HSRP pour former une paire d'Active/Standby de HSRP de Routeurs. Les paires d'Active/Standby partagent la même adresse IP virtuelle et permutent continuellement des messages d'état. Les informations de session de CUBE sont checkpointed à travers les paires d'Active/Standby de Routeurs. Ceci permet au routeur de réserve d'assurer immédiatement toutes les responsabilités de Traitement des appels de CUBE si le routeur actif va hors service pour des raisons prévues ou non planifiées.

L'implémentation ha de Redondance de case-à-case de CUBE prend en charge la conservation de medias au-dessus d'un basculement de HSRP des appels SIP-SIP, mais aucune signalisation d'appel n'est préservée. Cette capacité est prise en charge en date de la version de logiciel 15.1.2T de Cisco IOSÝ. La conservation de signalisation d'appel est prise en charge dans la plus défunte version de logiciel 15.2.3T de Cisco IOS.

Remarque: Le pour en savoir plus, se rapportent à des caractéristiques de Protocol-indépendant de Logiciel Cisco Unified Border Element et installent le guide de configuration, la version de Cisco IOS 15.2M&T.

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant d'essayer cette configuration :

  • Connaissance de base de la façon configurer et utiliser la Voix de Cisco IOS

  • Connaissance de base de la façon configurer et utiliser le CUBE

  • Connaissance de base de la façon dont la Haute disponibilité de HSRP travaille aux Plateformes générales de routeur

Les exigences de base pour installer la Redondance de case-à-case d'ISR G2 de CUBE incluent :

  • Deux ISR identique G2s équipés du permis de module de technologie UC (SL-29-UC-K9 ou SL-39-UC-K9) installé, mémoire de la DRACHME 1G, et la version de logiciel 15.1.2T ou ultérieures de Cisco IOS

  • Les deux Routeurs doivent être physiquement placés sur le même LAN Ethernet.

  • La configuration de CUBE des deux Routeurs est identique et doit être manuellement copiée d'un routeur sur l'autre.

  • Un routeur est indiqué le routeur actif de HSRP, le deuxième est le standby. Il y a de légères différences dans la configuration de HSRP entre les Routeurs actifs et de réserve.

  • Écoulements d'appel SIP-SIP

Composants utilisés

Les informations dans ce document sont basées sur une version logicielle minimale du CUBE 8.5 (Cisco IOS version 15.1.2T), mise en application sur une génération 2 (ISR G2) de routeur de service intégré de gamme Cisco 2900 ou 3900.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

la Redondance de Case-à-case exige deux Plateformes identiques d'ISR G2 : un configuré comme Active, l'autre comme standby. Le HSRP est configuré sur les interfaces physiques pour constituer un groupe de HSRP.

S'il y a une panne de type Heartbeat quand le routeur actif descend, le deuxième routeur de réserve assure les adresses de Routage IP du premier routeur et continue à expédier les mêmes paquets de RTP qui ont été précédemment conduits au premier routeur.

Les flots de RTP des appels établis sont checkpointed entre les Routeurs actifs et de réserve par l'intermédiaire du protocole de HSRP. Par conséquent les flux multimédias des appels établis sont préservés au-dessus du Basculement de HSRP de l'Active aux Routeurs de réserve. Des appels dans un état transitoire (les appels qui ne sont pas établis encore, ou sont en cours d'être modifié avec une fonction de transfert ou d'attente) au moment de Basculement sont déconnectés. En outre, aucun appel utilisant des services DSP tels que le transcodage n'est préservé.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

La configuration de HSRP de CUBE suit une commande spécifique des étapes, qui inclut :

  1. Redondance de CUBE et de CUBE en enable

  2. HSRP d'enable

  3. Configurez le transport de transmission de HSRP

  4. Configurez le HSRP sur les interfaces

  5. Configurez les hsrp timers

  6. Configurez le temporisateur d'inactivité de medias

  7. Configurez le SIP liant à l'adresse de HSRP

  8. Rechargez les Routeurs

  9. Commutateurs logiciels reliés par point à l'adresse virtuelle de HSRP de CUBE

Rechargez les les deux les Routeurs après qu'étapes 1-5 soient terminées. Une recharge est exigée seulement quand le HSRP est configuré pour la première fois sur un routeur.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour obtenir plus d'informations sur les commandes utilisées dans cette section.

Diagramme du réseau

Ce diagramme affiche la topologie d'une paire d'Active/Standby de Routeurs d'ISR G2 utilisés dans un déploiement de joncteur réseau de SIP entre Cisco Unified Communications Manager (CUCM) et un joncteur réseau de SIP de fournisseur de services (fournisseur de services) pour l'accès PSTN.

http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-01.gif

Étape 1 : Redondance de CUBE et de CUBE en enable

CUBE en enable sur les deux Routeurs :

voice service voip 
  mode border-element
  allow-connections sip to sip

Activez la Redondance de CUBE et appelez la prise de point de contrôle sur les deux Routeurs :

voice service voip 
  redundancy

Étape 2 : HSRP d'enable

Activez les structures de redondance de routeur sur les deux Routeurs, où :

  • schéma ? schéma de cheminement d'état de Redondance

  • standby ? schéma de cheminement (HSRP) d'état de réserve d'enable

  • SB ? le nom de groupe de veille de HSRP

redundancy inter-device
  scheme standby SB

Étape 3 : Configurez le transport de transmission de HSRP

Configurez le transport de transmission d'Inter-périphérique de HSRP comme suit :

Configuration active :

ipc zone default
  association 1
    no shutdown
    protocol sctp
      local-port 5000
        local-ip 10.10.24.14
      remote-port 5000
        remote-ip 10.10.24.13

Configuration de réserve :

ipc zone default
  association 1
   no shutdown
   protocol sctp
     local-port 5000
       local-ip 10.10.24.13
     remote-port 5000
       remote-ip 10.10.24.14

Remarque: Quittez de la demande de « gens du pays-sctp » pour configurer les paramètres distants de SCTP comme suit :

XFR-2(config)#ipc zone default
XFR-2(config-ipczone)#association 1
XFR-2(config-ipczone-assoc)#protocol sctp 
XFR-2(config-ipc-protocol-sctp)#no sh
XFR-2(config-ipczone-assoc)#protocol sctp
XFR-2(config-ipc-protocol-sctp)#local-port 5000
XFR-2(config-ipc-local-sctp)#local-ip 10.10.24.13
XFR-2(config-ipc-local-sctp)#exit
XFR-2(config-ipc-protocol-sctp)#remote-port 5000
XFR-2(config-ipc-remote-sctp)#remote-ip 10.10.24.14
XFR-2(config-ipc-remote-sctp)#end

Ce sont l'explication des champs utilisés dans cette configuration :

  • ipc zone default ? Configure le protocole de communication d'Inter-périphérique (IPC) et écrit le mode de configuration de zone IPC. Utilisez cette commande d'initier la liaison de communication entre les périphériques actifs et de réserve.

  • association 1 ? Configure une association entre les deux périphériques et écrit le mode de configuration d'association IPC. Sous ceci, configurez les détails de l'association tels que le protocole de transport, le port local, l'adresse IP locale, le port distant et l'adresse IP distante. Les id valides d'association s'étendent de 1 à 255. Il n'y a aucun id par défaut d'association.

  • aucun arrêt ? Redémarre une association handicapée et son protocole de transport associé. Pour toutes les modifications aux paramètres de protocole de transport, cette association doit être arrêt.

  • sctp de protocole ? Configure le Protocole SCTP (Stream Control Transmission Protocol) comme protocole de transport pour cette association et active le mode de configuration de protocole de SCTP.

  • port_num de local-port ? Définit le numéro de port local de SCTP pour l'utiliser pour communiquer avec le pair redondant.

  • ip_addr gens du pays-IP ? Définit l'adresse IP du routeur local pour l'utiliser pour communiquer avec le pair redondant. L'adresse IP locale doit apparier l'adresse IP distante sur le routeur redondant.

  • port_num de remote-port ? Définit le numéro de port distant de SCTP pour l'utiliser pour communiquer avec le pair redondant.

  • ip_addr distant-IP ? Définit l'adresse IP distante du routeur de pair utilisé pour communiquer avec le périphérique local. Toutes les adresses IP distantes doivent indiquer le même périphérique.

Remarque: Le local-port et la remote-port doivent être placés à 5000 sur les Routeurs actifs et de réserve.

Étape 4 : Configurez le HSRP sur les interfaces

Configurez le transport de transmission d'Inter-périphérique de HSRP comme suit :

Configuration active

interface GigabitEthernet0/0
  ip address 10.10.25.14 255.255.255.0
  duplex auto
  keepalive
  speed auto
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 10.10.25.1
  standby 0 preempt
  standby 0 priority 50
  standby 0 track 2 decrement 10 
  standby 0 name SB
     bfd interval 500 min_rx 500 multiplier 3
!
interface GigabitEthernet0/1
  ip address 10.10.24.14 255.255.255.0
  duplex auto
  speed auto
  media-type rj45
  standby delay minimum 30 reload 60
  standby version 2
  standby 6 ip 10.10.24.1
  standby 6 priority 50
  standby 6 track 1 decrement 10
     bfd interval 500 min_rx 500 multiplier 3

Configuration de réserve

interface GigabitEthernet0/0
  ip address 10.10.25.13 255.255.255.0
  duplex auto
  speed auto
  keepalive
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 10.10.25.1
  standby 0 preempt
  standby 0 priority 50
  standby 0 name SB
		standby 0 track 2 decrement 10
     bfd interval 500 min_rx 500 multiplier 3
!
interface GigabitEthernet0/1
  ip address 10.10.24.13 255.255.255.0
  duplex auto
  speed auto
  media-type rj45
  standby delay minimum 30 reload 60
  standby version 2
  standby 6 ip 10.10.24.1
  standby 6 priority 50
		standby 6 preempt		  standby 6 track 1 decrement 10
     bfd interval 500 min_rx 500 multiplier 3

C'est une explication des champs utilisés dans cette configuration :

  • 0/6 ? Définit le nombre de groupe de veille.

  • keepalive ? Permet à la keepalive pour que le HSRP surveille des événements haut/bas.

  • retard de réserve ? Retarde l'initialisation de HSRP jusqu'à ce que l'interface physique soit en hausse.

  • IP de réserve x ? Définit l'adresse IP virtuelle d'ipv4 partagée entre les périphériques actifs et de réserve. Ce commandes enables le HSRP sur l'interface.

  • le standby X acquièrent ? Permet au routeur pour devenir le routeur actif quand la priorité est supérieur à tous autres Routeurs Hsrp-configurés dans le groupe de secours immédiat. Si vous n'utilisez pas la commande de standby preempt dans la configuration pour un routeur, ce routeur ne devient pas le routeur actif, même si la priorité est supérieur à tous autres Routeurs.

  • priorité de réserve x ? Définit la priorité de secours immédiat utilisée en choisissant le routeur actif. Il s'étend de 1 à 255 où 1 dénote la priorité la plus basse et 255 le plus prioritaire.

    Remarque: Dans les cas où le standby priority est identique, le périphérique avec l'adresse IP plus élevée assume le rôle du routeur actif.

  • nom du standby X ? Définit le nom du groupe de veille qui apparie le schéma défini dans l'étape 2 (« SB "). Pour des groupes HSRP multiples, le même standby name est utilisé en tant que seulement un schéma de réserve est autorisé dans les configurations.

  • décrément 10 de la piste 1 du standby 6 ? Définit le cheminement prioritaire. Pour plus d'informations sur le suivi d'interface, a cliquez ici.

  • le multiplicateur 3 du min_rx 500 de l'intervalle 500 de bfd ? définit la détection bidirectionnelle d'expédition.

Pour éviter des conditions de compétitivité quand les amorçages d'un routeur se lèvent et une interface est soulevée pour établir le contact (« bonjour ") entre les Routeurs actifs et de réserve, il est également recommandé pour configurer ce qui suit :

interface GigabitEthernet0/0
  standby delay minimum 30 reload 60

Pour plus d'informations sur cette commande, a cliquez ici.

Étape 5 : Configurez les hsrp timers

Il y a deux importants hsrp timers :

  • Minuteur Hello : L'intervalle entre les messages successifs de hsrp hello d'un routeur donné. Ce temporisateur peut être configuré en quelques secondes ou les millisecondes sous le HSRP relient. La valeur par défaut est de 3 secondes.

  • Temporisateur d'attente : L'intervalle entre la réception d'un message Hello et la présomption que le routeur émetteur a manqué. Cette fois peut être configurée en quelques secondes ou les millisecondes sous le HSRP relient. La valeur par défaut est de 8 secondes.

Dans les configurations dans l'étape 4, les hsrp hello et les temporisateurs d'attente sont placés à leurs valeurs par défaut. Par conséquent, ils n'apparaissent pas explicitement dans les configurations. Les valeurs recommandées pour bonjour/temporisateurs d'attente sont les valeurs par défaut.

Remarque: Si vous utilisez des valeurs autres que par défaut, vous devez configurer chaque routeur des valeurs pour utiliser même d'intervalle Hello et d'attente temporisateur.

Des temporisateurs bonjour et d'attente peuvent être configurés sous l'interface de HSRP utilisant le CLI suivant :

Router(config-if)#standby 0 timers ?
  <1-254>  Hello interval in seconds
  msec     Specify hello interval in milliseconds

Router (config-if)#standby 0 timers 2 ?
  <3-255>  Hold time in seconds
  msec     Specify hold interval in milliseconds
Router(config-if)#standby 0 timers 2 msec 40

Dans la configuration précédente, le minuteur Hello est placé à 2 secondes et au temporisateur d'attente à 40 millisecondes.

Remarque: Vous pouvez diminuer les paramètres du temporisateur pour accélérer le Basculement ou la préemption. Cependant, éviter a augmenté l'état de réserve inutile d'utiliser-et CPU s'agitant, elle est recommandée de ne pas placer le minuteur Hello à moins de 1 seconde, et le temporisateur d'attente à moins de 4 secondes.

Étape 6 : Configurez le temporisateur d'inactivité de medias

Le temporisateur d'inactivité de medias permet aux paires de routeur d'Active/Standby de surveiller et déconnecter des appels si aucun paquet de Protocole RTP (Real-Time Protocol) n'est reçu au cours d'un délai prévu configurable.

Quand des paquets de RTP pour un appel ne sont pas reçus par le routeur d'Active/Standby, le temporisateur d'inactivité de medias de SIP libère la session. Ceci est utilisé pour garder contre toutes les sessions interrompues qui pourraient avoir résulté du Basculement au cas où un débranchement d'appel normal ferait pas clair l'appel.

La même durée pour le temporisateur d'inactivité de medias devrait être configurée sur les deux Routeurs. La valeur par défaut est de 28 secondes. Ce temporisateur est configuré comme suit :

ip rtcp report interval 3000
gateway
  media-inactivity-criteria all
  timer receive-rtp 86400
  timer receive-rtcp 5

Étape 7 : Configurez le SIP liant à l'adresse de HSRP

Configurez la Messagerie de SIP de CUBE pour utiliser l'adresse virtuelle de HSRP dans la Messagerie de SIP.

dial-peer voice 100 voip
  description to-SIP
  voice-class sip bind control source-interface GigabitEthernet0/0
  voice-class sip bind media source-interface GigabitEthernet0/0  
!
dial-peer voice 200 voip
  description to-CUCM
  voice-class sip bind control source-interface GigabitEthernet0/1
  voice-class sip bind media source-interface GigabitEthernet0/1

Une fois que le HSRP est configuré sous l'interface physique et la commande de grippage a été émise, les appels à l'adresse IP physique échoueront. C'est parce que le socket de écoute de SIP est maintenant lié à l'adresse IP virtuelle mais les paquets de signalisation utilisent l'adresse IP physique, et ne peut pas donc être manipulé.

Étape 8 : Rechargez les Routeurs

Une fois que toutes les configurations ci-dessus ont été terminées, la sortie d'exposition de Redondance est comme suit :

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_INIT
  Pending Scheme: Standby (Will not take effect until next reload)
      Pending Groupname: b2bha
  Scheme: <NOT CONFIGURED>
  Peer present: UNKNOWN
  Security: Not configured

Lors de recharger le routeur la configuration de HSRP est activée comme suit :

Routeur actif

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_ACT
  Scheme: Standby
      Groupname: b2bha Group State: Active
  Peer present: RF_INTERDEV_PEER_COMM
  Security: Not configured

Routeur de secours

CUBE_XFR#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_STDBY
  Scheme: Standby
      Groupname: b2bha Group State: Standby
  Peer present: RF_INTERDEV_PEER_COMM
  Security: Not configured

Étape 9 : Commutateurs logiciels reliés par point à l'adresse virtuelle de HSRP de CUBE

Le CUCM, l'IP-PBX, le proxy SIP ou les ordinateurs monocarte de fournisseur de services ou les commutateurs logiciels de fournisseur de services qui conduisent des appels POUR CUBER doivent utiliser l'adresse virtuelle de HSRP dans leur Messagerie de SIP. Des messages SIP aux adresses IP physiques de CUBE ne sont pas traités avec une configuration de HSRP.

Pleines configurations d'échantillon pour la Redondance Double-reliée de HSRP de CUBE

Voici les configurations d'échantillon complètes pour les Routeurs actifs et de réserve de CUBE. Dans ces configurations, les temporisateurs de hsrp hello et d'attente utilisent leurs valeurs par défaut de 3 et 8 secondes respectivement, et ne sont pas affichés explicitement dans la sortie CLI.

Configuration de routeur actif

ipc zone default
  association 1
    no shutdown
    protocol sctp
      local-port 5000
        local-ip 10.10.24.14
      remote-port 5000
        remote-ip 10.10.24.13
!
voice service voip
  mode border-element
  allow-connections sip to sip
  redundancy
!
redundancy inter-device
  scheme standby SB
!
redundancy
!
interface GigabitEthernet0/0
  ip address 10.10.25.14 255.255.255.0
  duplex auto
  keepalive
  speed auto
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 10.10.25.1
   standby 0 preempt
  standby 0 priority 50
  standby 0 track 2 decrement 10 
  standby 0 name SB
     bfd interval 500 min_rx 500 multiplier 3
!
interface GigabitEthernet0/1
  ip address 10.10.24.14 255.255.255.0
  duplex auto
  speed auto
  media-type rj45
  standby delay minimum 30 reload 60
  standby version 2
  standby 6 ip 10.10.24.1
  standby 6 priority 50
  standby 6 track 1 decrement 10
     bfd interval 500 min_rx 500 multiplier 3
!
ip rtcp report interval 3000
!
track 1 interface GigabitEthernet0/0 line-protocol 
!
track 2 interface GigabitEthernet0/1 line-protocol  
!
dial-peer voice 100 voip
  description to-SIP
  destination-pattern 9T
  session protocol sipv2
  session target ipv4:x.x.x.x
  voice-class sip bind control source-interface GigabitEthernet0/0
  voice-class sip bind media source-interface GigabitEthernet0/0  
!
dial-peer voice 200 voip
  description to-CUCM
  destination-pattern 555....
  session protocol sipv2
  session target ipv4:y.y.y.y
  voice-class sip bind control source-interface GigabitEthernet0/1
  voice-class sip bind media source-interface GigabitEthernet0/1
!
gateway 
  media-inactivity-criteria all
  timer receive-rtcp 5
  timer receive-rtp 1200

Configuration de routeur de réserve

ipc zone default
  association 1
    no shutdown
    protocol sctp
      local-port 5000
        local-ip 10.10.24.13
      remote-port 5000
        remote-ip 10.10.24.14
!
voice service voip
  mode border-element
  allow-connections sip to sip
  redundancy
!
redundancy inter-device
  scheme standby SB
!
redundancy
!
interface GigabitEthernet0/0
  ip address 10.10.25.13 255.255.255.0
  duplex auto
  keepalive
  speed auto
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 10.10.25.1
  standby 0 preempt
  standby 0 priority 50
  standby 0 name SB
		standby 0 track 2 decrement 10
     bfd interval 500 min_rx 500 multiplier 3
!
interface GigabitEthernet0/1
  ip address 10.10.24.13 255.255.255.0
  duplex auto
  speed auto
  media-type rj45
  standby delay minimum 30 reload 60
  standby version 2
  standby 6 ip 10.10.24.1
  standby 6 priority 50
		standby 6 preempt
  standby 6 track 1 decrement 10
     bfd interval 500 min_rx 500 multiplier 3
!
ip rtcp report interval 3000
!
track 1 interface GigabitEthernet0/0 line-protocol 
!
track 2 interface GigabitEthernet0/1 line-protocol  
!
dial-peer voice 100 voip
  description to-SIP
  destination-pattern 9T
  session protocol sipv2
  session target ipv4:x.x.x.x
  voice-class sip bind control source-interface GigabitEthernet0/0
  voice-class sip bind media source-interface GigabitEthernet0/0  
!
dial-peer voice 200 voip
  description to-CUCM
  destination-pattern 555....
  session protocol sipv2
  session target ipv4:y.y.y.y
  voice-class sip bind control source-interface GigabitEthernet0/1
  voice-class sip bind media source-interface GigabitEthernet0/1
!
gateway 
  media-inactivity-criteria all
  timer receive-rtcp 5
  timer receive-rtp 1200

Pleine configuration d'échantillon pour la Redondance Simple-reliée de HSRP de CUBE

Tandis qu'un CUBE double-relié est la configuration la plus commune, particulièrement pour des connexions de jonction de SIP de fournisseur de services, il est également possible de configurer la Redondance de case-à-case de HSRP de CUBE avec un déploiement simple-relié de CUBE comme donné dans cette section.

Configuration de routeur actif

ipc zone default
  association 1
    no shutdown
    protocol sctp
      local-port 5000
       local-ip 1.2.175.8
     remote-port 5000
       remote-ip 1.2.175.12
!
voice service voip
  mode border-element
  allow-connections sip to sip
  redundancy
  sip
    bind control source-interface GigabitEthernet0/0
    bind media source-interface GigabitEthernet0/0
!
redundancy inter-device
 scheme standby SB
!
redundancy
!
interface GigabitEthernet0/0
  ip address 1.2.175.8 255.255.0.0
  duplex auto
  speed auto
  keepalive
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 1.2.175.100
 standby 0 preempt
  standby 0 priority 50
  standby 0 name SB
  standby 0 track 1 decrement 10
  bfd interval 500 min_rx 500 multiplier 3
!
ip rtcp report interval 3000 
!
dial-peer voice 5 voip
  description to-SIP-application
  destination-pattern 9T
  session protocol sipv2
  session target ipv4:x.x.x.x
!
dial-peer voice 9 voip
  description to-CUCM
  destination-pattern 555....
  session protocol sipv2
  session target ipv4:y.y.y.y
!
gateway 
 media-inactivity-criteria all
 timer receive-rtcp 5
 timer receive-rtp 1200

Configuration de routeur de réserve

ipc zone default
  association 1
    no shutdown
    protocol sctp
      local-port 5000
       local-ip 1.2.175.12
     remote-port 5000
       remote-ip 1.2.175.8
!
voice service voip
  mode border-element
  allow-connections sip to sip
  redundancy
  sip
    bind control source-interface GigabitEthernet0/0
    bind media source-interface GigabitEthernet0/0
!
redundancy inter-device
 scheme standby SB
!
redundancy
!
interface GigabitEthernet0/0
  ip address 1.2.175.12 255.255.0.0
  duplex auto
  speed auto
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 1.2.175.100
  standby 0 priority 50
		standby 0 preempt
  standby 0 name SB
  standby 0 track 1 decrement 10
  bfd interval 500 min_rx 500 multiplier 3
!
ip rtcp report interval 3000 
!
dial-peer voice 5 voip
  description to-SIP-application
  destination-pattern 9T
  session protocol sipv2
  session target ipv4:x.x.x.x
!
dial-peer voice 9 voip
  description to-CUCM
  destination-pattern 555....
  session protocol sipv2
  session target ipv4:y.y.y.y
!
gateway 
 media-inactivity-criteria all
 timer receive-rtcp 5
 timer receive-rtp 1200

Retirer des configurations ha

Terminez-vous ces étapes afin de retirer une configuration précédemment écrite de HSRP d'un routeur de CUBE :

  1. Retirez la configuration de Redondance de niveau application.

    Router(config)#voice service voip 
    Router(config-voice service voip)#no redundancy
  2. Retirez le schéma de réserve configuré sous le mode de configuration d'inter-périphérique.

    Router(config)#redundancy inter-device 
    Router(config-red-interdevice)#no scheme standby b2bha
    % Redundancy interdevice scheme change will not take effect until 
    configuration is saved and device reloaded
  3. Sauvegardez les modifications de configuration à la mémoire et rechargez le routeur.

    Router(config)#write
    Router#reload
  4. Après que la recharge, émettent cette commande de vérifier que le HSRP a été désactivé :

    Router#show redundancy inter-device
    Redundancy inter-device state: RF_INTERDEV_STATE_INIT
      Scheme: <NOT CONFIGURED>
      Peer present: UNKNOWN
      Security: Not configured
    
  5. Désactivez l'association entre les deux périphériques et retirez la configuration de SCTP.

    Router(config)#ipc zone default
    Router(config-ipczone)#association 1
    Router(config-ipczone-assoc)#shutdown
    Router(config-ipczone-assoc)#no protocol sctp
    Router(config-ipczone-assoc)#no association 1
    Router(config-ipczone)#exit
    Router(config)#no ipc zone default
  6. Retirez la configuration de HSRP de l'interface à l'aide « non » des formes des commandes de HSRP.

    Router(config)#interface gigabitEthernet 0/0
    Router(config-if)#no standby 0 name
    Router(config-if)#no standby 0 priority 
    Router(config-if)#no standby 0 ip
  7. Save configuration changes.

    Router(config)#write

Notes en utilisation de caractéristique

  • Le routeur deux utilisé pour une paire de HSRP devrait être identique (pour assurer le même niveau de capacité de représentation et d'appel).

  • le support de configuration de Redondance de Case-à-case aux appels SIP-SIP circule, le transport de SIP peut être UDP-UDP ou UDP-TCP

  • Adressage d'ipv4 de support d'adresses virtuelles de HSRP seulement.

  • Le flux multimédia des appels établis est préservé au-dessus d'un Basculement, mais la signalisation n'est pas. Par conséquent, des appels préservés ne peuvent pas être modifiés (Attente/Reprise, transfert, conférence, etc.).

  • Des appels impliquant des services supplémentaires tels que le transcodage, le DTMF-interworking, la conversion RVI, SIP-TLS, de RSVP, STUN, RTP-SRTP, ou les caractéristiques de télécopie/modem ne sont pas préservés dans un Basculement.

  • Des flux vidéos ne sont pas préservés lors du basculement, bien que le flux audio puisse être préservé.

  • Des groupes HSRP multiples par routeur sont pris en charge, mais seulement un seul groupe de HSRP par interface physique.

  • Des adresses de bouclage avec le HSRP ne sont pas prises en charge, la commande de grippage de SIP doivent utiliser l'adresse IP virtuelle de HSRP.

  • La synchronisation de configuration entre le routeur actif et de réserve est manuelle, là n'est aucune automatisation. Des modifications de configuration doivent être apportées manuellement aux deux Routeurs.

Vérifiez

Employez le CLI ci-dessous pour vérifier la configuration de HSRP est correct et fonctionner.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Vérifiez l'état de Redondance

Vérifiez l'état de Redondance avec l'inter-périphérique de show redundancy et les commandes d'état de show redundancy. Ces commandes affichent les informations de redundancy inter-device telles que les états de redundancy inter-device.

Avant que la configuration d'inter-périphérique soit faite, la sortie d'exposition est comme suit :

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_PNC_NO_HSRP
Scheme: Standby
Groupname: b2bha Group State: Init
Protocol: <NOT CONFIGURED>

XFR-2#show redundancy states
my state = 3  -NEGOTIATION 
peer state = 1  -DISABLED 
Mode = Simplex
Unit ID = 0

Maintenance Mode = Disabled
Manual Swact = disabled (system is simplex (no peer unit))
Communications = Down      Reason: Simplex mode

client count = 14
client_notification_TMR = 30000 milliseconds
RF debug mask = 0x0

Après que la configuration d'inter-périphérique soit faite mais avant le routeur rechargé, la sortie d'exposition est comme suit :

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_INIT
Pending Scheme: Standby (Will not take effect until next reload)
Pending Groupname: b2bha
Scheme: <NOT CONFIGURED>
Peer present: UNKNOWN
Security: Not configured

Après le routeur rechargé, la sortie d'exposition est comme suit affichant l'état de « Init » :

CUBE_XFR#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_PNC_NO_HSRP
Scheme: Standby
Groupname: b2bha Group State: Init
Peer present: UNKNOWN
Security: Not configured

CUBE_XFR#show redundancy states 
my state = 3  -NEGOTIATION 
peer state = 13 -ACTIVE 
Mode = Duplex
Unit ID = 0

Maintenance Mode = Disabled
Manual Swact = disabled (this unit is still initializing)
Communications = Up

client count = 14
client_notification_TMR = 30000 milliseconds
RF debug mask = 0x0

Pendant un basculement, par exemple le routeur actif est vers le bas et tandis que le routeur de réserve commute à devenir l'Active, la sortie d'exposition est comme suit :

CUBE_XFR#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_ACT
Scheme: Standby
Groupname: b2bha Group State: Active
Peer present: RF_INTERDEV_PEER_NO_COMM
Security: Not configured

XFR-2#show redundancy states
my state = 13 -ACTIVE 
peer state = 1  -DISABLED 
Mode = Simplex
Unit ID = 0

Maintenance Mode = Disabled
Manual Swact = disabled (system is simplex (no peer unit))
Communications = Up

client count = 14
client_notification_TMR = 30000 milliseconds
RF debug mask = 0x0

Après le basculement, mais avant que les Routeurs aient permuté bonjour des messages d'état, la sortie d'exposition est comme suit :

CUBE_XFR#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_ACT
Scheme: Standby
Groupname: b2bha Group State: Active
Peer present: RF_INTERDEV_PEER_NO_COMM
Security: Not configured

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_HSRP_STDBY_PNC
Scheme: Standby
Groupname: b2bha Group State: Standby
Peer present: RF_INTERDEV_PEER_NO_COMM
Security: Not configured

Après que l'échange bonjour des messages d'état, la sortie d'exposition soit comme suit :

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_ACT
Scheme: Standby
Groupname: b2bha Group State: Active
Peer present: RF_INTERDEV_PEER_COMM
Security: Not configured
  
XFR-2#show redundancy states
my state = 13 -ACTIVE 
peer state = 8  -STANDBY HOT 
Mode = Duplex
Unit ID = 0

Maintenance Mode = Disabled
Manual Swact = disabled (peer unit not yet in terminal standby state)
Communications = Up

client count = 14
client_notification_TMR = 30000 milliseconds
RF debug mask = 0x0  
 
CUBE_XFR#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_STDBY
Scheme: Standby
Groupname: b2bha Group State: Standby
Peer present: RF_INTERDEV_PEER_COMM
Security: Not configured
        
CUBE_XFR#show redundancy states
my state = 8  -STANDBY HOT 
peer state = 13 -ACTIVE 
Mode = Duplex
Unit ID = 0

Maintenance Mode = Disabled
Manual Swact = cannot be initiated from this the standby unit
Communications = Up

client count = 14
client_notification_TMR = 30000 milliseconds
RF debug mask = 0x0

Vérifiez l'état de HSRP

Vérifiez l'état de HSRP avec la commande brief de show standby. Cette commande montre que la brève sortie sur le HSRP comprenant le HSRP relie, nombres de groupe de veille, priorités, adresses IP d'Active et de standby aussi bien qu'adresses IP virtuelles. La commande de show standby donne le plein, les informations détaillées.

Router1#show standby brief
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active     Standby      Virtual IP
Gi0/0       0    50    Active  local      9.13.25.134  9.13.25.22

Router2#show standby brief
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active       Standby  Virtual IP
Gi0/0       0    50    Standby 9.13.25.133  local    9.13.25.22

Vérifiez l'état d'appel après un basculement

La commande récapitulative facilement disponible de Voix d'exposition est utilisée de vérifier :

  • La prise de point de contrôle des faire appel au routeur de réserve après un basculement

  • Le compte de support-inactivité sur l'Active quand les appels sont terminés

  • Pour vérifier (par exemple, préservé) des appels indigènes et non-natifs quand les deux types d'appels sont présents

  • Pour identifier la présence du RTP coulé, ha, sessions SPI

Affichez la prise de point de contrôle des faire appel au routeur de réserve après un basculement

Dans cet exemple, 800 appels étaient checkpointed de l'Active au standby après le basculement.

CUBE_XFR#show voice high-availability summary
======== Voice HA DB INFO ========
Number of calls in HA DB: 0
Number of calls in HA sync pending DB: 0
Number of calls in HA preserved session DB: 0

-----------------------------
First a few entries in HA DB:
-----------------------------

---------------------------------------
First a few entries in Sync Pending DB:
---------------------------------------

----------------------------

======== Voice HA Process INFO ========
Active process current tick: 3100
Active process number of tick events pending: 0
Active process number of tick events processed: 0
voice service voip is  configured to have redundancy

======== Voice HA RF INFO ========
Voice HA RF Client Name: VOIP RF CLIENT
Voice HA RF Client ID: 1345
My current rf state STANDBY HOT
Peer current rf state ACTIVE
Voice HA Standby is not available.
System has not experienced switchover.

======== Voice HA CF INFO ========
Voice HA CF Client Name: CHKPT VOIP SYMPHONY
Voice HA CF Client ID: 252
Voice HA CF Client Status: Peer NOT READY; TP flow ON.

======== Voice HA COUNTERS ========
Total number of checkpoint requests sent (Active): 0
Total number of checkpoint requested received (Standby): 971
Total CREATE received on Standby: 800
Total MODIFY received on Standby: 0
Total DELETE received on Standby: 800
Media Inactivity event count: 0

Checkpoint CREATE overflow: 0
Checkpoint MODIFY overflow: 0
Checkpoint DELETE overflow: 0
HA DB elememnt pool overrun count: 0
HA DB aux element pool overrun count: 0
HA DB insertion failure count: 0
HA DB deletion failure count: 0
Tick event pool overrun count: 0
Tick event queue overrun count: 0
Checkpoint send failure count: 0
Checkpoint get buffer failure count: 0

Affichez le compte de support-inactivité sur l'Active quand les appels sont terminés

Dans cet exemple, 800 appels sont effacés par le temporisateur de support-inactivité.

XFR-2#show voice high-availability summary
======== Voice HA DB INFO ========
Number of calls in HA DB: 0
Number of calls in HA sync pending DB: 0
Number of calls in HA preserved session DB: 0

-----------------------------
First a few entries in HA DB:
-----------------------------

---------------------------------------
First a few entries in Sync Pending DB:
---------------------------------------

----------------------------

======== Voice HA Process INFO ========
Active process current tick: 4213
Active process number of tick events pending: 0
Active process number of tick events processed: 0
voice service voip is  configured to have redundancy

======== Voice HA RF INFO ========
Voice HA RF Client Name: VOIP RF CLIENT
Voice HA RF Client ID: 1345
My current rf state ACTIVE
Peer current rf state STANDBY HOT
Voice HA Active and Standby are in sync.
System has experienced switchover.

======== Voice HA CF INFO ========
Voice HA CF Client Name: CHKPT VOIP SYMPHONY
Voice HA CF Client ID: 252
Voice HA CF Client Status: Peer READY; TP flow ON.

======== Voice HA COUNTERS ========
Total number of checkpoint requests sent (Active): 971
Total number of checkpoint requested received (Standby): 800
Total CREATE received on Standby: 800
Total MODIFY received on Standby: 0
Total DELETE received on Standby: 0
Media Inactivity event count: 800

Checkpoint CREATE overflow: 0
Checkpoint MODIFY overflow: 0
Checkpoint DELETE overflow: 0
HA DB elememnt pool overrun count: 0
HA DB aux element pool overrun count: 0
HA DB insertion failure count: 0
HA DB deletion failure count: 0
Tick event pool overrun count: 0
Tick event queue overrun count: 0
Checkpoint send failure count: 0
   Checkpoint get buffer failure count: 0

Pour vérifier des appels (préservés) indigènes et non-natifs quand chacun des deux sont présents

Les nombres de faire appel au système sont affichés comme suit :

  • Nombre total d'appels = « nombre d'appels dans le DB ha » + un « nombre d'appels dans le DB en attendant de sync ha ». C'est 100 + 50 = 150 dans l'exemple de sortie ci-dessous.

  • Le nombre total de préserver (non-natif) appelle = « nombre d'appels dans le DB de session préservé par ha ». C'est 70 dans l'exemple de sortie ci-dessous.

  • Le nombre total d'appels d'indigène (installation d'appels puisque le Basculement et donc non préservé au-dessus du Basculement) est la différence dans les deux nombres précédents. Dans cet exemple, il est 150 ? 70 = 80.

XFR-2#show voice high-availability summary
======== Voice HA DB INFO ========
Number of calls in HA DB: 100
Number of calls in HA sync pending DB: 50
Number of calls in HA preserved session DB: 70

Pour identifier la présence du RTP coulé, ha, sessions SPI

Le nombre total d'appels (non-natifs) préservés effacés par l'inactivité de medias est = « total CREATE reçue EFFACEMENT total en état d'alerte » ? « reçu en état d'alerte » comme sortie au-dessous des expositions. Comparez ce nombre « au compte d'opérations d'inactivité de medias » aussi bien que le nombre d'événements de medias vers le bas affichés par la sortie de la commande de stats de fpi de voip d'exposition.

XFR-2#show voice high-availability summary
======== Voice HA DB INFO ========
Number of calls in HA DB: 0
Number of calls in HA sync pending DB: 0
Number of calls in HA preserved session DB: 0

======== Voice HA COUNTERS ========
Total number of checkpoint requests sent (Active): 971
Total number of checkpoint requested received (Standby): 800
Total CREATE received on Standby: 800
Total MODIFY received on Standby: 0
Total DELETE received on Standby: 0
Media Inactivity event count: 800

Vérifiez les attaches d'adresse IP de SIP

L'état obligatoire de SIP d'affichages de commande de show sip-ua status.

Router1#show sip-ua status
SIP User Agent Status
SIP User Agent for UDP : ENABLED
SIP User Agent for TCP : ENABLED

SIP User Agent for TLS over TCP : ENABLED
SIP User Agent bind status(signaling): DISABLED
SIP User Agent bind status(media): DISABLED
Snapshot of SIP listen sockets : 2
            Local Address      Listen Port  Secure Listen Port
=============================  ===========  ==================
 10.10.25.14                     5060         5061
 10.10.24.14                     5060         5061
SIP early-media for 180 responses with SDP: ENABLED
SIP max-forwards : 70

Vérifiez l'utilisation CPU de courant

La commande d'historique CPU de processus d'exposition est utilisée de vérifier le pourcentage d'utilisation du processeur à intervalles réguliers.

Vérifiez l'utilisation du processeur avant d'exécuter un basculement et procédez à un Basculement obligatoire seulement quand l'utilisation du processeur est moins de 70%. La commande triée par CPU de processus d'exposition peut également être émise à plusieurs reprises pour avoir une idée de l'utilisation du processeur pour un processus particulier.

Vérifiez que des appels sont traités pendant un basculement

La commande de show sip-ua statistics est utilisée de vérifier des baisses d'appel pendant le basculement en vérifiant le nombre de messages BYE. Des appels en cours pendant le basculement sont abandonnés. Seulement des appels établis sont préservés.

La commande de traçabilité d'interface d'exposition est utilisée de vérifier la confirmation de chemin de medias pendant un basculement.

Router#show interfaces g0/0 accounting
GigabitEthernet0/0 
Protocol  Pkts In   Chars In   Pkts Out   Chars Out
Other     1         58         6          360
IP        406       178841     201        16394
ARP       569       34292      0          0
CDP       116       31672      22         7304

IP « paquets dans » et « paquets de contrôle » pare ? ceux-ci devraient augmenter à un débit raisonnable. Par exemple, si vous n'utilisez G.711 le packetization 20ms et aucun VAD, vous devriez voir les compteurs de paquet augmenter environ de 50 chaque seconde.

Forcer un Basculement manuel pour le test

la Redondance de Case-à-case utilisant le HSRP prend en charge un basculement de support-avec état des appels qui signifie que le support (RTP) des appels n'est préservé, mais pas la signalisation. Par conséquent, seulement des appels dans l'état active (chemin de medias en mode de connexion de « sendrecv ») sont préservés alors que les appels dans l'état transitoire (état, chemin inactifs de medias pas en mode de connexion de « sendrecv ») ne sont pas préservés pendant le basculement.

Les basculements se produisant dans de vrais environnements où il y a des appels constants d'une combinaison dans le transiteur (établissement d'appel ou étant modifié) et l'état établi, là seront toujours un certain nombre d'appels abandonnés pendant un Basculement. Le nombre total d'appels abandonnés prévus peut être estimé par : (0.3 + attente-temporisateur de HSRP) * CPS.

Remplissez la procédure ci-dessous pour forcer un basculement manuel pour vérifier que la configuration et l'exécution est correcte.

Pour assurer le basculement obligatoire sans heurt, faites ce qui suit :

  • Surveillez l'utilisation du processeur % sur les paires d'Active/Standby. L'Active aura une utilisation du processeur plus élevée comme il traite activement les appels, alors que le standby affichera 0 utilisations du processeur car c'est inactif jusqu'à ce qu'un basculement se produise.

  • Assurez qu'un basculement manuel est exécuté quand l'utilisation du processeur du routeur actif est pas plus de 70%. Tous les basculements mènent à un pic dans l'utilisation du processeur.

  • Utilisez les commandes récapitulatives facilement disponibles de Voix de connexion et d'exposition de voip rtp d'exposition de veiller des appels existants pour synched à travers les paires de routeur d'Active/Standby.

Un basculement de HSRP fait participer autrefois le routeur actif rechargeant, alors que le routeur autrefois de réserve succède et devient le nouveau routeur actif traitant de nouveaux appels et mettant à jour les flux multimédias pour des appels préservés jusqu'à ce qu'ils soient complets. Le nouveau routeur actif restera en tant que routeur actif jusqu'à ce qu'un autre basculement se produise.

Des basculements (obligatoires) manuels peuvent être réalisés dans des n'importe quelles de ces manières :

  • Initiez-le par le CLI « force de commutateur-activité de Redondance » sur le routeur actif.

  • Recharge du routeur actif

  • Reprise dure du routeur actif

  • Retirez l'interface de HSRP ou le câble d'alimentation du routeur actif.

  • Arrêt l'interface de HSRP du routeur actif.

  • Un changement de n'importe quel paramètre de l'interface de HSRP du routeur d'Active/Standby sans arrêter l'association sous le mode IPC mène à un routeur rechargé. Par conséquent, l'interface doit être arrêt avant que toutes les modifications soient apportées, à moins que vous employiez ceci comme déclencheur pour forcer un basculement.

La commande de show voip rtp connections affiche le nombre de connexions actives sur les Routeurs actifs et de réserve après un basculement.

La commande brief de show call active voice n'affiche aucune sortie sur le routeur de réserve après un basculement parce que les informations de signalisation ne sont pas checkpointed.

Étapes pour exécuter et vérifier un basculement simple

Procédez comme suit :

  1. Configurez la Redondance de case-à-case de HSRP selon la section de configurer dans ce document.

  2. Rechargez et maintenez les deux Routeurs dans le rommon.

  3. Routeur de l'amorce une. Après qu'il soit, émettez la commande d'état de show redundancy et assurez-vous qu'elle affiche mon état comme état d'Active et de pair comme handicapés. Ceci peut prendre un moment après amorce.

    XFR-2#show redundancy states
    my state = 13 -ACTIVE 
    peer state = 1  -DISABLED
  4. Initialisez le deuxième routeur. Après qu'il soit, émettez la commande d'état de show redundancy de s'assurer qu'elle affiche mon état en tant qu'état Standby-chaud et de pair en tant qu'Active.

    CUBE_XFR#show redundancy states
    my state = 8  -STANDBY HOT 
    peer state = 13 -ACTIVE
  5. Commencez un ou plusieurs appels à travers le système. Émettez le résumé facilement disponible de Voix d'exposition et affichez que des commandes de connexion de voip rtp sur les Routeurs actifs et de réserve de s'assurer les appels sont haut et checkpointed.

  6. Basculement de test en rechargeant le routeur actif. Si vous utilisez un téléphone pour faire des appels, vous pouvez écouter le téléphone pour s'assurer que chemin de support est préservé. Si vous utilisez l'équipement de test, vous pouvez employer les affichages de paquet pour déterminer si les medias pour les appels circulent :

    Router#show interfaces g0/0 accounting
    GigabitEthernet0/0 
    Protocol  Pkts In   Chars In   Pkts Out   Chars Out
    Other     1         58         6          360
    IP        406       178841     201        16394
    ARP       569       34292      0          0
    CDP       116       31672      22         7304
  7. Inactivité de milieux d'essai : Arrêtez l'appel. Connexion de voip rtp d'exposition de répétition. Après l'échéance du temporisateur de support-inactivité, il ne devrait y avoir plus de connexions actives de RTP. Vous pouvez également vérifier ceci par l'intermédiaire de la commande récapitulative facilement disponible de Voix d'exposition et rechercher :

    Router#show voice high-availability summary | include media
    Media Inactivity event count: 1

    Le compte d'opérations d'inactivité de medias devrait afficher 1.

Captures d'écran pour vérifier un appel unique préservé au-dessus d'un Basculement

L'affichage avant le Basculement :

  • Routeur actif (#01)

    http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-02.gif

  • Routeur de réserve (#02)

    http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-03.gif

Rechargement du routeur actif (#01) pour forcer un Basculement :

http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-04.gif

Le routeur de réserve (#02) succède en tant que nouvel Active, l'appel est préservé (standby = nouvel Active) :

http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-05.gif

Précédemment les recharges du routeur actif (#01) en tant que nouveau routeur de réserve, et l'appel est préservées en nouvel état d'alerte.

  • Nouveau routeur (#01) de réserve :

    http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-06.gif

  • Nouveau routeur (#02) actif :

    http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-07.gif

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Remarque: Référez-vous aux informations importantes sur les commandes de débogage avant d'utiliser les commandes de débogage.

Ceux-ci affichent et les commandes de débogage sont utiles pendant le dépannage de la Redondance de case-à-case :

show redundancy state
show redundancy inter-device
show standby brief
show standby internal
show sip-ua status
show sip-ua statistics
show voice high-availability summary
show voip rtp connection | include connection
show arp
debug voip ccapi all
debug voip ccapi error
debug voip rtp session
debug voip rtcp session
debug voip rtp error
debug voip rtcp error
debug voice high-availability all
debug voice high-availability error
debug ccsip info
debug ccsip messages
debug ccsip media
debug ccsip error
debug standby terse

Remarque: N'activez pas l'un grand nombre met au point sur un système portant un grand volume du trafic d'appel actif.

Remarque: Sur chaque basculement, après le routeur rechargé, met au point doit être réactivé sur le nouveau routeur de réserve.

Chaque routeur dans un groupe de HSRP participe au protocole en mettant en application un ordinateur d'état simple. Tous les Routeurs commencent dans l'état initial.

  1. Initiale : C'est l'état commençant et indique que le HSRP ne s'exécute pas. Cet état est écrit par l'intermédiaire d'une modification de configuration ou quand une interface d'abord est soulevée.

  2. Apprenez : Le routeur n'a pas déterminé l'adresse IP virtuelle, et a pas encore vu un message Hello authentifié à partir du routeur actif. Dans cet état le routeur attend toujours d'avoir des nouvelles du routeur actif.

  3. Écoutez : Le routeur connaît l'adresse IP virtuelle, mais est ni le routeur actif ou de réserve. Il détecte à l'oreille les messages Hello de ces routeurs.

  4. Parlez : Le routeur envoie des messages Hello périodiques et participe activement à l'élection du routeur actif et/ou de réserve. Un routeur ne peut pas entrer dans l'état Speak à moins qu'il ait l'adresse IP virtuelle.

  5. Standby : Le routeur est un candidat pour devenir le prochain routeur actif et envoie des messages Hello périodiques. À l'exclusion des conditions passagères, il DOIT y avoir tout au plus un routeur dans le groupe dans l'état de réserve.

  6. Active : Le routeur est actuellement des transferts des paquets qui sont envoyés à l'adresse IP virtuelle MAC/du groupe. Le routeur envoie des messages Hello périodiques. Sans compter que des conditions passagères, il DOIT y avoir tout au plus un routeur dans l'état active dans le groupe.

Conseil de dépannage : Pourquoi y a-t-il deux routeurs actifs ?

Ceci se produit quand les deux Routeurs ne voient pas le HSRP Hellos entre eux.

  • Vérifiez si chaque routeur peut cingler l'autre adresse de l'interface IP. Sinon, alors les transmissions entre les Routeurs est en baisse.

  • Utilisez la commande de debug standby de voir si les Routeurs sont envoyants et/ou recevants des paquets de hsrp hello. Si le pair envoie Hellos, mais eux ne sont pas reçus alors vérifient des commandes d'interface ou de show controller d'exposition de voir si l'interface écoute l'adresse de multidiffusion de HSRP.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 112095