IP : IP version 6

IPv6 au-dessus de MPLS VPN

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

IP version 6 (IPv6) est une nouvelle version d'IP conçue pour remplacer IP version 4 (IPv4), qui est largement déployée et utilisée partout dans le monde actuellement. Les avantages de l'IPv6 sont principalement un résultat de sa espace adresse beaucoup plus grande, qui est exigée pour faire face à l'extension d'Internet et à l'explosion des appliances Internet-capables.

Un IPv6 VPN est connecté au-dessus d'une interface ou d'une sous-interface d'IPv6 au circuit principal de fournisseur de services (fournisseur de services) par l'intermédiaire d'un routeur PE. Le site peut être ipv4 et IPv6 capable. Chaque IPv6 VPN a son propre espace d'adressage qui signifie qu'une adresse donnée dénote des autres systèmes dans différents VPN. Ceci est réalisé par l'intermédiaire d'un nouvel address-family, de l'address-family VPN-IPv6 ou VPNv6, qui ajoute un moteur de distinction de route au début (RD) à l'adresse IP.

Une adresse VPNv6 est un début de la quantité 24-byte avec un RD 8-byte et une fin avec un ipv6 addres 16-byte. Quand un site est ipv4 et IPv6 capables, le même RD peut être utilisé pour la publicité des deux adresses d'ipv4 et d'IPv6.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Remarque: Pour le support de Virtual Routing and Forwarding d'IPv6 (VRF) sur quelques Plateformes (par exemple, le routeur de gamme 7600), vous devrez configurer le mls ipv6 vrf en configuration globale.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

ipv6-over-mpls-vpn-01.gif

Configuration de VRF

Routeur CE1
ipv6 unicast-routing
ipv6 cef
!
interface Serial 0/0
 ipv6 address 2001:1::1/124
!
interface Loopback 0
 ipv6 address ABCD::1/128
!

Routeur CE2
ipv6 unicast-routing
ipv6 cef
!
interface Serial 0/0
 ipv6 address 2001:2::1/124
!
interface Loopback 0
 ipv6 address ABCD::2/128
!

Routeur 6VPE1
ipv6 unicast-routing
ipv6 cef
!
mpls label protocol ldp
mpls ldp router-id Loopback 0 force

!
!----- The VRF is defined with vrf definition <vrf-name> and is made IPv6 aware
!

vrf definition CUST1
 rd 1:1
 !
 address-family ipv6
 route-target import 1:1
 route-target export 1:1
 exit-address-family
!
interface Serial 0/0
 vrf forwarding CUST1
 ipv6 address 2001:1::2/124
!
interface Loopback 0
 ip address 1.1.1.1 255.255.255.255
 ip ospf 1 area 0
!

Routeur 6VPE2
ipv6 unicast-routing
ipv6 cef
!
mpls label protocol ldp
mpls ldp router-id Loopback 0 force
!
vrf definition CUST1
 rd 1:1
 !
 address-family ipv6
 route-target import 1:1
 route-target export 1:1
 exit-address-family
!
interface Serial 0/0
 vrf forwarding CUST1
 ipv6 address 2001:2::2/124
!
interface Loopback 0
 ip address 3.3.3.3 255.255.255.255
 ip ospf 1 area 0
!

Configuration multiprotocole BGP (MP-BGP)

L'address-family vpnv6 est configuré sur les Routeurs 6VPE pour la connexion d'iBGP. Il y a une connexion d'eBGP entre le 6VPE et les Routeurs de la CE.

Routeur CE1
router bgp 65101
 neighbor 2001:1::2 remote-as 100
 !
 address-family ipv6
 neighbor 2001:1::2 activate
 network ABCD::1/128
 exit-address-family
!

Routeur 6VPE1
router bgp 100
 neighbor 3.3.3.3 remote-as 100
 neighbor 3.3.3.3 update-source Loopback 0
 !
 address-family vpnv6
 neighbor 3.3.3.3 activate
 exit-address-family
 !
 address-family ipv6 vrf CUST1
 neighbor 2001:1::1 remote-as 65101
 neighbor 2001:1::1 activate
 redistribute connected
 exit-address-family
!

Routeur CE2
router bgp 65102
 neighbor 2001:2::2 remote-as 100
 !
 address-family ipv6
 neighbor 2001:2::2 activate
 network ABCD::2/128
 exit-address-family
!

Routeur 6VPE2
router bgp 100
 neighbor 1.1.1.1 remote-as 100
 neighbor 1.1.1.1 update-source Loopback 0
 !
 address-family vpnv6
 neighbor 1.1.1.1 activate
 exit-address-family
 !
 address-family ipv6 vrf CUST1
 neighbor 2001:2::1 remote-as 65102
 neighbor 2001:2::1 activate
 redistribute connected
 exit-address-family
!

Vérifiez

Adresse de bgp next-hop

6VPE2# 
show bgp vpnv6 unicast vrf CUST1
BGP table version is 30, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1:1 (default for vrf CUST1)
*>i2001:1::/124     ::FFFF:1.1.1.1           0    100      0 ?
*> 2001:2::/124     ::                       0         32768 ?
*>iABCD::1/128      ::FFFF:1.1.1.1           0    100      0 65101 i
*> ABCD::2/128      2001:2::1                0             0 65102 i

6VPE2# show bgp vpnv6 unicast vrf CUST1 ABCD::1/128
BGP routing table entry for [1:1]ABCD::1/128, version 30
Paths: (1 available, best #1, table CUST1)
  Advertised to update-groups:
        2
  65101
    ::FFFF:1.1.1.1 (metric 3) from 1.1.1.1 (1.1.1.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      Extended Community: RT:1:1
      mpls labels in/out nolabel/20

Imposition d'étiquette

Quand un routeur 6VPE reçoit un paquet d'un routeur CE relié, il des consultations l'adresse de destination d'IPv6 de paquet dans la table de VRF correspondant à ce routeur CE. Ceci lui permet de trouver une artère VPNv6. L'artère VPNv6 a des mpls label associés (étiquette supérieure) et une étiquette associée de bgp next-hop (étiquette inférieure).

6VPE2# show bgp vpnv6 unicast vrf CUST1 ABCD::1/128
BGP routing table entry for [1:1]ABCD::1/128, version 30
Paths: (1 available, best #1, table CUST1)
  Advertised to update-groups:
        2
  65101
    ::FFFF:1.1.1.1 (metric 3) from 1.1.1.1 (1.1.1.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      Extended Community: RT:1:1
      mpls labels in/out nolabel/20

6VPE2# 
show ip cef 1.1.1.1
1.1.1.1/32
  nexthop 10.2.2.1 FastEthernet2/0 label 16

6VPE2# 
show ipv6 cef vrf CUST1 ABCD::1/128 detail
ABCD::1/128, epoch 0
  recursive via 1.1.1.1 label 20
    nexthop 10.2.2.1 FastEthernet2/0 label 16

Préfixes d'IPv6 annoncés aux Routeurs de la CE

La commande BGP de show ipv6 route affiche les routes BGP apprises par le routeur.

CE1# show ipv6 route bgp
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
B   2001:2::/124 [20/0]
     via FE80::C808:17FF:FE2C:0, Serial0/0
B   ABCD::2/128 [20/0]
     via FE80::C808:17FF:FE2C:0, Serial0/0
CE2# show ipv6 route bgp
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
B   2001:1::/124 [20/0]
     via FE80::C809:14FF:FEB4:0, Serial0/0
B   ABCD::1/128 [20/0]
     via FE80::C809:14FF:FEB4:0, Serial0/0

Dépannez

Utilisez cette section pour dépanner votre configuration.

Négociation de capacité BGP

Le MP-BGP est utilisé pour annoncer les artères de l'IPv6 VPN dans le MP_REACH NLRI.

Remarque: L'identifiant de famille d'adresse/identifiant ultérieur de famille d'adresse (AFI/SAFI) utilisé est 2/128. Le vaule de AFI = 2 représente l'IPv6 et le vaule de SAFI = 128 représente VPNv6 étiqueté par MPLS.

debug ip bgp

21:10:10.387: BGP: 3.3.3.3 went from Active to OpenSent
21:10:10.391: BGP: 3.3.3.3 sending OPEN, version 4, my as: 100, holdtime 180
    seconds
21:10:10.395: BGP: 3.3.3.3 send message type 1, length (incl. header) 61
21:10:10.579: BGP: 3.3.3.3 rcv message type 1, length (excl. header) 42
21:10:10.579: BGP: 3.3.3.3 rcv OPEN, version 4, holdtime 180 seconds
21:10:10.583: BGP: 3.3.3.3 rcv OPEN w/ OPTION parameter len: 32
21:10:10.583: BGP: 3.3.3.3 rcvd OPEN w/ optional parameter type 2 (Capability)
    len 6
21:10:10.583: BGP: 3.3.3.3 OPEN has CAPABILITY code: 1, length 4
21:10:10.587: BGP: 3.3.3.3 OPEN has MP_EXT CAP for afi/safi: 1/1
21:10:10.587: BGP: 3.3.3.3 rcvd OPEN w/ optional parameter type 2 (Capability)
    len 6
21:10:10.587: BGP: 3.3.3.3 OPEN has CAPABILITY code: 1, length 4
21:10:10.587: BGP: 3.3.3.3 OPEN has MP_EXT CAP for afi/safi: 2/128
21:10:10.591: BGP: 3.3.3.3 rcvd OPEN w/ optional parameter type 2 (Capability)
    len 2
21:10:10.591: BGP: 3.3.3.3 OPEN has CAPABILITY code: 128, length 0
21:10:10.591: BGP: 3.3.3.3 OPEN has ROUTE-REFRESH capability(old) for all
    address-families
21:10:10.591: BGP: 3.3.3.3 rcvd OPEN w/ optional parameter type 2 (Capability)
    len 2
21:10:10.595: BGP: 3.3.3.3 OPEN has CAPABILITY code: 2, length 0
21:10:10.595: BGP: 3.3.3.3 OPEN has ROUTE-REFRESH capability(new) for all 
    address-families
21:10:10.595: BGP: 3.3.3.3 rcvd OPEN w/ optional parameter type 2 (Capability)
    len 6
21:10:10.595: BGP: 3.3.3.3 OPEN has CAPABILITY code: 65, length 4
21:10:10.599: BGP: 3.3.3.3 OPEN has 4-byte ASN CAP for: 100
BGP: 3.3.3.3 rcvd OPEN w/ remote AS 100, 4-byte remote AS 100
21:10:10.599: BGP: 3.3.3.3 went from OpenSent to OpenConfirm
21:10:10.603: BGP: 3.3.3.3 went from OpenConfirm to Established
21:10:10.603: %BGP-5-ADJCHANGE: neighbor 3.3.3.3 Up
21:10:11.547: %BGP-5-ADJCHANGE: neighbor 2001:1::1 vpn vrf CUST1 Up
6VPE1# show bgp vpnv6 unicast all neighbors
BGP neighbor is 3.3.3.3,  remote AS 100, internal link
  BGP version 4, remote router ID 3.3.3.3
  BGP state = Established, up for 00:05:32
  Last read 00:00:30, last write 00:00:20, hold time is 180, keepalive interval
      is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(new)
    New ASN Capability: advertised and received
    Address family IPv4 Unicast: advertised and received
    Address family VPNv6 Unicast: advertised and received

    !
    !---output omitted
    !

BGP neighbor is 2001:1::1,  vrf CUST1,  remote AS 65101, external link
  BGP version 4, remote router ID 10.210.0.1
  BGP state = Established, up for 00:05:54
  Last read 00:00:54, last write 00:00:43, hold time is 180, keepalive interval
      is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(new)
    New ASN Capability: advertised
    Address family IPv6 Unicast: advertised and received

    !
    !---output omitted
    !

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 112085