Routeurs : Routeurs à services intégrés de la gamme Cisco 3800

Exemple de configuration de client VPN AnyConnect (SSL) sur routeur IOS avec CCP

19 mars 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (29 février 2016) | Commentaires

Introduction

Ce document décrit comment installer un routeur de Cisco IOS® pour exécuter Secure Sockets Layer (SSL) VPN sur un bâton avec le Cisco AnyConnect VPN Client utilisant le Cisco Configuration Professional (CCP). Cette installation applique à un cas spécifique où AnyConnect sur le routeur est configuré avec la Segmentation de tunnel, et il permet l'accès sécurisé de client aux ressources de l'entreprise et fournit également l'accès à Internet sans garantie.

La technologie de VPN SSL ou de webvpn est prise en charge sur la plupart des Plateformes de routeur telles que la génération 1 de l'Integrated Services Router (ISR), la génération 2 (référez-vous les Produits ISR pour la liste de Produits ISR). Des clients sont informés se référer le guide de navigateur de caractéristique afin d'obtenir une liste complète de plates-formes Cisco IOS qui prennent en charge le client d'AnyConnect VPN (SSL) (ou toute autre technologie de caractéristique d'ailleurs). Ces informations sont disponibles dans le navigateur de caractéristique.

Le CCP est un outil de Gestion de périphériques basé sur GUI qui te permet pour configurer les Routeurs basés sur IOS d'accès de Cisco. Le CCP est installé sur un PC et simplifie le routeur, la Sécurité, les transmissions unifiées, la radio, le WAN, et les configurations LAN de base par basé sur GUI, des assistants conviviaux.

Contribué par Bratin Saha et Rahul Govindan, ingénieurs TAC Cisco.

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant d'essayer cette configuration :

  • Système d'exploitation approprié de client. Référez-vous les notes de mise à jour en AnyConnect pour les systèmes d'exploitation pris en charge.

  • Le navigateur Web avec la version 1.4 ou ultérieures du SUN JRE ou un ActiveX a contrôlé le programme de lecture

  • Privilèges administratifs locaux sur le client ;

  • Routeur Cisco IOS avec image Advanced Security -12.4(20)T (ou version ultérieure) ;

  • Version 1.3 ou ultérieures de Cisco Configuration Professional

Si le Cisco Configuration Professional n'est pas déjà chargé sur votre ordinateur, vous pouvez obtenir un exemplaire gratuit du logiciel et installer le fichier .exe (cisco-config-pro-k9-pkg-2_8-en.zip) du téléchargement logiciel. Pour obtenir des informations détaillées sur l’installation et la configuration de CCP, reportez-vous au Guide de démarrage rapide Cisco Configuration Professional.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Routeur de la gamme CISCO2811 de Cisco IOS avec la version de logiciel 15.1(4)M8

  • Version 2.8 CCP

  • Version du client de VPN SSL de Cisco AnyConnect pour Windows 3.1.05160

Les informations contenues dans ce document ont été créées à partir des périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Configurez

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

Tâches de préconfiguration

  1. Configurez le routeur pour le CCP.

    Les Routeurs avec le permis approprié de paquet de Sécurité ont déjà l'application CCP chargée dans l'éclair. Référez-vous au guide de démarrage rapide de Cisco Configuration Professional afin d'obtenir et configurer le logiciel.

  2. Téléchargez une copie du fichier Anyconnect VPN .pkg sur votre ordinateur de gestion.

Configurations

Dans cette section, vous êtes présenté avec les étapes nécessaires afin de configurer les caractéristiques décrites dans ce document. Cet exemple de configuration utilise l'assistant CCP afin d'activer l'exécution de l'Anyconnect VPN sur le routeur IOS.

Exécutez ces étapes afin de configurer Anyconnect VPN sur le routeur Cisco IOS :

  1. Installez le CCP et découvrez le routeur Cisco IOS.

  2. Installez et activez le logiciel Anyconnect VPN sur le routeur Cisco IOS.

  3. Configurez un contexte de VPN SSL et une passerelle de VPN SSL avec l'assistant CCP.

  4. Configurez la base de données utilisateur pour des utilisateurs d'Anyconnect VPN.

  5. Configurez l'AnyConnect Full Tunnel.

Chacune de ces étapes est décrite plus en détail dans les sections suivantes de ce document.

Étape 1 : Installez le CCP et découvrez le routeur Cisco IOS

  1. Cliquez sur l'état du routeur sur la fenêtre CCP afin de visualiser l'information sur le périphérique de routeur.



  2. Cliquez sur Configure afin de commencer la configuration.



Étape 2 : Installez et activez le logiciel Anyconnect VPN sur le routeur IOS

Terminez-vous ces étapes afin d'installer et activer le logiciel d'Anyconnect VPN sur le routeur IOS :

  1. Ouvrez l'application CCP, naviguez pour configurer > Sécurité, et puis cliquez sur le VPN.

  2. Développez SSLVPN, puis sélectionnez Packages.



    Assurez-vous que le permis de caractéristique de VPN SSL est installé sur le périphérique, autrement vous pourrait obtenir l'avertissement affiché dans l'image précédente. Référez-vous le lien de permis de caractéristique afin de visualiser la section d'informations de commande.

  3. Dans le logiciel client Cisco SSLVPN, cliquez sur Browse.

    La boîte de dialogue choisie d'emplacement de SVC apparaît.



  4. Spécifiez l'emplacement de l'image de Cisco AnyConnect VPN Client (choisissez l'un ou l'autre des deux options disponibles).

    • Si l'image de Cisco AnyConnect VPN Client est dans le flash du routeur, cliquez sur la boîte de dialogue de case d'option de système de fichiers de routeur, et le clic parcourent.





    • Si l'image de Cisco AnyConnect VPN Client n'est pas dans le flash du routeur, cliquez sur la ma boîte de dialogue de radio d'ordinateur, et le clic parcourent.


  5. Sélectionnez l'image de client que vous voulez pour installer et cliquer sur OK.

  6. Une fois que vous avez spécifié l’emplacement de l’image client, cliquez sur Install.

  7. Cliquez sur oui et cliquez sur OK alors.

  8. Une fois que l'image de client est avec succès installée, vous recevez le message de succès. Cliquez sur OK afin de continuer.

  9. Une fois qu'installé, visualisez les détails de module installé sous la Sécurité > le VPN > le VPN SSL > les modules.

Étape 3 : Configurez un contexte SSLVPN et la passerelle SSLVPN avec l'assistant CCP

Terminez-vous ces étapes afin de configurer un contexte de VPN SSL et la passerelle de VPN SSL :

  1. Accédez à Configure > Security > VPN, puis cliquez sur SSL VPN.

  2. Cliquez sur le gestionnaire de VPN SSL et puis cliquez sur l'onglet de VPN SSL de création.



  3. Suivez les demandes afin d'activer l'Authentification, autorisation et comptabilité (AAA) s'il n'est pas déjà activé.









  4. Vérifiez la création une nouvelle case d'option de VPN SSL et puis cliquez sur le lancement la tâche sélectionnée.

    La boîte de dialogue de l’Assistant VPN SSL s’affiche.



  5. Cliquez sur Next (Suivant).



    Remarque: Si le VPN SSL est configuré sous l'interface par laquelle Cisco CP est appelé, il pourrait entraîner Cisco CP au disconnet du routeur. Comme meilleure pratique, vous pouvez accéder au routeur Cisco IOS par l'intermédiaire du CCP de l'interface interne (dans cet exemple, 10.106.44.141) ou de n'importe quelle autre interface, alors que le VPN SSL est configuré sous l'interface externe FastEthernet0/0 (dans cet exemple, 10.105.130.149).





  6. Écrivez l'adresse IP de la nouvelle passerelle de VPN SSL et écrivez un nom unique pour ce contexte de VPN SSL.

    Vous pouvez créer différents contextes VPN SSL pour la même adresse IP (passerelle VPN SSL), cependant, chaque nom doit être unique. Cet exemple utilise l’adresse IP suivante : https://10.105.130.149/

  7. Cliquez sur Next, et continuez à la section suivante.

Étape 4 : Configurer la base de données utilisateur pour les utilisateurs d’Anyconnect VPN

Pour l’authentification, vous pouvez utiliser un serveur AAA, des utilisateurs locaux ou les deux. Cet exemple de configuration utilise les utilisateurs local-créés pour l'authentification.

Effectuez les étapes suivantes pour configurer la base de données utilisateur pour les utilisateurs d’Anyconnect VPN :

  1. Après que vous vous terminiez l'étape 3, cliquez sur localement en fonction la cette case d'option de routeur située dans la boîte de dialogue d'authentification de l'utilisateur d'assistant de VPN SSL.



    Cette boîte de dialogue vous permet d’ajouter des utilisateurs à la base de données locale.

  2. Cliquez sur Add et écrivez les informations utilisateur.



  3. Cliquez sur OK et ajoutez les utilisateurs supplémentaires selon les besoins.

  4. Après que vous ajoutiez les utilisateurs nécessaires, cliquez sur Next, et continuez à la section suivante.

Étape 5. Configurez le tunnel d'Anyconnect

Terminez-vous ces étapes afin de configurer le tunnel d'Anyconnect et le groupe d'adresses IP pour les utilisateurs :

  1. Puisqu'Anyconnect fournit l'accès direct aux ressources en intranet d'entreprise, la liste URL n'est pas nécessaire afin de configurer. Cliquez sur le bouton Next situé dans la boîte de dialogue Configure Intranet Websites.



  2. Vérifiez que la case Enable Full Tunnel est cochée.



  3. Créez un pool d’adresses IP pouvant être utilisé par les clients de ce contexte VPN SSL.

    Le groupe d'adresses doit correspondre aux adresses disponibles et routable sur votre intranet.

  4. Cliquez sur les ellipses () à côté du champ de groupe d'adresse IP, et choisissez créent un nouveau pool d'IP.

  5. Dans la boîte de dialogue Add IP Local Pool, saisissez un nom pour le pool (par exemple, nouveau), puis cliquez sur Add.



  6. Dans la boîte de dialogue de plage d'adresses IP d'ajouter, écrivez la plage de pool d'adresses pour les clients d'Anyconnect VPN et cliquez sur OK.

    Remarque: Avant version 12.4(20)T, le groupe d'IP address devrait être dans une série d'une interface directement connectée au routeur. Si vous voulez utiliser une plage différente de groupe, vous pouvez créer une adresse de bouclage associée avec votre nouveau groupe afin de répondre à cette exigence.



  7. Cliquez sur OK.

  8. Configure a avancé des options de tunnel, telles que la Segmentation de tunnel, les DN fendus, les paramètres de proxy du navigateur, et le Système de noms de domaine (DNS) et les serveurs de service de nom de Windows Internet (WINS).

    Remarque: Cisco recommande que vous configuriez au moins des DN et des serveurs WINS.



    Terminez-vous ces étapes afin de configurer des options avancées de tunnel, telles que la Segmentation de tunnel :

    1. Cliquez sur le bouton Advanced Tunnel Options (Options de tunnel avancées).

    2. Cliquez sur les DN et l'onglet de serveurs WINS et écrivez les adresses IP primaires pour les DN et les serveurs WINS.



    3. Cliquez sur l'onglet de Segmentation de tunnel afin de configurer la Segmentation de tunnel.



      La possibilité de transmettre du trafic sécurisé comme du trafic non sécurité sur la même interface est connue sous le nom de transmission tunnel partagée. Pour la transmission tunnel partagée, vous devez spécifier exactement quel est le trafic sécurisé ainsi que sa destination afin que seul le trafic spécifié accède au tunnel alors que le reste du trafic est transmis non chiffré sur le réseau public (Internet).

      Dans l'exemple, le tunnel partagé est configuré afin d'inclure le trafic.


  9. Après avoir configuré les options nécessaires, cliquez sur Next. Choisissez l'option d'interface de tunnel appropriée de VPN SSL et cliquez sur Next.



  10. Personnaliser la page SSL VPN Portal ou sélectionner les valeurs par défaut.

    L’option Customize SSL VPN Portal Page vous permet de personnaliser l’affichage de la page SSL VPN Portal pour vos clients.



  11. Après avoir personnalisé la page du portail VPN SSL, cliquez sur Next.

  12. Cliquez sur Finish (Terminer).



  13. Cliquez sur livrent afin de sauvegarder votre configuration et puis cliquer sur OK.

    L'assistant de VPN SSL soumet vos commandes au routeur.





Fondamentalement ce sont les commandes qui sont fournies du CCP au routeur :

AAA commands:

aaa new-model
aaa authorization exec default local
aaa authentication login default local
line vty 0 4
login authentication default
authorization exec default
exit

Remaining commands:

aaa authentication login ciscocp_vpn_xauth_ml_1 local
ip local pool IP_Pool 192.168.1.10 192.168.1.15
interface Virtual-Template1
exit
default interface Virtual-Template1
interface Virtual-Template1
no shutdown
ip unnumbered FastEthernet0/0
exit
webvpn gateway gateway_1
ip address 10.105.130.149 port 443
http-redirect port 80
inservice
ssl trustpoint TP-self-signed-1878971148
exit
webvpn context Test
aaa authentication list ciscocp_vpn_xauth_ml_1
gateway gateway_1
virtual-template 1
max-users 1000
inservice
secondary-color white
title-color #FF9900
text-color black
policy group policy_1
svc split include 10.106.44.0 255.255.255.0
svc keep-client-installed
functions svc-enabled
svc address-pool IP_Pool netmask 255.255.255.255
svc default-domain cisco.com
svc dns-server primary 10.106.44.10
svc wins-server primary 10.106.44.12
exit
default-group-policy policy_1
exit
! IP address / user account command
username user1 privilege 1 secret 0 *********

Remarque: Si vous recevez un message d'erreur, le permis de VPN SSL pourrait être incorrect.

Terminez-vous ces étapes afin de corriger une question de permis :

  1. Accédez à Configure > Security > VPN, puis cliquez sur SSL VPN.

  2. Cliquez sur le gestionnaire de VPN SSL et puis cliquez sur l'onglet de VPN SSL d'éditer dans le côté droit.



  3. Mettez en valeur votre contexte de création récente et cliquez sur le bouton d'éditer.



  4. Dans le champ « Maximum Number of users » (Nombre maximal d’utilisateurs), saisissez le nombre correct d’utilisateurs de votre licence.

  5. Cliquez sur OK, puis cliquez sur Deliver.

    Les commandes sont écrites au fichier de configuration.

Configuration CLI

CCP crée les configurations de ligne de commande suivantes :

Router#show running-config
Building configuration...

Current configuration : 3590 bytes
!
! Last configuration change at 06:30:34 UTC Sat Nov 29 2014
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication login ciscocp_vpn_xauth_ml_1 local
aaa authorization exec default local
!
!
!
!
!
aaa session-id common
!
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
!
!
multilink bundle-name authenticated
!
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-1878971148
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1878971148
 revocation-check none
 rsakeypair TP-self-signed-1878971148
!
!
crypto pki certificate chain TP-self-signed-1878971148
 certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31383738 39373131 3438301E 170D3134 31313239 30353537
  32355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 38373839
  37313134 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100C77D F135BBCA 8A84DE7D A3330085 3694EC3B 9BAE2F94 AF19CAEC 89A4AA6A
  DC098301 AC996CA7 BE1C6AB2 BF4745F4 911E9812 97BC1A1F 15D1AFD0 384878C6
  8781D8A7 3BFCFCFF 5626EF1A BCF73C78 B07E4587 710B6F18 B4E0017F 807606EA
  03E398B0 A2DE06B6 2D39B122 32D82E1B 7AE55554 63D8BDD6 222CF884 C9D5570D
  74BD0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 1455F1A2 00753895 04EB04BE 13273EEF D48D86C6 84301D06
  03551D0E 04160414 55F1A200 75389504 EB04BE13 273EEFD4 8D86C684 300D0609
  2A864886 F70D0101 05050003 81810013 B72A05AE E7816FB7 377FC3B3 8EE7D2AC
  9211B78D 8B6A604A DA7D571F 6E083B78 279F0EB1 95B5ADC8 79572616 53B52B90
  1BF1A39B 46F8C88C 3335F498 E2CF5ABC 5D942A23 7DE35239 04D509EF 88E60201
  8B111BD6 FE82E159 67E05A62 03BFBCA6 E99EA1CE DA52F66A 8CE502C1 B9FAA488
  8A5B022A 3003F718 E8E1C6CC 2EB03C
        quit
!
!
license udi pid CISCO2811 sn FHK1404F3X2
username username privilege 15 secret 5 $1$hPnV$zwQ6MMwLA7HUC/NJRCMyt1
username user1 secret 5 $1$X3Vu$h5/xHipon7Fym16G2SCrz1
!
redundancy
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address dhcp
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address dhcp
 duplex auto
 speed auto
!
interface Virtual-Template1
 ip unnumbered FastEthernet0/0
!
ip local pool IP_Pool 192.168.1.10 192.168.1.15
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
 transport input all
!
scheduler allocate 20000 1000
!
webvpn gateway gateway_1
 ip address 10.105.130.149 port 443
 http-redirect port 80
 ssl trustpoint TP-self-signed-1878971148
 inservice
 !
webvpn install svc flash:/webvpn/anyconnect-win-3.1.05160-k9.pkg sequence 1
 !
webvpn context Test
 secondary-color white
 title-color #FF9900
 text-color black
 ssl authenticate verify all
 !
 !
 policy group policy_1
   functions svc-enabled
   svc address-pool "IP_Pool" netmask 255.255.255.255
   svc default-domain "cisco.com"
   svc keep-client-installed
   svc split include 10.106.44.0 255.255.255.0
   svc dns-server primary 10.106.44.10
   svc wins-server primary 10.106.44.12
 virtual-template 1
 default-group-policy policy_1
 aaa authentication list ciscocp_vpn_xauth_ml_1
 gateway gateway_1
 inservice
!
end

Router#sh run int Virtual-Access2
Building configuration...

Current configuration : 104 bytes
!
interface Virtual-Access2
 description ***Internally created by SSLVPN context Test***
 mtu 1406
end

Établir la connexion AnyConnect VPN Client

Terminez-vous ces étapes afin d'établir une connexion VPN d'AnyConnect avec le routeur.

Remarque: Ajoutez un routeur à la liste des sites de confiance en Internet Explorer. Pour plus d’informations, reportez-vous à Ajout d’un appareil de sécurité/routeur à la liste des sites de confiance (IE).

  1. Écrivez l'URL ou l'adresse IP de l'interface de webvpn de routeur en votre navigateur Web dans le format comme affiché.

    https://<url>


    OU

    https://<IP address of the Router WebVPN interface>


  2. Saisissez votre nom d’utilisateur et votre mot de passe.



  3. Début de clic afin d'initier la connexion en tunnel d'Anyconnect VPN.



    Cette fenêtre apparaît avant que la connexion VPN SSL ne soit établie.



    Remarque: Le logiciel d'ActiveX doit être installé sur votre ordinateur avant que vous téléchargiez l'Anyconnect VPN.





  4. Une fois la connexion correctement établie, cliquez sur l’onglet Statistics (Statistiques).

    L’onglet Statistics (Statistiques) affiche des informations relatives à la connexion SSL.



    Les statistiques détaillent les informations statistiques de connexion détaillées par affichages de boîte de dialogue, qui incluent l'état du tunnel et le mode, la durée de la connexion, le nombre d'octets et les encadrent envoyé et reçu, les informations d'adresse, les informations de transport, et l'état d'estimation de posture de Cisco Secure Desktop. Le bouton Reset de cet onglet permet de réinitialiser les statistiques de transmission. Le bouton de stats d'exportation te permet pour exporter les statistiques en cours, l'interface, et la table de routage à un fichier texte. Le client AnyConnect vous invite à saisir un nom et à sélectionner un emplacement pour le fichier texte. Le nom par défaut est A nyConnect-ExportedStats.txt et l'emplacement par défaut est sur l'appareil de bureau.

  5. Vérifiez les détails d'artère (basés sur la configuration de tunnel partagé) sous l'onglet de détails d'artère.



  6. Dans la boîte de dialogue de Cisco AnyConnect VPN Client, cliquez sur environ l'onglet afin d'afficher les informations de version de Cisco AnyConnect VPN Client.



Vérifiez

Utilisez cette section pour confirmer que votre configuration fonctionne correctement.

Commandes

Remarque: L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Plusieurs commandes show sont associées au WebVPN. Vous pouvez exécuter ces commandes au CLI afin d'afficher des statistiques et d'autres informations. Pour obtenir des informations détaillées à propos des commandes show, reportez-vous à Vérification de la configuration de WebVPN.

affichez le contexte tout de session de webvnp

Router#show webvpn session context all
WebVPN context name: Test
Client_Login_Name  Client_IP_Address  No_of_Connections  Created  Last_Used
user1              10.106.42.10                1         00:01:22  00:00:01

test de contexte de l'utilisateur user1 de show webvpn session

Router#show webvpn session user user1 context Test detail
Session Type      : Full Tunnel
Client User-Agent : AnyConnect Windows 3.1.05160

Username          : user1                Num Connection : 1
Public IP         : 10.106.42.10         VRF Name       : None
Context           : Test                 Policy Group   : policy_1
Last-Used         : 00:00:00             Created        : *06:33:24.505 UTC Sat
Nov 29 2014
Session Timeout   : Disabled             Idle Timeout   : 2100
DNS primary serve : 10.106.44.10         WINS primary s : 10.106.44.12
DPD GW Timeout    : 300                  DPD CL Timeout : 300
Address Pool      : IP_Pool              MTU Size       : 1199
Rekey Time        : 3600                 Rekey Method   :
Lease Duration    : 43200
Tunnel IP         : 192.168.1.10         Netmask        : 255.255.255.255
Rx IP Packets     : 0                    Tx IP Packets  : 617
CSTP Started      : 00:01:22             Last-Received  : 00:00:00
CSTP DPD-Req sent : 0                    Virtual Access : 2
Msie-ProxyServer  : None                 Msie-PxyPolicy : Disabled
Msie-Exception    :
Split Include     : 10.106.44.0 255.255.255.0
Client Ports      : 60304

Detail Session Statistics for User:: user1
----------------------------------

CSTP Statistics::
Rx CSTP Frames    : 618                Tx CSTP Frames   : 0
Rx CSTP Bytes     : 46113              Tx CSTP Bytes    : 0
Rx CSTP Data Fr   : 617                Tx CSTP Data Fr  : 0
Rx CSTP CNTL Fr   : 1                  Tx CSTP CNTL Fr  : 0
Rx CSTP DPD Req   : 0                  Tx CSTP DPD Req  : 0
Rx CSTP DPD Res   : 0                  Tx CSTP DPD Res  : 0
Rx Addr Renew Req : 0                  Tx Address Renew : 0
Rx CDTP Frames    : 0                  Tx CDTP Frames   : 0
Rx CDTP Bytes     : 0                  Tx CDTP Bytes    : 0
Rx CDTP Data Fr   : 0                  Tx CDTP Data Fr  : 0
Rx CDTP CNTL Fr   : 0                  Tx CDTP CNTL Fr  : 0
Rx CDTP DPD Req   : 0                  Tx CSTP DPD Req  : 0
Rx CDTP DPD Res   : 0                  Tx CDTP DPD Res  : 0
Rx IP Packets     : 0                  Tx IP Packets    : 617
Rx IP Bytes       : 0                  Tx IP Bytes      : 41122

CEF Statistics::
Rx CSTP Data Fr   : 0                  Tx CSTP Data Fr  : 0
Rx CSTP Bytes     : 0                  Tx CSTP Bytes    : 0

show webvpn stats

Router#show webvpn stats
User session statistics:
    Active user sessions     : 1          AAA pending reqs         : 0
    Peak user sessions       : 1          Peak time                : 00:02:29
    Active user TCP conns    : 1          Terminated user sessions : 0
    Session alloc failures   : 0          Authentication failures  : 0
    VPN session timeout      : 0          VPN idle timeout         : 0
    User cleared VPN sessions: 0          Exceeded ctx user limit  : 0
    Exceeded total user limit: 0
    Client process rcvd pkts : 57         Server process rcvd pkts : 0
    Client process sent pkts : 8134       Server process sent pkts : 0
    Client CEF received pkts : 664        Server CEF received pkts : 0
    Client CEF rcv punt pkts : 29         Server CEF rcv punt pkts : 0
    Client CEF sent pkts     : 0          Server CEF sent pkts     : 0
    Client CEF sent punt pkts: 0          Server CEF sent punt pkts: 0

    SSLVPN appl bufs inuse   : 0          SSLVPN eng  bufs inuse   : 0
    Active server TCP conns  : 0

Mangling statistics:
    Relative urls            : 0          Absolute urls            : 0
    Non-http(s) absolute urls: 0          Non-standard path urls   : 0
    Interesting tags         : 0          Uninteresting tags       : 0
    Interesting attributes   : 0          Uninteresting attributes : 0
    Embedded script statement: 0          Embedded style statement : 0
    Inline scripts           : 0          Inline styles            : 0
    HTML comments            : 0          HTTP/1.0 requests        : 0
    HTTP/1.1 requests        : 3          Unknown HTTP version     : 0
    GET requests             : 3          POST requests            : 0
    CONNECT requests         : 0          Other request methods    : 0
    Through requests         : 0          Gateway requests         : 3
    Pipelined requests       : 0          Req with header size >1K : 0
    Processed req hdr bytes  : 844        Processed req body bytes : 0
    HTTP/1.0 responses       : 0          HTTP/1.1 responses       : 0
    HTML responses           : 0          CSS responses            : 0
    XML responses            : 0          JS responses             : 0
    Other content type resp  : 0          Chunked encoding resp    : 0
    Resp with encoded content: 0          Resp with content length : 0
    Close after response     : 0          Resp with header size >1K: 0
    Processed resp hdr size  : 0          Processed resp body bytes: 0
    Backend https response   : 0          Chunked encoding requests: 0

HTTP Authentication stats :
    Successful NTLM Auth     : 0          Failed NTLM Auth         : 0
    Successful Basic Auth    : 0          Failed Basic Auth        : 0
    Unsupported Auth         : 0          Unsup Basic HTTP Method  : 0
    NTLM srv kp alive disabld: 0          NTLM Negotiation Error   : 0
    Oversize NTLM Type3 cred : 0          Internal Error           : 0
    Num 401 responses        : 0          Num non-401 responses    : 0
    Num Basic forms served   : 0          Num NTLM forms served    : 0
    Num Basic Auth sent      : 0          Num NTLM Auth sent       : 0

CIFS statistics:
  SMB related Per Context:
    TCP VC's                 : 0          UDP VC's                 : 0
    Active VC's              : 0          Active Contexts          : 0
    Aborted Conns            : 0
  NetBIOS related Per Context:
    Name Queries             : 0          Name Replies             : 0
    NB DGM Requests          : 0          NB DGM Replies           : 0
    NB TCP Connect Fails     : 0          NB Name Resolution Fails : 0
  SMB related Global:
    Sessions in use          : 0          Mbufs in use             : 0
    Mbuf Chains in use       : 0          Active VC's              : 0
    Active Contexts          : 0          Browse Errors            : 0
    Empty Browser List       : 0          NetServEnum Errors       : 0
    Empty Server List        : 0          NBNS Config Errors       : 0
    NetShareEnum Errors      : 0
  HTTP related Per Context:
    Requests                 : 0          Request Bytes RX         : 0
    Request Packets RX       : 0          Response Bytes TX        : 0
    Response Packets TX      : 0          Active Connections       : 0
    Active CIFS context      : 0          Requests Dropped         : 0
  HTTP related Global:
    Server User data         : 0          CIFS User data           : 0
    Net Handles              : 0          Active CIFS context      : 0
    Authentication Fails     : 0          Operations Aborted       : 0
    Timers Expired           : 0          Pending Close            : 0
    Net Handles Pending SMB  : 0          File Open Fails          : 0
    Browse Network Ops       : 0          Browse Network Fails     : 0
    Browse Domain Ops        : 0          Browse Domain Fails      : 0
    Browse Server Ops        : 0          Browse Server Fails      : 0
    Browse Share Ops         : 0          Browse Share Fails       : 0
    Browse Dir Ops           : 0          Browse Network Fails     : 0
    File Read Ops            : 0          File Read Fails          : 0
    File Write Ops           : 0          File Write Fails         : 0
    Folder Create Ops        : 0          Folder Create Fails      : 0
    File Delete Ops          : 0          File Delete Fails        : 0
    File Rename Ops          : 0          File Rename Fails        : 0
    URL List Access OK       : 0          URL List Access Fails    : 0

Socket statistics:
    Sockets in use           : 1          Sock Usr Blocks in use   : 1
    Sock Data Buffers in use : 0          Sock Buf desc in use     : 0
    Select timers in use     : 1          Sock Select Timeouts     : 0
    Sock Tx Blocked          : 150        Sock Tx Unblocked        : 150
    Sock Rx Blocked          : 0          Sock Rx Unblocked        : 0
    Sock UDP Connects        : 0          Sock UDP Disconnects     : 0
    Sock Premature Close     : 0          Sock Pipe Errors         : 13
    Sock Select Timeout Errs : 0

Smart Tunnel statistics:
  Client                                Server
    proc pkts                : 0          proc pkts                 : 0
    proc bytes               : 0          proc bytes                : 0
    cef  pkts                : 0          cef  pkts                 : 0
    cef  bytes               : 0          cef  bytes                : 0

Port Forward statistics:
  Client                                Server
    proc pkts                : 0          proc pkts                 : 0
    proc bytes               : 0          proc bytes                : 0
    cef pkts                 : 0          cef pkts                  : 0
    cef bytes                : 0          cef bytes                 : 0

WEBVPN Citrix statistics:

               Server                   Client
  Packets in  : 0                        0
  Packets out : 0                        0
  Bytes in    : 0                        0
  Bytes out   : 0                        0

ACL statistics:
    Permit web request       : 0          Deny web request         : 0
    Permit cifs request      : 0          Deny cifs request        : 0
    Permit without ACL       : 0          Deny without match ACL   : 0
    Permit with match ACL    : 0          Deny with match ACL      : 0

Single Sign On statistics:
    Auth Requests            : 0          Pending Auth Requests    : 0
    Successful Requests      : 0          Failed Requests          : 0
    Retranmissions           : 0          DNS Errors               : 0
    Connection Errors        : 0          Request Timeouts         : 0
    Unknown Responses        : 0

URL-rewrite splitter statistics:
    Direct access request    : 0          Redirect request         : 0
    Internal request         : 0

Tunnel Statistics:
    Active connections       : 1
    Peak connections         : 1          Peak time                : 00:01:44
    Connect succeed          : 2          Connect failed           : 0
    Reconnect succeed        : 1          Reconnect failed         : 0
    DPD timeout              : 0
  Client
    in  CSTP frames          : 671        in  CSTP control         : 1
    in  CSTP data            : 670        in  CSTP bytes           : 50002
    out CSTP frames          : 0          out CSTP control         : 0
    out CSTP data            : 0          out CSTP bytes           : 0
    in  CDTP frames          : 0          in  CDTP control         : 0
    in  CDTP data            : 0          in  CDTP bytes           : 0
    out CDTP frames          : 0          out CDTP control         : 0
    out CDTP data            : 0          out CDTP bytes           : 0
    cef in  CSTP data frames : 0          cef in  CSTP data bytes  : 0
    cef out CSTP data frames : 0          cef out CSTP data bytes  : 0
    cef in  CDTP data frames : 0          cef in  CDTP data bytes  : 0
    cef out CDTP data frames : 0          cef out CDTP data bytes  : 0
  Server
    In  IP pkts              : 0          In  IP bytes             : 0
    Out IP pkts              : 670        Out IP bytes             : 44587

Dans le CCP, choisissez la surveillance > la Sécurité > l'état VPN > le VPN SSL (tous les contextes) afin de visualiser les listes des utilisateurs en cours de VPN SSL dans le routeur.

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Dépannage des commandes

Plusieurs commandes clear sont associées à WebVPN. Pour obtenir des informations détaillées à propos de ces commandes, reportez-vous à Utilisation des commandes Clear WebVPN.

Plusieurs commandes debug sont associées à WebVPN. Pour obtenir des informations détaillées à propos de ces commandes, reportez-vous à Utilisation des commandes Debug WebVPN.

Remarque: L’utilisation des commandes debug peut avoir un impact négatif sur votre périphérique Cisco. Avant d'utiliser les commandes debug, référez-vous à la section Informations importantes sur les commandes Debug.

Informations connexes


Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Document ID: 110608