Commutateurs : Syst�me Cisco Catalyst 6500 Virtual Switching System 1440

Migration en mode autonome du commutateur Cisco Catalyst 6500 vers le système de commutation virtuelle de Cisco Catalyst 6500

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit des informations au sujet de la procédure pour migrer une gamme Cisco Catalyst 6500 autonome commutent à un Système de commutation virtuelle de Cisco Catalyst 6500.

Remarque: Ce document fournit les étapes communes qui sont exigées pour le transfert. Des étapes précises sont basées sur la configuration en cours de commutateur et peuvent varier légèrement de la procédure mentionnée.

Conditions préalables

Conditions requises

Cisco vous recommande de prendre connaissance des rubriques suivantes :

Composants utilisés

Les informations dans ce document sont basées sur le Commutateurs de la gamme Cisco Catalyst 6500 avec le superviseur VS-S720-10G-3C/XL qui exécute la version de logiciel 12.2(33)SXH1 ou ultérieures de Ý de Cisco IOS.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

Le système de commutation virtuelle (VSS) est une fonctionnalité nouvelle et novatrice des commutateurs de la gamme Cisco Catalyst 6500 qui permet le groupement de deux châssis physiques dans une entité logique simple. Cette technologie permet de nouvelles améliorations dans tous les domaines du déploiement sur les campus d'entreprises et les centres de traitement de données, et inclut haute disponibilité, évolutivité/performances, gestion et maintenance.

L'implémentation actuelle du VSS vous permet de fusionner deux commutateurs physiques de la gamme Cisco Catalyst 6500 en une entité gérée avec logique. L'illustration suivante est une représentation graphique du concept où deux châssis 6509 peuvent être gérés comme un seul châssis 18 emplacements une fois le VSS activé :

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration1.gif

Procédé de transfert

Matériel et support logiciel

Le VSS est une caractéristique de logiciel disponible seulement avec le Commutateurs de la gamme Cisco Catalyst 6500. Afin d'activer et configurer cette caractéristique, ceci est exigé :

Matériel VS-S720-10G-3C/XL

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration2.gif

Logiciel Logiciel Cisco IOS version 12.2(33)SXH1 ou plus tard

Châssis pris en charge par le Système de commutation virtuelle de Cisco

Numéro de modèle Description
WS-C6503-E Châssis du gamme E 3-slot
WS-C6504-E Châssis du gamme E 4-slot
WS-C6506 châssis 6-slot
WS-C6506-E Châssis du gamme E 6-slot
WS-C6509 châssis 9-slot
WS-C6509-E Châssis du gamme E 9-slot
WS-C6509-NEB-A châssis vertical de normes de bâtiment de l'équipement réseau 9-slot (NEB)
WS-C6509-V-E Châssis de verticale du gamme E 9-slot
WS-C6513 châssis 13-slot

Cette table donne une liste complète du châssis pris en charge avec la version initiale du Système de commutation virtuelle de Cisco. Le pour en savoir plus, se rapportent au Système de commutation virtuelle de gamme Cisco Catalyst 6500 (VSS) 1440.

Chemins de migration

Le tableau présente certains des chemins de migration possibles au VSS. Cette liste est seulement suggestive et non complète.

Première installation Mise à jour requise Installation finale
Deux Commutateurs de la gamme Cisco Catalyst 6500 avec des superviseurs WS-SUP720-3B.

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration3.gif

Mise à niveau matérielle - Mise à niveau de logiciel des superviseurs VS-S720-10G-3C/XL - Cisco IOS 12.2(33)SXH1 ou plus tard VSS

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration4.gif

Deux Commutateurs de la gamme Cisco Catalyst 6500 avec des superviseurs VS-S720-10G-3C/XL.

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration5.gif

Mise à niveau de logiciel - Cisco IOS 12.2(33)SXH1 ou plus tard VSS

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration4.gif

Aperçu de transfert

Configuration commune dans l'environnement autonome

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration6.gif

Caractéristiques ou protocoles qui fonctionnent entre le noyau de la couche 3 (L3) et la distribution L2/L3 :

  • Protocoles de Routage IP

  • Caractéristique multivoie des Ports canalisés L3 ou de l'EqualCost de Routage IP

Caractéristiques ou protocoles qui fonctionnent entre la distribution L2/L3 et la couche d'accès :

  • protocole STP

  • D'abord protocoles de routage de saut (FHRP)

  • Stratégies : QoS, ACL

  • Joncteurs réseau L2, VLAN, Ports canalisés

Transfert au VSS

C'est un processus multipas, et chaque étape est expliquée dans cette section.

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration7.gif

Étapes de transfert entre le noyau et la couche de distribution :

  • Configurant l'EtherChannel de MultiChassis (MEC)

  • Modifiant la configuration de Routage IP et retirant les commandes, qui sont plus exigées

Étapes de transfert entre la distribution et la couche d'accès :

  • Configurer MEC

  • Maintenant le Protocole Spanning Tree activé

  • Modifier des commandes FHRP

  • Stratégies en mouvement de QoS et d'ACL à MEC (s'il y a lieu)

  • Configuration en mouvement des joncteurs réseau L2 à MEC

Procédé pas à pas de transfert

Procédez comme suit :

  1. Dans l'installation autonome initiale, le trafic est généralement chargement-équilibré parmi des commutateurs de distribution utilisant partager de chargement VLAN et configuration de HSRP.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration8.gif

  2. Modifiez la configuration de HSRP et STP de sorte que Distribution-1 soit en activité pour tous les écoulements, et les périphériques voisins détectent cette modification et envoient tout le trafic à Distribution-1.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration9.gif

  3. Arrêtez les interfaces physiques de Distribution-2, de sorte qu'il soit isolé dans le réseau.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration10.gif

    .

    Une fois que le Distribution-2 est complètement retiré du réseau, il peut être converti en mode VSS sans perturber le trafic de production.

  4. Sinon précédemment installé, installez le nouveau superviseur (VS-SUP720-10G) et vérifiez l'état.

    Distribution-2#show module
    Mod Ports Card Type                              Model              Serial No.
    --- ----- -------------------------------------- ------------------ -----------
      5    5  Supervisor Engine 720 10GE (Active)    VS-S720-10G        SAD104707BB
      9   48  CEF 720 48 port 10/100/1000mb Ethernet WS-X6748-GE-TX     SAL1020NGY3
  5. Copiez le logiciel compatible de Cisco IOS VSS sur le sup-bootdisk :

    Distribution-2#copy ftp: sup-bootdisk:
    Address or name of remote host []? 172.16.85.150
    Source filename []? s72033-ipservices_wan_vz.122-33.SXH1.bin
    Destination filename [s72033-ipservices_wan_vz.122-33.SXH1.bin]?
    Accessing ftp://172.16.85.150/s72033-ipservices_wan_vz.122-33.SXH1.bin...
  6. Mettez à jour le bootvar pour charger le logiciel de Cisco IOS copié sur le sup-bootdisk :

    Distribution-2(config)#boot system flash sup-bootdisk:s72033-ipservices_wan_vz.122-33.SXH1.bin
    
    
  7. Pour le Distribution-2 commutez pour s'exécuter en mode VSS, une liaison de commutateur virtuelle (VSL) est exigé. Le lien en cours de Port canalisé entre Distribution-1 et Distribution-2 peut être utilisé pour former le VSL.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration11.gif

  8. Configurez les attributs virtuels de commutateur :

    1. Nombre virtuel de domaine de commutateur (seul dans le réseau)

    2. Nombre virtuel de commutateur (seul dans le domaine)

    3. Liaison de commutateur virtuelle (VSL)

    Distribution-2(config)#hostname VSS
    
    VSS(config)#switch virtual domain 100
    
    VSS(config-vs-domain)#switch 1
    
    
    !--- After conversion Distribution-2 will be noted 
    !--- as Switch 1 in VSS mode.
    
    VSS(config-vs-domain)# exit
    VSS(config)#interface port-channel 1
    VSS(config-if)#switch virtual link 1
    
    VSS(config-if)#interface TenG 5/4
    VSS(config-if)#channel-group 1 mode on
    VSS(config-if)#interface TenG 5/5
    VSS(config-if)#channel-group 1 mode on
    VSS(config-if)# ^Z
    VSS#
  9. Convertissez le commutateur Distribution-2 en mode VSS.

    Remarque: Émettez cette commande par l'intermédiaire de la console du commutateur :

    VSS#switch convert mode virtual
    
    This command will convert all interface
    names to naming convention "interface-type
    switch-number/slot/port",
    save the running config to startup-config and
    reload the switch.
    Do you want to proceed? [yes/no]: yes
    Converting interface names
    Building configuration...
    
    
    !--- At this point the switch will reboot
    
    
    
    !--- snippet of the console output
    
    System detected Virtual Switch configuration...
     Interface TenGigabitEthernet 1/5/4 is member of
    PortChannel 1
     Interface TenGigabitEthernet 1/5/5 is member of
    PortChannel 1
    
    !--- snippet of the console output
    
    00:00:23: %PFREDUN-6-ACTIVE: Initializing as ACTIVE
    processor for this switch
    
    !--- snippet of the console output
    
    00:00:28: %VSL_BRINGUP-6-MODULE_UP: VSL module in slot 5
    switch 1 brought up
    Initializing as Virtual Switch Active
    
  10. Vérifiez la conversion du commutateur Distribution-2 en mode VSS.

    VSS#show switch virtual role
    
    Switch  Switch Status  Preempt    Priority   Role     Session ID
            Number         Oper(Conf) Oper(Conf)          Local  Remote
    -------------------------------------------------------------------
    LOCAL    1     UP      FALSE(N)    110(110)  ACTIVE    0      0
    
    In dual-active recovery mode: No

    Le commutateur Distribution-2 est avec succès converti et fonctionne en mode VSS. des étapes de Pré-configuration peuvent également être exécutées après conversion du commutateur Distribution-1. Cependant, la pré-configuration aide à réduire la quantité de perte de paquets pendant le transfert.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration12.gif

  11. Terminez-vous ces étapes pour préconfigurer le commutateur 1 VSS :

    1. Configurez MEC utilisant des interfaces locales Switch-1. Des interfaces de Switch-2 (actuellement Distribution-1) peuvent être ajoutées à MEC après conversion de lui en mode VSS.

      • Configurez MEC.

      • Déplacez la configuration d'interface à MEC.

      • Déplacez QoS et stratégies d'ACL à MEC.

      Configuration initiale
      interface TenGigabitEthernet1/2/1
       ip address 192.168.4.2 255.255.255.0
      
      interface GigabitEthernet1/1/2
       switchport
       switchport trunk encapsulation dot1q
       switchport trunk allowed vlan 10,20
      Modifications de configuration
      
      !--- MEC to Core layer
      
      VSS(config)# int ten 1/2/1
      VSS(config-if)# no ip address
      VSS(config-if)# interface po20
      VSS(config-if)# ip address 192.168.4.2 255.255.255.0
      VSS(config-if)# no shut
      VSS(config-if)# interface ten1/2/1
      VSS(config-if)# channel-group 20 mode desirable
      
      
      !--- MEC to Access layer
      
      VSS(config-if)# interface po10
      VSS(config-if)# switchport
      VSS(config-if)# switchport trunk encapsulation dot1q
      VSS(config-if)# switchport trunk allowed vlan 10,20
      VSS(config-if)# no shut
      VSS(config-if)# interface gig1/1/2
      VSS(config-if)# switchport
      VSS(config-if)# channel-group 10 mode desirable
      Configurez les périphériques voisins pour faciliter le Port canalisé

      La connexion entre VSS Switch-1 et ses périphériques voisins sont en baisse à ce moment. Par conséquent, un Port canalisé est configuré sans trafic de intervention traversent Distribution-1.

      
      !--- In Core layer devices
      
      Core(config)# int gig 1/1
      Core(config-if)# no ip address
      Core(config-if)# int po20
      Core(config-if)# ip address 192.168.4.1 255.255.255.0
      Core(config-if)# no shut
      Core(config-if)# int gig 1/1
      Core(config-if)# channel-group 20 mode desirable
      
      !--- In Access layer devices
      
      Access(config)# int po10
      Access(config-if)# switchport
      Access(config-if)# switchport trunk encapsulation dot1q
      Access(config-if)# switchport trunk
      Access(config-if)# no shut
      Access(config-if)# int gig 1/1
      Access(config-if)# channel-group 10 mode desirable
    2. Dans un châssis actif et de réserve VSS, utilisez les châssis actifs brûler-dans l'adresse MAC et l'adresse IP VLAN. Le HSRP n'est plus exigé.

      • Déplacez les adresses IP virtuelles de HSRP aux interfaces VLAN.

      • Retirez la configuration de HSRP des interfaces VLAN.

      Configuration initiale
      interface Vlan10
       ip address 10.1.1.2 255.255.255.0
       standby 10 ip 10.1.1.1
       standby 10 priority 110
      !
      interface Vlan20
       ip address 20.1.1.2 255.255.255.0
       standby 20 ip 20.1.1.1
       standby 20 priority 110
      !
      Modifications de configuration
      VSS(config)# interface Vlan10
      VSS(config-if)# no standby 10 ip 10.1.1.1
      VSS(config-if)# no standby 10 priority 110
      VSS(config-if)# ip address 10.1.1.1 255.255.255.0
      VSS(config-if)# interface Vlan20
      VSS(config-if)# no standby 20 ip 20.1.1.1
      VSS(config-if)# no standby 20 priority 110
      VSS(config-if)# ip address 20.1.1.1 255.255.255.0

      Remarque: Les périphériques d'extrémité dirigeaient toujours leurs entrées d'ARP pour parafer l'adresse MAC de HSRP. Jusqu'à ce que ces entrées chronomètrent ou un autre ARP est envoyé pour mettre à jour leur cache, il y a une certaine perte de Connectivité.

    3. Activez la caractéristique NSF-SSO pour les protocoles de Routage IP utilisés. Le VSS simplifie la configuration de routage, ainsi certaines des déclarations de réseau ne sont plus exigées. Par conséquent, ils peuvent être retirés.

      VSS Switch-1
      VSS#show running-config | begin ospf
      router ospf 1
       log-adjacency-changes
       network 10.1.1.0 0.0.0.255 area 0
       network 20.1.1.0 0.0.0.255 area 0
       network 192.168.4.0 0.0.0.255 area 0
       network 192.168.5.0 0.0.0.255 area 0
      
      !--- rest of output elided
      
      
      
      !--- Previous L3 interfaces are merged as MEC, hence some
      routing statements are no longer required.
      
      
      VSS(config)# router ospf 1
      VSS(config-router)# nsf
      VSS(config-router)# no network 192.168.5.0 0.0.0.255 area 0
      Noyau
      Core#show running-config | begin ospf
      router ospf 1
       log-adjacency-changes
       network 192.168.4.0 0.0.0.255 area 0
       network 192.168.5.0 0.0.0.255 area 0
      
      !--- rest of output elided
      
      
      
      !--- Previous L3 interfaces are merged as MEC, hence some
      routing statements are no longer required.
      
      
      Core(config)# router ospf 1
      Core(config-router)# nsf
      Core(config-router)# no network 192.168.5.0 0.0.0.255 area 0
    4. Modifiez la configuration STP de sorte que VSS Switch-1 devienne la racine pour tous les VLAN.

  12. Vérifiez la configuration et la Connectivité VSS Switch-1.

    • Interfaces VSS Switch-1 d'enable.

    • Vérifiez la Connectivité L2 aux périphériques de couche d'accès.

    • Vérifiez la Connectivité L3 pour creuser des périphériques de couche.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration13.gif

  13. Après que la Connectivité VSS Switch-1 soit vérifiée, arrêtez les interfaces de Distribution-1 pour commuter le trafic plus d'au VSS.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration14.gif

  14. Répétez les étapes de conversion sur le commutateur Distribution-1 pour apporter cela dans le mode standby préféré VSS.

    Distribution-1(config)#hostname VSS
    
    VSS(config)#switch virtual domain 100
    
    VSS(config-vs-domain)#switch 2
    
    
    !--- After conversion Distribution-1 will be noted 
    !--- as Switch 2 in VSS mode.
    
    VSS(config-vs-domain)# exit
    VSS(config)#interface port-channel 2
    VSS(config-if)#switch virtual link 2
    
    VSS(config-if)#interface TenG 5/4
    VSS(config-if)#channel-group 2 mode on
    VSS(config-if)#interface TenG 5/5
    VSS(config-if)#channel-group 2 mode on
    VSS(config-if)# ^Z
    VSS#
    
    VSS#switch convert mode virtual
    
    This command will convert all interface
    names to naming convention "interface-type
    switch-number/slot/port",
    save the running config to startup-config and
    reload the switch.
    Do you want to proceed? [yes/no]: yes
    Converting interface names
    Building configuration...
    
    
    !--- At this point the switch will reboot
    
    
    
    !--- snippet of the console output
    
    System detected Virtual Switch configuration...
     Interface TenGigabitEthernet 2/5/4 is member of
    PortChannel 2
     Interface TenGigabitEthernet 2/5/5 is member of
    PortChannel 2
    
    !--- snippet of the console output
    
    00:00:23: %PFREDUN-6-ACTIVE: Initializing as ACTIVE
    processor for this switch
    
    !--- snippet of the console output
    
    00:00:28: %VSL_BRINGUP-6-MODULE_UP: VSL module in slot 5
    switch 2 brought up
    Initializing as Virtual Switch Standby
    
  15. Après que le commutateur de réserve VSS initialise, la configuration active VSS est automatiquement synchronisée au standby VSS. Sur l'amorce, les interfaces du standby VSS (Switch-2) sont dans l'état d'arrêt.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration15.gif

  16. Menez la configuration à bonne fin virtuelle de commutateur.

    Remarque: Cette étape finale et essentielle s'applique seulement pour une conversion pour la première fois. Si le commutateur a été déjà converti ou partiellement converti, vous ne pouvez pas utiliser cette commande. Un message d'erreur est généré si le commutateur est converti ou partiellement converti :

    11:27:30: %PM-SP-4-ERR_DISABLE: channel-misconfig error detected
    on Po110, putting Gi9/2 in err-disable state
    

    Vous pouvez émettre cette commande de configurer automatiquement la configuration virtuelle de réserve de commutateur sur le commutateur virtuel actif :

    VSS#switch accept mode virtual
    
    This command will bring in all VSL configurations from the standby 
    switch and populate it into the running configuration.
    In addition the startup configurations will be updated with the 
    new merged configurations.
    Do you want proceed? [yes/no]: yes
    Merging the standby VSL configuration. . .
    Building configuration...

    Remarque: Rendez-vous compte que le commutateur reçoivent le mode la commande que virtuelle n'est nécessaire plus dans le Logiciel Cisco IOS version 12.2 SXI pendant que les configurations sont fusionnées automatiquement.

  17. Ajoutez les interfaces Switch-2 à MEC.

    • VSS
      
      !--- To Core layer
      
      VSS(config)# interface range tengig 1/2/1, tengig2/2/1
      VSS(config-if-range)# channel-group 20 mode desirable
      VSS(config-if-range)# no shut
      
      
      !--- To Access layer
      
      VSS(config)# interface range gig 1/1/2, gig 2/1/2
      VSS(config-if-range)# switchport
      VSS(config-if-range)# channel-group 10 mode desirable
      VSS(config-if-range)# no shut
      
    • Voisin VSS - Noyau
      Core(config)# interface range gig 1/1, gig 1/2
      Core(config-if-range)# channel-group 20 mode desirable
      Core(config-if-range)# no shut
    • Voisin VSS - Access
      Access(config)# interface range gig 1/1, gig 1/2
      Access(config-if-range)# channel-group 10 mode desirable
      Access(config-if-range)# no shut

    Le transfert au VSS est complet. En ce moment, les deux Commutateurs de VSS s'exécutent et le trafic est chargement-équilibré sur toutes les interfaces avec liaison ascendante.

    http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-virtual-switching-system-1440/109573-vss-migration16.gif

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 109573