Commutateurs : Syst�me Cisco Catalyst 6500 Virtual Switching System 1440

Remplacement du module de superviseur dans le système de commutation virtuelle 1440 de Cisco Catalyst 6500

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit une procédure pas à pas pour remplacer un mauvais superviseur dans un Système de commutation virtuelle de Cisco Catalyst 6500.

Un Système de commutation virtuelle (VSS) se compose de deux châssis de Catalyst 6500. Chaque châssis est équipé d'une engine simple de superviseur. Si un des superviseurs meurt en raison d'une défaillance matérielle, le superviseur de rechange qui est livré avec une configuration par défaut ne devient pas un membre VSS automatiquement. Ce nouveau superviseur initialise au commencement en mode autonome, et il exige de la configuration VSS afin de démarrer en mode VSS.

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant d'essayer cette configuration :

  • Copiez l'image valide du superviseur actif VSS sur un périphérique de compact flash.

  • Copiez la configuration active VSS sur un périphérique de compact flash (peuvent être les mêmes).

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

Système de commutation virtuelle 1440 de Cisco Catalyst 6500 sur la version de logiciel 12.2(33)SXH1 ou ultérieures de Ý de Cisco IOS

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour obtenir plus d'informations sur les commandes utilisées dans cette section.

Le nouveau superviseur a besoin de que vous démarrez avec une image valide et une configuration. L'image peut être copiée avec le TFTP ou un périphérique de compact flash. Si le compact flash n'est pas disponible, l'image logicielle et le fichier de configuration peuvent être copiés avec le TFTP, aussi bien.

  1. Copiez l'image valide du superviseur actif VSS sur un périphérique de compact flash.

    VSS#dir sup-bootdisk:
    Directory of sup-bootdisk:/
    1 -rwx 117668516 Jan 22 2008 11:53:58 +00:00 s72033-
       ipservices_wan-vz.122-33.SXH1
    2 -rwx 33554432 Aug 16 2007 12:40:22 +00:00 sea_log.dat
    3 -rwx 7366 Aug 22 2007 20:05:42 +00:00 default-config
    

    Notez qu'en mode VSS, les superviseurs actifs et de réserve exécutent la même version de l'image logicielle.

    VSS#copy sup-bootdisk:s72033-ipservices_wan-vz.122-33.SXH1 disk0:
    Destination filename [s72033-ipservices_wan-vz.122-33.SXH1]?
    Copy in progress...CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
       CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
    
    !--- Output suppressed.
    
    
  2. Copiez la configuration en cours du superviseur actif VSS sur un périphérique de compact flash.

    VSS#copy running-config disk0:
    Destination filename [startup-config]? <VSS.cfg>
    11196 bytes copied in 0.712 secs (15725 bytes/sec)

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

Comm2 panne de superviseur

replace_vss_sup_proc_v1.gif

Installez et configurez le nouveau superviseur

Terminez-vous ces étapes pour installer et configurer le nouveau superviseur :

  1. Installez le nouveau superviseur dans le châssis et, au cas où les liaisons ascendantes de superviseur seraient utilisées pour VSL, connectez-les physiquement. Démarrez l'image du compact flash.

  2. Effacez le fichier de configuration de démarrage du nouveau superviseur. Cette étape est exigée pour s'assurer qu'aucune configuration éventée n'existe dans le nouveau superviseur.

  3. Copiez l'image logicielle qui a été précédemment copiée sur le périphérique de compact flash au nouveau sup-bootdisk de superviseur :

    Router#copy disk0:s72033-ipservices_wan-vz.122-33.SXH1 sup-bootdisk:
    Destination filename [s72033-ipservices_wan-vz.122-33.SXH1]?
    Copy in progress ..CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
    CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
    117668516 bytes copied in 332.283 secs (354121 bytes/sec)
    
    !--- Output suppressed.
    
    
    !--- If you choose to download software image from a tftp server,
         connect one of the switch interfaces to the network in order to have connectivity 
         to the tftp server. Configure IP address to the management interface; verify 
         the connectivity between the switch and the tftp server.
    
    
    !--- The management IP address should be different from what is 
         already assigned to active VSS switch.
    !--- Configure management IP address
    
    Router(config)#interface gig 1/3
    Router(config-if)#ip address 10.10.10.100 255.255.255.0
    Router(config-if)#no shutdown
    
    !--- verify Management interface status and configuration
    
    Router#show interface gig 1/3
    GigabitEthernet1/3 is up, line protocol is up (connected)
    Hardware is C6k 1000Mb 802.3, address is 0005.dce7.8180 
       (bia 0005.dce7.8180)
    Internet address is 10.10.10.100/24
    
    !--- Output omitted
    !--- If the TFTP server and switch management interface are not in the same 
         layer-3 subnet, add a (default) route.
    
    Router(config)#ip route 0.0.0.0 0.0.0.0 10.10.10.1
    
    !--- verify IP connectivity between switch and TFTP server
    
    Router#ping 10.20.20.200
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.20.20.200, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
    
    !---Copy the new software image into supervisor bootflash:
    
    Router#copy tftp: sup-bootdisk:
    Address or name of remote host []? 10.20.20.200
    Source filename []? s72033-ipservices_wan-vz.122-33.SXH1
    Destination filename [s72033-ipservices_wan-vz.122-33.SXH1]?
    Copy in progress ..CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
    CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
    
    !--- Output omitted
    
    
  4. Copiez la configuration de superviseur active, qui précédemment avait été enregistrée sur le périphérique de compact flash, sur le nouveau fichier de configuration de startup-config de superviseur.

    Router#copy disk0:VSS.cfg startup-config
    Destination filename [startup-config]?
    11196 bytes copied in 7.460 secs (1501 bytes/sec)
    Router#

    Remarque: Cette étape est essentielle parce que la configuration VSS et toutes les variables de démarrage exigées pour démarrer la bonne image logicielle IOS sont ajoutées.

    
    !--- Highlighted VSS configuration commands are critical 
         to boot up the supervisor in VSS mode.
    !--- Verify VSS configuration in the startup-config file
    
    Router#more nvram:startup-config
    !
    hostname VSS
    boot system flash sup-bootdisk:s72033-ipservices_wan-vz.122-33.SXH1
    
    !--- Switch Virtual domain <id> is configured with respective 
         switch priorities
    
    switch virtual domain 1
    switch mode virtual 
    
    !--- this command gets populated upon converting standalone switch to VSS mode. 
         Make sure this command is part the configuration.
    
    switch 1 priority 110
    switch 2 priority 100
    
    
    !--- Verify Virtual Switch Link (VSL) configuration
    
    interface Port-channel1
    no switchport
    no ip address
    switch virtual link 1
    mls qos trust cos
    no mls qos channel-consistency
    !
    interface Port-channel2
    no switchport
    no ip address
    switch virtual link 2
    mls qos trust cos
    no mls qos channel-consistency
    
    !--- Physical interfaces that are part of VSL
    
    interface TenGigabitEthernet1/1/4
    no switchport
    no ip address
    mls qos trust cos 
    channel-group 1 mode on
    
    interface TenGigabitEthernet1/1/5
    no switchport
    no ip address
    mls qos trust cos 
    channel-group 1 mode on
    
    interface TenGigabitEthernet2/1/4
    no switchport
    no ip address
    mls qos trust cos 
    channel-group 2 mode on
    
    interface TenGigabitEthernet2/1/5
    no switchport
    no ip address
    mls qos trust cos 
    channel-group 2 mode on
    
  5. Configurez le VSS Switch_ID qui identifie un commutateur de Catalyst 6500 dans un domaine virtuel de commutation. Puisque le VSS peut se composer de seulement deux Commutateurs, vous devez choisir la personne à charge 1 ou 2 sur quelles valeurs sont définies sur le commutateur actif. Vous ne pouvez utiliser aucune valeur autre que 1 ou 2.

    
    !--- Verify active Switch_ID on the active switch
    
    Router#switch read switch_num local
    Read switch_num from Active rommon is 1
    
    !--- Note that since Switch_ID=1 is used for active switch, 
         we would define Switch_ID=2 in the new supervisor.
    
    
    !--- Configure the Switch_ID on the supervisor.
    
    
    !--- Below command sets a Switch_ID ROMMON variable. 
         It is used during VSS boot up to identify a switch within a VSS domain.
    !--- Note that the Switch_ID doesn’t dictate the state (active vs. standby) of the supervisor.
    
    Router#switch set switch_num 2 local
    Set rommon's switch_num to 2
    
    !--- Verify the Switch_ID configuration on the new supervisor.
    
    Router#switch read switch_num local
    Read switch_num from Active rommon is 2
  6. Rechargez le commutateur de sorte que, quand vous recharge, le commutateur démarre en mode VSS.

    attention Attention : Ne sauvegardez pas votre running-config au startup-config en ce moment. Si vous faites, le startup-config est remplacé avec la configuration par défaut, et le commutateur ne démarre pas en mode VSS.

    Exemple CLI sorti :

    Router# reload
    System configuration has been modified. Save? [yes/no]: no
    Proceed with reload? [confirm]
    00:25:07: %SYS-5-RELOAD: Reload requested by console. 
       Reload Reason: Reload Command.
    00:26:49: %SYS-SP-3-LOGGER_FLUSHING: 
       System pausing to ensure console debugging output.
    00:26:49: %OIR-SP-6-CONSOLE: 
       Changing console ownership to switch processor
    
    !--- Output omitted
    !--- SP booting up, pay attention to the name of the image being loaded by SP
    
    System Bootstrap, Version 8.5(1)
    Copyright (c) 1994-2006 by cisco Systems, Inc.
    Cat6k-Sup720/SP processor with 1048576 Kbytes of main memory
    Autoboot executing command: “ boot system flash 
       sup-bootflash:s72033-ipservices_wan-vz.122-33.SXH1”
    Loading image, please wait ...
    Initializing ATA monitor library...
    Self decompressing the image : 
       ######################################
       #####################################
    Restricted Rights Legend
    Use, duplication, or disclosure by the Government is
    subject to restrictions as set forth in subparagraph
    (c) of the Commercial Computer Software - Restricted
    Rights clause at FAR sec. 52.227-19 and subparagraph
    (c) (1) (ii) of the Rights in Technical Data and Computer
    Software clause at DFARS sec. 252.227-7013.
    cisco Systems, Inc.
    170 West Tasman Drive
    San Jose, California 95134-1706
    Cisco IOS Software, s72033_sp Software 
       (s72033_sp-IPSERVICES_WAN-VM), 
       Version 12.2(33)SXH1, RELEASE SOFTWARE (fc3)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2008 by Cisco Systems, Inc.
    Compiled Thu 17-Jan-08 04:38 by prod_rel_team
    Image text-base: 0x01020150, data-base: 0x01021000
    
    !--- VSS configuration pre-parsed during bootup
    
    System detected Virtual Switch configuration...
    Interface TenGigabitEthernet 2/8/4 is member of Portchannel 2
    
    
    !--- output omitted
    
    Initializing as Virtual Switch STANDBY processor
    
    !--- VSL module ( supervisor in this scenario) 
         brought up and role is resolved as standby 
         since there is already a active VSS switch.
    
    
    00:00:30: %VSL_BRINGUP-6-MODULE_UP: 
       VSL module in slot 8 switch 2 brought up
    00:00:57: %VSLP-5-VSL_UP: 
       Ready for Role Resolution with Switch=1, 
       MAC=0014.1bc6.1c00 over 8/4
    00:01:01: %VSLP-5-RRP_ROLE_RESOLVED: 
       Role resolved as STANDBY by VSLP
    00:01:01: %VSL-5-VSL_CNTRL_LINK: New VSL Control Link 8/4
    
    !--- RP is booting up
    
    System Bootstrap, Version 12.2(17r)SX5, RELEASE SOFTWARE (fc1)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 2006 by cisco Systems, Inc.
    Cat6k-Sup720/RP platform with 1048576 Kbytes of main memory
    Download Start
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
       !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    Restricted Rights Legend
    Use, duplication, or disclosure by the Government is
    subject to restrictions as set forth in subparagraph
    (c) of the Commercial Computer Software - Restricted
    Rights clause at FAR sec. 52.227-19 and subparagraph
    (c) (1) (ii) of the Rights in Technical Data and Computer
    Software clause at DFARS sec. 252.227-7013.
    cisco Systems, Inc.
    170 West Tasman Drive
    San Jose, California 95134-1706
    Cisco IOS Software, s72033_rp Software (s72033_rp-IPSERVICES_WAN-VM), 
       Version 12.2(33)SXH1, RELEASE SOFTWARE (fc3)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2008 by Cisco Systems, Inc.
    Compiled Thu 17-Jan-08 04:04 by prod_rel_team
    Image text-base: 0x01020150, data-base: 0x01021000
    
    !--- output omitted
    
    Press RETURN to get started!
    
    !--- Look out for –- 
         “%PFREDUN-SW2_SPSTBY-6-STANDBY: Initializing for SSO mode”
         in the active console to make sure stadby is running in SSO mode.
    !--- After standby boots up it’s console is locked
    
    VSS-sdby>
    Standby console disabled
    VSS-sdby>
    Standby console disabled

    Remarque: Afin de configurer le VSS sur de plusieurs sous-réseaux, la configuration de réserve n'est pas nécessaire sur le VSS. Des Routeurs de passerelle devraient être installés comme VLAN SVI.

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Non-concordance de logiciel entre les engines de superviseur

S'il y a une non-concordance de logiciel entre les engines de superviseur, le superviseur standy monte en mode de Redondance RPR (pas en mode de Redondance SSO), et le VSS n'initialise pas entièrement.

Afin de résoudre le problème, assurez-vous que le logiciel exigé est présent dans l'éclair du superviseur standy et les déclarations de démarrage indiquent le logiciel correct. Rechargez le superviseur standy de sorte qu'il démarre avec le logiciel correct et joigne le VSS.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 109334