Commutateurs : Commutateurs Cisco Catalyst, s�rie�6500

Exemple de configuration de commutateurs Catalyst pour l'équilibrage de charge réseau Microsoft

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (6 octobre 2015) | Commentaires

Introduction

Ce document décrit comment configurer les commutateurs Cisco Catalyst afin d'interagir avec l'Équilibrage de charge de réseau Microsoft (NLB).

Contribué par Ambrose Taylor, Dale Miller, et Shashank Singh, ingénieurs TAC Cisco.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Commutateurs de la gamme Cisco Catalyst 6500 avec l'engine 2T (Sup2T) de superviseur cette version de logiciel 15.1(1)SY1 de Cisco IOS® de passage

  • Commutateurs de gamme Cisco Catalyst 4948 qui exécutent la version de logiciel 15.0(2)SG7 de Cisco IOS

  • Microsofts Windows Server

Remarque: Consultez le guide de configuration compétent pour les commandes qui sont utilisées afin d'activer ces caractéristiques sur d'autres Plateformes de Cisco.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Informations générales

La technologie NLB peut être utilisée afin de distribuer des demandes de client à travers un ensemble de serveurs. Afin de s'assurer que les clients éprouvent toujours les niveaux de performance acceptables, Microsoft Windows NLB fournit la capacité d'ajouter les serveurs supplémentaires de sorte que vous puissiez mesurer des applications sans état, telles que des web server basés sur IIS, à mesure que le chargement de client augmente. En outre, il réduit le temps d'arrêt qui est provoqué par par les serveurs qui fonctionnent mal.

Microsoft Windows NLB est une technologie de groupement qui est offerte comme partie des systèmes d'exploitation de toute la famille de Windows 2000 Server et de serveur Windows 2003. Il fournit une adresse IP virtuelle simple pour tous les clients comme adresse IP de destination pour la batterie entière.

Vous pouvez configurer NLB pour travailler dans un de ces trois modes :

  • Mode d'Unicast
  • Mode de Multidiffusion
  • Mode de Protocole IGMP (Internet Group Management Protocol)

Mode Unicast

Voici quelques notes au sujet de l'utilisation de NLB en mode d'Unicast :

  • En mode d'Unicast, NLB remplace l'adresse réelle de Contrôle d'accès au support (MAC) de chaque serveur dans la batterie par une adresse MAC commune NLB. Quand tous les serveurs dans la batterie ont la même adresse MAC, tous les paquets qui sont expédiés à cette adresse sont envoyés à tous les membres dans la batterie. Le NLB crée une adresse MAC factice et l'assigne à chaque serveur dans la batterie NLB. Le NLB assigne à chaque serveur NLB une adresse MAC factice différente, basée sur l'ID d'hôte du membre. Cette adresse s’affiche dans l’en-tête de trame Ethernet.

  • L'adresse MAC n'est utilisée dans l'en-tête de Protocole ARP (Address Resolution Protocol), pas l'en-tête Ethernet. Le commutateur utilise l’adresse MAC contenue dans l’en-tête Ethernet et non celle de l’en-tête ARP. Ceci entraîne une question quand un paquet est envoyé à la batterie NLB avec l'adresse MAC de destination comme adresse MAC 00-bf-ac-10-00-01 de batterie. Le commutateur visualise la table associative de mémoire (CAM) pour l'adresse MAC 00-bf-ac-10-00-01, et puisqu'il n'y a aucun port inscrit à l'adresse MAC 00-bf-ac-10-00-01 de batterie NLB, la trame est fournie à tous les ports de commutateur. Ceci introduit l'inondation d'unicast. Afin d'éviter d'inonder, Cisco recommande que vous utilisiez un VLAN dédié pour NLB de sorte que l'inondation soit contrainte.

Mode Multicast

Voici quelques notes au sujet de l'utilisation de NLB en mode de Multidiffusion :

  • En mode de Multidiffusion, l'administrateur système clique sur le bouton de Multidiffusion dans le GUI de configuration de Microsoft NLB. Ce choix instruit les clusters members répondre aux ARPs pour leur adresse virtuelle avec l'utilisation d'une adresse MAC de Multidiffusion, telle que 0300.5e01.0101.

  • Le processus d'ARP ne se termine pas pour des adresses de MAC multicast (ceci casse RFC 1812). Une adresse MAC statique est exigée afin d'atteindre la batterie en dehors de du sous-réseau local.

  • L'adresse IP virtuelle est 10.100.1.99 et l'adresse MAC de Multidiffusion est 0300.5e01.0101. Sélectionnez cette commande afin de remplir table ARP statiquement :
    arp 10.100.1.99 0300.5e01.0101
  • Puisque les paquets entrant ont une adresse IP de destination d'unicast et une adresse MAC de destination de Multidiffusion, le périphérique de Cisco ignore cette entrée et l'unicast inonde chaque paquet de batterie-limite. Afin d'éviter cette inondation, insérez une entrée de la table d'adresses MAC statique afin de commuter les paquets de batterie-limite dans le matériel :
    mac address-table static 0300.5e01.0101 vlan 200 interface TenGigabitEthernet1/4
    TenGigabitEthernet1/5

Remarque: Quand vous tracez statiquement une adresse MAC aux plusieurs ports, elle est seulement prise en charge par le logiciel sur la gamme Cisco Catalyst 4500 commutent. En outre, l'utilisation de cette configuration sur le commutateur de gamme Catalyst 4500 pourrait entraîner la CPU de haute. Afin d'éviter ce problème, vous pouvez localiser le NLB dans une particularité VLAN, ajoutez seulement les entrées statiques d'ARP, et permettez l'inondation sur ce VLAN.

Mode IGMP

Voici quelques notes au sujet de l'utilisation de NLB en mode IGMP :

  • L'utilisation de NLB en mode IGMP exige la moins quantité de configuration manuelle. Les chutes virtuelles d'adresse MAC dans l'Internet Assigned Numbers Authority (IANA) s'étendent et des débuts avec 0100.5exx.xxxx. Puisque l'adresse MAC se conforme maintenant aux caractéristiques IANA, les Commutateurs de Cisco peuvent dynamiquement programmer l'adresse MAC avec l'utilisation de la surveillance IGMP. Ceci enlève la nécessité de programmer manuellement l'adresse MAC aux cartes de port qui sont exigées en mode de Multidiffusion afin d'empêcher inonder au VLAN.

  • La surveillance IGMP programme l'adresse MAC virtuelle pour vous une fois que le commutateur reçoit un rapport d'adhésion d'un membre dans la batterie. Un port de Mrouter doit également être programmé pour le NLB VLAN avec l'utilisation du Protocol Independent Multicast (PIM) ou de la caractéristique querier IGMP.

  • Puisque l'adresse IP virtuelle utilise une adresse MAC de Multidiffusion, c'est extérieur inaccessible du sous-réseau local. Afin d'adresser ceci, vous devez configurer une entrée statique d'ARP sur chaque périphérique avec une interface de la couche 3 (L3) dans la batterie VLAN. Terminez-vous ceci de la même mode qu'avec le mode de Multidiffusion. Par exemple, si l'adresse IP virtuelle est 10.100.1.99 et l'adresse MAC de Multidiffusion est 0100.5e01.0101, employez cette commande afin de remplir table ARP statiquement :
    arp 10.100.1.99 0100.5e01.0101

Mises en garde

Voici les informations importantes à maintenir dans l'esprit quand vous utilisez NLB en mode IGMP :

  • Comme dépisté dans l'ID de bogue Cisco CSCsw72680, vous ne pouvez pas utiliser PIM sur le NLB VLAN Switch Virtual Interface (SVI) avec certaines versions de code. Visualisez les détail du bogue pour les releases de code qui abordent cette question ou utilisent la caractéristique querier de surveillance IGMP.

  • Comme dépisté dans l'ID de bogue Cisco CSCsy62709, des paquets sont reproduits pour tout les trafic qui est conduit aux serveurs NLB en mode IGMP. Visualisez les détail du bogue pour les versions affectées de code.

  • En raison d'une limitation matérielle qui est dépistée par l'ID de bogue Cisco CSCug49149, le trafic NLB ne peut pas être envoyé à travers un EtherChannel distribué sur le même linecard 6708 quand le commutateur fonctionne en mode PFC3B ou PFC3C. Le Port canalisé doit être câblé de sorte que toutes les liaisons membres soient sur la même engine d'expédition.

Configurez

Cette section décrit comment configurer NLB pour les Plateformes de gammes Cisco Catalyst 6500 et 4948 qui fonctionnent dans la Multidiffusion ou le mode IGMP.

Diagramme du réseau

Configuration pour le mode de Multidiffusion

Cette section décrit comment configurer NLB pour les Plateformes de gammes Cisco Catalyst 6500 et 4948 qui fonctionnent en mode de Multidiffusion :

6500-1#show running-config
Building configuration...
!
hostname 6500-1
!
boot system flash disk0:s2t54-adventerprisek9-mz.SPA.151-1.SY1
!
interface TenGigabitEthernet1/4
switchport
switchport trunk allowed vlan 1,100,200
switchport mode trunk
!
interface TenGigabitEthernet1/5
switchport
switchport trunk allowed vlan 1,100,200
switchport mode trunk
!
interface Vlan100
ip address 10.100.1.1 255.255.255.0

!
!        
interface Vlan200
ip address 10.200.1.1 255.255.255.0

!
!
arp 10.100.1.88 0300.5e01.0101 ARPA
!
!
mac address-table static 0300.5e01.0101 vlan 200 interface TenGigabitEthernet1/4
TenGigabitEthernet1/5 TenGigabitEthernet5/5

!
end

Voici quelques informations importantes au sujet de cette configuration :

  • La valeur d'IP address de l'interface Vlan100 configure l'utilisateur VLAN.

  • La valeur d'IP address de l'interface Vlan200 configure la batterie VLAN NLB. Il est important que vous configuriez la passerelle par défaut du serveur de Microsoft à cette adresse.

  • L'ARP 10.100.1.88 0300.5e01.0101 ARPA inclut toutes les interfaces L3 dans le VLAN et est l'adresse IP virtuelle des serveurs de batterie NLB.

  • L'interface du VLAN 200 du mac address-table static 0300.5e01.0101 crée une entrée de MAC statique au mappage de ports dans le commutateur pour l'adresse MAC virtuelle de Multidiffusion.

Remarque: Assurez-vous que vous utilisez le mode de Multidiffusion sur la batterie NLB. Cisco vous recommande de ne pas utiliser d’adresses MAC multicast commençant par 01 car elles entrent en conflit avec la configuration IGMP.

4948-1#show running-config
Building configuration...
!
hostname 4948-1
!
boot system bootflash:cat4500-entservices-mz.150-2.SG7
!
interface GigabitEthernet1/1
 switchport access vlan 200
!
interface TenGigabitEthernet1/49
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
interface TenGigabitEthernet1/50
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
mac address-table static 0300.5e01.0101 vlan 200 interface Gi1/1 Te1/49 Te1/50
!
!
end

Remarque: L'interface du VLAN 200 du mac address-table static 0300.5e01.0101 crée une entrée statique dans le commutateur pour l'adresse MAC virtuelle de Multidiffusion. Il est important de se souvenir que toutes les interfaces de joncteur réseau qui portent le trafic NLB entre les Commutateurs doivent être ajoutées. Une fois qu'une adresse MAC statique est définie, l'inondation est contrainte. Si vous oubliez d'inclure une interface, la batterie NLB se casse. 

Configuration pour le mode IGMP

Cette section décrit comment configurer NLB pour les Plateformes de gammes Cisco Catalyst 6500 et 4948 qui fonctionnent en mode IGMP :

6500-1#show running-config
Building configuration...
!
hostname 6500-1
!
boot system flash disk0:s2t54-adventerprisek9-mz.SPA.151-1.SY1
!
ip igmp snooping querier
!
!
vlan configuration 1,100
 no ip igmp snooping querier
!        
vlan configuration 200
ip igmp snooping querier address 10.200.1.1
!
!
interface TenGigabitEthernet1/4
 switchport
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
interface TenGigabitEthernet1/5
 switchport
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
!
interface Vlan100
 ip address 10.100.1.1 255.255.255.0

!
!        
interface Vlan200
 ip address 10.200.1.1 255.255.255.0

!
!
arp 10.100.1.99 0100.5e01.0101 ARPA
!
!
end

Voici quelques informations importantes au sujet de cette configuration :

  • L'ip igmp snooping querier active la caractéristique querier pillante.

  • L'adresse 10.200.1.1 d'ip igmp snooping querier configure piller querier pour le NLB VLAN.

  • L'utilisateur VLAN est l'interface Vlan100.

  • La batterie VLAN NLB est l'interface Vlan200. Il est important que vous configuriez la passerelle par défaut du serveur de Microsoft à cette adresse (IP address 10.200.1.1 255.255.255.0).

  • L'ARP 10.100.1.99 0100.5e01.0101 ARPA est l'adresse IP virtuelle des serveurs de batterie NLB. L'ARP statique doit être sur toutes les interfaces L3 dans le VLAN.

4948-1#show running-config
Building configuration...
!
hostname 4948-1
!
boot system bootflash:cat4500-entservices-mz.150-2.SG7
!
interface GigabitEthernet1/1
 switchport access vlan 200
!
interface TenGigabitEthernet1/49
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
interface TenGigabitEthernet1/50
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
end

Remarque: Il n'y a aucun besoin de configurer les entrées statiques, car la surveillance IGMP fait ceci dynamiquement en ce mode. En outre, aucune configuration spéciale pour ce mode n'est exigée sur les Commutateurs en aval de la couche 2 (L2).

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

Remarque: L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Vérification de mode de Multidiffusion

Sélectionnez la commande de show ip arp afin de visualiser le cache d'ARP :

6500-1#show ip arp
Protocol Address         Age (min) Hardware Addr   Type   Interface
Internet 10.100.1.99            -   0300.5e01.0101  ARPA

Sélectionnez la commande de show mac address-table static afin de visualiser une charge statique de table d'adresse MAC et une entrée dynamique spécifique ou la charge statique et les entrées dynamiques de table d'adresse MAC sur une interface ou un VLAN spécifique :

6500-1#show mac address-table static add 0300.5e01.0101

vlan   mac address    type   learn    age      ports
----+---------------+-------+-----+------+-----------------
200 0300.5e01.0101   static   No       -  Te1/4 Te1/5 Te5/5
4948-1#show mac address-table static add 0300.5e01.0101

Multicast Entries
vlan    mac address     type   ports
------+---------------+-------+--------------------
200    0300.5e01.0101   static Gi1/1,Te1/49,Te1/50

Vérification de mode IGMP

Sélectionnez la commande de show ip arp afin de visualiser le cache d'ARP :

6500-1#show ip arp

Protocol Address       Age (min) Hardware Addr   Type   Interface
Internet 10.100.1.99         -   0100.5e01.0101  ARPA

Entrez dans le show ip igmp snooping mrouter afin de visualiser le port de Mrouter qui est programmé par les requêtes reçues de piller d'en amont querier :

4948-1#show ip igmp snooping mrouter

Vlan    ports
----    -----
 200   Te1/49(dynamic)

Écrivez le show mac address-table multicast igmp-pillant afin de visualiser l'adresse MAC dynamique-ajoutée qui est apprise de la surveillance IGMP et des ports membres :

4948-1#show mac address-table multicast igmp-snooping

Multicast Entries
 vlan   mac address     type    ports
------+---------------+------+-------------
 200   0100.5e01.0101  igmp Gi1/1,Te1/49

Entrez dans le show ip igmp snooping groups afin de visualiser la liste des ports de clusters members qui ont joint le groupe de multidiffusion :

4948-1#show ip igmp snooping groups

Vlan      Group      Version    Port List
-----------------------------------------
200       239.1.1.1   v2         Gi1/1

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.


Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Document ID: 107995