Commutateurs : Commutateurs Cisco Catalyst, s�rie�6500

Exemple de configuration de commutateurs Catalyst pour l'équilibrage de charge réseau Microsoft

21 décembre 2013 - Traduction automatique
Autres versions: PDFpdf | Anglais (19 décembre 2013) | Commentaires

Introduction

Ce document décrit la méthode de configuration de commutateurs Cisco Catalyst afin qu’ils interagissent avec l’équilibrage de charge réseau (NLB) Microsoft.

Contribué par Shashank Singh, ingénieur TAC Cisco.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Commutateur de Catalyst 6500 qui exécute le logiciel de Cisco IOS®

  • Commutateur du Catalyst 4500 qui exécute le logiciel de Cisco IOS

  • Commutateur du Catalyst 3550 qui exécute le logiciel de Cisco IOS

  • Commutateur de Catalyst 3560 qui exécute le logiciel de Cisco IOS

  • Commutateur de Catalyst 3750 qui exécute le logiciel de Cisco IOS

  • Serveurs Microsoft Windows 2000/2003

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Informations générales

La technologie NLB peut être utilisée pour distribuer des demandes de client à travers un ensemble de serveurs. Afin de s’assurer que les clients bénéficient toujours de niveaux de performances acceptables, Windows NLB est fréquemment utilisé pour garantir la possibilité d’ajouter des serveurs supplémentaires pour faire évoluer les applications, notamment les serveurs Web basés sur IIS, à mesure que la charge client augmente. En outre, il permet de réduire les temps d’arrêt causés par des défaillances de serveurs. Les utilisateurs finaux n’ont jamais connaissance de la désactivation d’un serveur spécifique du système Windows NLB.

L’équilibrage de charge réseau est une technologie de mise en cluster proposée par Microsoft et intégrée à tous les systèmes d’exploitation de la gamme Windows 2000 Server et Windows Server 2003. NLB utilise un algorithme distribué pour équilibrer la charge du trafic réseau sur un certain nombre de serveurs.

Cette technologie regroupe les serveurs en un groupe multicast et tente d’utiliser l’adresse multicast IP et l’adresse MAC standard. Dans le même temps, elle fournit une adresse IP virtuelle unique servant d’adresse IP cible à tous les clients, ce qui signifie que les serveurs rejoignent le même groupe multicast, sans que les clients n’en aient conscience. Ils utilisent un accès unicast normal au VIP.

Vous pouvez configurer le NLB de sorte qu’il fonctionne dans l’un des modes suivants :

Mode Unicast

Par défaut, le NLB est défini en mode unicast. En mode unicast, NLB remplace l’adresse MAC réelle de chaque serveur du cluster par une adresse MAC NLB commune. Quand tous les serveurs dans la batterie ont la même adresse MAC, tous les paquets expédiés à cette adresse sont envoyés à tous les membres de la batterie. Cependant, un problème avec cette configuration est quand la batterie des serveurs NLB est connectée au même commutateur. Vous ne pouvez pas faire enregistrer deux ports sur le commutateur la même adresse MAC. Afin de résoudre ce problème, NLB masque l'adresse MAC de batterie. Le commutateur examine l’adresse MAC source dans l’en-tête de trame Ethernet afin de connaître les adresses MAC associées à ses ports. NLB crée une adresse MAC factice qu’il assigne à chaque serveur du cluster NLB. NLB attribue à chaque serveur NLB une adresse MAC factice différente, en fonction de l’ID d’hôte du membre. Cette adresse s’affiche dans l’en-tête de trame Ethernet.

Par exemple, l’adresse MAC du cluster NLB est 00-bf-ac-10-00-01. NLB en mode d'unicast prend l'adresse MAC de batterie et, pour chaque cluster member, NLB change-il le deuxième octet de sorte qu'il comprenne le membre NLB ? l'identification d'hôte s par exemple, serveur le numéro 1 a l'adresse MAC factice 00-01-ac-10-00-01, hôte que le numéro d'ID 2 a l'adresse MAC factice 00-02-ac-10-00-01, ainsi de suite. Si une seule adresse MAC est enregistrée sur chaque port de commutateur, des paquets ne sont pas livrés à tous les membres de la baie. En revanche, des paquets devraient encore être envoyés aux différents ports de commutateur basés sur l'adresse MAC assignée à ce port. Afin d'avoir des trames fournies à tous les membres du NLB groupez quand chaque port de commutateur connecté à un cluster member NLB enregistre une adresse MAC différente, émission de Protocole ARP (Address Resolution Protocol) est utilisé. Lorsque le routeur envoie une demande ARP afin d’obtenir l’adresse MAC de l’adresse IP virtuelle, la réponse contient un en-tête APR comportant l’adresse MAC réelle du cluster NLB (00-bf-ac-10-00-01 comme indiqué dans l’exemple ci-dessus) et non l’adresse MAC factice.

Les clients utilisent l’adresse MAC contenue dans l’en-tête ARP et non dans l’en-tête Ethernet. Le commutateur utilise l’adresse MAC contenue dans l’en-tête Ethernet et non celle de l’en-tête ARP. La question est quand un client envoie un paquet à la batterie NLB avec l'adresse MAC de destination comme adresse MAC 00-bf-ac-10-00-01 de batterie. Le commutateur regarde la table associative de mémoire (CAM) pour l'adresse MAC 00-bf-ac-10-00-01. Étant donné qu’aucun port n’est enregistré avec l’adresse MAC de cluster NLB 00-bf-ac-10-00-01, la trame est livrée à tous les ports de commutation. Cela entraîne une inondation du commutateur. Commutez les questions de causes d'inondation quand une importante quantité de circulation et aussi quand il y a d'autres serveurs sur le même commutateur. Pour résoudre le problème de l’inondation de commutateur, il suffit de placer un simple concentrateur devant les membres du cluster NLB puis d’établir une liaison ascendante entre le concentrateur et un port de commutation. Grâce à cette solution, il n’est pas nécessaire de masquer l’adresse MAC du cluster NLB car le port de commutation unique connecté au concentrateur apprend l’adresse MAC du cluster NLB. Ceci évite le problème de deux ports de commutateur qui enregistrent la même adresse MAC. Lorsque le client envoie des paquets à l’adresse MAC du cluster NLB, le paquet est transmis directement au port de commutation connecté au concentrateur, puis aux membres du cluster NLB.

Mode Multicast

Une autre solution est d'utiliser le mode de Multidiffusion dans le GUI de configuration du MS NLB au lieu du mode d'unicast. En mode de Multidiffusion, l'administrateur système clique sur le bouton de Multidiffusion de Protocole IGMP (Internet Group Management Protocol) dans le GUI de configuration du MS NLB. Ce choix instruit les clusters members répondre aux ARPs pour leur adresse virtuelle avec une adresse MAC de Multidiffusion (par exemple, 0100.5e11.1111) et envoyer des paquets de rapport d'adhésion IGMP. Si IGMP Snooping est activé sur le commutateur local, les paquets IGMP transitant dans le commutateur sont interceptés. De cette façon, quand ARPs d'un client pour la batterie ? l'adresse IP virtuelle s, la batterie répond avec le MAC multicast (par exemple, 0100.5e11.1111). Quand le client envoie le paquet à 0100.5e11.1111, le commutateur local en avant que le paquet chacun des ports a connecté aux clusters members. Il est alors impossible d’inonder l’ensemble des ports avec le paquet ARP. La question avec le mode de Multidiffusion est l'adresse IP virtuelle devient inaccessible une fois accédée à de l'extérieur du sous-réseau local parce que les périphériques de Cisco ne reçoivent pas une réponse d'ARP pour une adresse IP d'unicast qui contient une adresse MAC de Multidiffusion. La portion MAC de l’entrée ARP s’affiche alors comme incomplete (Incomplète). (Entrez dans le show arp de commande pour visualiser la sortie.) Car il n'y a aucune partie de MAC dans la réponse d'ARP, l'entrée d'ARP n'apparaît jamais dans la table ARP. Il par la suite quitte ARPing et renvoie un message d'inaccessibilité d'hôte d'ICMP aux clients. Afin d'ignorer ceci, employez une entrée statique d'ARP pour remplir table ARP comme affiché ici. Dans la théorie, ceci permet au périphérique de Cisco pour remplir sa table d'adresse MAC. Par exemple, si l'adresse IP virtuelle est 172.16.63.241 et l'adresse MAC de Multidiffusion est 0100.5e11.1111, sélectionnez cette commande afin de remplir table ARP statiquement :

arp 172.16.63.241 0100.5e11.1111

Cependant, puisque les paquets entrant ont un MAC de destination d'adresse IP et de Multidiffusion de destination d'unicast, le périphérique de Cisco ignore ces entrée et processus-Commutateurs chaque paquet de batterie-limite. Afin d'éviter cette commutation de processus, insérez une entrée de table statique d'adresse MAC comme affiché ici afin de commuter des paquets de batterie-limite dans le matériel.

mac-address-table static 0100.5e11.1111 vlan 200 interface fa2/3 fa2/4

Remarque: Statiquement la cartographie d'une adresse MAC aux plusieurs ports est prise en charge seulement en logiciel sur le commutateur du Catalyst 4500. Cette configuration pourrait entraîner la CPU de haute sur le commutateur du Catalyst 4500.

Remarque: Pour le Commutateurs de la gamme Cisco Catalyst 6500, vous devez ajouter le paramètre de débronchement-snopping. Exemple :

débronchement-piller de l'interface fa2/3 fa2/4 du VLAN 200 du mac-address-table static 0100.5e11.1111

Le paramètre débronchement-pillant s'applique essentiel et seulement pour le Commutateurs de la gamme Cisco Catalyst 6500. Sans cette instruction, le comportement n’est pas affecté.

Veuillez noter que sur le Commutateurs de la gamme Cisco Catalyst 6500 l'option snooping de débronchement est disponible seulement pour les plages 0100.5exx.xxxx et 3333.xxxx.xxxx du MAC multicast adresse.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour obtenir plus d'informations sur les commandes utilisées dans cette section.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

107995-config-catalyst-01.gif

Configurations

Ce document utilise la configuration de commutateur Catalyst 6509 décrite dans cette section.

Cat6K#show running-config
Building configuration...
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6K
!
boot buffersize 126968
boot system flash slot0:c6sup11-jsv-mz.121-8a.E.bin
!
redundancy
main-cpu
 auto-sync standard
ip subnet-zero
!
!
interface GigabitEthernet1/1
no ip address
shutdown
!
interface GigabitEthernet1/2
no ip address
shutdown
!
interface FastEthernet2/1
description "Uplink to the Default Gateway"
no ip address
switchport
switchport access vlan 100
!
interface FastEthernet2/2
no ip address
shutdown
!
interface FastEthernet2/3
description "Connection to Microsoft server"
no ip address
switchport
switchport access vlan 200
!
interface FastEthernet2/4
description "Connection to Microsoft server"
no ip address
switchport
switchport access vlan 200
!
interface FastEthernet2/5
no ip address
shutdown
!
interface FastEthernet2/48
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
mac-address-table static 0100.5e11.1111 vlan 200 interface fa2/3 fa2/4 disable-snooping

! --- Creating a static entry in the switch for the multicast virtual mac.

! --- fa2/3 & fa2/4 are the ports connected to server.

!--- The disable-snooping is applicable only for Cisco Catalyst 6500 series switches

arp 172.16.63.241 0100.5e11.1111

! --- 172.16.63.241 is the Virtual IP of 2 servers

interface Vlan100
ip address 172.17.63.240 255.255.255.192

!--- Client Side Vlan

!
interface Vlan200
ip address 10.1.1.250 255.255.255.0

!--- Server Vlan

!--- Important: Configure the default gateway

!--- of the Microsoft Server to this address.

!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.63.193
no ip http server
!
line con 0
line vty 0 4
login
!
end

Remarque: Assurez-vous que le cluster NLB est défini en mode multicast. Cisco vous recommande de ne pas utiliser d’adresses MAC multicast commençant par 01 car elles entrent en conflit avec la configuration IGMP.

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

  • show mac-address-table - Affiche une charge statique de table d'adresse MAC et une entrée dynamique spécifique ou la charge statique et les entrées dynamiques de table d'adresse MAC sur une interface ou un VLAN spécifique.

    Cat6K#show mac-address-table 0100.5e11.1111

    Mac Address Table
    -------------------------------------------

    Vlan Mac Address Type Ports
    ---- ----------- -------- -----
    200 0100.5e11.1111 STATIC Fa2/3 Fa2/4
  • show ip arp - Affiche le cache d'ARP.

    Cat6K#show ip arp
    Protocol Address Age (min) Hardware Addr Type Interface
    Internet 172.16.1.1 - 0100.5e11.1111 ARPA Vlan200

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Informations connexes


Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Document ID: 107995