IP : Traduction d'adresses de réseau (NAT)

Équilibrage de charge NAT IOS pour deux connexions ISP

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document décrit une configuration pour qu'un routeur de½ du¿Â du Cisco IOSï connecte un réseau à l'Internet au Traduction d'adresses de réseau (NAT) par deux connexions ISP. La NAT du logiciel Cisco IOS peut distribuer les connexions TCP et les sessions ultérieures d'UDP sur des connexions de réseau multiples, si les routes à coût égal vers une destination donnée sont disponibles.

/image/gif/paws/100658/ios-nat-load-balancing-2isp-01.gif

Conditions préalables

Conditions requises

Ce document suppose que vous commencez à travailler avec des connexions de LAN et WAN et ne fournit pas de connaissances de fond sur la configuration ou le dépannage pour établir la connectivité initiale. Ce document ne décrit pas un mécanisme pour différencier les routes ; ainsi, il n'y a aucune possibilité de préférer une connexion plus souhaitable à une connexion moins souhaitable.

Composants utilisés

Cette configuration a été développée pour l'utilisation d'un routeur Cisco 1811 avec la version du logiciel Cisco IOS 12.4(15)T3 de services avancés IP . Si une version différente du logiciel est utilisée, quelques fonctionnalités ne sont probablement pas disponibles ou la cabine de commandes de configuration diffère de celles montrées dans ce document. Une configuration identique devrait être disponible sur toutes les plates-formes de routage Cisco IOS, bien que la configuration d'interface varie vraisemblablement entre différentes plates-formes.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Vous devez ajouter le routage basé sur une réglementation pour le trafic spécifique afin de s'assurer qu'il utilise toujours une connexion ISP. Les exemples du trafic qui requièrent ce comportement incluent les clients IPSec VPN, la téléphonie VoIP et tout autre trafic de routage qui devrait toujours utiliser une seule des options de connexion ISP pour préférer la même adresse IP, un plus haut débit ou une plus faible latence sur la connexion.

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil de recherche de commande (réservé aux clients inscrits) pour plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/100658/ios-nat-load-balancing-2isp-02.gif

Cet exemple de configuration décrit un routeur d'accès qui utilise une connexion IP à configuration DHCP à un ISP, qui est montré par FastEthernet 0, et une connexion PPPoE sur une autre connexion ISP. Les types de connexion n'ont aucune incidence particulière sur la configuration, bien que certains types de connexion puissent nuire à la convivialité de cette configuration dans des scénarios de panne spécifiques, en particulier dans les cas où la connectivité IP sur un service WAN connecté à Ethernet est utilisé, par exemple, un câble modem ou des services DSL où un périphérique supplémentaire termine la connectivité WAN et fournit le transfert Ethernet au routeur Cisco IOS. Dans les cas où l'adressage IP statique est appliqué, par opposition aux adresses affectées à DHCP ou à PPPoE, et où une panne WAN se produit, faisant que le port Ethernet maintient toujours la liaison Ethernet au périphérique de connectivité WAN, le routeur continue à tenter la connectivité d'équilibrage des charges à travers les bonnes et mauvaises connexions WAN. Si votre déploiement requiert que des routes inactives soient supprimées de l'équilibrage de charges, reportez-vous à la configuration donnée dans le document, Equilibrage des charges IOS NAT avec un routage optimisé de périphérie pour deux connexions Internet, qui décrit l'ajout du routage de périphérie optimisé afin de contrôler la validité de route.

Configurations

Ce document utilise la configuration suivante :

interface FastEthernet0
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
!
interface FastEthernet1
 no ip address
 pppoe enable
 no cdp enable
!
interface FastEthernet2
 no cdp enable
!


!
interface Vlan1
 description LAN Interface
 ip address 192.168.108.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452


!---Define LAN-facing interfaces with "ip nat inside".

!

!
Interface Dialer 0
 description PPPoX dialer
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 ip tcp adjust-mss


!---Define ISP-facing interfaces with "ip nat outside".

!
ip route 0.0.0.0 0.0.0.0 dialer 0 track 123
!
 
!
ip nat inside source route-map fixed-nat interface Dialer0 overload
ip nat inside source route-map dhcp-nat interface FastEthernet0 overload
!

!--- Configure NAT overload (PAT) in order to use route-maps.

 
!
access-list 110 permit ip 192.168.108.0 0.0.0.255 any
!

!--- Define ACLs for traffic that are NATed to 
!--- the ISP connections.


!
route-map fixed-nat permit 10
 match ip address 110
 match interface Dialer0
!
route-map dhcp-nat permit 10
 match ip address 110
 match interface FastEthernet0


!--- Route-maps associate NAT ACLs with NAT outside on 
!--- the ISP-facing interfaces.

Vérifiez

Utilisez cette section pour confirmer que votre configuration fonctionne correctement.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

  • show ip nat translation - Affiche l'activité NAT entre les hôtes internes NAT et les hôtes NAT extérieurs. Cette commande fournit la vérification que des hôtes internes sont traduits aux deux adresses NAT externes.

    Router#show ip nat translation
    Pro Inside global      Inside local       Outside local      Outside global
    tcp 172.16.108.44:54486 192.168.108.3:54486 172.16.104.10:22 172.16.104.10:22
    tcp 172.16.106.42:49620 192.168.108.3:49620 172.16.102.11:80 172.16.102.11:80
    tcp 172.16.108.44:1623 192.168.108.4:1623 172.16.102.11:445  172.16.102.11:445
    Router#
  • show ip route - Vérifie que plusieurs itinéraires vers Internet sont disponibles.

    Router#show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is 172.16.108.1 to network 0.0.0.0
    
    C    192.168.108.0/24 is directly connected, Vlan1
         172.16.0.0/24 is subnetted, 2 subnets
    C       172.16.108.0 is directly connected, FastEthernet4
    C       172.16.106.0 is directly connected, Vlan106
    S*   0.0.0.0/0 [1/0] via 172.16.108.1
                   [1/0] via 172.16.106.1
    Router#

Dépannez

Utilisez cette section pour dépanner votre configuration.

Une fois que vous avez configuré le routeur Cisco IOS avec NAT, si les connexions ne fonctionnent pas, assurez-vous que :

  • NAT est appliqué convenablement sur les interfaces externes et internes.

  • La configuration NAT est complète et la liste reflète le trafic qui doit être soumis à NAT.

  • Plusieurs itinéraires vers Internet/WAN sont disponibles.


Informations connexes


Document ID: 100658