Voix et communications unifiées : Logiciel Cisco Unified Border Element

Exemple de configuration de transcodage Unified Border Element

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Le Logiciel Cisco Unified Border Element (CUBE) prend en charge le transcodage pour les appels qui traversent et qui exigent différents codecs sur les deux tronçons d'appel. Le transcodage entre de divers codecs est pris en charge, et le CUBE insère un transcodeur basé sur la configuration aussi bien qu'une non-concordance entre les codecs négociée sur les deux tronçons d'appel des appels.

Le transcodage exige des DSP de terminer le flot de RTP et de décoder et encoder la charge utile voix avec les codecs appropriés. Les DSP utilisés par le CUBE pour transcoder peuvent être Co-résident sur le même routeur que le CUBE ou peuvent se trouvent sur une plate-forme distincte de routeur.

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant d'essayer cette configuration :

Composants utilisés

Les informations dans ce document sont basées en fonction :

  • Logiciel Cisco Unified Border Element qui fonctionne sur un routeur de Cisco 3745 et utilise la Cisco IOS version 12.3.11T ou ultérieures

  • Ressources DSP de transcodage sur un serveur d'accès de Cisco AS5400XM avec une carte fonctionnelle AS5X-FC remplie avec des cartes AS5X-PVDM2-64 DSP

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour obtenir plus d'informations sur les commandes utilisées dans cette section.

Diagramme du réseau

Cette figure affiche un exemple de CUBE avec des DSP externes pour le transcodage :

/image/gif/paws/100480/cube_transcode.gif

Les ressources DSP peuvent également être internes (ou Co-résident de) à la même plate-forme de routeur qui héberge le CUBE. Si c'est le cas, le contrôle des ressources DSP est local au routeur, et l'ordre d'exécution de SCCP dans la figure n'est pas présent.

Les ressources DSP qui CUBENT des utilisations pour transcoder doivent être configurées indépendamment de si les DSP sont Co-résident avec le CUBE. La seule différence dans les configurations est l'adressage IP entre le CUBE et les ressources DSP. Pour une configuration de Co-résident, l'adresse IP est identique pour chacun des deux.

Étapes de configuration

Cette section décrit comment configurer le transcodage externe DSP. Un routeur de Cisco 3745 est utilisé comme CUBE, et un AS5400XM est utilisé pour accueillir les ressources DSP pour le transcodage.

La configuration s'applique à cet écoulement d'appel :

  1. L'appel commence à partir de l'OGW vers le CUBE par l'intermédiaire de H.323 avec G.711.

  2. CUBEZ en avant l'appel par l'intermédiaire de H.323 à l'OGW (qui est configuré pour G.729).

  3. Pour l'établissement d'appel au TGW à être réussi, une conversion de codecs est exigée de G.711 en G.729. Si les ressources de transcodage sont non configurées ou disponibles, l'établissement d'appel échoue.

Configuration de CUBE pour le contrôle externe de transcodage

Un routeur de CUBE est configuré pour contrôler les ressources DSP pour le transcodage. Cette configuration utilise l'ordre de service téléphonique, qui est semblable à la configuration de transcodage pour le Manager Express de Cisco Unified Communications. Les ressources DSP s'inscrivent à l'entité (qui dans cet exemple est CUBE, mais pourrait également être CUCME ou CUCM).

CUBE 3745
vdouut3#show running-config | begin telephony
!
telephony-service
sdspfarm units 1 -- Specifies the maximum number of DSP farms that can
                    be registered to CUBE. A maximum of 5 DSP resource units
                    (farms) can be configured.
sdspfarm transcode sessions 128 -- Specifies the maximum transcoding
                    sessions supported across all DSP farms registered
                    with CUBE.
sdspfarm tag 1 vdouut1 -- Specifies the device name of the DSP farm. For
                    uniqueness the device name can be the MAC address of the 
                    DSP source interface. In this example the hostname of
                    the DSP farm router is used.
ip source-address 1.2.61.73 port 2000 – The IP address and port-no: (TCP)
                    of the interface through which SCCP messages are
                    transmitted/received from CUBE.

Configuration de ferme DSP pour accueillir les ressources DSP externes en transcodage

Un routeur est configuré pour héberger des ressources DSP pour transcoder utilisé par une entité, qui dans cet exemple est CUBE sur un routeur différent. Les ressources DSP sont inscrites à l'entité pour les rendre disponibles pour appeler des écoulements.

Batterie DSP
vdouut1#show running-config | begin voice-card
voice-card 1
  dsp services dspfarm –- This makes the DSPs available for “DSP farming”
                    which includes transcoding services.

vdouut1#show running-config | begin sccp
sccp local GigabitEthernet0/0 -- Defines the source interface of the DSP
                    farm through which SCCP messages are exchanged with
                    controlling CUBE.               
sccp ccm 1.2.61.73 identifier 1 -- Specifies the IP address of the CUBE
                    system that the DSP farm registers to. This should
                    match the CUBE IP address on the “ip source-address”
                    configuration on CUBE.
sccp
sccp ccm group 1 -- Group configuration for linking “sccp ccm global”
                    configurations as well as the dspfarm profile(s)
  bind interface GigabitEthernet0/0
associate ccm 1 priority 1 -- Associate the sccp identifier “ccm” with
                  the “sccp ccm group”.
associate profile 1 register vdouut1 -- Associate the dspfarm profile 
                  with the DSP farm device name. In this example the 
                  hostname of the DSP farm hosted router is used
                  (vdouut1). The same name must be used on CUBE where
                  “sdspfarm tag 1” is configured.
!
dspfarm profile 1 transcode -- Configure the dspfarm profile to define
                     the codecs supported, the maximum sessions, and
                     enable SCCP.
  codec g711ulaw
  codec g711alaw
  codec g729ar8
  codec g729abr8
  codec g729r8
  codec g729br8
  maximum sessions 128
  associate application SCCP

Pleines configurations d'échantillon pour le transcodage interne

Cette section fournit un exemple de configuration complète pour une installation où le même routeur (un AS5400XM) est configuré pour héberger le CUBE et les ressources DSP pour le transcodage. Les parties saillantes de la configuration aredisplayed en texte en gras.

Les différences entre ces installation de configuration et configuration de ferme DSP pour accueillir les ressources DSP externes en transcodage sont comme suit :

  • Les ressources DSP réelles (« voice-card X » > « dsp services dspfarm ") et l'entité (« service téléphonique ") apparaissent sur le même routeur.

  • L'adresse IP des ressources DSP (« identificateur-1 de 9.13.29.30 de sccp ccm ") et l'adresse IP de l'entité (« service téléphonique » > « port de 9.13.29.30 de source-address d'IP ") sont identique.

5400XM
5400XM#show run
Building configuration...

Current configuration : 3149 bytes
!
version 12.4
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 5400XM
!
boot-start-marker
no boot startup-test
boot-end-marker
!
logging buffered 100000000 debugging
no logging console
enable secret 5 $1$g301$4BVklIIq97tihABYS6Guy/
enable password xxx
!
resource-pool disable
no aaa new-model
!
resource policy
!
voice-card 1
 dsp services dspfarm
!
voice-card 5
!
ip cef
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 h323
 modem passthrough none codec g729r8 pre-ietf
!
controller T1 5/0
 framing sf
 linecode ami
!
controller T1 5/1
 framing sf
 linecode ami
!
controller T1 5/2
 framing sf
 linecode ami
!
controller T1 5/3
 framing sf
 linecode ami
!
controller T1 5/4
 framing sf
 linecode ami
!
controller T1 5/5
 framing sf
 linecode ami
!
controller T1 5/6
 framing sf
 linecode ami
!
controller T1 5/7
 framing sf
 linecode ami
!
interface GigabitEthernet0/0
 ip address 9.13.29.30 255.255.255.0
 duplex auto
 speed auto
 negotiation auto
 no cdp enable
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 negotiation auto
 no cdp enable
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
 no fair-queue
!
interface Serial5/0
 no ip address
 shutdown
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
 no cdp enable
!
ip route 0.0.0.0 0.0.0.0 9.13.29.1
!
no ip http server
!
dialer-list 1 protocol ip permit
!
sccp local GigabitEthernet0/0
sccp ccm 9.13.29.30 identifier 1 version 4.0 -- Use its own IP address
sccp
!
sccp ccm group 1
 associate ccm 1 priority 1
 associate profile 1 register XCODE123456
 keepalive retries 1
 keepalive timeout 10
 switchover method immediate
 switchback method immediate
!
dspfarm profile 1 transcode
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec gsmfr
 codec g729r8
 codec g729br8
 maximum sessions 10
 associate application SCCP
!
dial-peer voice 1 voip
 destination-pattern 630222100.
 session protocol sipv2
 session target ipv4:9.13.29.22
 dtmf-relay rtp-nte digit-drop
 codec g711ulaw
!
dial-peer voice 2 voip
 session protocol sipv2
 incoming called-number 630222100.
 codec g729br8 bytes 10
!
dial-peer voice 3 voip
 destination-pattern 2000
 session protocol sipv2
 session target ipv4:9.13.29.22
 dtmf-relay rtp-nte digit-drop
!
dial-peer voice 4 voip
 session protocol sipv2
 incoming called-number 2000
 codec g711ulaw
!
gatekeeper
 shutdown
!
telephony-service
 max-ephones 1
 max-dn 1
 ip source-address 9.13.29.30 port 2000 --> Use its own IP address
 sdspfarm units 1
 sdspfarm transcode sessions 10
 sdspfarm tag 1 XCODE123456
 ss7 mtp2-variant Bellcore 0
 ss7 mtp2-variant Bellcore 1
 ss7 mtp2-variant Bellcore 2
 ss7 mtp2-variant Bellcore 3
 !
line con 0
 exec-timeout 0 0
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 password cisco
 login
!
scheduler allocate 10000 400
no process cpu extended
no process cpu autoprofile hog
end

Vérifiez

La sortie dans cette section concerne la configuration installée pour le transcodage externe.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

CUBE

Le nom du périphérique avec lequel la batterie DSP est inscrite au CUBE et à l'adresse IP du routeur hôte de ferme DSP sont affichés en texte en gras.

vdouut3#show sdspfarm units
Load for five secs: 0%/0%; one minute: 0%; five minutes: 3%
Time source is NTP, 23:46:40.649 PST Tue Nov 21 2006


mtp-1 Device:vdouut1 TCP socket:[1] REGISTERED
actual_stream:256 max_stream 256 IP:1.2.61.71  27519  MTP YOKO keepalive 45  
Supported codec:
                 G711Ulaw
                 G711Alaw
                 G729
                 G729a
                 G729b
                 G729ab
 max-mtps:1, max-streams:256, alloc-streams:256, act-streams:0

Cette sortie affiche l'installation de configuration de CUBE.

vdouut3#show telephony-service
ip source-address 1.2.61.73 port 2000
max-ephones 128
max-dn 1
max-conferences 8 gain -6
dspfarm units 1
dspfarm transcode sessions 128
dspfarm 1 vdouut1

Cette sortie prouve qu'après qu'un appel soit fait aux codecs (affichés en texte en gras) qui sont utilisés pour les tronçons d'appel par le CUBE.

vdouut3#show sdspfarm sessions active 
Load for five secs: 1%/0%; one minute: 1%; five minutes: 1%
Time source is NTP, 23:52:43.922 PST Tue Nov 21 2006

Stream-ID:37 mtp:1 1.2.61.71  20190  Local:2000 START  
 usage: Ip-Ip                        
 codec:G729  duration:20 vad:0 peer Stream-ID:38 

Stream-ID:38 mtp:1 1.2.61.71  21326  Local:2000 START  
 usage: Ip-Ip                        
 codec:G711Ulaw64k  duration:20 vad:0 peer Stream-ID:37

Cette sortie affiche l'active de sessions entre l'OGW et le TGW par le CUBE.

vdouut3#show voip rtp connections     
Load for five secs: 1%/0%; one minute: 1%; five minutes: 1%
Time source is NTP, 23:54:22.722 PST Tue Nov 21 2006
VoIP RTP active connections :
No. CallId     dstCallId  LocalRTP RmtRTP LocalIP         RemoteIP       
1   3991       3992       18496    17430  1.2.61.73       1.2.61.48      
2   3992       3991       17382    19706  1.2.61.73       1.2.61.68      
Found 2 active RTP connections

Cette sortie affiche un résumé compact des sessions actives et des codecs (affichés en texte en gras) utilisés par les tronçons d'appel.

vdouut3#show call active voice compact 
Load for five secs: 1%/0%; one minute: 1%; five minutes: 1%
Time source is NTP, 02:31:58.156 PST Wed Nov 22 2006
 <callID>  A/O FAX T<sec> Codec     type  Peer Address  IP R<ip>:<udp>
Total call-legs: 2
      4023 ANS     T25    g711ulaw  VOIP  P5200         1.2.61.48:16934
      4024 ORG     T25    g729r8    VOIP  P6200         1.2.61.68:17040

Hôte de ferme DSP

Cette sortie affiche le statut de l'état d'enregistrement de ressources DSP. Les informations saillantes apparaissent en texte en gras.

vdouut1#show sccp
SCCP Admin State: UP
Gateway IP Address: 1.2.61.71, Port Number: 2000
IP Precedence: 5
User Masked Codec list: None
Call Manager: 1.2.61.73, Port Number: 2000
                Priority: N/A, Version: 3.1, Identifier: 1

Transcoding Oper State: ACTIVE - Cause Code: NONE
Active Call Manager: 1.2.61.73, Port Number: 2000
TCP Link Status: CONNECTED, Profile Identifier: 1
Reported Max Streams: 256, Reported Max OOS Streams: 0
Supported Codec: g711ulaw, Maximum Packetization Period: 30
Supported Codec: g711alaw, Maximum Packetization Period: 30
Supported Codec: g729ar8, Maximum Packetization Period: 60
Supported Codec: g729abr8, Maximum Packetization Period: 60
Supported Codec: g729r8, Maximum Packetization Period: 60
Supported Codec: g729br8, Maximum Packetization Period: 60
Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 30
Supported Codec: rfc2833 pass-thru, Maximum Packetization Period: 30
Supported Codec: inband-dtmf to rfc2833 conversion, Maximum Packetization Period: 30

Cette sortie affiche la configuration des ressources DSP (tandis qu'inactif).

vdouut1#show dspfarm all
Dspfarm Profile Configuration

 Profile ID = 1, Service = TRANSCODING, Resource ID = 1  
 Profile Description :  
 Profile Admin State : UP 
 Profile Operation State : ACTIVE 
 Application : SCCP   Status : ASSOCIATED 
 Resource Provider : FLEX_DSPRM   Status : UP 
 Number of Resource Configured : 128 
 Number of Resource Available : 128
 Codec Configuration 
 Codec : g711ulaw, Maximum Packetization Period : 30 
Codec : g711alaw, Maximum Packetization Period : 30 
 Codec : g729ar8, Maximum Packetization Period : 60 
 Codec : g729abr8, Maximum Packetization Period : 60 
 Codec : g729r8, Maximum Packetization Period : 60 
 Codec : g729br8, Maximum Packetization Period : 60


SLOT DSP VERSION  STATUS CHNL USE   TYPE   RSC_ID BRIDGE_ID PKTS_TXED PKTS_RXED

1    1   9.2.1    UP     N/A  FREE  xcode  1      -         -         -        
1    1   9.2.1    UP     N/A  FREE  xcode  1      -         -         -        
1    1   9.2.1    UP     N/A  FREE  xcode  1      -         -         -  

Cette sortie affiche le statut des ressources DSP (après qu'un appel est fait).

vdouut1#show sccp connections summary 
  SCCP Application Service(s) Statistics Summary:
  Total Conferencing Sessions: 0, Connections: 0
  Total Transcoding Sessions: 1, Connections: 2
  Total MTP Sessions: 0, Connections: 0
  Total ALG-Phone Sessions: 0, Connections: 0
  Total BRI-Phone Sessions: 0, Connections: 0
  Total SCCP Sessions: 1, Connections: 2

vdouut1#show dspfarm dsp active 
SLOT DSP VERSION  STATUS CHNL USE   TYPE   RSC_ID BRIDGE_ID PKTS_TXED PKTS_RXED

1    1   9.2.1    UP     1    USED  xcode  1      15        9400      9405     
1    1   9.2.1    UP     1    USED  xcode  1      16        9400      9394     

Total number of DSPFARM DSP channel(s) 1

Cette sortie affiche les sessions de RTP entre les ressources DSP (ce routeur) et l'entité (CUBE). Deux tronçons d'appel VoIP avec différents codecs sont affichés. Les tronçons chacun des deux sont établis avec le CUBE (1.2.61.73).

vdouut1#show voip rtp connections 
VoIP RTP active connections :
No. CallId     dstCallId  LocalRTP RmtRTP LocalIP         RemoteIP       
1   46         47         17668    2000   1.2.61.71       1.2.61.73      
2   48         47         21530    2000   1.2.61.71       1.2.61.73      
Found 2 active RTP connections

vdouut1#show call active voice compact 
 <callID>  A/O FAX T<sec> Codec     type   Peer Address  IP R<ip>:<udp>
Total call-legs: 2
        46 ORG     T150   g711ulaw  VOIP   P             1.2.61.73:2000 
        48 ORG     T150   g729r8    VOIP   P             1.2.61.73:2000

Dépannez

Voici quelques commandes de dépannage utiles pour le transcodage :

  • messages de debug sccp

  • mettez au point le mtp d'ephone

  • debug ephone state

Remarque: Référez-vous aux informations importantes sur les commandes de débogage avant d'utiliser les commandes de débogage.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 100480