Voix et communications unifiées : Cisco Unified Communications Manager Express

Cisco Unified Communications Manager Express : Guide d'implémentation SIP

19 septembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit des instructions pas à pas pour installer un Cisco Unified Communications Manager Express autonome (CME) ce des téléphones SIP d'utilisations. Le document trace les grandes lignes d'un système de Cisco Unified Communications Manager Express avec quatre téléphones SIP, avec des configurations pour installer le système et les téléphones SIP de Cisco Unified Communications Manager Express.

Remarque: Bien que le document couvre des étapes de configuration pour permettre au Cisco Unified Communications Manager Express pour interopérer avec le Cisco Unity Express, la configuration de Cisco Unity Express est en dehors de la portée de ce document. Référez-vous à Cisco CallManager Express/à l'exemple configuration de Cisco Unity Express pour plus d'informations sur des configurations de Cisco Unified Communications Manager Express et de Cisco Unity Express.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel suivantes :

  • Cisco 2801 qui exécute le Cisco Unified Communications Manager Express 4.2 avec la version de logiciel 12.4(11)XW2 de Ý de Cisco IOS

  • 9-port 10/100BASE-T commutateur ethernet de la taille double HWIC

  • Cisco 7970 téléphones SIP

  • Téléphone SIP de Cisco 3911

Les informations dans ce document sont basées sur ces versions de firmware :

  • 7970 téléphones IP (SIP) — SIP70.8-2-1S

  • 3911 téléphones IP (SIP) — SIP3951.8-0-2-9

Référez-vous à la matrice de compatibilité de version de logiciel de Cisco Unified CME et de Cisco IOS afin de déterminer le micrologiciel approprié de SIP pour l'utiliser pour chaque version de Cisco Unified Communications Manager Express. Puisque le Cisco Unified Communications Manager Express 4.2 est utilisé, référez-vous au lien de caractéristiques du Cisco Unified Communications Manager Express 4.2.

Les phoneloads de SIP peuvent être téléchargés de ces emplacements :

Après que vous ayez défait la fermeture éclair de chacun des deux les fichier zip dans votre répertoire TFTP, copiez tous les fichiers de micrologiciel sur l'éclair de Cisco Unified Communications Manager Express avec votre serveur TFTP. Assurez-vous vous copie tous ces fichiers sur l'éclair.

SIP3951.8-0-2-9.loads
SIP3951.8-0-2-9.zz
DSP3951.0-0-0-1.zz
BOOT3951.0-0-0-9.zz
SIP70.8-2-1S.loads
term70.default.loads
term71.default.loads
apps70.8-0-2-55.sbn
cnu70.8-2-0-55.sbn 
cvm70.sip.8-2-0-55.sbn
dsp70.8-2-0-55.sbn
jar70.sip.8-0-2-25.sbn

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Ces tables tracent les grandes lignes des systèmes d'adressage qui sont utilisés dans cette installation.

But VLAN Réseau Interface Adresse d'interface
Voix 192 192.168.10.0/24 VLAN 192 192.168.10.1/24
Données 100 10.10.10.0/24 VLAN 100 10.10.10.1/24

Protocol Type de téléphone Numéro de poste Masque externe de numéro de téléphone
SIP 7970 101 4085251001
SIP 7970 102 4085251002
SIP 3911 103 4085251003
SIP 3911 104 4085251004

Numéro pilote de messagerie vocale 100 Pilote aa 110
MWI en fonction 800 MWI hors fonction 801

Remarque: L'utilisez afin d'obtenir plus d'informations sur les commandes utilisées dans cette section.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/99946/cme-sip-guide01.gif

Configurations système

Ce document utilise les configurations suivantes :

Configurez le DHCP

Il est nécessaire de configurer deux pools DHCP distincts ; L'utilisation de Téléphones IP le pool DHCP de Voix et les PC utilisent le pool DHCP de données. Le besoin de Téléphones IP d'employer l'option 150 DHCP afin de fournir l'adresse IP du serveur TFTP.

S'il y a des périphériques dans l'un ou l'autre de groupe avec des adresses IP statiques, assurez-vous que ces adresses sont exclues du pool DHCP afin d'éviter d'adresser des conflits. Vous pouvez employer la commande de show ip dhcp binding afin de vérifier qui adresse les Téléphones IP et les PC reçoivent du routeur.

Configuration DHCP
ip dhcp excluded-address 10.10.10.1 10.10.10.10
ip dhcp excluded-address 192.168.10.1 192.168.10.10
!
ip dhcp pool data
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1 
!
ip dhcp pool voice
   network 192.168.10.0 255.255.255.0
   option 150 ip 192.168.10.1
   default-router 192.168.10.1

Configurez l'interface FastEthernet et les switchports

Dans cette section, vous configurez les interfaces VLAN pour les les deux les données et exprimez le VLAN et assignez des switchports dans leurs VLAN respectifs.

Remarque: Avant la configuration des VLAN, soyez sûr d'ajouter les VLAN précédents à la base de données VLAN avec ces commandes :

Interface FastEthernet et configuration switchport
CME-SIP#vlan database
% Warning: It is recommended to configure VLAN from config mode,
 as VLAN database mode is being deprecated. Please consult user
  documentation for configuring VTP/VLAN in config mode.

CME-SIP(vlan)#vlan 100
VLAN 100 modified:
CME-SIP(vlan)#vlan 192
VLAN 192 modified:
CME-SIP(vlan)#exit
APPLY completed.
Exiting....
CME-SIP#

Configurez les switchports à connecter à la Voix et aux données VLAN. Des Téléphones IP sont automatiquement assignés dans la Voix VLAN et PC connectés au switchport directement ou connectés au switchport sur le téléphone IP qui est assigné aux données VLAN.

Configuration DHCP
interface FastEthernet0/3/0
 description 7970 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/1
 description 7970 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
! 
 interface FastEthernet0/3/2
 description 3911 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/3
 description 3911 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
! !
interface Vlan100
description Data VLAN
 ip address 10.10.10.1 255.255.255.0
!
interface Vlan192
description Voice VLAN
 ip address 192.168.10.1 255.255.255.0

Configurez le TFTP

Cette configuration permet au Cisco Unified Communications Manager Express pour servir aux Téléphones IP leur micrologiciel.

Remarque: Cette configuration est obligatoire.

Configuration TFTP
tftp-server flash:SIP3951.8-0-2-9.loads
tftp-server flash:SIP3951.8-0-2-9.zz
tftp-server flash:DSP3951.0-0-0-1.zz
tftp-server flash:BOOT3951.0-0-0-9.zz
tftp-server flash:SIP70.8-2-1S.loads
tftp-server flash:term70.default.loads
tftp-server flash:term71.default.loads
tftp-server flash:apps70.8-0-2-55.sbn
tftp-server flash:cnu70.8-2-0-55.sbn 
tftp-server flash:cvm70.sip.8-2-0-55.sbn
tftp-server flash:dsp70.8-2-0-55.sbn
tftp-server flash:jar70.sip.8-0-2-25.sbn

Configurez les caractéristiques de base de téléphonie

Configurez les paramètres de service vocal

Configurez le système pour permettre à des appels de SIP POUR SIROTER les points finaux et le registrar de SIP d'enable.

Remarque: Cette configuration est obligatoire.

Configuration de paramètres de service vocal
voice service voip
allow-connections sip to sip 

!--- Enable SIP to SIP calls.

sip
registrar server expires max 1200 min 300 

!--- Enable Cisco IOS SIP registrar.

Configurez les paramètres globaux de registre de Voix

Dans cette section, vous configurez des paramètres globaux de registre de Voix.

Remarque: Les configurations globales de registre de Voix pour le SIP sont semblables aux paramètres de configuration de service téléphonique pour des téléphones SCCP.

Remarque: Cette configuration est obligatoire.

Configuration de paramètres globaux de registre de Voix
voice register global                     
 mode cme  

!--- Set Cisco IOS SIP registrar to CME mode.

 source-address 192.168.10.1 port 5060 

!--- Set the source address for phone registration.

 max-dn 20 

!--- Set max extensions.

 max-pool 10 

!--- Set max phones.

 load 7970 SIP7 SIP70.8-2-1S 

!--- Specify phone loads for each phone type.

 load 3911 SIP3951.8-0-2-9 

!--- Specify phone loads for each phone type.

 authenticate register 

!--- Set authentication for phone registration.

 authenticate realm cisco.com 
 tftp-path flash:  

!--- Specify path for tftp files.

 create profile 

!--- Create configuration files for all phones.

 dialplan-pattern 1 4085251... extension-length 3  

!--- Configure dial-plan pattern for the system.

Voici un lien à un vidéo sur la Communauté de support de Ciscoleavingcisco.com qui explique la procédure pour enregistrer un téléphone IP avec le Cisco Unified Communications Manager Express (CME) utilisant le SIP Protocol :

Enregistrement d'un téléphone IP de gamme 79xx utilisant le SIP Protocol sur CUCME leavingcisco.com

/image/gif/paws/99946/cme-sip-guide02.gif

Configurez la connexion au Cisco Unity Express

Configurez les cadran-pairs et les ephone-dn nécessaires de MWI pour interopérer avec le Cisco Unity Express. Pour que le Cisco Unified Communications Manager Express interopère avec le Cisco Unity Express, il est nécessaire de configurer le Cisco Unified Communications Manager Express de SIP comme a de nouveau à l'agent d'utilisateur arrière (B2BUA), ainsi il signifie que tous les signalisation et flot de RTP passe par le Cisco Unified Communications Manager Express. Cette configuration est exigée afin d'activer la Connectivité au Cisco Unity Express.

Configuration de connexion de Cisco Unity Express
dial-peer voice 2 voip
    destination-pattern 1.0  

!--- Specify destination-pattern to reach CUE VM and AA.

    session target ipv4:10.1.10.1  

!--- Configure IP address to reach Cisco Unity Express.

    session protocol sipv2
    dtmf-relay sip-notify  

!--- Configure DTMF method to communicate with Cisco Unity Express.

    b2bua  

!--- Enable B2BUA for Cisco Unified Communications Manager Express
!--- for calls to Cisco Unity Express.

    codec g711ulaw 
    no vad

Configurez le soutien de MWI de Cisco Unity Express de l'outcall afin d'activer le MWI pour des téléphones SIP.

Configuration de MWI de Cisco Unity Express
ephone-dn 11
number 800
mwi on
!
ephone-dn 12
number 801
mwi off

Configurez l'extension et les paramètres

Configurez le dn de registre de Voix afin de créer des numéros de poste pour des ephones. En topologie du réseau précédente, il y a quatre extensions, qui doivent être créées comme donné ici.

Remarque: Cette configuration est obligatoire.

Configuration d'extension
voice register dn 1 
name Phone1 

!--- Set display name.

label 4085251001  

!--- Set display label.

number 101 

!--- Set extension number.

call-forward b2bua noan 100 timeout 20  

!--- Configure call forward noan to voicemail pilot.

call-forward b2bua busy 100 timeout 20  

!--- Configure call forward busy to voicemail pilot.

allow watch  

!--- Allow this number to be watched (presence).

! 
voice register dn 2 
name Phone2
label 4085251002
number 102 
call-forward b2bua noan 100 timeout 20  

!--- Configure call forward noan to voicemail pilot.

call-forward b2bua busy 100 timeout 20  

!--- Configure call forward busy to voicemail pilot.

allow watch
!
voice register dn 3 
name Phone3
label 4085251003
number 103 
call-forward b2bua noan 100 timeout 20  

!--- Configure call forward noan to voicemail pilot.

call-forward b2bua busy 100 timeout 20  

!--- Configure call forward busy to voicemail pilot.

allow watch 
! 
voice register dn 4 
name Phone4
label 4085251004
number 104 
call-forward b2bua noan 100 timeout 20  

!--- Configure call forward noan to voicemail pilot.

call-forward b2bua busy 100 timeout 20  

!--- Configure call forward busy to voicemail pilot.

allow watch

Configurez le téléphone SIP

Configurez les paramètres de groupe de registre de Voix pour chaque téléphone SIP.

Remarque: Le groupe de registre de Voix pour des téléphones SIP est identique aux ephones pour des téléphones SCCP.

Remarque: Cette configuration est obligatoire.

Configuration de paramètres de groupe de registre de Voix
voice register pool  3
 id mac 001A.A11B.500E  

!--- Specify phone mac-address.

 type 3911  

!--- Specify phone type.

 number 1 dn 3  

!--- Assign button 1 dn tag 3.

 dtmf-relay sip-notify  

!--- Configure dtmf-relay sip-notify to work 
!--- with Cisco Unity Express.

 codec g711ulaw  

!--- Specify codec.

 username user1 password cisco  

!--- Configure username and password for SIP registrar.

Remarque: De plusieurs méthodes pour DTMF peuvent être configurées sous le groupe de registre de Voix, mais pour chaque téléphone SIP qui a une boîte vocale sur le Cisco Unity Express, configurent le dtmf-relay sip-annoncent.

Configure a avancé des paramètres

Dans cette section, vous configurez des paramètres avancés pour des téléphones SIP tels que la présence avec l'état du témoin lumineux de ligne occupée (BLF). La présence avec le BLF permet à un téléphone SCCP ou au téléphone SIP pour surveiller le statut des autres extensions de SIP, qui active les informations de présence entre les téléphones.

Remarque: C'est une configuration facultative.

Service de présence de SIP de support de ces téléphones sur le Cisco Unified Communications Manager Express.

Restrictions

BLF Call-List
Supported only on Cisco Unified IP Phone 7941G, 7941GE, 7961G, 7961GE, 7970G, and 7971GE.
BLF Speed-Dial
Supported only on Cisco Unified IP Phone 7941G, 7941GE, 7961G, 7961GE, 7970G, and 7971GE.

Présence d'enable pour les lignes internes

Terminez-vous ces étapes afin de permettre au routeur de recevoir des demandes entrantes de présence des watchers internes et DE SIROTER des joncteurs réseau.

1.  enable 
2.  configure terminal 
3.  sip-ua 
4.  presence enable 
5.  exit 
6.  presence 
7.  max-subscription number 
8.  presence call-list 
9.  end
Présence d'enable pour les lignes internes
Presence  

!--- Enable presence service.

 presence call-list  

!--- Enable BLF monitoring of directory numbers.

 max-subscription 120  

!--- Configure max number watched sessions.

!
sip-ua
 presence enable  

!--- Enable router to accept incoming presence request.

Permettez à un nombre de répertoire d'être observé

Terminez-vous ces étapes afin d'activer une ligne associée avec un nombre de répertoire à surveiller par un téléphone enregistré à un routeur exprès de Cisco Unified Communications. La ligne est activée pendant qu'un presentity et les téléphones peuvent s'abonner à son état de ligne par la liste des appels BLF et les fonctions de numérotation rapide BLG. Il n'y a aucune restriction sur le type de téléphone qui peut avoir ses lignes surveillées ; n'importe quelle ligne sur tout téléphone IP ou à un téléphone analogique sur les Passerelles voix prises en charge peut être un presentity.

1.  enable 
2.  configure terminal 
3.  voice register dn dn-tag 
4.  number number 
5.  allow watch 
6.  end
Permettez à un nombre de répertoire d'être observé
voice register dn  1
 number 101
 allow watch  

!--- Allow this number to be watched.

 name Phone1
 label 4085251001

Remarque: Répétez cette configuration pour chaque numéro de poste qui doit être observé. Cette étape a été déjà faite quand vous avez configuré la première fois des dn de registre de Voix.

Permettez au téléphone SIP de surveiller l'état BLF pour des numérotations abrégées et des listes des appels

Un watcher peut surveiller le statut de lignes associées avec les nombres de répertoire internes et externes (presentities) par les caractéristiques de présence de numérotation abrégée BLF et de liste des appels BLF. Terminez-vous ces étapes afin d'activer les caractéristiques de notification BLF à un téléphone SIP :

1.  enable 
2.  configure terminal 
3.  voice register pool pool-tag 
4.  number tag dn dn-tag 
5.  blf-speed-dial tag number label string 
6.  presence call-list 
7.  exit 
8.  voice register global 
9.  mode cme 
10.  create profile 
11.  restart 
12.  end
Permettez au téléphone SIP de surveiller l'état BLF pour des numérotations abrégées et des listes des appels
voice register pool  1
 id mac 0016.47CD.9BD7
 type 7970
 number 1 dn 1
 presence call-list  

!--- Enable this phone to have presence call list.

 dtmf-relay sip-notify  
 username user1 password cisco
 codec g711ulaw
 blf-speed-dial 2 102 label "Phone2"  

!--- Enable this line to monitor extension 1002.

 blf-speed-dial 3 103 label "3911-1"  

!--- Enable this line to monitor extension 1003.

 blf-speed-dial 4 104 label "3911-2"  

!--- Enable this line to monitor extension 1004.

Remarque:  Soyez sûr d'exécuter la reprise chaque fois que vous changez une configuration de téléphone SIP.

Remarque: Référez-vous à comment configurer le service de présence pour plus d'informations sur les configurations du service de présence de SIP.

Configurez le groupe de recherche parallèle

Dans cette section, les extensions 102, 103, et 104 sont assignées dans un groupe de recherche parallèle. Un groupe de recherche parallèle est un groupe de recherche qui sonne tous les membres dans le groupe simultanément.

Configuration parallèle de groupe de recherche
voice hunt-group 1
pilot 180  

!--- Configure Hunt group pilot number.

list 102, 103, 104  

!--- Specify members in hunt-group.

final 100  

!--- Specify final number as Voicemail Pilot.

CME implémentation de SIP : Exemple de configuration

Cette section fournit la configuration d'échantillon complète pour installer un Cisco Unified Communications Manager Express autonome qui utilise des téléphones SIP.

CME implémentation de SIP : Exemple de configuration
CME-SIP#show version
Cisco IOS Software, 2801 Software (C2801-IPVOICE-M), Version 12.4(11)XW2, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Mon 02-Jul-07 19:10 by prod_rel_team

ROM: System Bootstrap, Version 12.3(8r)T6, RELEASE SOFTWARE (fc1)

CME-SIP uptime is 18 hours, 55 minutes
System returned to ROM by reload at 17:01:34 UTC Wed Oct 3 2007
System image file is "flash:c2801-ipvoice-mz.124-11.XW2.bin"

Cisco 2801 (revision 4.1) with 235520K/26624K bytes of memory.
Processor board ID FHK084510HS
11 FastEthernet interfaces
1 terminal line
2 Voice FXO interfaces
3 DSPs, 48 Voice resources
1 cisco service engine(s)
DRAM configuration is 64 bits wide with parity disabled.
191K bytes of NVRAM.
62720K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

CME-SIP#show running-config
Building configuration...

Current configuration : 6227 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-SIP
!
boot-start-marker
boot-end-marker
!
logging buffered 999999
no logging console
enable password cisco
!
no aaa new-model
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1 10.10.10.10
ip dhcp excluded-address 192.168.10.1 192.168.10.10
!
ip dhcp pool data
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1 
!
ip dhcp pool voice
   network 192.168.10.0 255.255.255.0
   option 150 ip 192.168.10.1 
   default-router 192.168.10.1 
!
!
no ip domain lookup
multilink bundle-name authenticated
!
!
!
voice service voip 
 allow-connections sip to sip
 sip
  registrar server expires max 1200 min 300
!
!
!
!
!
voice register global
 mode cme
 source-address 192.168.10.1 port 5060
 max-dn 20
 max-pool 10
 load 7970 SIP70.8-2-1S
 load 3911 SIP3951.8-0-2-9
 authenticate register
 authenticate realm cisco.com
 voicemail 100
 tftp-path flash:
 create profile sync 0000589556325309
!
voice register dn  1
 number 101
 call-forward b2bua noan 100 timeout 20
 allow watch
 name Phone1
 label 4085251001
!
voice register dn  2
 number 102
 call-forward b2bua noan 100 timeout 20
 allow watch
 name Phone2
 label 4085251002
!
voice register dn  3
 number 103
 call-forward b2bua noan 100 timeout 20
 allow watch
 name Phone3
 label 4085251003
!
voice register dn  4
 number 104
 call-forward b2bua noan 100 timeout 20
 allow watch
 name Phone4
 label 4085251004
!
voice register pool  1
 id mac 0016.47CD.9BD7
 type 7970
 number 1 dn 1
 presence call-list
 dtmf-relay sip-notify
 username user1 password cisco
 codec g711ulaw
 blf-speed-dial 2 102 label "Phone2"
 blf-speed-dial 3 103 label "3911-1"
 blf-speed-dial 4 104 label "3911-2"
!
voice register pool  2
 id mac 0014.6948.1D52
 type 7970
 number 1 dn 2
 dtmf-relay sip-notify
 username user2 password cisco
 codec g711ulaw
!
voice register pool  3
 id mac 001A.A11B.4FCE
 type 3911
 number 1 dn 3
 dtmf-relay sip-notify
 username user3 password cisco
 codec g711ulaw
!
voice register pool  4
 id mac 001A.A11B.500E
 type 3911
 number 1 dn 4
 dtmf-relay sip-notify
 username user4 password cisco
 codec g711ulaw
!
voice hunt-group 1 parallel
 final 100
 list 102,103,104
 pilot 180 
!
!
!
!
voice-card 0
!
!
!
archive
 log config
 hidekeys
!
!
!
interface Loopback0
 ip address 10.1.10.2 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Service-Engine0/0
 ip unnumbered Loopback0
 service-module ip address 10.1.10.1 255.255.255.0
 service-module ip default-gateway 10.1.10.2
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/3/0
 description 7970 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/1
 description 7970 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/2
 description 3911 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/3
 description 3911 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/4
 description Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/5
 description Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/6
 description Phone
 switchport access vlan 192
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/7
 description Phone
 switchport access vlan 192
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/8
 switchport access vlan 192
!
interface Vlan1
 no ip address
!
interface Vlan100
 ip address 10.10.10.1 255.255.255.0
!
interface Vlan192
 ip address 192.168.10.1 255.255.255.0
!
ip route 10.1.10.1 255.255.255.255 Service-Engine0/0
!
!
ip http server
!
!
!
tftp-server flash:BOOT3951.0-0-0-9.zz
tftp-server flash:SIP3951.8-0-2-9.zz
tftp-server flash:DSP3951.0-0-0-1.zz
tftp-server flash:SIP3951.8-0-2-9.loads
tftp-server flash:SIP70.8-2-1S.loads
tftp-server flash:term70.default.loads
tftp-server flash:term71.default.loads
tftp-server flash:apps70.8-0-2-55.sbn
tftp-server flash:cnu70.8-2-0-55.sbn 
tftp-server flash:cvm70.sip.8-2-0-55.sbn
tftp-server flash:dsp70.8-2-0-55.sbn
tftp-server flash:jar70.sip.8-0-2-25.sbn
!
control-plane
!
!
!
voice-port 0/1/0
!
voice-port 0/1/1
!
!
!
!
!
dial-peer voice 2 voip
 description ** cue voicemail pilot number **
 translation-profile outgoing PSTN_CallForwarding
 destination-pattern 100
 b2bua
 session protocol sipv2
 session target ipv4:10.1.10.1
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 3 voip
 description ** cue auto attendant number **
 translation-profile outgoing PSTN_CallForwarding
 destination-pattern 110
 b2bua
 session protocol sipv2
 session target ipv4:10.1.10.1
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
!
presence
 presence call-list
 max-subscription 120
!
sip-ua 
 presence enable
!
!
telephony-service
 max-ephones 24
 max-dn 72
 ip source-address 10.100.100.10 port 2000
 system message CME1
 time-zone 5
 voicemail 100
 max-conferences 8 gain -6
 call-forward pattern .T
 web admin system name cisco secret 5 $1$4FC/$CMer08o/KELFlVrhL5QRO0
 dn-webedit 
 time-webedit 
 transfer-system full-blind
 transfer-pattern 9.T
!
!
ephone-dn  11
 number 800
 mwi on
!
!
ephone-dn  12
 number 801
 mwi off
!
!
line con 0
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
end

CME-SIP#

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Le téléphone IP de SIP n'obtient pas la tonalité

Une cause classique pour des Téléphones IP de SIP qui ne peuvent pas obtenir une tonalité est qu'il y a un autre téléphone avec la même extension. En date du Cisco Unified Communications Manager Express 4.2, la ligne partagée n'est pas prise en charge aux téléphones SIP. Ainsi, les téléphones SIP ne peuvent pas mettre en commun la même extension entre de plusieurs téléphones. Supplémentaire, assurez-vous que le téléphone SIP provisioned avec une extension appropriée.

Afin de résoudre ce problème, assurez-vous que ceux-ci se produisent :

  • Le téléphone SIP a l'extension configurée et des expositions d'extension au téléphone SIP.

  • Il n'y a pas un SIP ou un téléphone SCCP différent configuré avec la même extension.

Le téléphone IP ne peut pas améliorer au plus défunt micrologiciel

Les causes le plus susceptibles pour que le manque puisse améliorer un téléphone est les fichiers de micrologiciel manquants placés sur l'éclair de Cisco Unified Communications Manager Express ou les commandes manquantes de tftp-server.

Essayez ces étapes afin de résoudre ce problème :

  • Vérifiez que les fichiers de micrologiciel nécessaires sont enregistrés sur l'éclair. Exécutez l'éclair de dir : commande afin de vérifier l'éclair pour des fichiers.

  • Vérifiez pour voir si vous avez mis le dossier à jour OS79XX.TXT pour refléter le micrologiciel correct. Les téléphones 79XX vérifient ce fichier afin de charger le microprogramme approprié et changer du SCCP POUR SIROTER.

  • Vérifiez pour s'assurer que les déclarations correctes de tftp-server sont ajoutées pour chaque fichier de micrologiciel. Voyez la section du configurer TFTP.

  • Assurez-vous que la commande de chargement sous le registre de Voix global est ajoutée pour chaque type de téléphone SIP. Voyez la section de paramètres globaux de registre de Voix de configurer.

Afin de dépanner plus loin, collectez ces derniers met au point afin de voir si le téléphone peut obtenir les chargements appropriés de téléphone de l'éclair de Cisco Unified Communications Manager Express.

Debug tftp events

Incapable de provision le téléphone

Les causes le plus susceptibles pour ne pas pouvoir provision est téléphone est que le téléphone n'a pas l'adresse IP appropriée avec l'option de serveur TFTP.

  • Vérifiez pour voir que le téléphone reçoit une adresse IP et l'adresse IP pour serveur TFTP appropriée.

  • Assurez-vous que toutes les commandes globales appropriées de registre de Voix sont ajoutées. Voyez la section de paramètres globaux de registre de Voix de configurer.

  • Vérifiez que vous utilisez l'adresse MAC correcte sous chaque configuration de groupe de registre de Voix.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 99946