Voix et communications unifiées : Logiciel Cisco Unified Border Element

Exemple de configuration de CUBE (Cisco Unified Border Element) avec CUCM (Cisco Unified Communications Manager)

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Le Logiciel Cisco Unified Border Element facilite la Connectivité simple et rentable entre les joncteurs réseau de Protocole SIP (Session Initiation Protocol) de transmissions unifiés par entreprise au réseau téléphonique commuté public (PSTN). A conçu pour rencontrer l'entreprise et la Session Border Controller de prestataire de service que (SBC) le périphérique a besoin, le Logiciel Cisco Unified Border Element (CUBE) est une application logicielle intégrée de½ du¿Â du Cisco IOSï qui fonctionne en fonction :

  • Routeurs à services intégrés de la gamme Cisco 2800

  • Routeurs à services intégrés de la gamme Cisco 3800

  • Plates-formes multiservices de gamme de Cisco 2600XM

  • Routeurs de la gamme Cisco 3700

  • Routeurs de Cisco 7200VXR

  • Routeur Cisco 7301

  • Cisco AS5400XM et passerelles AS5350XM Access

Les interconnexions directes IP entre les réseaux de communications unifiés offrent la meilleure flexibilité de prendre en charge des services d'émergeant en comparaison avec les interconnexions traditionnelles du multiplexage temporel du réseau téléphonique commuté public (PSTN) (TDM).

Le Logiciel Cisco Unified Border Element fournit un point d'interface entre réseaux pour :

  • Signalant l'interworking — H.323, SIP

  • Interworking de medias — multifréquence à deux tonalités [DTMF], télécopie, modem, et transcodage de codecs

  • Adresse et traductions de port — masquer d'intimité et de topologie

  • Normalisation de l'article mouvement d'affichage et d'appel (CDR)

  • Qualité de service (QoS) et gestion de la bande passante — Marquage de QoS utilisant le point de code de Différenciation de services [DSCP] ou le Type de service (ToS), l'application de bande passante utilisant le RSVP Protocol [RSVP] et filtrage de codecs

Un Logiciel Cisco Unified Border Element interopère avec beaucoup de différents éléments de réseau comprenant des Passerelles voix, des Téléphones IP, et des serveurs de contrôle d'appel dans beaucoup d'environnements d'application différente, des services vocaux d'entreprise et/ou des services vidéos avancés avec Cisco Unified Communications Manager ou Cisco Unified Communications Manager Express, aussi bien qu'applications plus simples de contournement de contournement et de transport de la voix sur ip (VoIP).

Le Logiciel Cisco Unified Border Element fournit à des organismes toutes les fonctions de contrôleur de cadre intégrées dans la couche réseau pour interconnecter des architectures unifiées d'entreprise-à-service-fournisseur de Voix et de vidéo de transmissions. Le Logiciel Cisco Unified Border Element est utilisé par entreprise et organismes petits et moyens pour interconnecter l'accès PSTN de SIP avec le SIP et H.323 les réseaux de communications unifiés par entreprise.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations dans ce document sont basées sur le Logiciel Cisco Unified Border Element (CUBE).

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour obtenir plus d'informations sur les commandes utilisées dans cette section.

Configurations

Cette configuration active la fonctionnalité de base de Logiciel Cisco Unified Border Element sur une plate-forme. Cette fonctionnalité termine un appel entrant VoIP et re-le commence avec l'utilisation d'un homologue de numérotation VoIP sortant. Les appels peuvent être H.323 DE SIROTER ou SIROTER POUR SIROTER.

voice service voip
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
allow-connections h323 to h323

Configurez les cadran-pairs entrants et sortants avec le protocole approprié, le type DTMF, et les informations de codecs.

dial-peer voice 1 voip
session target ipv4:10.13.8.150
incoming called-number 8...
dtmf-relay h245-alphanumeric
codec g711ulaw
!
dial-peer voice 2 voip
destination-pattern 8...
session protocol sipv2
session target ipv4:10.13.8.16
dtmf-relay rtp-nte
codec g711ulaw

Configuration d'agent d'utilisateur de SIP

Configurez l'agent d'utilisateur de SIP (uA) pour l'enregistrement et l'authentification.

Agent d'utilisateur de SIP (uA)
sip-ua
registrar ipv4:10.1.1.10
or
registrar dns:csps.cisco.com
authentication username xyz password xyz realm cisco.com

Interconnexion avec Cisco Unified Communications Manager

Cisco Unified Communications Manager peut être interconnecté avec le Logiciel Cisco Unified Border Element avec l'utilisation de l'H.323 ou du joncteur réseau de transmissions unifié par SIP.

H.323 joncteur réseau au Logiciel Cisco Unified Border Element

Il y a deux méthodes de définir H.323 un joncteur réseau au Logiciel Cisco Unified Border Element sur Cisco Unified Communications Manager :

  • Avec un garde-porte — Configurez un joncteur réseau H.225 (GK contrôlé) vers le Logiciel Cisco Unified Border Element

  • Sans garde-porte — Configurez le Logiciel Cisco Unified Border Element comme passerelle H.323

Conditions requises du Media Termination Point (MTP) :

  • Si le Logiciel Cisco Unified Border Element fait H.323 H.323 aux appels, un MTP n'est pas obligatoire tant que la version de Logiciel Cisco Unified Border Element est 12.4(6)T ou plus tard et Cisco Unified Communications Manager est version 4.1 ou ultérieures.

  • Un matériel ou un logiciel MTP peut être Co-résident sur le même routeur que le Logiciel Cisco Unified Border Element (sur les Plateformes de Routeurs qui prennent en charge CUCM MTPs, qui incluent les gammes Cisco 2800 et 3800 ISR).

H.323 conditions requises de démarrage rapide :

  • Si le Logiciel Cisco Unified Border Element fait H.323 POUR SIROTER l'interworking pour Cisco Unified Communications Manager, la plupart des serveurs proxys SIP exigent de l'appel de SIP d'être offre tôt. Ceci implique H.323 le latéral doit être H.323 démarrage rapide. Par conséquent, Cisco Unified Communications Manager doit être configuré pour H.323 le démarrage rapide d'arrivée et sortant, qui exige également un MTP.

La figure 1 affiche la configuration pour un Logiciel Cisco Unified Border Element défini comme passerelle H.323 sur Cisco Unified Communications Manager.

Figure 1. La configuration du Logiciel Cisco Unified Border Element comme passerelle H.323 sur Cisco Unified Communications Manager

/image/gif/paws/99863/cube-config01.gif

cube-config02.gif

La figure 2 affiche que la configuration de Logiciel Cisco Unified Border Element appariait la configuration précédente de Cisco Unified Communications Manager.

Configuration du schéma 2. sur le Logiciel Cisco Unified Border Element pour H.323 un joncteur réseau

cube-config03.gif

Joncteur réseau de SIP au Logiciel Cisco Unified Border Element

La version 5.x ou ultérieures de Cisco Unified Communications Manager est exigée pour définir un joncteur réseau unifié de SIP de transmissions au Logiciel Cisco Unified Border Element.

Conditions requises MTP :

  • Joncteur réseau de SIP sans MTP — Configurez un joncteur réseau unifié de SIP de transmissions sans MTP si des medias retardés ou l'invitez sans le SDP est acceptable.

  • Joncteur réseau de SIP avec MTP — Configurez un joncteur réseau unifié de SIP de transmission (avec MTP) si des medias tôt ou l'invitez avec le SDP est une condition requise (G.711 appels seulement).

Les figures 3 affiche la configuration pour un Logiciel Cisco Unified Border Element défini avec un joncteur réseau unifié de SIP de transmissions à Cisco Unified Communications Manager.

Figure 3. La configuration du Logiciel Cisco Unified Border Element avec un joncteur réseau de SIP à Cisco Unified Communications Manager

/image/gif/paws/99863/cube-config04.gif

La figure 4 affiche à configuration la configuration de Logiciel Cisco Unified Border Element pour apparier la configuration précédente de Cisco Unified Communications Manager.

Configuration du schéma 4. sur le Logiciel Cisco Unified Border Element pour un joncteur réseau de SIP

/image/gif/paws/99863/cube-config05.gif

Co-résident MTP avec le Logiciel Cisco Unified Border Element

Si un logiciel MTP est exigé par la configuration de Cisco Unified Communications Manager, ceci peut être configuré sur le même routeur utilisé pour le Logiciel Cisco Unified Border Element.

C'est la configuration sur le Logiciel Cisco Unified Border Element pour un MTP :

sccp local FastEthernet0/1

sccp ccm 15.5.34.1 identifier 1 version 4.1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register MTP

!

dspfarm profile 1 mtp

codec g711ulaw

maximum sessions software 100

associate application SCCP

Transcodage sur le Logiciel Cisco Unified Border Element

Le Logiciel Cisco Unified Border Element peut faire le transcodage entre le ½ du ¿  G.711ï - law/a-law et diverses saveurs de G.729. Le transcodage peut être appelé pour n'importe quel appel s'il provient de Cisco Unified Communications Manager vers le PSTN, ou du PSTN vers Cisco Unified Communications Manager. Le critère principal est si les deux tronçons d'appel sur le Logiciel Cisco Unified Border Element ont différents codecs - G.711 et G.729. La configuration du transcodage sur le Logiciel Cisco Unified Border Element exige des DSP d'être disponibles sur la plate-forme.

C'est la configuration sur le Logiciel Cisco Unified Border Element pour le transcodage :

voice-card 2

dspfarm

dsp services dspfarm

sccp local FastEthernet 0/0

sccp ccm 200.1.1.100 identifier 1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register MTP123456782012

keepalive retries 5

switchover method immediate

switchback method immediate

switchback interval 15

!

dspfarm profile 1 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec gsmfr

codec g729r8

maximum sessions 5

associate application SCCP

telephony-service

load 7960-7940 P00303020214

max-ephones 48

max-dn 48

ip source-address 200.1.1.100 port 2000

sdspfarm units 1

sdspfarm transcode sessions 50

sdspfarm tag 1 MTP123456782012

create cnf-files version-stamp 7960 Jul 29 2002 13:50:03

Utilisant TCL RVI sur le Logiciel Cisco Unified Border Element

Le Logiciel Cisco Unified Border Element prend en charge des Scripts TCL, et vous pouvez les configurer sous les homologues de numérotation VoIP. Il n'y a aucun besoin de DSP afin d'utiliser la fonctionnalité TCL. Il y a un certain nombre d'applications TCL déjà établies dans le logiciel de Cisco IOS qui peut être utilisé pour des déploiements de Logiciel Cisco Unified Border Element. La fonctionnalité d'Authentification, autorisation et comptabilité (AAA) de Cisco IOS peut également être utilisée en même temps que le script TCL et le Logiciel Cisco Unified Border Element pour fournir l'authentification et l'autorisation des appels.

aaa new-model

!

aaa authentication login h323 group radius

aaa authorization exec h323 local group radius

aaa accounting exec h323 start-stop group radius

!

application

service debitcard tftp://15.5.27.11/app_debitcard.2.0.2.8.tcl

paramspace english index 1

paramspace english language en

paramspace english location tftp://15.5.27.11/prompts/en/

param pid-len 4

paramspace english prefix en

param uid-len 6

!

gw-accounting aaa

!

radius-server host 15.5.27.11 auth-port 1645 acct-port 1646

radius-server timeout 10

radius-server key lab

radius-server vsa send accounting

radius-server vsa send authentication

Pleine configuration d'échantillon

router#show run
Building configuration...
Current configuration : 1122 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname IPIPGW-1
!
boot-start-marker
boot-end-marker
!
no network-clock-participate aim 0
no network-clock-participate aim 1
no aaa new-model
ip subnet-zero
ip cef
!
! aaa new-model
!
aaa authentication login h323 group radius
aaa authorization exec h323 local group radius
aaa accounting exec h323 start-stop group radius
!
application
service debitcard tftp://15.5.27.11/app_debitcard.2.0.2.8.tcl
paramspace english index 1
paramspace english language en
paramspace english location tftp://15.5.27.11/prompts/en/
param pid-len 4
paramspace english prefix en
param uid-len 6
!
gw-accounting aaa
!
radius-server host 15.5.27.11 auth-port 1645 acct-port 1646
radius-server timeout 10
radius-server key lab
radius-server vsa send accounting
radius-server vsa send authentication
!
no ip domain lookup
no ftp-server write-enable
!
voice service voip
allow-connections h323 to sip 

!--- key command

allow-connections sip to h323 

!--- key command

allow-connections sip to sip 

!--- key command

allow-connections h323 to h323 

!--- key command

!
interface FastEthernet0/0
ip address 200.1.1.100 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 200.1.1.1
ip http server
!
control-plane
!
dial-peer voice 1 voip
application debitcard 

!--- TCL Application

session target ipv4:9.13.8.150
incoming called-number 8...
dtmf-relay h245-alphanumeric 

!--- DTMF config for h.245 alphanumeric

codec g711ulaw
!
dial-peer voice 2 voip
destination-pattern 8...
session protocol sipv2
session target ipv4:9.13.8.16
dtmf-relay rtp-nte 

!--- DTMF config for RFC2833

codec g711ulaw
!
gatekeeper
shutdown
sip-ua
registrar ipv4:200.1.1.10 or registrar dns:csps.cisco.com
authentication username xyz password xyz realm cisco.com
!
line con 0
line aux 0
line vty 0 4
login
!
end

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Dépannage des commandes

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Remarque: Référez-vous aux informations importantes sur les commandes de débogage avant d'utiliser les commandes de débogage.

  • se connecter — Il est important de s'assurer que le Logiciel Cisco Unified Border Element est installé pour se connecter le comme indiqué dans cet exemple et pour exécuter également l'élimination des imperfections pendant des heures de non-crête aussi loin que possible puisque les commandes de débogage sont bavardes.

    logging console informational
    logging buffer 200000 debug
    service sequence-number
    service timestamp debug date msec
  • exposition — C'est sortie appropriée :

    show version
    show run
    show voip rtp connection (once the call is up)
    show call active voice brief (once the call is up)
  • mettez au point — Veillez à effacer le log avant qu'un appel pour l'élimination des imperfections soit fait, et à obtenir la sortie de la commande de show logging après l'appel a exécuté.

    H.323 H.323 aux scénarios

    debug h225 asn1
    debug h225 q931
    debug h225 events
    debug h245 asn1
    debug h245 events
    debug h225 q931
    debug cch323 all
    debug voip ipipgw
    debug voip ccapi inout

    SIROTER H.323 des scénarios

    debug h225 asn1
    debug h225 q931
    debug h225 events
    debug h245 asn1
    debug h245 events
    debug cch323 all
    debug voip ipipgw
    debug voip ccapi inout
    debug ccsip all

    SIP POUR SIROTER des scénarios

    debug ccsip all
    debug voip ccapi inout
  • mettez au point — En plus des commandes de débogage basées sur le scénario décrit plus tôt, ces commandes de débogage de transcodeur devraient être activées :

    debug dspfarm all
    debug sccp messages
  • nommer-événements de session de debug voip rtp — Si RFC2833 (rtp-nte de dtmf-relay) est utilisé, vous devriez également activer cette commande de débogage.


Informations connexes


Document ID: 99863