IP : Traduction d'adresses de réseau (NAT)

Équilibrage de charge NAT IOS avec routage de périphérie optimisé pour deux connexions Internet

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document décrit une configuration pour qu'un routeur de½ du¿Â du Cisco IOSï connecte un réseau à l'Internet à la traduction d'adresses réseau par deux connexions ISP. Le Traduction d'adresses de réseau (NAT) de logiciel de Cisco IOS peut distribuer les connexions TCP et les sessions ultérieures d'UDP au-dessus de plusieurs connexions réseau si les artères de coût égal à une destination donnée sont disponibles. Au cas où une des connexions deviendrait inutilisable, le Suivi d'objets, un composant d'Optimized Edge Routing (OER), peut être utilisé pour désactiver l'artère jusqu'à ce que la connexion devienne disponible de nouveau, qui assure la Disponibilité de réseau malgré l'instabilité ou le manque de fiabilité d'une connexion Internet.

/image/gif/paws/99427/ios-nat-2isp-1.gif

Conditions préalables

Conditions requises

Ce document suppose que vous entretenez les relations fonctionnelles de LAN et WAN ; il ne fournit pas le fond de configuration ou de dépannage pour établir la connectivité initiale.

  1. Ce document ne décrit pas une manière de différencier entre les artères, tellement là n'est aucune manière de préférer une connexion plus-desirable au-dessus d'une connexion moins-desirable.

  2. Ce document décrit la configuration de l'OER pour activer ou désactiver l'un ou l'autre de route Internet basée sur l'accessibilité des serveurs DNS de l'ISP. Vous devez identifier les hôtes spécifiques qui peuvent être accessibles par seulement un des connexions ISP et ne peuvent pas être disponibles si cette connexion ISP n'est pas disponible.

Composants utilisés

Cette configuration a été développée avec un routeur de Cisco 1811 avec le logiciel de Services IP avancé par 12.4(15)T. Si une version de logiciel différente est utilisée, quelques caractéristiques ne sont potentiellement pas disponibles, ou les commandes de configuration peuvent différer de ceux affichés dans ce document. La configuration semblable sont disponible sur toutes les Plateformes de routeur Cisco IOS bien que la configuration d'interface varie vraisemblablement entre différentes Plateformes.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Vous devez potentiellement ajouter le routage basé sur la politique pour que le trafic spécifique s'assure qu'il utilise toujours une connexion ISP. Les exemples du trafic qui exigent ce comportement incluent les combinés téléphoniques de clients vpn, VoIP d'IPSec, et n'importe quel autre trafic qui utilisent seulement un des options d'ISP-connexion de préférer la même adresse IP, vitesse supérieure, ou de diminuer la latence sur la connexion.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/99427/ios-nat-2isp-2.gif

Configurations

Cet exemple de configuration, comme illustré dans le schéma de réseau, décrit un routeur d'accès qui utilise une connexion IP DHCP-configurée à un ISP (comme affiché par FastEthernet 0), et une connexion PPPoE au-dessus de l'autre connexion ISP. Les types de connexion n'ont aucune incidence particulière sur la configuration à moins que le Suivi d'objets et l'OER et/ou le routage basé sur la politique doive être utilisé avec une connexion Internet DHCP-assignée. Dans des ces cas, il peut être très difficile de définir un routeur du prochain saut pour le routage ou l'OER de stratégie.

Exemple de configuration de routeur
track timer interface 5
!
! Configure timers on route tracking
!
track 123 rtr 1 reachability
 delay down 15 up 10
!
track 345 rtr 2 reachability
 delay down 15 up 10
!
! Use “ip dhcp client route track [number]” 
   ! to monitor route on DHCP interfaces
! Define ISP-facing interfaces with “ip nat outside”
!
interface FastEthernet0
 ip address dhcp
 ip dhcp client route track 345
 ip nat outside
 ip virtual-reassembly
!
interface FastEthernet1
 no ip address
 pppoe enable
 no cdp enable
!
interface FastEthernet2
 no cdp enable
!
interface FastEthernet3
 no cdp enable
!
interface FastEthernet4
 no cdp enable
!
interface FastEthernet5
 no cdp enable
!
interface FastEthernet6
 no cdp enable
!
interface FastEthernet7
 no cdp enable
!
interface FastEthernet8
 no cdp enable
!
interface FastEthernet9
 no cdp enable
!
! Define LAN-facing interfaces with “ip nat inside”
!
interface Vlan1
 description LAN Interface
 ip address 192.168.108.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!
! Define ISP-facing interfaces with “ip nat outside”
!
Interface Dialer 0
 description PPPoX dialer
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 ip tcp adjust-mss
!
ip route 0.0.0.0 0.0.0.0 dialer 0 track 123
!
! Configure NAT overload (PAT) to use route-maps
!
ip nat inside source route-map fixed-nat
   interface Dialer0 overload
ip nat inside source route-map dhcp-nat 
   interface FastEthernet0 overload
!
! Configure an OER tracking entry 
   ! to monitor the first ISP connection
!
ip sla 1
 icmp-echo 172.16.108.1 source-interface Dialer0
 timeout 1000
 threshold 40
 frequency 3
!
! Configure a second OER tracking entry 
   ! to monitor the second ISP connection
!
ip sla 2
 icmp-echo 172.16.106.1 source-interface FastEthernet0
 timeout 1000
 threshold 40
 frequency 3
!
! Set the SLA schedule and duration
!
ip sla schedule 1 life forever start-time now
ip sla schedule 2 life forever start-time now
!
! Define ACLs for traffic that 
   ! will be NATed to the ISP connections
!
access-list 110 permit ip 192.168.108.0 0.0.0.255 any
!
! Route-maps associate NAT ACLs with NAT 
   ! outside on the ISP-facing interfaces
!
route-map fixed-nat permit 10
 match ip address 110
 match interface Dialer0
!
route-map dhcp-nat permit 10
 match ip address 110
 match interface FastEthernet0 

Avec le cheminement DHCP-assigné d'artère :

Exemple de cheminement DHCP-assigné de configuration d'artère (facultatif)
interface FastEthernet0
 description Internet Intf
 ip dhcp client route track 123
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 speed 100
 full-duplex
 no cdp enable

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

  • show ip nat translation - Affiche l'activité NAT entre les hôtes internes NAT et les hôtes NAT extérieurs. Cette commande fournit la vérification que des hôtes internes sont traduits aux deux adresses NAT d'extérieur.

    Router# sh ip nat tra
    Pro Inside global      Inside local       Outside local      Outside global
    tcp 172.16.108.44:54486 192.168.108.3:54486 172.16.104.10:22 172.16.104.10:22
    tcp 172.16.106.42:49620 192.168.108.3:49620 172.16.102.11:80 172.16.102.11:80
    tcp 172.16.108.44:1623 192.168.108.4:1623 172.16.102.11:445  172.16.102.11:445
    Router#
    
  • show ip route - Vérifie que plusieurs itinéraires vers Internet sont disponibles.

    Router# sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, 
           L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, 
           U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is 172.16.108.1 to network 0.0.0.0
    
    C    192.168.108.0/24 is directly connected, Vlan1
         172.16.0.0/24 is subnetted, 2 subnets
    C       172.16.108.0 is directly connected, 
            FastEthernet4
    C       172.16.106.0 is directly connected, Vlan106
    S*   0.0.0.0/0 [1/0] via 172.16.108.1
                   [1/0] via 172.16.106.1
    Router#
    

Dépannez

Après que vous configuriez le routeur Cisco IOS avec NAT, si les connexions ne fonctionnent pas, soyez sûr de ces derniers :

  • NAT est appliqué convenablement sur les interfaces externes et internes.

  • La configuration NAT est complète et la liste reflète le trafic qui doit être soumis à NAT.

  • Plusieurs itinéraires vers Internet/WAN sont disponibles.

  • Si vous utilisez l'artère dépistant pour être sûr que les connexions Internet sont disponibles, vérifiez l'état du cheminement d'artère.


Informations connexes


Document ID: 99427