Commutateurs : Commutateurs Cisco Catalyst, s�rie 3750

Routage de stub PIM sur les commutateurs des gammes Catalyst 3750 et 3560

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Le trafic d'avion de contrôle de Multidiffusion est toujours vu par chaque routeur sur un environnement de RÉSEAU LOCAL. Le Protocole IP Multicast de stub est utilisé pour réduire et réduire le trafic de multidiffusion inutile qui est vu sur le RÉSEAU LOCAL dans la couche d'accès et pour sauvegarder la bande passante sur les medias pour expédier le trafic de multidiffusion à la couche en amont de distribution/noyau.

Dans les Commutateurs de gammes Catalyst 3750 et 3560, le routage de Multidiffusion de prises en charge de fonctionnalité de multicast d'extrémité PIM entre la couche de distribution et la couche d'accès. Il prend en charge deux types d'interfaces PIM : interfaces de la liaison ascendante PIM et interfaces de passif PIM. En particulier, une interface conduite configurée avec le mode passif PIM ne passe pas/trafic en avant d'avion de contrôle PIM ; il passe seulement/en avant le trafic IGMP.

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant d'essayer cette configuration :

  • Le routeur d'extrémité PIM ne conduit pas le trafic de transit entre les routeurs de distribution. Ce comportement est imposé par le routage de stub de l'unicast (EIGRP). La configuration appropriée de routage de stub d'unicast est exigée pour aider ce comportement de routeur d'extrémité PIM. La caractéristique de stub PIM n'empêche pas l'administrateur de routeur configurant le RIP, les artères de charge statique, ou le PIM RP pour sauter cette restriction.

  • Seulement on permet des récepteurs direct-connectés et les sources de la Multidiffusion (IGMP) dans les domaines d'accès de la couche 2. Le protocole PIM n'est pas pris en charge dans des domaines d'accès.

  • La topologie redondante de routeur d'extrémité PIM n'est pas prise en charge.

Composants utilisés

Les informations dans ce document sont basées sur la sortie du commutateur de Catalyst 3750.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Produits connexes

Cette configuration peut également être utilisée avec ces derniers commutent des types :

  • Commutateurs de gammes Catalyst 3750 et 3560

Le Cisco Catalyst 3750 et 3560 Commutateurs prennent en charge la version 12.2(37)SE et ultérieures de code de routage de multicast d'extrémité PIM.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Le SSM PIM est utilisé sur les liaisons ascendantes pour communiquer avec le routeur en amont. Les utilisateurs peuvent utiliser n'importe quel autre mode PIM (par exemple, dense ou clairsemé).

Pour des informations supplémentaires sur la configuration du routage de Multidiffusion sur les Commutateurs de gamme 3750, référez-vous à l'acheminement de configuration de Protocole IP Multicast.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour obtenir plus d'informations sur les commandes utilisées dans cette section.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/98289/pim_stub-1.gif

Configurations

Ce document utilise les configurations suivantes :

Terminez-vous ces étapes pour configurer la Stub Routing PIM :

  1. Émettez cette commande d'activer la Multidiffusion conduisant globalement sur le commutateur ou la pile de commutateurs :

    mix_stack(config)#ip multicast-routing distributed
    
  2. Émettez cette commande de définir la plage de SSM de l'adresse de Protocole IP Multicast avec la plage de groupe par défaut :

    mix_stack(config)#ip pim ssm default
    
  3. Émettez cette commande d'activer le SSM PIM sur la liaison ascendante :

    mix_stack(config)#interface GigabitEthernet3/0/25
    
    
    !--- By default switch configures the Layer 2 parameters.
    So in order to configure the Layer 3 parameter, use the next command.
    
    mix_stack(config-if)#no switchport
    
    mix_stack(config-if)#ip pim sparse-dense-mode
    
  4. Émettez cette commande d'activer la Stub Routing PIM sur l'interface VLAN :

    mix_stack(config)#interface vlan100
    mix_stack(config-if)#ip pim passive
    

Commutez la configuration (de mix_stack)

mix_stack#show run
Building configuration...
 
Current configuration : 7810 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname mix_stack
!
!
switch 2 provision ws-c3750e-24pd
switch 3 provision ws-c3750g-24ts
switch 5 provision ws-c3750-24fs
switch 9 provision ws-c3750e-24pd
!
ip routing
!
!
ip multicast-routing distributed
!
!--- Output suppressed.
!
!
vlan 100
!
!
interface GigabitEthernet2/0/1
switchport access vlan 100
no keepalive
spanning-tree portfast
!
interface GigabitEthernet2/0/2
switchport access vlan 100
no keepalive
spanning-tree portfast
!
!
!--- Output suppressed.
!
!
interface GigabitEthernet3/0/25
no switchport
ip address 3.1.1.2 255.255.255.248
ip pim sparse-dense-mode
!
!
!--- Output suppressed.
!
!
interface GigabitEthernet9/0/24
no switchport
ip address 10.1.1.1 255.255.255.0
ip pim passive
no keepalive
!
!
!--- Output suppressed.
!
!
interface Vlan1
no ip address
!
interface Vlan100
ip address 100.1.1.1 255.255.255.0
ip pim passive
!
!
!--- Output suppressed.
!
! 
ip pim ssm default
!
!
!--- Output suppressed.
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
speed 115200
line vty 0 4
login
line vty 5 15
login
!
end

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Émettez la commande de show ip pim interface afin d'afficher la stub PIM qui est enable pour chaque interface.

mix_stack#show ip pim interface 

Address    Interface               Ver/    Nbr     Query   DR     DR
                                   Mode    Count   Intvl   Prior

3.1.1.2    GigabitEthernet3/0/25   v2/SD   1       30      1      3.1.1.2
100.1.1.1  Vlan100                 v2/P    0       30      1      100.1.1.1
10.1.1.1   GigabitEthernet9/0/24   v2/P    0       30      1      10.1.1.1

Émettez le détail de show ip igmp groups pour afficher le client intéressé qui a joint la source multicast/groupe spécifiques.

mix_stack#show ip igmp groups 232.0.0.9 det

Flags: L - Local, U - User, SG - Static Group, VG - Virtual Group,
SS - Static Source, VS - Virtual Source,
Ac - Group accounted towards access control limit

Interface: GigabitEthernet9/0/24
Group: 232.0.0.9
Flags: SSM 
Uptime: 00:00:10
Group mode: INCLUDE
Last reporter: 10.1.1.2
CSR Grp Exp: 00:02:57
Group source list: (C - Cisco Src Report, U - URD, R - Remote, S - Static,
V - Virtual, M - SSM Mapping, L - Local,
Ac - Channel accounted towards access control limit)
Source Address Uptime v3 Exp CSR Exp Fwd Flags
200.1.1.3 00:00:10 stopped 00:02:57 Yes CM

Interface: Vlan100
Group: 232.0.0.9
Flags: SSM 
Uptime: 01:42:08
Group mode: INCLUDE
Last reporter: 100.1.1.3
CSR Grp Exp: 00:02:00
Group source list: (C - Cisco Src Report, U - URD, R - Remote, S - Static,
V - Virtual, M - SSM Mapping, L - Local,
Ac - Channel accounted towards access control limit)
Source Address Uptime v3 Exp CSR Exp Fwd Flags
200.1.1.3 01:42:12 stopped 00:02:00 Yes CM
mix_stack#

Émettez le show ip mroute pour vérifier que le flot de Multidiffusion en avant de la source aux clients intéressés.

mix_stack#show ip mroute 232.0.0.9
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report, 
Z - Multicast Tunnel, z - MDT-data group sender, 
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(200.1.1.3, 232.0.0.9), 01:44:23/00:02:52, flags: sTI
Incoming interface: GigabitEthernet3/0/25, RPF nbr 3.1.1.1
Outgoing interface list:
GigabitEthernet9/0/24, Forward/Sparse-Dense, 00:02:24/00:02:50
Vlan100, Forward/Sparse-Dense, 01:44:23/00:02:52

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 98289