Commutateurs : Commutateurs Cisco Catalyst, s�rie�6500

Configuration des commutateurs Catalyst pour les téléphones de conférence Polycom

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (7 octobre 2015) | Commentaires


Contenu


Introduction

Ce document fournit des configurations d'échantillon sur des Commutateurs de Catalyst afin de se connecter à IP 430 de la référence 7935/7936 et du Polycom SoundPoint de conférence IP de Polycom. Ce document ne comporte pas des configurations de power inline et de Qualité de service (QoS).

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant d'essayer cette configuration :

Composants utilisés

Les informations dans ce document sont basées sur la gamme Cisco Catalyst 6500 commutent avec l'engine 720 de superviseur et la version de logiciel 12.2(18)SXD6 exécutant Cisco IOSÝ et la gamme Cisco Catalyst 6500 commute avec le Supervisor Engine 2 et la version de logiciel 8.4(4) de Cisco CatOS d'exécution.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Produits connexes

Cette configuration peut également être utilisée avec les commutateurs Cisco Catalyst qui exécutent le Cisco IOS logiciel, excepté la gamme 2900XL et 3500XL de Cisco. Les configurations de CatOS peuvent être utilisées avec tous les commutateurs Cisco Catalyst qui exécutent le logiciel Catalyst OS.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

Ce document explique la configuration des Commutateurs qui connectent les PC et l'IP de Polycom SoundPoint de téléphone IP 430 sur un port de commutateur. Ce document explique également la configuration des Commutateurs qui se connectent à un port de commutateur de la référence 7935/7936 de conférence IP de Polycom.

La référence 7935/7936 de conférence IP de Polycom a une connexion simple réseau local des Ethernets 10/100BaseTx au réseau par une interface de câble de RJ-45 et à la différence de l'autre gamme 7900 de Téléphones IP de Cisco Unified, elle n'a pas une connexion réseau local des Ethernets 10/100BaseTx afin de se connecter à un PC.

En raison de l'absence de la disposition de connecter un PC à la connexion du LAN Ethernet 10/100BaseTx sur Cisco à 7935/7936 téléphone de conférence IP, au concept d'une Voix ou au VLAN auxiliaire n'applique pas directement et peut poser des problèmes. La connexion simple du LAN Ethernet 10/100BaseTx que la référence 7935/7936 de conférence IP de Cisco a est utilisée afin de connecter ce périphérique à un port de commutateur. Puisque cette connexion porte le trafic pour seulement la Voix, le port de commutateur devrait appartenir à un VLAN simple.

L'IP 430 de Polycom SoundPoint a de doubles ports Ethernet de 10/100 Mbits/s. Un port se connecte au commutateur et l'autre port se connecte à un PC. À cet égard, le port porte le trafic pour ces deux VLAN :

  • Le trafic des données (PC)

  • Le trafic de Voix (téléphone IP)

Dans ce scénario, vous avez besoin d'un port de joncteur réseau afin de passer le trafic pour plus d'un VLAN.

Remarque: La référence 7935/7936 de conférence IP de Polycom n'a pas l'alimentation externe, ainsi ou le commutateur doit assurer l'alimentation par ses ports PoE, ou un injecteur de courant distinct doit être utilisé.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'Outil de recherche de commande (clients enregistrés seulement) pour obtenir plus d'informations sur les commandes utilisées dans cette section.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-series-switches/97229-config-cat-switches-polycom.gif

Configurations Cisco IOS

Ce document utilise la configuration suivante :

  • Catalyst 6500

Catalyst 6500 en mode indigène de Cisco IOS
Cat6500#show running-config 
 Building configuration...
Current configuration : 5869 bytes
!
version 12.1 
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat6500
!

boot system sup-bootflash:s72033-psv-mz.122-18.SXD6.bin


main-cpu
 auto-sync standard
ip subnet-zero
!
!
no ip finger
!
!
!
!
vlan 1
name DataVlan
!
vlan 2
name VoiceVlan
!
interface FastEthernet4/1
 no ip address 
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1
 switchport trunk allowed vlan 1,2
 switchport mode trunk
 spanning-tree portfast

!--- Use PortFast only when you connect a single end station to a
!--- Layer 2 access port. Otherwise, you create a network loop.
!--- Refer to Using Portfast and Other Commands to Fix Workstation Startup
!--- Connectivity Delays for more information on how to enable portfast.

!
interface FastEthernet4/2
 no ip address
 switchport
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast

!--- Use PortFast only when you connect a single end station to a 
Layer 2 access port. Otherwise, you create a network loop.

!
interface FastEthernet4/3
 no ip address
 shutdown
!

!--- Output suppressed.

!
ip classless
no ip http server
!
!
!
line con 0
transport input none
line vty 0 4 
!
end

Configurations de CatOS

Cet exemple explique la configuration des Commutateurs dans le mode hybride qui connectent le PC et l'IP de Polycom SoundPoint de téléphone IP 430 sur un port de commutateur. Ce document explique également la configuration des Commutateurs qui se connectent à un port de commutateur de la référence 7935/7936 de conférence IP de Polycom. Cette configuration utilise le même diagramme que l'exemple précédent.

Catalyst 6500 dans le mode hybride

!--- Set the VLAN Trunk Protocol (VTP) mode.
!--- In this example, the mode is set to transparent.
!--- Dependent upon your network, set the VTP mode accordingly.
!--- Refer to Understanding and Configuring VLAN Trunk Protocol (VTP) 
!--- for more information on VTP.

Catalyst6500> (enable) set vtp mode transparent
VTP domain modified


!--- Add VLAN 2. VLAN 1 already exists by default.
 
Catalyst6500> (enable) set vlan 2
VLAN 2 configuration successful


!--- Add port 4/2 to VLAN 2.

Catalyst6500> (enable) set vlan 2 4/2
VLAN 2 modified.
VLAN 1 modified.
VLAN  Mod/Ports
---- -----------------------
2     4/2


!--- Enable trunking on port 4/1.

Catalyst6500> (enable) set trunk 4/1 1,2 dot1q on
Vlan(s) 1,2 already allowed on the trunk
Please use the 'clear trunk' command to remove vlans from allowed list.
Port(s)  4/1 trunk mode set to on.
Port(s)  4/1 trunk type set to dot1q.
Catalyst6500> (enable) 


!--- Enable spanning tree portfast on the ports. Refer to 
!--- Using Portfast and Other Commands to Fix Workstation Startup Connectivity Delays
!--- for more information on how to enable portfast.

Catalyst6500> (enable) set spantree portfast 4/1 enable

Warning: Connecting Layer 2 devices to a fast start port can cause
temporary spanning tree loops. Use with caution.

Spantree port  4/1 fast start enabled.
Catalyst6500> (enable) set spantree portfast 4/2 enable

Warning: Connecting Layer 2 devices to a fast start port can cause
temporary spanning tree loops. Use with caution.

Spantree port  4/2 fast start enabled.
Catalyst6500> (enable)


!--- If you want to ONLY allow VLAN 1 and VLAN 2 on trunk port 4/1, do this.
!--- A trunk port allows all VLANs by default.

Catalyst6500> (enable) show trunk 4/1
* - indicates vtp domain mismatch
# - indicates dot1q-all-tagged enabled on the port
$ - indicates non-default dot1q-ethertype value
Port      Mode         Encapsulation  Status        Native vlan
--------  -----------  -------------  ------------  -----------
 4/1      on           dot1q          not-trunking  1

Port      Vlans allowed on trunk
--------  ---------------------------------------------------------------------
 4/1      1-4094

Port      Vlans allowed and active in management domain 
--------  ---------------------------------------------------------------------
 4/1      1

Port      Vlans in spanning tree forwarding state and not pruned
--------  ---------------------------------------------------------------------
 4/1       
Catalyst6500> (enable) clear trunk 4/1 1-4094
Removing Vlan(s) 1-4094 from allowed list.
Port  4/1 allowed vlans modified to none.


!--- Allow only VLAN 1 and VLAN 2 on trunk port 4/1.

Catalyst6500> (enable) set trunk 4/1 1,2 dot1q on
Adding vlans 1,2 to allowed list.
Port(s)  4/1 allowed vlans modified to 1,2.
Port(s)  4/1 trunk mode set to on.
Port(s)  4/1 trunk type set to dot1q.

Catalyst6500> (enable) show trunk 4/1
* - indicates vtp domain mismatch
# - indicates dot1q-all-tagged enabled on the port
$ - indicates non-default dot1q-ethertype value
Port      Mode         Encapsulation  Status        Native vlan
--------  -----------  -------------  ------------  -----------
 4/1      on           dot1q          not-trunking  1

Port      Vlans allowed on trunk
--------  ---------------------------------------------------------------------
 4/1      1,2

Port      Vlans allowed and active in management domain 
--------  ---------------------------------------------------------------------
 4/1      1

Port      Vlans in spanning tree forwarding state and not pruned
--------  ---------------------------------------------------------------------
 4/1       

!--- Refer to Configuring Ethernet VLAN Trunks for more
!--- information on how to configure trunk ports. 


!--- Issue the show config <module_number> command 
!--- in order to check the configuration.

Catalyst6500> (enable) show config 4
This command shows non-default configurations only.
Use 'show config <mod> all' to show both default and non-default configurations.
.................................
begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
#time: Thu Jun 21 2007, 23:37:51 
!
# default port status is enable
!
!
#module 4 : 16-port 1000BaseX Ethernet
set vlan 2    4/2
clear trunk 4/1  1-9,11-39,41-4094
set trunk 4/1  on dot1q 1,2
set spantree portfast    4/1-2 enable
end
Catalyst6500> (enable) 

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Boucle de spanning tree due aux Téléphones IP de Polycom

Quand vous connectez un téléphone IP à un commutateur, il peut éprouver des boucles STP, qui fait monter la CPU du commutateur à 100 pour cent d'utilisation. Les boucles STP peuvent se produire même si le portfast est activé sur le port de commutateur où le téléphone IP est connecté.

  1. Vérifiez la configuration de port de commutateur. Si le port où le téléphone IP est connecté entre dans un état d'errer-handicapés et s'il n'y a aucune boucle physique, vous pouvez essayer de récupérer le port de l'état d'errer-handicapés. Référez-vous à la reprise d'état de port errdisable sur le pour en savoir plus de plates-formes Cisco IOS.

  2. Afin d'éviter le port pour entrer dans un état d'errer-handicapés quand il y a un risque que les utilisateurs finaux créent une boucle physique par erreur, vous pouvez activer la reprise d'errer-débronchement tellement il n'y a pas un besoin de remettre à l'état initial manuellement un port qui devient handicapé. Référez-vous aux améliorations de protocole spanning-tree utilisant le fonctionnalités de protection contre les boucles et de détection des différences de temps de propagation des BPDU pour plus d'informations sur le Loop Guard STP.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 97229