Commutateurs : Commutateurs de la gamme Cisco Catalyst 3750

Exemples de configuration de QoS sur les commutateurs Cisco Catalyst 3750

18 octobre 2014 - Traduction automatique
Autres versions: PDFpdf | Anglais (24 septembre 2014) | Commentaires


Contenu


Introduction

Les commutateurs Cisco catalyst 3750 prennent en charge diverses fonctionnalités QoS telles que la classification, le marquage, la mise en file d'attente et la planification. Ce document explique ces fonctionnalités QoS avec des exemples de configuration.

Conditions préalables

Conditions requises

Cisco recommande d'avoir des connaissances sur la manière de configurer QoS.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Commutateur Cisco Catalyst 3750 - WS-C3750-24TS

  • Logiciel Cisco IOS® Version 12.2(35)SE2

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Aperçu Qos

Avec QoS, vous pouvez accorder un traitement préférentiel à certains types de traffic. Vous pouvez différencier les trafics utilisant des étiquettes QoS. Les deux étiquettes QoS les plus fréquemment utilisées dans l'en-tête IP de la couche 3 sont le champ de priorité IP et la zone de DSCP. L'étiquette QoS dans l'en-tête de trame de la couche 2 est appelée Classe de service (CoS). Les outils de commutateur Catalyst QoS peuvent fournir un traitement préférentiel en fonction des étiquettes de la couche 3 ou de la couche 2. Ce document fournit divers exemples pouvant donner une idée de l'utilisation des étiquettes QoS de la couche 2 et 3 dans les commutateurs Cisco Catalyst.

/image/gif/paws/91862/cat3750-qos-config1.gif

Commutateur Cisco Catalyst 3750 Switch sans QoS

QoS est désactivé par défaut sur les commutateurs Catalyst 3750. Lorsque que QoS est désactivé, l'ensemble des trames et paquets sont transmis sans être altérés par le commutateur. Par exemple, si une trame de classe de service 5 contenant un paquet avec DSCP EF rentre dans le commutateur, les étiquettes CoS et DSCP restent inchangées. Le trafic sort avec les mêmes valeurs CoS et DSCP qu'à son entrée. Tous les trafics, dont le trafic vocal, sont livrés de la meilleure manière possible.

Switch#show mls qos
QoS is disabled
QoS ip packet dscp rewrite is enabled

!--- Even though it says QoS ip packet dscp rewrite is enabled,
!--- the switch does not alter the DSCP label on the packets when 
!--- the QoS is disabled.

Commutateur Cisco Catalyst 3750 avec fonctionnalités QoS

Après que QoS est activé sur les commutateurs 3750, un nombre réduit de fonctionnalités QoS sont activées par défaut. Ce diagramme affiche une vue générale QoS de l'architecture du commutateur :

/image/gif/paws/91862/cat3750-qos-config2.gif

Voici un résumé des points du diagramme :

  • Les fonctionnalités QoS en entrée telles que la classification, le marquage et la réglementation peuvent être configurés en fonction de chaque port.

  • Les tables de MAP d'entrée et la file d'attente en entrée peuvent être configurées de manière globale. En revanche, ces dernières ne peuvent pas être configurées en fonction de chaque port.

  • SRR pour la file d'attente en entrée peut être configuré globalement.

  • La largeur de bande d'anneau de la pile dépend du câblage de pile. Si la pile est connectée avec une largeur de bande maximale, la largeur de bande reçue est de 32 Gbits. Cette largeur de bande est partagée par tous les commutateurs de la pile.

  • Des tables de MAP de sortie et les files d'attente de sortie sont configurées globalement. Vous pouvez avoir deux ensembles de configurations de file d'attente et appliquer l'un ou l'autre à un port.

  • SRR pour la file d'attente de sortie peut être configuré par port.

Fonctionnalités QoS en entrée

Cette section explique les concepts liés aux différentes configurations possibles de la QoS en entrée. Les thèmes suivants sont abordés :

Configuration par défaut QoS en entrée

Voici la manière dont le commutateur traite par défaut les trames après l'activation de QoS :

  • Une trame entre dans le port du commutateur et n'est pas marquée (ce port est donc un port d'accès. La trame qui entre dans le commutateur n'a pas d'encapsulation ISL ou dot1q).

  • Le commutateur encapsule la trame avec dot1q (ignorez ISL car dot1q est défini par défaut sur tous les nouveaux commutateurs).

  • Dans le marquage de trame dot1q, trois bits appelés bits de priorité 802.1p ou CoS sont disponibles. Ces bits sont définis sur 0.

  • Puis, le commutateur calcule la valeur DSCP d'après la table de MAP COS-DSCP. Selon la table, le commutateur place la valeur DSCP à 0. valeurs DSCP se trouve à l'en-tête IP du paquet.

En résumé, la CoS et les valeurs DSCP de la trame entrent dans le commutateur en étant définis par défaut sur 0, si la QoS est activée sur le commutateur.

Classification et marquage

À la différence des routeurs, la classification QoS et le marquage agissent différemment dans les commutateurs Cisco Catalyst. Dans les routeurs Cisco, vous pouvez classifier les paquets en utilisant MQC soit d'après la valeur DSCP du paquet entrant ou d'après la liste de contrôle d'accès (ACL). Cela dépend si vous faites confiance au label QoS du paquet entrant ou non. Dans le commutateur Cisco Catalyst 3750, vous pouvez classifier les trames soit d'après les valeurs entrantes CoS/DSCP ou d'après les ACL.

La configuration d'après la valeur CoS/DSCP peut être définie de trois manières différentes :

Vous pouvez utiliser l'une ou l'autre de ces trois méthodes. Vous ne pouvez pas utiliser plus d'une méthode dans un port. Par exemple, vous avez configuré la commande mls qos trust cos sur un port. Quand vous configurez le port avec la commande service-policy input <policy-map-name>, la commande mls qos trust cos est supprimée automatiquement.

La section Classification et marquage en fonction des ports explique la configuration basée sur les ports.

La section Classification et marquage en fonction de MQC explique la classification basée sur MQC.

Classification et marquage en fonction des ports

Cette section explique la classification basée sur une configuration spécifique d'interface. Le title de la section Classification et marquage peut amener à s'interroger. En effet, dans les commutateurs Cisco Catalyst 3750, les valeurs CoS ou DSCP des trames (paquet dans la trame) sont identifiées à partir des tables de MAP. Les tables de MAP ne sont pas disponibles dans les routeurs Cisco. Elles sont uniquement disponibles dans les commutateurs Cisco Catalyst. Leurs fonctionnalités seront expliquées dans la section qui suit.

Deux configurations sont traitées :

/image/gif/paws/91862/cat3750-qos-config3.gif

Classification - Configuration de la confiance accordée aux ports

Un paquet ou une trame entrants peuvent déjà avoir une étiquette attribuée. Les questions suivantes se posent :

  • Faites-vous confiance à l'étiquette QoS du paquet/trame entrants sur un port ?

  • Si un téléphone IP et un PC sont connectés à un port, faites-vous confiance à leurs étiquettes QoS ?

Si vous ne faites pas confiance aux étiquettes QoS du paquet ou de la trame entrants, vous devez classifier le paquet d'après une étiquette QoS de liste d'accès ou de marquage. Si vous faites confiance aux étiquettes QoS du paquet ou de la trame entrants, devez-vous faire confiance aux valeurs CoS ou DSCP du paquet ou de la trame entrants sur un port ? Tout dépend du scenario envisagé. Les différents scénarios possibles sont illustrés par des exemples dans cette section.

Les options de configuration de confiance accordée aux ports sont les suivantes :

Switch(config-if)#mls qos trust ?
  cos            cos keyword
  device         trusted device class
  dscp           dscp keyword
  ip-precedence  ip-precedence keyword
  <cr>
  • Exemple 1 : Si le port est un port d'accès ou de la couche 3, vous devez configurer la commande mls qos trust dscp. Vous ne pouvez pas utiliser la commande mls qos trust cos car la trame issue du port d'accès ou du port de couche 3 ne contient pas de marquage dot1q ou ISL. Les bits de CoS sont présents dans la trame dot1q ou ISL uniquement.

    interface GigabitEthernet1/0/1
     description **** Layer 3 Port ****
     no switchport
     ip address 192.168.10.1 255.255.255.0
     mls qos trust dscp
    end
    interface GigabitEthernet1/0/2
     description **** Access Port ****
     switchport access vlan 10
     switchport mode access
     mls qos trust dscp
    end
  • Exemple 2 : Si le port est un port de jonction, vous pouvez configurer les commandes mls qos trust cos ou mls qos trust dscp. La table de MAP DSCP/CoS est utilisée pour calculer la valeur de CoS si le port est configuré pour faire confiance à DSCP. La table de MAP DSCP/CoS est utilisée pour calculer la valeur DSCP si le port est configuré pour faire confiance à CoS.

    interface GigabitEthernet1/0/3
    description **** Trunk Port ****
    switchport trunk encapsulation dot1q
    switchport mode trunk
    switchport trunk native vlan 5
    switchport trunk allowed vlan 5,10,20,30,40,50
    mls qos trust cos
    end
    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     spanning-tree portfast
    end
    
    !--- The Cisco IP Phone uses IEEE 802.1Q frames for Voice 
    !--- VLAN traffic.
    
    
  • Exemple 3 : Si le port est un port de jonction dot1q et configuré avec la commande mls qos trust cos, les trames du VLAN natif auront des valeurs CoS et DSCP définies sur 0. Puisque les trames du VLAN natif ne sont marquées qu'après leur entrée dans le commutateur, ce dernier définira la valeur CoS par défaut sur 0, et la table CoS-to-DSCP définira la valeur DSCP par défaut sur 0.

    Remarque: La valeur DSCP du paquet provenant du VLAN natif sera réinitialisée à 0.

    Vous pouvez également configurer le port de commutation pour modifier la valeur CoS des trames non-marquées de 0 à toutes les autres valeurs entre 0 et 7, à l'aide de la commande mls qos cos<0-7>. Cette commande ne change pas les valeurs CoS des trames marquées.

    Par exemple, le port GigabitEthernet1/0/12 est configuré avec le VLAN d'accès 10 et le VLAN vocal 20.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     spanning-tree portfast
    
    !--- The Cisco IP Phone uses IEEE 802.1Q frames for Voice 
    !--- VLAN traffic. Voice VLAN is only supported on access ports and not  
    !--- on trunk ports, even though the configuration is allowed.
    
    end

    Par défaut, le PC envoie des données non-marquées. Le trafic non marqué du périphérique relié au téléphone Cisco IP est inchangé lors de son passage dans le téléphone, et ce indépendamment de l'état de confiance accordé au port d'accès sur le téléphone. Le téléphone envoie des trames marquées dot1q avec l'ID de VLAN vocal 20. Par conséquent, si vous configurez le port avec la commande mls qos trust cos, le port fait confiance aux valeurs CoS des trames du téléphone (les trames marquées) et définit sur 0 la valeur CoS des trames (non-marquées) provenant du PC. Ensuite, la table de MAP de CoS-DSCP définit sur 0 la valeur DSCP du paquet à l'intérieur de la trame car la table de MAP CoS-DSCP a une valeur de 0 pour la valeur 0 de CoS. Si les paquets provenant du PC ont une valeur DSCP spécifique, cette valeur sera réinitialisée à 0. Si vous configurez la commande mls qos cos 3 sur le port, le port définit sur 3 la valeur CoS de toutes les trames provenant du PC et ne modifie pas la valeur CoS des trames provenant du téléphone.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     mls qos cos 3
     spanning-tree portfast
    end

    Si vous configurez le port avec la commande mls qos cos 3 override, le port définit sur 3 les valeurs CoS de toutes les trames (marquées ou non). Il ne tient pas compte des valeurs de confiance précédemment configurées.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     mls qos cos 3 override
    
    !--- Overrides the mls qos trust cos.
    
    
    !--- Applies CoS value 3 on all the incoming packets on both 
    !--- the vlan 10 and 20.
    
     spanning-tree portfast
    end
  • Exemple 4 : Par exemple, observez la configuration de port gi 1/0/12 :

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     spanning-tree portfast
    end

    Si le PC marque sa trame avec le VLAN 20, il définit également sur 5 la valeur CoS. Le commutateur traite le trafic de données marquées (trafic dans les types de trames IEEE 802.1Q ou IEEE 802.1p) du périphérique relié au port d'accès sur le téléphone IP Cisco. Puisque l'interface est configurée pour faire confiance à la valeur CoS, tout trafic reçu par le port d'accès du téléphone IP Cisco reste inchangé lors de son passage dans le téléphone. Le commutateur autorise et fait confiance au trafic du PC et lui accorde la même priorité qu'au trafic du téléphone IP. Ce n'est pas le résultat généralement souhaité. Ceci peut être évité utilisant la commande switchport priority extend cos <cos-value>.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     switchport priority extend cos 0
    
    !--- Overrides the CoS value of PC traffic to 0.
    
     spanning-tree portfast
    end

    La commande switchport priority extend cos <cos-value> permet de configurer le téléphone, tout comme le téléphone IP modifie à 0 la valeur CoS du trafic du PC.

  • Exemple 5 : Par exemple, dans la même interface, une personne se connecte au PC directement via le commutateur et marque les données du PC avec une trame dot1q de valeur CoS plus élevée. Ceci peut être évité utilisant la commande mls qos trust device cisco-phone.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     switchport priority extend cos 0
     mls qos trust device cisco-phone 
    
    !--- Specify that the Cisco IP Phone is a trusted device.
    
     spanning-tree portfast
    end
  • Exemple 6 : Par exemple, dans l'interface GigabitEthernet1/0/12, vous devez faire confiance aux étiquettes QoS du PC. En outre, le PC est connecté au VLAN indigène 10. dans ce cas, le cos de mls qos trust que la commande n'aide pas parce que le paquet PC n'étiquette pas la valeur CoS. Seule la valeur DSCP sera marquée. Par conséquent, le commutateur ajoute la trame dot1q et configure la valeur CoS par défaut sur 0. Ensuite, la table CoS-DSCP calcule et réinitialise la valeur DSCP à 0.

    Afin de remédier à ce problème, vous avez deux possibilités. Il est possible de configurer la classification et le marquage à l'aide de MQC. Vous pouvez créer une ACL correspondant au trafic de votre PC reprenant les adresses IP source et de destination ainsi que les numéros des ports source et de destination. A l'aide de class-map, vous pouvez par conséquent faire correspondre cette liste d'accès. Vous pouvez créer un policy-map pour faire confiance à ce trafic. Cette solution sera traitée dans la section suivante. La seconde méthode y sera également abordée. Cette seconde méthode consiste à faire confiance à l'étiquette DSCP au lieu de la valeur CoS. Ensuite, l'étiquette DSCP-Cos calcule et défini la valeur CoS correspondant à la valeur DSCP.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust dscp
     spanning-tree portfast
    end

    La première méthode est la plus utilisée car il est déconseillé de faire confiance à toutes les étiquettes QoS du trafic du PC.

Marquage - Configuration des tables de MAP QoS

Après que la QoS soit activé, les tables de MAP sont créées avec les valeurs par défaut, puis sont activées.

Distribution1#show mls qos maps cos-dscp
   Cos-dscp map:
        cos:   0  1  2  3  4  5  6  7
     --------------------------------
       dscp:   0  8 16 24 32 40 48 56

Distribution1#show mls qos maps dscp-cos
   Dscp-cos map:
     d1 :  d2 0  1  2  3  4  5  6  7  8  9
     ---------------------------------------
      0 :    00 00 00 00 00 00 00 00 01 01
      1 :    01 01 01 01 01 01 02 02 02 02
      2 :    02 02 02 02 03 03 03 03 03 03
      3 :    03 03 04 04 04 04 04 04 04 04
      4 :    05 05 05 05 05 05 05 05 06 06
      5 :    06 06 06 06 06 06 07 07 07 07
      6 :    07 07 07 07
  • Exemple 1 : Si le port est configuré pour faire confiance à CoS, toutes les valeurs CoS entrantes sont acceptées et les valeurs DSCP sont identifiées à partir de la table CoS-DSCP. Les valeurs, d'après la configuration CoS-DSCP, sont mappées comme suit :

    Cos DSCP (décimal) DSCP
    0 0 Par défaut
    1 8 CS1
    2 16 CS2
    3 24 CS3
    4 32 CS4
    5 40 CS5
    6 48 CS6
    7 56 CS7

    Une valeur importante à noter ici est la valeur de DSCP correspondant à la valeur CoS 5. Il s'agit de CS5. L'exemple 2 traite de cette valeur.

  • Exemple 2 : Par exemple, l'interface GigabitEthernet1/0/12 est configurée pour faire confiance à CoS.

    interface GigabitEthernet1/0/12
     description **** Cisco IP Phone  ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 20
     mls qos trust cos
     spanning-tree portfast
    end

    Le téléphone IP Cisco marque la charge utile vocale avec le CoS 5 et DSCP EF quand il envoie le trafic au commutateur. Lorsque le trafic entre dans le port Gi 1/0/12, le commutateur fait confiance à la valeur CoS. Ensuite, le commutateur calcule la valeur DCSP CS5 (40) pour obtenir la valeur CoS 5 à partir de la table de CoS-DSCP. Toutes les charges utiles vocales avec CoS 5 sont identifiées par la valeur CS5 de DSCP. Ce n'est pas la valeur souhaitée. La valeur DSCP requise pour la charge utile vocale est DSCP EF. Par défaut, les autres valeurs CoS vers DSCP sont correctement mappées d'après le RFC.

    Cette configuration permet de définir la table de mappage CoS-DSCP pour changer la valeur de DSCP EF correspondant à CoS 5.

    Distribution1(config)# mls qos map cos-dscp 0  8 16 
    24 32 46 48 56
    
    !--- DSCP 46 is EF
    
    

    Avec cette configuration, les valeurs sont ensuite mappées comme suit :

    Cos DSCP (décimal) DSCP
    0 0 Par défaut
    1 8 CS1
    2 16 CS2
    3 24 CS3
    4 32 CS4
    5 46 E-F
    6 48 CS6
    7 56 CS7

  • Exemple 3 : Si le port est configuré pour faire confiance à DSCP, toutes les valeurs DSCP entrantes sont acceptées et les valeurs CoS sont identifiées à partir de la table DSCP-CoS. Les valeurs, d'après la configuration DSCP-CoS, sont mappées comme suit :

    DSCP DSCP (décimal) Cos
    Par défaut 0-7 0
    CS1 AF11 AF12 AF13 8-15 1
    CS2 AF21 AF22 AF23 16-23 2
    CS3 AF31 AF32 AF33 24-31 3
    CS4 AF41 AF42 AF43 32-39 4
    CS5 E-F 40-47 5
    CS6 48-55 6
    CS7 56-63 7

    Vous n'avez pas besoin de changer ces valeurs par défaut.

Ce tableau récapitule les valeurs de DSCP et des valeurs de CoS uniquement pour référence :

DSCP (décimal) DSCP Cos
0 Par défaut 0
     
8 CS1 1
10 AF11 1
12 AF12 1
14 AF13 1
     
16 CS2 2
18 AF21 2
20 AF22 2
22 AF23 2
     
24 CS3 3
26 AF31 3
28 AF32 3
30 AF33 3
     
32 CS4 4
34 AF41 4
36 AF42 4
38 AF43 4
     
40 CS5 5
42   5
44   5
46 E-F 5
     
48 CS6 6
     
56 CS7 7

Remarque: Dans un réseau, tous les commutateurs Cisco Catalyst devraient avoir des tables de MAP identiques. Les différentes valeurs de table de mappage dans différents commutateurs entraînent des effets indésirables avec QoS.

Classification et marquage en fonction de MQC

Comme décrit dans la section Classification et marquage, vous pouvez utiliser MQC pour classifier et marquer le paquet. Vous pouvez utiliser MQC au lieu de la configuration spécifique au port. Vous pouvez également marquer les paquets entrants avec le policy-map.

Les éléments suivants ont servi aux besoins de l'exemple :

  • Faites confiance aux valeurs CoS du trafic du téléphone IP.

  • Marquez la valeur DSCP des paquets d'application du logiciel du téléphone à partir du PC relié au téléphone IP.

  • Ne faites pas confiance aux autres trafics provenant du PC.

cat3750-qos-config4.gif

Ce diagramme montre qu'un policy-map est attaché à l'entrée de l'interface. Vous ne pouvez pas appliquer un policy-map à la sortie d'une interface dans le commutateur Catalyst 3750. La configuration suivante représente le diagramme. Cette section ne traite pas des détails de la partie de mise en file d'attente de la fonctionnalité QoS. Ici, le sujet aborde uniquement l'application de MQC sur une interface.

Le VLAN de données supposé est 10 et son adresse de sous-réseau est 172.16.10.0/24. Le VLAN voix est 100 et son adresse de sous-réseau est 192.168.100.0/24.


!--- Section A

Distribution1(config)#ip access-list extended voice-traffic
Distribution1(config-std-nacl)#permit ip 192.168.100.0 0.0.0.255 any

Distribution1(config-std-nacl)#ip access-list extended
 database-application
Distribution1(config-ext-nacl)#permit tcp any any eq 1521
Distribution1(config-ext-nacl)#permit tcp any any eq 1810
Distribution1(config-ext-nacl)#permit tcp any any eq 2481
Distribution1(config-ext-nacl)#permit tcp any any eq 7778
Distribution1(config-ext-nacl)#exit

Distribution1(config)#class-map  Class-A
Distribution1(config-cmap)#match access-group name voice-traffic
Distribution1(config-cmap)#exit
Distribution1(config)#class-map  Class-B
Distribution1(config-cmap)#match access-group name
 database-application
Distribution1(config-cmap)#exit


!--- Section B

Distribution1(config)#policy-map sample-policy1
Distribution1(config-pmap)#class Class-A
Distribution1(config-pmap-c)#trust cos
Distribution1(config-pmap-c)#exit
Distribution1(config-pmap)#class Class-B
Distribution1(config-pmap-c)#set dscp af21
Distribution1(config-pmap-c)#exit
Distribution1(config-pmap)#exit


!--- Section C

Distribution1(config)#interface gigabitEthernet 1/0/13
Distribution1(config-if)#switchport access vlan 10
Distribution1(config-if)#switchport mode access
Distribution1(config-if)#switchport voice vlan 100
Distribution1(config-if)#spanning-tree portfast
Distribution1(config-if)#service-policy input sample-policy1
Distribution1(config-if)#exit

Section A :

  • Classifie le trafic du téléphone IP comme étant de Classe A. Le téléphone IP appartient au VLAN vocal et a une adresse IP dans le sous-réseau 192.168.100.0.

  • Classifie le trafic d'application de base de données comme étant de Classe B. Les trafics du PC (n'importe quel trafic, d'après la configuration) envoyés à n'importe quelle destination et avec les numéros de port 1521, 1810, 2481, 7778, sont classifiés dans la class-map de Classe B.

Section B :

  • Les trafics de Classe 1 sont configurés de manière à faire confiance à l'étiquette CoS. Ceci signifie que les valeurs CoS de l'ensemble du trafic du téléphone IP sont acceptées. D'après le diagramme, la valeur DSCP est calculée à partir de la table de mappage CoS-DSCP pour le trafic de Classe A.

  • Les trafics de Classe B sont configurés de manière à définir la valeur DSCP à AF21. D'après le diagramme, la valeur CoS est calculée à partir de la table de MAP de DSCP-CoS pour le trafic de Classe B.

  • Les configurations sous chaque classe de policy-map sont appelées les actions PHB. Le marquage, la file d'attente, la réglementation, le shaping et la prévention de congestion sont les actions PHB prises en charge dans les routeurs Cisco. Le marquage et la réglementation sont les seules actions PHB prises en charge dans les commutateurs Cisco Catalyst 3750.

    Distribution1(config)#policy-map test
    Distribution1(config-pmap)#class test
    Distribution1(config-pmap-c)#?
    QoS policy-map class configuration commands:
      exit            Exit from QoS class action configuration mode
      no              Negate or set default values of a command
      police          Police
      service-policy  Configure QoS Service Policy
      set             Set QoS values
      trust           Set trust value for the class
      <cr>

    Les commandes set et trust sont des actions PHB de Marquage. Vous pouvez configurer les actions PHB set ou trust. Vous ne pouvez pas configurer les deux actions dans une classe de policy-map. Vous pouvez cependant configurer set dans une classe et trust dans une autre classe, au sein de la policy-map.

    La commande police correspond à l'action PHB Réglementation. Le sujet est abordé dans la section suivante.

    Le shaping n'est pas pris en charge dans les commutateurs Cisco Catalyst 3750. La file d'attente et la prévention de congestion sont prises en charge dans les commutateurs Cisco Catalyst 3750, mais ne sont pas configurables avec MQC. Les configurations de file d'attente et de prévention de congestion sont traitées en détail plus loin dans ce document.

Section C :

  • Le policy-map peut être appliqué seulement à l'entrée de l'interface. En l'activant à la sortie de l'interface, le message d'erreur suivant apparaît :

    Distribution1(config)#int gi 1/0/3
    Distribution1(config-if)#service-policy output test
    Warning: Assigning a policy map to the output side of an
             interface not supported
    
    Service Policy attachment failed
    Warning: Assigning a policy map to the output side of an
             interface not supported
  • Si d'autres QoS méthodes de classification, notamment en fonction du port ou du VLAN, sont configurées sur le port gi 1/0/3, ces configurations sont retirées quand vous appliquez le policy-map. Par exemple, le port Gi 1/0/13 est configuré pour faire confiance au CoS comme illustré ici :

    interface GigabitEthernet1/0/13
     description **** Access Port ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
     mls qos cos 3
     mls qos trust cos
     spanning-tree portfast
  • Quand vous appliquez le policy-map à l'interface, il retire la commande trust.

    Distribution1(config)#int gi 1/0/13
    Distribution1(config-if)#service-policy input sample-policy1
    Distribution1(config-if)#do show run int gi 1/0/13
    Building configuration...
    
    Current configuration : 228 bytes
    !
    interface GigabitEthernet1/0/13
     description **** Access Port ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
     service-policy input sample-policy1  
     
    !--- It replaces the mls qos trust or mls qos 
    !--- vlan-based command.
    
     mls qos cos 3    
     
    !--- This command is not removed.
    
     spanning-tree portfast
    end

    Vous pouvez voir que la commande service-policy input substitue uniquement la commande mls qos trust ou mls qos vlan-based. Il ne change pas les autres commandes, telles que mls qos cos ou mls qos dscp-mutation. En résumé, il substitue la commande de classification QoS et ne substitue pas les commandes QoS de marquage.

  • Dans le policy-map, vous voyez seulement deux class-map. La Classe A correspond au trafic du téléphone IP et la Classe B correspond au trafic d'application de base de données du PC. Tout autre trafic de PC (sauf le trafic d'application de base de données défini dans la liste d'accès) est classifié sous la classe "Classe par défaut" du policy-map. Il s'agit d'un trafic de relai qui récupère le trafic ne correspondant pas aux class-map liés au policy-map. Par conséquent, la confiance n'est pas accordée par le port à ce trafic appartenant à la classe par défaut. Les paquets de ce trafic sont définis sur 0 avec les étiquettes CoS et DSCP par défaut. Vous pouvez choisir de définir n'importe quelle valeur CoS ou DSCP par défaut pour ce trafic de classe par défaut.

    Vous pouvez définir la valeur DSCP par défaut utilisant MQC. La valeur CoS est calculée à partir de la table de MAP de DSCP-CoS.

    Distribution1(config)#policy-map sample-policy1
    Distribution1(config-pmap)#class class-default
    Distribution1(config-pmap-c)#set dscp af13
    Distribution1(config-pmap-c)#exit
    

    Vous pouvez définir la valeur CoS par défaut comme décrit ici. La valeur DSCP est calculée à partir de la table de MAP de CoS-DSCP.

    Distribution1(config)#int gi 1/0/13
    Distribution1(config-if)#mls qos cos 3
    Distribution1(config-if)#do show run int gi 1/0/13
    Building configuration...
    
    Current configuration : 228 bytes
    !
    interface GigabitEthernet1/0/13
     description **** Access Port ****
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
     service-policy input sample-policy1  
     mls qos cos 3    
     spanning-tree portfast

Placez le plus prioritaire au trafic

Dans cet exemple, la configuration est utilisée pour placer le plus prioritaire au trafic du port TCP 1494.

  1. Le trafic VoIP doit être assigné une valeur DSCP d'E-F :

    
    !--- Classifying all traffic coming with dscp value of EF 
    !--- under this class-map.
    
    Switch(config)# class-map match-all AutoQoS-VoIP-RTP-Trust
    Switch(config-cmap)# match ip dscp ef 
    
    Switch(config)# policy-map AutoQoS-Police-CiscoPhone
    Switch(config-pmap)# class AutoQoS-VoIP-RTP-Trust
    
    !--- Again setting the dscp value back to EF.
    
    Switch(config-pmap-c)# set dscp ef
    Switch(config-pmap-c)# police 320000 8000 exceed-action 
    policed-dscp-transmit
    
  2. Le trafic du TCP 1494 doit être assigné une valeur DSCP de CS4 :

    Switch(config)# access-list 100 permit tcp <source source-wildcard>
                 <destination destination-wildcard> eq 1494
    
    Switch(config)# class-map tcp 
    Switch(config-cmap)# match access-group 100
    
    Switch(config)# policy-map AutoQoS-Police-CiscoPhone
    Switch(config-pmap)# class tcp
    Switch(config-pmap-c)# set dscp cs4
    
  3. Tout autre trafic doit être assigné CS3 :

    Switch(config)# access-list 200 permit ip any any
    
    Switch(config)# class-map default
    Switch(config-cmap)# match access-group 200
    
    Switch(config)# policy-map AutoQoS-Police-CiscoPhone
    Switch(config-pmap)# class default
    Switch(config-pmap-c)# set dscp cs3
    
  4. Appliquez-le sous des interfaces appropriées :

    Switch(config)# interface <interface-type><interface number>
    
    Switch(config-if)# service-policy <policy-map-name>
    
    

Maintien de l'ordre

Sur les commutateurs Cisco Catalyst 3750, la réglementation peut seulement être configurée sur le port en entrée. La réglementation peut seulement être configurée via MQC. Ceci signifie qu'aucune commande spécifique d'interface n'existe pour réglementer le trafic. Vous pouvez configurer la réglementation dans le policy-map et vous pouvez appliquer le policy-map uniquement à l'aide de la commande service-policy input <policy-name>. Vous ne pouvez appliquer aucun policy-map à la sortie de l'interface.

Distribution1(config-if)#service-policy output test
police command is not supported for this interface
Configuration failed!
Warning: Assigning a policy map to the output side of an 
         interface not supported.

Cette section traite des sujets suivants :

Classification, marquage et réglementation (excès - rejet)

Ceci explique la configuration de la réglementation pour le rejet du trafic excessif. La réglementation permet de mesurer le trafic entrant et met à jour le débit d'entrée par seconde des buts configurés. Le commutateur Cisco Catalyst 3750 prend seulement en charge la réglementation à débit et compartiment uniques. Ceci signifie que le commutateur mesure à un débit unique et utilise deux couleurs pour représenter un trafic conforme ou excessif. Le diagramme montre un policy-map sample-policy2 avec trois class-map.

Les éléments suivants ont servi aux besoins de l'exemple :

  • Réglementation ftp, pop3, trafic IMAP à 10Mbps.

  • Faites confiance à la valeur DSCP des paquets d'application du communicateur IP provenant du PC connecté au téléphone IP. En outre, il convient de réglementer ce trafic à 1 Mbps.

  • Marquez et réglementez l'application Filnet.

cat3750-qos-config5.gif

Cette configuration représente le policy-map mentionné dans le diagramme :


!--- Create Access-list and Class map Class-A

Distribution1(config)#ip access-list extended BULK-DATA
Distribution1(config-ext-nacl)#permit tcp any any eq ftp
Distribution1(config-ext-nacl)#permit tcp any any eq ftp-data
Distribution1(config-ext-nacl)#permit tcp any any eq pop3
Distribution1(config-ext-nacl)#permit tcp any any eq 143
Distribution1(config-ext-nacl)#exit

Distribution1(config)#class-map Class-A
Distribution1(config-cmap)#match access-group name BULK-DATA
Distribution1(config-cmap)#exit


!--- Create Access-list and Class map Class-B

Distribution1(config)#ip access-list extended IP-Communicator
Distribution1(config-ext-nacl)#remark *** Voice Payload ***
Distribution1(config-ext-nacl)#permit udp any any range 16384 32767
Distribution1(config-ext-nacl)#remark *** Voice Signalling ***
Distribution1(config-ext-nacl)#permit tcp any any range 2000 2002
Distribution1(config-ext-nacl)#exit

Distribution1(config)#class-map Class-B
Distribution1(config-cmap)#match access-group name IP-Communicator
Distribution1(config-cmap)#exit


!--- Create Access-list and Class map Class-C

Distribution1(config)#ip access-list extended application
Distribution1(config-ext-nacl)#remark *** Application for example ***
Distribution1(config-ext-nacl)#permit tcp any any eq 32768
Distribution1(config-ext-nacl)#permit udp any any eq 32768
Distribution1(config-ext-nacl)#permit tcp any any eq 32769
Distribution1(config-ext-nacl)#permit udp any any eq 32769
Distribution1(config-ext-nacl)#exit

Distribution1(config)#class-map Class-C
Distribution1(config-cmap)#match access-group name application
Distribution1(config-cmap)#exit


!--- Create Policy map

Distribution1(config-cmap)#policy-map sample-policy2
Distribution1(config-pmap)#class Class-A
Distribution1(config-pmap-c)#police 10000000 8000 exceed-action drop
Distribution1(config-pmap-c)#class Class-B
Distribution1(config-pmap-c)#trust dscp
Distribution1(config-pmap-c)#police 256000 8000 exceed-action drop
Distribution1(config-pmap-c)#class Class-C
Distribution1(config-pmap-c)#set dscp CS2
Distribution1(config-pmap-c)#police 25000000 8000 exceed-action drop
Distribution1(config-pmap-c)#exit
Distribution1(config-pmap)#exit


!--- Apply Policy map to the interface

Distribution1(config)#interface GigabitEthernet1/0/20
Distribution1(config-if)#service-policy input sample-policy2

La configuration dans le policy-map est expliquée ici :

  • Classe A : Le trafic de Classe A est réglementé à un débit de 10 Mbps. Les étiquettes QoS sur le trafic de classe A ne sont pas fiables. Les valeurs CoS et DSCP sont marqués comme égales à 0. Les paquets excessifs sont rejetés par le régulateur.

  • Classe B : Deux actions PHB sont exécutées sur le trafic de classe B correspondante. L'une correspond à la définition du niveau de confiance et l'autre correspond à la réglementation. La confiance est accordée à la valeur DSCP du trafic de Classe B. La valeur CoS sera calculée à partir de la table DSCP-CoS. Ensuite, le trafic de classe B est réglementé à un débit de 256 Kbps. Les paquets excessifs sont rejetés par le régulateur.

  • Classe C : Deux actions PHB sont exécutées sur le trafic de classe B correspondante. L'une correspond au marquage et l'autre correspond à la réglementation. Les paquets entrant correspondant à la classe C sont identifiés par la valeur DSCP CS2. La valeur CoS est calculée à partir de la table de DSCP-CoS, qui est de 2. Ensuite, le trafic de classe C est réglementé à un débit de 25 Mbps. Les paquets excessifs sont rejetés par le régulateur.

Classification, marquage et réglementation (excès - transmission DSCP réglementé)

Cette section décrit la configuration de la réglementation chargée du marquage et de la transmission du trafic excessif. Ce diagramme montre un policy-map sample-policy3 avec deux class-map :

/image/gif/paws/91862/cat3750-qos-config6.gif

Le commutateur marque le trafic excédant la réglementation configurée sur base des valeurs de DSCP réglementé de table de MAP. Le MAP de DSCP réglementé s'utilise uniquement lorsqu'il est défini dans la configuration de la réglementation. La table de mappage de DSCP réglementé est présentée ci-dessous :

Distribution1(config)#do show mls qos map policed-dscp
   Policed-dscp map:
     d1 :  d2 0  1  2  3  4  5  6  7  8  9
     ---------------------------------------
      0 :    00 01 02 03 04 05 06 07 08 09
      1 :    10 11 12 13 14 15 16 17 18 19
      2 :    20 21 22 23 24 25 26 27 28 29
      3 :    30 31 32 33 34 35 36 37 38 39
      4 :    40 41 42 43 44 45 46 47 48 49
      5 :    50 51 52 53 54 55 56 57 58 59
      6 :    60 61 62 63

Dans cette table, vous pouvez voir que les mêmes valeurs DSCP correspondent. Par exemple, DSCP 34 est mis en correspondance avec DSCP 34. Le trafic en conformité avec le débit du régulateur est transmis sans altération de la valeur DSCP. Le trafic dépassant le débit du régulateur peut être transmis avec une valeur DSCP différente. Par exemple, il peut être marqué par la valeur DSCP la plus à même d'être rejetée.

Si vous utilisez les valeurs par défaut du DSCP réglementé, la réglementation n'est d'aucune utilité. Par exemple, vous avez configuré la régulation du trafic avec un débit de 10 Mbps. Le paquet entrant a la valeur DSCP de CS4. En conservant la valeur DSCP par défaut, le trafic en conformité avec le débit de 10 Mbps est transmis avec une valeur DSCP de CS2. En outre, le trafic qui dépasse les 10 Mbps est transmis avec une valeur DSCP de CS2. En effet, les valeurs du DSCP réglementé par défaut mappent les mêmes valeurs. Par conséquent, il est recommandé de configurer convenablement la table de mappage de DSCP réglementée afin de différencier les valeurs DSCP.

Les éléments suivants ont servi aux besoins de l'exemple :

  • Configurez la table de mappage de DSCP réglementée pour mapper :

    • EF à AF31

    • CS3 à AF13

    • CS2 à AF11

  • Faites confiance aux valeurs DSCP des paquets du communicateur IP et réglementez-les à 256 Kbps. Si le trafic dépasse les 256 Kbps, effectuez à nouveau un marquage des valeurs DSCP à l'aide de la table de MAP de DSCP réglementé.

  • Marquez et réglementez l'application Filnet. Si le trafic dépasse les 256 Mbps, effectuez à nouveau un marquage des valeurs DSCP à l'aide de la table de MAP de DSCP réglementé.

Cette configuration représente le policy-map mentionné dans le diagramme :


!--- Policed DSCP table Configuration

Distribution1(config)#mls qos map policed-dscp 46 to 26
Distribution1(config)#mls qos map policed-dscp 24 to 14
Distribution1(config)#mls qos map policed-dscp 16 to 10


!--- Create Access-list and Class map Class-A

Distribution1(config)#ip access-list extended IP-Communicator
Distribution1(config-ext-nacl)#remark *** Voice Payload ***
Distribution1(config-ext-nacl)#permit udp any any range 16384 32767
Distribution1(config-ext-nacl)#remark *** Voice Signalling ***
Distribution1(config-ext-nacl)#permit tcp any any range 2000 2002
Distribution1(config-ext-nacl)#exit

Distribution1(config)#class-map Class-A
Distribution1(config-cmap)#match access-group name IP-Communicator
Distribution1(config-cmap)#exit


!--- Create Access-list and Class map Class-C

Distribution1(config)#ip access-list extended application
Distribution1(config-ext-nacl)#remark *** Application for example ***
Distribution1(config-ext-nacl)#permit tcp any any eq 32768
Distribution1(config-ext-nacl)#permit udp any any eq 32768
Distribution1(config-ext-nacl)#permit tcp any any eq 32769
Distribution1(config-ext-nacl)#permit udp any any eq 32769
Distribution1(config-ext-nacl)#exit

Distribution1(config)#class-map Class-B
Distribution1(config-cmap)#match access-group name application
Distribution1(config-cmap)#exit


!--- Create Policy map

Distribution1(config-cmap)#policy-map sample-policy3
Distribution1(config-pmap-c)#class Class-A
Distribution1(config-pmap-c)#trust dscp
Distribution1(config-pmap-c)#police 256000 8000 exceed-action 
policed-dscp-transmit
Distribution1(config-pmap-c)#class Class-B
Distribution1(config-pmap-c)#set dscp CS2
Distribution1(config-pmap-c)#police 25000000 8000 exceed-action 
policed-dscp-transmit
Distribution1(config-pmap-c)#exit
Distribution1(config-pmap)#exit


!--- Apply Policy map to the interface

Distribution1(config)#interface GigabitEthernet1/0/21
Distribution1(config-if)#service-policy input sample-policy3

La configuration dans le policy-map est expliquée ici :

  • DSCP réglementé : Trois valeurs sont modifiées dans la table de MAP de DSCP réglementé.

    • EF à AF31

    • CS3 à AF13

    • CS2 à AF11

    Les deux premières valeurs sont modifiées sur base des types de trafic classifiés dans les class-map de classe A et B.

  • Classe A : La charge utile vocale et le contrôle de voix du logiciel du téléphone sont classifiés dans la class map Classe A. La charge utile vocale a une valeur DSCP de EF, et le contrôle de voix une valeur DSCP de CS3. Selon la configuration de policy-map, la confiance est ou non accordée à ces valeurs DSCP. Le trafic est réglementé à un débit de 256 Kbps. Le trafic en conformité avec ce débit sera envoyé avec la valeur DSCP entrante. Le trafic dépassant ce débit sera de nouveau marqué par la table de DSCP réglementé puis transmis. La table de DSCP réglementé marquera de nouveau EF par AF31 et CS3 avec AF13 d'après les valeurs configurées. Puis, les valeurs CoS qui correspondent seront calculées à partir de la table DSCP-CoS.

  • Classe B : Les paquets entrants qui correspondent à la classe B sont marqués avec une valeur DSCP de CS2. Le trafic de classe B est réglementé à un débit de 25 Mbps. Le trafic qui se conforme à ce débit sera envoyé avec la valeur DSCP de 2 et la valeur CoS sera dérivée de la table DSCP-CoS qui est de 2. Le trafic dépassant ce débit sera de nouveau marqué par la table de DSCP réglementé puis transmis. La table de DSCP réglementé marquera de nouveau EF par AF31 et CS3 avec AF13 d'après les valeurs configurées. Puis, les valeurs CoS qui correspondent seront calculées à partir de la table DSCP-CoS.

Gestion et prévention de congestion

La gestion et la prévention de débordement font partie d'un processus en trois étapes. Les étapes sont : mise en file d'attente, rejet et planification. La mise en file d'attente place paquets dans les différentes files d'attente de logiciel à l'aide des étiquettes QoS. Le commutateur Cisco Catalyst 3750 dispose de deux files d'attente en entrée. Une fois classifié et marqué avec des étiquettes QoS, le trafic peut être transféré dans deux files d'attente distinctes par le biais des étiquettes QoS.

WTD (Weighted Tail Drop) est utilisé pour gérer la longueur des files d'attente et fournir des priorités de rejet pour les différentes classifications de trafic.

Les files d'attente d'entrée et de sortie sont gérées par SRR, qui contrôle le débit d'envoi des paquets. Dans les files d'attente en entrée, SRR envoie les paquets à l'anneau de la pile. SRR peut fonctionner avec deux modes différents, le mode shaping et le mode partagé. Pour des files d'attente en entrée, le mode partagé est défini par défaut et se trouve être le seul pris en charge. En mode partagé, les files d'attente se partagent la bande passante selon les poids de file d'attente configurés. À ce niveau, une quantité de bande passante est garantie mais ne s'y limite pas.

Cette section décrit trois types de configurations.

Les commandes disponibles pour configurer ces éléments sont :

Distribution1(config)#mls qos srr-queue input ?

!--- Queueing

  buffers         Configure buffer allocation
  cos-map         Configure cos-map for a queue id
  dscp-map        Configure dscp-map for a queue id

!--- Scheduling

  bandwidth       Configure SRR bandwidth
  priority-queue  Configure priority scheduling

!--- Dropping

  threshold       Configure queue tail-drop thresholds

Configuration de la mise en file d'attente par défaut, du rejet et la planification

Cette sortie montre l'étiquette QoS par défaut pour le mappage de file d'attente. Chaque file d'attente peut prendre en charge trois niveaux seuil. Par défaut, chaque support de file d'attente dispose uniquement d'une valeur de seuil de 100%.

cat3750-qos-config7.gif

  • Configuration du MAP de file d'attente par défaut :

    Les paquets avec la CoS 5 (DSCP 40 à 47) sont placés dans la file d'attente 2. Les paquets restants sont placés dans la file d'attente 1.

    Distribution1#show mls qos maps cos-input-q
       Cos-inputq-threshold map:
                  cos:  0   1   2   3   4   5   6   7
                  ------------------------------------
      queue-threshold: 1-1 1-1 1-1 1-1 1-1 2-1 1-1 1-1
    
    Distribution1#show mls qos maps dscp-input-q
       Dscp-inputq-threshold map:
         d1 :d2  0    1    2    3    4    5    6    7    8    9
         ------------------------------------------------------------
          0 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
          1 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
          2 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
          3 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
          4 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 01-01 01-01
          5 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
          6 :  01-01 01-01 01-01 01-01

    Cette table représente le CoS/DSCP par défaut pour le mappage de file d'attente :

    Cos DSCP File d'attente en entrée
    0 0 à 7 1
    1 8 à 15 1
    2 16 à 23 1
    3 24 à 31 1
    4 32 à 39 1
    5 40 à 47 2
    6 48 à 55 1
    7 56 à 63 1

  • Configuration de la file d'attente par défaut :

    La mémoire tampon de file d'attente d'entrée est partagée 90% par la file d'attente 1 et 10% par les seuils d'avertissement de la file d'attente 2. 1, 2 et 3 sont 100%.

    Distribution1#show mls qos input-queue
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      90      10
    bandwidth :       4       4
    priority  :       0      10
    threshold1:     100     100
    threshold2:     100     100
    
  • Configuration du planificateur par défaut :

    La file d'attente 2 est la file d'attente prioritaire. SRR gère la file d'attente prioritaire dont le poids configuré est de 10%. Ensuite, SRR partage la bande passante restante (90 %) avec des files d'attente en entrée et les gère selon les poids configurés. Dans ce cas, les files d'attente 1 et 2 sont gérées avec un débit de 45 % chacune.

    Distribution1#show mls qos input-queue
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      90      10
    bandwidth :       4       4
    priority  :       0      10
    threshold1:     100     100
    threshold2:     100     100

Mise en file d'attente et planification

Trois étapes sont nécessaires pour configurer la mise en file d'attente et la planification. Les étapes sont les suivantes :

  1. Configuration du MAP de file d'attente :

    La configuration de mappage de file d'attente mappe les paquets vers les deux files d'attente en entrée sur base des valeurs DSCP ou CoS.

  2. Configuration de file d'attente :

    La configuration de la file d'attente permet de définir le coefficient (ou allocation de la quantité d'espace) à utiliser pour diviser les tampons en entrée entre les deux files d'attente.

  3. Configuration du planificateur :

    SRR se charge de la configuration du coefficient des poids, lequel contrôle la fréquence de sortie de file d'attente des paquets, des files d'attente vers l'anneau de la pile.

Les configurations de file d'attente et du planificateur contrôlent la quantité de données pouvant être mises en mémoire tampon avant le rejet des paquets.

cat3750-qos-config8.gif

Dans cette section, les niveaux de rejet de WTD ne sont pas configurés. Ce qui signifie que les paquets seront relâchés si la file d'attente est à 100%.

  • Configuration du MAP de file d'attente :

    Dans un premier temps, les valeurs CoS sont mappées sur les files d'attente. Dans cette section, les valeurs de seuil ne sont pas configurées.

    
    !--- Assign the frames into the queue based on the CoS value.
    
    Distribution1(config)#mls qos srr-queue input cos-map
     queue 1 0 1 
    Distribution1(config)#mls qos srr-queue input cos-map
     queue 2 2 3 4 5 6 7
    
    
    !--- Show output.
    
    Distribution1#show mls qos maps cos-input-q
       Cos-inputq-threshold map:
                  cos:  0   1   2   3   4   5   6   7
                  ------------------------------------
      queue-threshold: 1-1 1-1 2-1 2-1 2-1 2-1 2-1 2-1
    
    Distribution1#show mls qos maps dscp-input-q
       Dscp-inputq-threshold map:
         d1 :d2   0    1    2    3    4    5    6    7    8    9
         ------------------------------------------------------------
         0 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         1 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         2 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         3 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         4 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 01-01 01-01
         5 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         6 :  01-01 01-01 01-01 01-01

    Vous pouvez voir le conflit dans les cartes Cos-inputq-threshold et Dscp-inputq-threshold. Par exemple, la CoS 3 est mappée sur la file d'attente 2 dans la table Cos-inputq-threshold. Cependant, la valeur DSCP de 24 (qui correspond à la CoS 3) est mappée sur la file d'attente 1 dans la carte Dscp-inputq-threshold. En réalité, la carte Dscp-inputq-threshold ne tient pas compte de Cos-inputq-threshold. Ces mappages devraient être aussi cohérents que possible, afin d'être facilement prévisibles et de simplifier la résolution des problèmes. Par conséquent, la carte Dscp-inputq-threshold est configurée pour correspondre à la carte Cos-inputq-threshold.

    
    !--- Assign the frames into the queue based on the DSCP value.
    
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2
      16 17 18 19 20 21 22 23
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2
      24 25 26 27 28 29 30 31
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2
      32 33 34 35 36 37 38 39
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2
      48 49 50 51 52 53 54 55
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2
      56 57 58 59 60 61 62 63
    
    Distribution1#show mls qos maps dscp-input-q
       Dscp-inputq-threshold map:
         d1 :d2  0   1   2    3    4    5    6    7    8    9
         ------------------------------------------------------------
         0 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         1 :  01-01 01-01 01-01 01-01 01-01 01-01 02-01 02-01 02-01 02-01
         2 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01
         3 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01
         4 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01
         5 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01
         6 :  02-01 02-01 02-01 02-01
  • Configuration de file d'attente :

    L'IOS alloue l'espace par défaut dans la mémoire tampon pour mettre en file d'attente les paquets en entrée après l'activation de QoS. Les files d'attente en entrée 1 et 2 partagent cet espace de mémoire tampon. Dans les commutateurs Catalyst 3750, vous pouvez configurer le pourcentage d'espace de mémoire tampon à allouer pour chaque file d'attente. 67% de la mémoire disponible pour la file d'attente en entrée est allouée à la file d'attente 1 et 33% est allouée à la file d'attente 2.

    Distribution1(config)#mls qos srr-queue input buffers 67 33
    
    Distribution1(config)#do show mls qos input
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      67      33
    bandwidth :       4       4
    priority  :       0      10
    threshold1:     100     100
    threshold2:     100     100
  • Configuration du planificateur :

    Cette configuration est exécutée avec la commande mls qos srr-queue input bandwidth. Ici, la bande passante indique les quantités de bits gérés par SRR sur les files d'attente.

    Distribution1(config)#mls qos srr-queue input bandwidth 90 10
    Distribution1(config)#mls qos srr-queue input priority-queue 2 
    bandwidth 20
    
    Distribution1(config)#do show mls qos input
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      67      33
    bandwidth :      90      10
    priority  :       0      20
    threshold1:     100     100
    threshold2:     100     100

    Par défaut, la file d'attente 2 est la file d'attente prioritaire. 10% de la bande passante interne en anneau est alloué à la file d'attente prioritaire. Vous pouvez également configurer la file d'attente 1 comme file d'attente prioritaire. Cependant, vous ne pouvez pas configurer les deux files d'attente en tant que files d'attente prioritaires.

    Si la bande passante de l'anneau est de 10 Gbps, SRR gère en premier lieu 20% des 10 Gbps, soit 2 Gbps. La bande passante demeurante de sonnerie 8 GBP est partagée par la file d'attente 1 et la file d'attente 2. selon la configuration, la file d'attente 1 est entretenue 90% de 8 GBP et files d'attente 2 est de nouveau entretenue 10% de 8 GBP. Cette bande passante de 8 Gbps est gérée par SRR en mode partagé. Ceci signifie que les pourcentages de bande passante configurée sont garantis mais ne sont cependant pas limités à ces files d'attente.

    Remarque: Vous pouvez désactiver la file d'attente prioritaire avec la commande mls qos srr-queue input priority-queue 2 bandwidth 0.

    Distribution1(config)#do show mls qos input
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      90      10
    bandwidth :      90      10
    priority  :       0       0
    threshold1:     100     100
    threshold2:     100     100
    Distribution1(config)#

Mise en file d'attente, rejet et planification

Dans cette section, les niveaux seuil de WTD sont configurés, en plus de la taille de mémoire tampon allouée à la file d'attente. Vous pouvez attribuer une file d'attente et un seuil à chaque paquet traversant le commutateur.

cat3750-qos-config9.gif

Voici des exemples de configuration accompagnés d'explications :

  • Configuration du MAP de file d'attente :

    Dans un premier temps, les valeurs CoS sont mappées sur les files d'attente.

    
    !--- Assign the frames into the queue based on the CoS value.
    
    Distribution1(config)#mls qos srr-queue input cos-map queue 1
     threshold 2  1
    Distribution1(config)#mls qos srr-queue input cos-map queue 1
     threshold 3  0
    Distribution1(config)#mls qos srr-queue input cos-map queue 2
     threshold 1  2
    Distribution1(config)#mls qos srr-queue input cos-map queue 2
     threshold 2  4 6 7
    Distribution1(config)#mls qos srr-queue input cos-map queue 2
     threshold 3  3 5
    
    
    !--- Show output.
    
    Distribution1(config)#do show mls qos maps cos-input-q
       Cos-inputq-threshold map:
                  cos:  0   1   2   3   4   5   6   7
                  ------------------------------------
      queue-threshold: 1-3 1-2 2-1 2-3 2-2 2-3 2-2 2-2
    
    Distribution1(config)#do show mls qos maps dscp-input-q
       Dscp-inputq-threshold map:
         d1 :d2  0    1    2    3    4    5    6    7    8    9
         ------------------------------------------------------------
         0 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         1 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         2 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         3 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         4 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 01-01 01-01
         5 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
         6 :  01-01 01-01 01-01 01-01

    Vous pouvez voir le conflit dans les cartes Cos-inputq-threshold et Dscp-inputq-threshold. Par exemple, la CoS 3 est mappée sur la file d'attente 2 dans la table Cos-inputq-threshold, mais la valeur 24 (laquelle correspond à CoS 3) est mappée sur la file d'attente 1 dans la table Dscp-inputq-threshold. En réalité, la carte Dscp-inputq-threshold ne tient pas compte de Cos-inputq-threshold. Ces mappages devraient être aussi cohérents que possible, afin d'être facilement prévisibles et de simplifier la résolution des problèmes. Par conséquent, la carte Dscp-inputq-threshold est configurée pour correspondre à la carte Cos-inputq-threshold.

    
    !--- Assign the frames into the queue based on the DSCP value.
    
    Distribution1(config)#mls qos srr-queue input dscp-map queue 1
     threshold 2 9 10 11 12 13 14 15
    Distribution1(config)#mls qos srr-queue input dscp-map queue 1 
     threshold 3 0 1 2 3 4 5 6 7
    Distribution1(config)#mls qos srr-queue input dscp-map queue 1 
     threshold 3 32
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2 
     threshold 1 16 17 18 19 20 21 22 23
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2 
     threshold 2 33 34 35 36 37 38 39 48
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2 
     threshold 2 49 50 51 52 53 54 55 56
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2 
     threshold 2 57 58 59 60 61 62 63
    Distribution1(config)#mls qos srr-queue input dscp-map queue 2 
     threshold 3 24 25 26 27 28 29 30 31
    
    Distribution1(config)#do show mls qos maps dscp-input-q
       Dscp-inputq-threshold map:
         d1 :d2  0    1    2    3    4    5    6    7    8    9
         ------------------------------------------------------------
         0 :  01-03 01-03 01-03 01-03 01-03 01-03 01-03 01-03 01-01 01-02
         1 :  01-02 01-02 01-02 01-02 01-02 01-02 02-01 02-01 02-01 02-01
         2 :  02-01 02-01 02-01 02-01 02-03 02-03 02-03 02-03 02-03 02-03
         3 :  02-03 02-03 01-03 02-02 02-02 02-02 02-02 02-02 02-02 02-02
         4 :  02-03 02-03 02-03 02-03 02-03 02-03 02-03 02-03 02-02 02-02
         5 :  02-02 02-02 02-02 02-02 02-02 02-02 02-02 02-02 02-02 02-02
         6 :  02-02 02-02 02-02 02-02
  • Configuration de file d'attente :

    Par défaut, le seuil 3 est de 100% et ne peut pas être changé.

    Distribution1(config)#mls qos srr-queue input buffers 67 33
    Distribution1(config)#mls qos srr-queue input threshold 1 8 16
    Distribution1(config)#mls qos srr-queue input threshold 2 34 66
    
    Distribution1(config)#do show mls qos input
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      67      33
    bandwidth :       4       4
    priority  :       0      10
    threshold1:       8      34
    threshold2:      16      66
  • Configuration du planificateur :

    IOS alloue l'espace par défaut dans la mémoire tampon pour chaque port en entrée, après l'activation de QoS. Les deux files d'attente partagent cet espace de mémoire tampon. Dans les commutateurs Catalyst 3560/3750, vous pouvez configurer le pourcentage d'espace de mémoire tampon à allouer pour chaque file d'attente.

    Distribution1(config)#mls qos srr-queue input bandwidth 90 10
    Distribution1(config)#mls qos srr-queue input priority-queue 2
     bandwidth 20
    
    Distribution1(config)#do show mls qos input
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      67      33
    bandwidth :      90      10
    priority  :       0      20
    threshold1:       8      34
    threshold2:      16      66

    Par défaut, la file d'attente 2 est la file d'attente prioritaire. 10% de la bande passante interne en anneau est alloué à la file d'attente prioritaire. Vous pouvez également configurer la file d'attente 1 comme file d'attente prioritaire. Cependant, vous ne pouvez pas configurer les deux files d'attente en tant que files d'attente prioritaires.

    Si la bande passante de l'anneau est de 10 Gbps, SRR gère en premier lieu 20% des 10 Gbps, soit 2 Gbps. La bande passante demeurante de sonnerie 8 GBP est partagée par la file d'attente 1 et la file d'attente 2. selon la configuration, la file d'attente 1 est entretenue 90% de 8 GBP et files d'attente 2 est de nouveau entretenue 10% de 8 GBP. Cette bande passante de 8 Gbps est gérée par SRR en mode partagé. Ceci signifie que les pourcentages de bande passante configurée sont garantis mais ne sont cependant pas limités à ces files d'attente.

    Remarque: Vous pouvez désactiver la file d'attente prioritaire avec la commande mls qos srr-queue input priority-queue 2 bandwidth 0.

    Distribution1(config)#do show mls qos input
    Queue     :       1       2
    ----------------------------------------------
    buffers   :      90      10
    bandwidth :      90      10
    priority  :       0       0
    threshold1:     100     100
    threshold2:     100     100
    Distribution1(config)#

Fonctionnalités QoS de sortie

La gestion et la prévention de débordement correspondent aux fonctionnalités QoS prises en charge par les commutateurs Cisco Catalyst 3750. La gestion et la prévention de débordement font partie d'un processus en trois étapes. Les étapes sont : mise en file d'attente, rejet et planification.

La mise en file d'attente place paquets dans les différentes files d'attente de logiciel à l'aide des étiquettes QoS. Le commutateur Cisco Catalyst 3750 dispose de 4 files d'attente de sortie, avec 3 seuils par file d'attente. Une fois classifié et marqué avec des étiquettes QoS, le trafic peut être transféré dans quatre files d'attente distinctes par le biais des étiquettes QoS.

Chaque file d'attente peut être configurée avec la taille de la mémoire tampon, le seuil réservé, les niveaux de seuil et le seuil maximal. WTD (Weighted Tail Drop) est utilisé pour gérer la longueur des files d'attente et fournir des priorités de rejet pour les différentes classifications de trafic. Les paramètres de file d'attente en entrée sont configurés de manière globale. Les paramètres de file d'attente en entrée ne sont pas définis sur base de chaque port. Cependant, les paramètres de file d'attente de sortie sont configurés par port. La configuration est également définie par port. Vous ne pouvez pas configurer séparément chaque port. Vous pouvez configurer chaque port de deux manières différentes. Ce procédé porte le nom d'ensemble de configuration de file d'attente. Vous pouvez définir un maximum de deux configurations différentes de file d'attente dans la configuration globale. Vous pouvez ensuite appliquer l'une ou l'autre un de ces deux configurations à l'interface.

Les files d'attente d'entrée et de sortie sont gérées par SRR, qui contrôle le débit d'envoi des paquets. Dans les files d'attente en entrée, SRR envoie les paquets à l'anneau de la pile. SRR peut fonctionner avec deux modes différents, le mode shaping et le mode partagé. Pour des files d'attente en entrée, le mode partagé est défini par défaut et se trouve être le seul pris en charge. En mode partagé, les files d'attente se partagent la bande passante selon les poids de file d'attente configurés. À ce niveau, une quantité de bande passante est garantie mais ne s'y limite pas. En mode shaping, les files d'attente de sortie ont un pourcentage de bande passante garanti, auquel est limité leur débit. Le trafic de shaping n'excède pas la bande passante allouée, et ce même si le lien est inactif. Le shaping fournit un flux de trafic optimal dans la durée et permet de réduire les pics et les creux des trafics mouvementés. La file d'attente 1 peut être configurée comme file d'attente prioritaire.

Commandes QoS de sortie

Cette section décrit toutes les commandes de sortie QoS disponibles.

  • Configuration du MAP de file d'attente :

    Pour mapper les valeurs CoS sur les files d'attente de sortie :

    Rack1SW1(config)#mls qos srr-queue output cos-map queue ?
      <1-4>  enter cos-map output queue id
    
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 1
     threshold ? <1-3>  enter cos-map threshold id
    
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 1
     threshold 1 ? <0-7>  8 cos values separated by spaces

    Pour mapper les valeurs DSCP sur les files d'attente de sortie :

    Rack1SW1(config)#mls qos srr-queue output dscp-map queue ?
      <1-4>  enter dscp-map output queue id
    
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 1
     threshold ? <1-3>  enter dscp-map threshold id
    
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 1
     threshold 1 ? <0-63>  dscp values separated by spaces
     (up to 8 values total)
  • Configuration de file d'attente :

    La configuration de file d'attente de sortie permet de définir deux ensembles de configuration de file d'attente. Chaque ensemble de configuration de file d'attente permet de configurer la taille de la mémoire tampon et la valeur de seuil pour les quatre files d'attente de sortie. Ensuite, vous pouvez appliquer l'un ou l'autre des ensembles de configuration de file d'attente à n'importe quel port. Par défaut, la file d'attente 1 est allouée à tous les ports lorsque vous activez QoS sur le commutateur.

    Rack1SW1(config)#mls qos queue-set output ?
      <1-2>  queue-set id
    
    Rack1SW1(config)#mls qos queue-set output 1 ?
      buffers    assign buffers to each egress queue
      threshold  Assign threshold values to a queue
    

    Afin de configurer la taille du tampon pour les quatre files d'attente de sortie :

    Rack1SW1(config)#mls qos queue-set output 1 buffers ?
      <0-99>  enter buffer percentage for queue 1 0-99
    
    Rack1SW1(config)#mls qos queue-set output 1 buffers 10 ?
      <1-100>  enter buffer percentage for queue 2 1-100
     (includes CPU buffer)
    
    Rack1SW1(config)#mls qos queue-set output 1 buffers 10 20 ?
      <0-99>  enter buffer percentage for queue 3 0-99
    
    Rack1SW1(config)#mls qos queue-set output 1 buffers 10 20 30 ?
      <0-99>  enter buffer percentage for queue 4 0-99

    Afin de configurer deux valeurs de seuil et les valeurs de seuil réservées et maximales pour chaque file d'attente (le seuil 3 est de 100% par défaut et ne peut pas être changé) :

    Rack1SW1(config)#mls qos queue-set output 1 threshold ?
      <1-4>  enter queue id in this queue set
    
    Rack1SW1(config)#mls qos queue-set output 1 threshold 1 ?
      <1-400>  enter drop threshold1 1-400
    
    Rack1SW1(config)#mls qos queue-set output 1 threshold 1 50 ?
      <1-400>  enter drop threshold2 1-400
    
    Rack1SW1(config)#mls qos queue-set output 1 threshold 1 50 60 ?
      <1-100>  enter reserved threshold 1-100
    
    Rack1SW1(config)#mls qos queue-set output 1 threshold 1 50 60
     100 ? <1-400>  enter maximum threshold 1-400

    Pour appliquer l'ensemble de configuration de file d'attente à l'interface (par défaut, la file d'attente 1 est allouée à tous les ports lorsque vous activez QoS sur le commutateur) :

    Rack1SW1(config-if)#queue-set ?
      <1-2>  the qset to which this port is mapped
  • Configuration du planificateur :

    Trois configurations différentes sont disponibles pour l'interface du commutateur. Les configurations sont shaping, partage et limite de bande passante. Vous pouvez également définir la file d'attente de sortie 1 comme file d'attente prioritaire. Si la file d'attente prioritaire est activée, SRR la gère jusqu'à ce qu'elle soit vide avant de traiter les trois autres files d'attente. Cependant, dans la file d'attente prioritaire en entrée, SRR gère la file d'attente prioritaire avec la valeur configurée.

    Rack1SW1(config-if)#srr-queue bandwidth ?
      limit  Configure bandwidth-limit for this interface
      shape  Configure shaping on transmit queues
      share  Configure shared bandwidth
    
    Rack1SW1(config-if)#priority-queue ?
      out  egress priority queue

    Configuration de la limite de bande passante :

    Rack1SW1(config-if)#srr-queue bandwidth limit ?
      <10-90>  enter bandwidth limit for interface  as percentage

    Configuration du shaping de bande passante :

    Rack1SW1(config-if)#srr-queue bandwidth shape ?
      <0-65535>  enter bandwidth weight for queue id 1
    
    Rack1SW1(config-if)#srr-queue bandwidth shape 10 ?
      <0-65535>  enter bandwidth weight for queue id 2
    
    Rack1SW1(config-if)#srr-queue bandwidth shape 10 20 ?
      <0-65535>  enter bandwidth weight for queue id 3
    
    Rack1SW1(config-if)#srr-queue bandwidth shape 10 20 30 ?
      <0-65535>  enter bandwidth weight for queue id 4

    Configuration du partage de bande passante :

    Rack1SW1(config-if)#srr-queue bandwidth share ?
      <1-255>  enter bandwidth weight for queue id 1
    
    Rack1SW1(config-if)#srr-queue bandwidth share 10 ?
      <1-255>  enter bandwidth weight for queue id 2
    
    Rack1SW1(config-if)#srr-queue bandwidth share 10 20 ?
      <1-255>  enter bandwidth weight for queue id 3
    
    Rack1SW1(config-if)#srr-queue bandwidth share 10 20 30 ?
      <1-255>  enter bandwidth weight for queue id 4

    Chacune des quatre files d'attente est prise en compte dans SRR à moins que la file d'attente prioritaire soit activée. Dans ce cas, le premier poids de bande passante est ignoré et n'est pas utilisé dans le calcul de coefficient. La file d'attente prioritaire est gérée jusqu'à ce qu'elle soit vide, et ce avant que ne soient traitées les autres files d'attente. Vous activez la file d'attente prioritaire à l'aide de la commande de configuration d'interface priority-queue out.

Configuration par défaut

Configuration du MAP de file d'attente par défaut :

/image/gif/paws/91862/cat3750-qos-config10.gif

Ces mappages par défaut peuvent être changés selon vos besoins :


!--- Map CoS to Egress Queue

Distribution1#show mls qos maps cos-output-q
   Cos-outputq-threshold map:
              cos:  0   1   2   3   4   5   6   7
              ------------------------------------
  queue-threshold: 2-1 2-1 3-1 3-1 4-1 1-1 4-1 4-1


!--- Map DSCP to Egress Queue

Distribution1#show mls qos maps dscp-output-q
   Dscp-outputq-threshold map:
     d1 :d2  0    1    2    3    4    5    6    7    8    9
     ------------------------------------------------------------
     0 :  02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01
     1 :  02-01 02-01 02-01 02-01 02-01 02-01 03-01 03-01 03-01 03-01
     2 :  03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01
     3 :  03-01 03-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01
     4 :  01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 04-01 04-01
     5 :  04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01
     6 :  04-01 04-01 04-01 04-01

Configuration de la file d'attente par défaut :

cat3750-qos-config11.gif

Les configurations par défaut de file d'attente de sortie conviennent à la plupart des situations. Avant de les modifier, assurez-vous d'avoir acquis les connaissances relatives aux files d'attente de sortie et vérifiez bien que les paramètres par défaut ne correspondent pas à votre solution QoS.

Deux ensembles de configuration de file d'attente sont définis, et l'ensemble de configuration de la file d'attente 1 est alloué à tous les ports par.défaut. 25 pour cent de l'espace total de mémoire tampon sont alloués à chaque file d'attente. 50 pour cent de l'espace de mémoire tampon sont réservés pour chaque file d'attente, soit 12,5 pour cent de l'espace total de mémoire tampon. La somme de toutes les mémoires tampon réservées constitue le pool réservé. La mémoire tampon restante fait partie du pool commun. La configuration par défaut alloue 400 percent de mémoire maximum à cette file d'attente. Ce pourcentage doit être atteint avant que des paquets ne puissent être rejetés.

Distribution1#show mls qos queue-set 1
Queueset: 1
Queue     :       1       2       3       4
----------------------------------------------
buffers   :      25      25      25      25
threshold1:     100     200     100     100
threshold2:     100     200     100     100
reserved  :      50      50      50      50
maximum   :     400     400     400     400

Distribution1#show mls qos queue-set 2
Queueset: 2
Queue     :       1       2       3       4
----------------------------------------------
buffers   :      25      25      25      25
threshold1:     100     200     100     100
threshold2:     100     200     100     100
reserved  :      50      50      50      50
maximum   :     400     400     400     400

Distribution1#show mls qos int gigabitEthernet 1/0/20 buffers
GigabitEthernet1/0/20
The port is mapped to qset : 1
The allocations between the queues are : 25 25 25 25

Configuration du planificateur par défaut :

La file d'attente prioritaire est désactivée. Les modes shaping et partagé sont configurés pour SRR. Les poids du mode shaping prévalent sur la valeur du mode partagé. Par conséquent, la file d'attente 1 est gérée en mode shaping et les files d'attente 2, 3 et 4 sont gérées en mode partagé. Ainsi, la file d'attente 1 est gérée avec une valeur absolue de (1/25) pour cent, soit quatre percent de la bande passante. Les files d'attente 2, 3 et 4 sont gérées à 25 pour cent de la bande passante. Si la bande passante est disponible, alors les files d'attente 2, 3 et 4 peuvent être gérées au-delà de 25 pour cent de la bande passante.

Distribution1#show mls qos int gigabitEthernet 1/0/20 queueing
GigabitEthernet1/0/20
Egress Priority Queue : disabled
Shaped queue weights (absolute) :  25 0 0 0
Shared queue weights  :  25 25 25 25
The port bandwidth limit : 100  (Operational Bandwidth:100.0)
The port is mapped to qset : 1

Mise en file d'attente, rejet et planifiation

Voici des exemples de configuration :

  • Configuration du MAP de file d'attente :

    Rack1SW1(config)#mls qos srr-queue output cos-map queue 1
     threshold 3 5
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 1
     threshold 1 2 4
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 2 
     threshold 2 3
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 2
     threshold 3 6 7
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 3
     threshold 3 0
    Rack1SW1(config)#mls qos srr-queue output cos-map queue 4
     threshold 3 1
    
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 1
     threshold 3  46
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 1  16
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 1  18 20 22
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 1  25
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 1  32
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 1  34 36 38
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 2  24 26
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 2
     threshold 3  48 56
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 3
     threshold 3  0
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 4
     threshold 1  8
    Rack1SW1(config)#mls qos srr-queue output dscp-map queue 4
     threshold 3  10 12 14
    
  • Configuration de file d'attente :

    Cet exemple décrit la configuration des ensembles de configuration de file d'attente 1 et 2. Par défaut, l'ensemble de configuration de file d'attente 1 est appliqué à toutes les interfaces.

    Rack1SW3(config)#mls qos queue-set output 1 buffers 10 10 26 54
    Rack1SW3(config)#mls qos queue-set output 2 buffers 16 6 17 61
    
    Rack1SW3(config)#mls qos queue-set output 1 threshold 2 70 80
     100 100
    Rack1SW3(config)#mls qos queue-set output 1 threshold 4 40 100
     100 100
    
    Rack1SW3(config)#mls qos queue-set output 2 threshold 1 149 149
     100 149
    Rack1SW3(config)#mls qos queue-set output 2 threshold 2 118 118
     100 235
    Rack1SW3(config)#mls qos queue-set output 2 threshold 3 41 68
     100 272
    Rack1SW3(config)#mls qos queue-set output 2 threshold 4 42 72
     100 242
    
    Rack1SW3(config)#int fa 1/0/11
    Rack1SW3(config-if)#queue-set 2
    

    L'ensemble de configuration de file d'attente 2 est appliqué à l'interface 1/0/11.

    Rack1SW3(config-if)#do show mls qos int fa 1/0/10 buffers
    FastEthernet1/0/10
    The port is mapped to qset : 1
    The allocations between the queues are : 10 10 26 54
    
    Rack1SW3(config-if)#do show mls qos int fa 1/0/11 buffers
    FastEthernet1/0/11
    The port is mapped to qset : 2
    The allocations between the queues are : 16 6 17 61
  • Configuration du planificateur :

    Rack1SW3(config-if)#srr-queue bandwidth share 1 75 25 5
    Rack1SW3(config-if)#srr-queue bandwidth shape  3  0  0  0
    

    La file d'attente de sortie du Cisco Catalyst 3750 ne prend pas en charge la mise en file d'attente de faible latence (Low Latency Queueing, LLQ). Elle prend en charge la mise en file d'attente par priorité. Quand vous configurez la commande priority-queue out, la file d'attente 1 est toujours gérée lorsqu'elle à un paquet.

    Rack1SW3(config-if)#srr-queue bandwidth share 1 75 25 5
    Rack1SW3(config-if)#srr-queue bandwidth shape  3  0  0  0
    Rack1SW3(config-if)#priority-queue out
    

    Quand vous configurez cette commande, le poids SRR et les coefficients de taille de file d'attente sont altérés car une file d'attente ne participe plus dans SSR. Ainsi, weight1, dans les commandes srr-queue bandwidth shape ou srr-queue bandwidth share, est ignoré (non utilisé dans le calcul de coefficient).

Il s'agit de la commande permettant d'afficher les rejets sur des files d'attente spécifiques :

Étape 1 :

1/ #show platform pm if-numbers

Utilisez les si-nombres de show platform pm commandent et vérifient les informations de port correspondant à votre interface (c'est l'interface sortante sur vos 3750). Par exemple, FLB 0/3 sera le port 0/4. Gardez 4 comme valeur de port ; si la première valeur n'est pas un zéro, alors donnez le nombre asic après le numéro de port.

interface gid gpn lpn port slot unit slun port-type lpn-idb gpn-idb
------------------------------------------------------------------------
---------
Gi0/1     1    1    25   0/1  1    1    1    local     Yes     Yes
Gi0/2     2    2    26   0/0  1    2    2    local     Yes     Yes
Fa0/1     3    3    1    0/2  1    1    3    local     Yes     Yes
Fa0/2     4    4    2    0/3  1    2    4    local     Yes     Yes
Fa0/3     5    5    3    0/4  1    3    5    local     Yes     Yes
Fa0/4     6    6    4    0/5  1    4    6    local     Yes     Yes
Fa0/5     7    7    5    0/6  1    5    7    local     Yes     Yes
Fa0/6     8    8    6    0/7  1    6    8    local     Yes     Yes

La valeur de port correspondant à l'interface fa 0/3 est 0/4. Maintenant vous pouvez voir les baisses de file d'attente de l'interface fa 0/3 avec la commande du port 4 de baisse de stats de show platform port-asic.

2/ #show platform port-asic stats drop port 4 
       
Port-asic Port Drop Statistics - Summary
========================================
  RxQueue 0 Drop Stats: 0
  RxQueue 1 Drop Stats: 0
  RxQueue 2 Drop Stats: 0
  RxQueue 3 Drop Stats: 0
...
 
  Port 4 TxQueue Drop Statistics
    Queue 0
      Weight 0 Frames 0
      Weight 1 Frames 0
      Weight 2 Frames 0
    Queue 1
      Weight 0 Frames 0
      Weight 1 Frames 2755160   <--- Here is an example of drops
      Weight 2 Frames 0
    Queue 2
      Weight 0 Frames 0
      Weight 1 Frames 0
      Weight 2 Frames 0
    Queue 3
      Weight 0 Frames 0
      Weight 1 Frames 0
      Weight 2 Frames 8

Étape 2 :

  • Configuration de la limite de bande passante :

    Afin de limiter la sortie maximum sur un port, définissez la commande de configuration d'interface srr-queue bandwidth limit. Si vous définissez une valeur de 80 % avec cette commande, le port est inactif 20 pour cent du temps. Le coefficient de ligne diminue à 80 % de la vitesse de connexion. Ces valeurs ne sont pas précises car la configuration matérielle ajuste le coefficient de ligne en l'incrémentant de 6. Cette commande n'est pas disponible sur une interface Ethernet 10-Gigabit.

    srr-queue bandwidth limit weight1
    
    

    weight1 correspond au pourcentage de la vitesse à laquelle le port devrait être limité. La vitesse est comprise entre 10 et 90.

    Remarque: Les configurations par défaut de file d'attente de sortie conviennent à la plupart des situations. Avant de les modifier, assurez-vous d'avoir acquis les connaissances relatives aux files d'attente de sortie et vérifiez bien que les paramètres par défaut ne correspondent pas à votre solution QoS.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 91862